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BRAHMS introduced 

Managing Natural History 

BRAHMS is a management system for preserved and living natural history collections, taxonomic research and 

biogeographic study. Updated to the latest database technologies, BRAHMS is scalable from the individual 

research project to enterprise level systems with millions of records. 

For collection managers in museums, botanic gardens, herbaria and seed banks and for those undertaking 

researches related to natural history, BRAHMS helps integrate all of your data, increasing outputs and 

productivity. 

 

 

The Taxonomic data infrastructure lies at the core of all BRAHMS databases. 

 

 

BRAHMS has been developed to store all categories of natural history collection.  

Development priorities 

Intuitive  -   similar to MS Office applications   

Scalable  -  from individual researcher to multi-site enterprise systems  

Taxonomic Core  -  comprehensive across disciplines 

Integrating Digital Assets  -  including preserved and living collections  

Modular  -  allow others to develop, including web-based add-ons  

International  - with respect to data store and user interface 

Sustainable and providing custom support  -   
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For further information about BRAHMS, visit https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8 

BRAHMS v7 users 

Although v8 is a completely new system, v7 users will be able to adapt quickly. Most v7 features and functions 

have been carried over and are more intuitive in the new system.  For a summary of some of the key changes 

between v7 and v8,  refer to Annex 2. 

A selection of BRAHMS video clips 

Performance in a large database 

Connecting to the conifer demo database 

Create a new database project 

Adding a new user account 

Editing user access and permissions 

Using the species table form 

Adding text entries to taxa 

Using data grid filters 

Selecting visible columns 

Exporting to Excel/CSV 

Merging values - a fast way to tidy your data 

Creating an RDE file for geographic data 

Importing plant names from IPNI 

Importing bird sample data from an Excel table 

Adding species names to an RDE file 

 

Mapping in action 

Editing map points 

Living collection data: Excel to RDE 

Living collection data: RDE to BRAHMS 

Printing a garden plant list 

Design and print botanic garden labels 

Updating and viewing calculated fields 

Opening, docking and linking tables 

Using tags, filters and maps 

Generating labels and saving to pptx 

Images -> specimen RDE file for data capture 

Tracking edits and using Undo 

Managing transactions 

Deleting records 

 

Some acronyms and other terms used in BRAHMS  

ArcGIS API Internal mapper used in BRAHMS. 
 

BGCI Botanic Garden Conservation International. 
 

BOL BRAHMS Online. 
 

BRAHMS The acronym originally stood for ‘Botanical Research And Herbarium Management System’. 
The name BRAHMS is still used – however, the ‘Botanical’ and ‘Herbarium’ are no longer 
relevant as BRAHMS manages all natural history collections. 

Licensing and support are managed 

through Oxford University Innovation. 

OUI provide rigour to the BRAHMS project 
and through appropriate licensing, ensure 
projects receive the service and support 
they require. With OUI backing, a 
sustainable and long-term future for 
BRAHMS is secured. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#performancevideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#coniferconnect
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#createdb
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#useraccount
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#userpermissions
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#speciesformvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#addingspeciestext
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#datagridfilters
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#columnviewvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#exporttoexcel
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mergevalues
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#rdevideogazetteer
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#importingfromipni
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#importingfromexcel
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#rdevideoaddspeciesrde
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mappingvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#editmappoints
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#lcexceltorde
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#lcrdetobrahms
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#plantlist
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#gardenlabels
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#calcfields
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#opendocklink
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#tagsandmaps
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#labelstoppt
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#specimenimages
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#edithistory
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#transactions
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#deletion
https://innovation.ox.ac.uk/about/
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Calculated fields Fields that are not automatically updated – they are updated using the Recalculate function. 
 

Collection event Collection event records store details of collections: who by, when, where, what. They are 
known as Botanical Records in v7. An event may result in one to many physical specimens. 
Alternatively, it may be an observation or a recording from literature. 
 

Custom field A non-standard data field added to BRAHMS (known as link fields in v7). 
 

Data Connection A data connection is a link from the BRAHMS software to a data store. A data store may have 
one to many databases. 
 

Database project A specific database (= project) in a data store. 
 

Edit History The history of edits made to the database. This is called Track Changes in v7. 
 

Gazetteer A place name added to the main gazetteer table as a collection event location. Often a town 
name, park name, a forest, a mountain name or similar. If unknown or vague, a description 
may be stored in locality notes. The place name should be linked to a country and hopefully a 
major admin area such as a state or department. 
 

Lookup List The central lookup dictionary as found on Management > Lookup Lists. 
 

Merge records Merging records is used to join one or more records into one. This is used where there are 
two or more records representing the same thing. Merging records will also process child 
records, joining these to the selected record. 
 

Merge values If there are multiple spellings/formats of a text string in a given field, these can be edited to a 
standard value using Merge Values on the Summary form. 
 

Query or Filter Filter and query and one and the same thing in BRAHMS v8. These actions lead to a selection 
of your data which can subsequently be processed as you wish (exported, printed, mapped, 
etc.). 
 

RDE Rapid Data Entry. RDE files are external to BRAHMS, used for efficient data capture. Refer to 
the Rapid Data Entry section. 
 

Specimen A physical object of any category, derived from a collection event. 
 

Tag A single character mark (default=*) in the TAG field. This field is found in all tables. 
 

Tag groups Tag groups enable you to set up and save any logical grouping of records, for example a list of 
species records that are in some grouping, for example ‘Migratory birds’ or ‘Poisonous 
plants’. 
 

Transaction A transaction record describes a loan, exchange, gift or any other category of transaction. You 
can link specimens and/or living plant material to transactions. 
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Building a natural history database 

Introduction 

Some database project examples: 

• manage a grasshopper or beetle collection;  

• create a catalogue of fungi or cultivated plants;  

• produce an annotated checklist for a mountain in Cameroon;  

• develop a comprehensive botanic garden or seed bank management system;  

• or all of these together within a larger natural history museum or herbarium; 

• create an online portal to search and display your data, images and maps. 

The development of a well organised database is an important activity for managers and researchers. The 

strategy you adopt will vary depending on your resources, the amount of data to manage and your longer-term 

objectives. In all these cases, the paths to successful database development are broadly similar. 

Hardware 

For individual researchers running their own show, the software and the database will often be installed on a 

personal computer running Windows or on a Mac with Windows emulation. Aside from having sufficient disk 

space and as much RAM as possible (16GB or ideally more), there are no special requirements other than that 

the .NET version is sufficiently up to date.  

For institutions with large collections, perhaps many millions and many simultaneous users, the actual 

database will be stored on a server in PostgreSQL or MSSQL Server. It is important that the server is well 

resourced with sufficient disk space, adequate RAM and a good processor.  If you try to run a large database on 

an inadequately resourced server, performance, under most circumstances, will be poor. Performance is 

broadly related to how well resourced your infrastructure is.  An under-resourced server and/or client 

workstation leads to poorer performance. 

As an example, the BRAHMS server used in Oxford has 256 GB RAM. BRAHMS rarely uses more than 50% of 

this memory but nevertheless, where the server is used for multiple applications, it is comforting to have some 

extra RAM. RAM is helpful as some categories of task are cached. Having plenty of RAM makes querying more 

efficient. You do not need 256GB - but try to aim high. 

Disk space? These days, disk space is measured in TB. Make sure your server has adequate space bearing in 

mind that stores such as PostgreSQL or MSSQL Server tend to reserve empty space for database expansion. A 

BRAHMS database with ca. 10 million specimen records (including all the related tables) will use ca. 100GB. 

Images? It’s easy to calculate the space required for images. For example, 1 million images, each 5MB in size, 

would require 5TB storage. Images may be stored on different servers. They can be referenced in BRAHMS as 

physical files or as URL references (e.g. to a media library). 

BRAHMS itself will be installed on a shared drive that all users can access or on individual client workstations. 

You may also use remote server log in by users located on different sites. On larger networks, the set up will be 

fine-tuned to achieve the maximum performance, a specialised IT task that is not further discussed here.  

In addition to the server where the database is stored (possibly also the BRAHMS software), the role of client 

workstations should not be underestimated. When you log into the BRAHMS software, the system uses the 

resources of local workstations. Thus, even if your server is extremely well resourced, under-resourced 

workstations may not perform well.  

In summary, cutting corners on hardware set up is something of a false economy when it comes to established 

a healthy database environment, all the more so when there are large databases and many users. Institutions 

need to invest appropriately in managing their digital assets.  

We can provide further tailored advice on hardware on a project by project basis. 
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Data migration  

You may have data in an earlier version of BRAHMS, in Excel or Access tables or in other database packages. 

These data are important and can be migrated into BRAHMS. V7 databases are automatically upgraded and 

data in Excel can be imported to BRAHMS via RDE. Data held in other packages may require some form of 

migration input. However, one way or another, the idea of migration is that you maintain all the data your 

currently have. 

Optimising data capture 

Data entry efficiency (speed + accuracy) can be sensibly optimised for all projects, be they small or large. While 

smaller number of records can be added directly into BRAHMS, the recommended procedure for larger scale 

data capture is to use Rapid Data Entry (RDE). Data are added to external RDE spreadsheets (themselves 

portable mini-databases) and after checking, these data are transferred into the main database. RDE files can 

themselves be optimised for specific projects by setting up the desired fields and field order. 

To take full advantage of RDE, your database can be kick-started by importing useful dictionaries of data, for 

example collector, taxa and geographic names. Lookup lists can be added for any field where you have a fixed 

set of values. Although lookup lists can be generated on the fly, it’s usually best to have these defined in 

advance. You are then in a position to force selection for a defined list or allow the data entry person to add 

new entries. A more complete range of optimising procedures is discussed in the RDE section. 

Exploring your data 

One of the key attractions of BRAHMS is that you can explore your data in smart spreadsheets or data grids. 

While the provided BRAHMS forms are great for data editing, the data grids, together with the many toolbar 

options, are incredibly powerful for viewing, sorting, filtering, calculating and analysis. Data grids are 

virtualized, ensuring they are fast even if you are working in table with millions of records. 

Reports  

Aside from using the data export options provided in BRAHMS, you may want to create report templates for 

lists, labels, loan forms and others. You can gradually build up a library of handy report templates – and many 

of the tricks to learn for that are reviewed in detail in the report design section of this guide. Learning to design 

cool reports is one aspect of mastering BRAHMS where users with interest to do so can go the extra mile, 

delving into complete range of report design options as laid out, for example in 

https://www.stimulsoft.com/en/documentation and https://www.youtube.com/user/StimulsoftVideos 

Mapping 

Most projects want to produce maps and again, all the procedures for creating maps using different GIS 

options such as QGIS are reviewed in the map section. Bear in mind that if you are online, you have access not 

only to the in-built ArcGIS API but also the map point location editor. One of the handiest features in BRAHMS 

v8 is the ability to view data records and map points together, dynamically linking these to highlight the current 

data record, and respect filters. 

Special management areas 

In addition to the powerful system-wide features and functions listed above, BRAHMS includes specialist 

modules for managing museums, herbaria, botanic gardens and seed banks. These modules have been 

developed collaboratively with numerous institutions ensuring that provide the day to day curation and 

research support that projects need. 

 

 

 

https://www.stimulsoft.com/en/documentation
https://www.youtube.com/user/StimulsoftVideos
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Installation and updates 

Licensing 

To open BRAHMS, you will need either an evaluation key allowing you to test the system for 60 days or a full 

licence key. Both are obtained from Oxford University Innovation (OUI). 

• Apply for evaluation key: https://herbaria.plants.ox.ac.uk/bol/brahms/software/evaluations 

• Apply for licence: https://process.innovation.ox.ac.uk/software/p/14165/brahms/1 

The key you receive will be a long text string similar to: 

lgBAN8JkR7HNUBBQBmAE5hbWU9U29sYW51bSBQcm9qZWN0OiBSb3lhbCBCb3RhmljIEdhcmRlbnMgRWRpbmJ1cmdoICgTmF0dXJhbCBIaX

N0b3J5IE11c2V1bSNQdXJjaGFzZURhdGU9MDkvM123MjAxOQEPg4hL3jcIbjaoucSgmBN7OIiM2yDmE637gvJV/BArl5/UK0hY4ph84fKWap9q/

XRG8inHEyTGa8w2vRoOvfGm= 

If you have received a licence key from OUI, when you log into the software, simply copy the key into the 

licence key form when prompted. 

 

Prerequisites and .NET 

BRAHMS operates under Windows or on Macs with Parallels, Virtual Box, Boot Camp or equivalent. Your 

installed Windows .NET framework version needs to be v 4.7.2 or later. If it is not, BRAHMS prompts you to 

upgrade. If you do have to upgrade .NET, it will be best to restart your PC after. As further discussed below, 

ideally your workstation will have 8GB of RAM or more. RAM is used by database applications for most 

operations. 

Other issues you may encounter 

WebView2 installer 

If you have trouble accessing any web related functions in BRAHMS and/or have error messages in your log file 

that refer to ‘Couldn't find a compatible Webview2 Runtime installation to host WebViews. Source 

:Microsoft.Web.WebView2.Core’ (or similar to this), this usually implies that your PC does not have the 

required Microsoft webview2  components. In this case, please visit 

https://go.microsoft.com/fwlink/p/?LinkId=2124703 – this will download a exe runtime file 

MicrosoftEdgeWebview2Setup.exe which you can quicky install. 

C++ redistributable 

 

https://innovation.ox.ac.uk/about/
https://herbaria.plants.ox.ac.uk/bol/brahms/software/evaluations
https://process.innovation.ox.ac.uk/software/p/14165/brahms/1
https://go.microsoft.com/fwlink/p/?LinkId=2124703
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If you get an error similar to the above, you need to download the Microsoft Visual C++ redistributable as on:  

https://aka.ms/vs/17/release/vc_redist.x64.exe for a 64 bit system   

https://aka.ms/vs/17/release/vc_redist.x86.exe  for a 32 bit system 

(This will work for 2015, 2017, 2019, and 2022 versions) 

 

Blocked DLL files 

          

 

If the copy/deploy BRAHMS install zip is opened using the Windows default extraction, this may block access to 

some BRAHMS files. When logging in, you may see a message similar to the above.  Alternatively, your system 

menu may simply not display correctly – typically showing only System. The solution is to delete your BRAHMS 

software folder and then again open the zip file you have downloaded using 7z https://www.7-

zip.org/download.html or another utility. Another possible explanation is your security system (e.g. anti-virus) 

requires you to include brahms.exe as a trusted exception. 

 

Software folder location 

The BRAHMS software folder can be located on a drive that all users have access to, either through a share or 

via internet access. Alternatively, it can be installed on each local workstation/PC where it will be used. 

Otherwise, there are no restrictions of the location and/or name of the installation folder. 

Disk space and memory requirements 

For the complete system installation (including the ArcGIS and reporting runtime libraries, the training guide 

and other system components) you will need about 250 MB of disk space. This does not include the space 

required for your data. The demo conifer database requires about 100 MB.  

RAM requirements are not strictly imposed. However, as with most database systems, the more RAM you 

have, the more efficiently the system will operate.  Firstly, this needs to be considered for the server itself. For 

example, the more RAM MSSQL Server has, the better. The server database, independently from the BRAHMS 

software, will utilize available RAM for indexing, caching and querying. In Oxford, we use a server with 256 GB 

RAM although BRAHMS itself rarely uses more than 50% of this. If you are using a server database such as 

MSSQL Server, make sure the database has access to as much RAM as possible. 

The RAM requirements also need to be considered for the workstation where you are running BRAHMS from, 

even if the software is stored on a separate server. Running BRAHMS on a poorly resourced workstation, even 

if your server is well resourced, will not give the best result. For average use, the workstation you are using 

should have at least 8GB RAM but ideally 16GB or more. 

https://aka.ms/vs/17/release/vc_redist.x64.exe
https://aka.ms/vs/17/release/vc_redist.x86.exe
https://www.7-zip.org/download.html
https://www.7-zip.org/download.html
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Whether the software is on the server (above right) or on the workstation (above left), both will benefit from being well-
resourced.  

 

Installing v8  

The software is conveniently provided as a single (copy-deploy) zip file. 

Open the zip file to any location. Do not use the default windows file extraction tool as this may result in the 

blocked security status of some files. Please use 7z or similar.   

  

After opening the install zip, you will have a software folder similar to that shown here. This folder also has a BRAHMS 
licence file. Evaluation versions do not have this licence file. 

Files/Folders Notes 
 
bin 

 
Core application DLL and ArcGIS runtime files. 
 

 
Branding 

 
Branding banner image and other branding items as available. 
 

 
Logs 
 

 
Daily log files and any application error files. 
 

 
Modules 

 
Application DLL files linked to specific modules. 
 

 
Shared 
 

 
Shared data connection files and some other shared files. 
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BRAHMS.exe, 
BRAHMS.exe.config, 
BRAHMS.lic, NLog.config 
 

 
The main application exe file. System configuration files. The BRAHMS licence file (evaluation 
systems do not have a licence file). 

 

Initially, no installation of additional database management software is required as BRAHMS is delivered with a 

default SQLite data store. Further information on using MSSQL Server or PostgreSQL is provided below.  

 

Software and database updates 

The upgrading process  

Software updates are issued periodically.  Users who are within their licence period are eligible to download all 

categories of software update.  

Notification of updates with a software download link are sent to all licensed users and a summary of the 

update content is posted on https://herbaria.plants.ox.ac.uk/bol/brahms/software/revisions  

The new software folder replaces the existing software folder. As soon as you log into any database, the system 

will inform you if database structural changes are needed. If databases changes are needed, you can then 

proceed to auto-update. The database update process uses scripts that are drawn from the BRAHMS website. 

You need to be online to use the update options.  

If you have not updated your software for a longer period, several scripts may be needed and these are 

automatically run in the correct sequence. The same applies to RDE files. The entire update process is 

automated. 

 

As soon as you log into a database that requires updating, the system will inform you if database structural changes are 
needed. 

For further details on updates, refer to: 

https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_upgrading.pdf 

 

BRAHMS server access requirements for updates 

If it is necessary to update the structure of your database or your RDE files, the necessary scripts to run, as 

determined by your current database versioning ID and that of the newly installed one, are located by BRAHMS 

on the BRAHMS server. You need to be online and have access to these scripts - otherwise you will receive an 

upgrade failure message. 

Normally, access to https://herbaria.plants.ox.ac.uk should be sufficient. This is just a web server where the 

BRAHMS *.zip downloads are located and you should permit access to. If more specificity is required then 

https://herbaria.plants.ox.ac.uk/bol can be used. If you need to restrict it further, you would need to permit 

any .zip file download from https://herbaria.plants.ox.ac.uk/bol/content/software/vu/updates/. Please note 

that this URL is not directly viewable as browsing that location is not permitted and thus it would return a 

'forbidden' status unless a valid zip file name is appended for download). 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/revisions
https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_upgrading.pdf
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Logging into BRAHMS 

Brahms.exe and creating desktop shortcut 

The top-level BRAHMS software folder contains the file brahms.exe which you run to start the application. You 

can create a shortcut to this in the normal way. The shortcut on your local desktop may point to the software in 

any accessible location, be this local or on a drive /server that you have access to. 

Note: if you have file extension hidden on your PC, the correct file to run in the one with blue database icon. 

There is another file called brahms.exe.config which is not the application file. 

 

At this stage, if prompted to update your .NET version, proceed to do this and preferably, re-start your PC. 

Login to the personal data store 

After installation, you must initially log into BRAHMS using the Personal Data Location. The system will initially 

default to Windows Authentication using your Windows identity and thus you do not need to add a password. 

 

After installation, logging in using Window Authentication to the Personal database, no password will be needed. 

When you first log in, the system auto-creates an empty SQLite data store called brahms.db in your 

Documents/BRAHMS folder. The folder itself is created automatically. This may be on your physical PC or on a 

network drive with roaming user profiles. In the latter case, you will be able to access it from different work 

stations. 

If for any reason you cannot log in under Windows Authentication, change this setting to BRAHMS 

Authentication on the log in form. Choose any user name and a password. Passwords are case sensitive. In this 

case, the user name and password will be added to the BRAHMS user file. You must remember a BRAHMS user 

name and password. 

 

Logging in using BRAHMS Authentication. 
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First log in and database ownership 

The first log in to a newly created database assigns ownership to that database. Thus, if you log in using 

Windows Authentication, your windows account will, initially, be the only way to open the database. Adding or 

editing different users is discussed in the users and permissions section. 

 

The Database Projects Manager form opens 

As initially, the default personal data store is empty (it has no database projects), the first log in will auto-open 

the Database Projects Manager screen with options New and Import. At this stage, you have three choices: 

• Create a New database project. 

• Import data from an XML folder you have been provided. 

• Close this form and move on to connecting the demo or another database. 

 

 

This form auto-opens when there are no database projects available in the current data store. 

The Documents/BRAHMS folder 

When you first log in, by default, a folder called BRAHMS is created in your Documents folder. This is used for 

the location of the empty brahms.db data store and some setup files.  As discussed below, a different folder 

can be assigned. 

 

 

If you delete the BRAHMS folder, it will be recreated when you next log in. 

 

File/Folder Notes 
 
brahms.db 

 
The default SQLite datastore, initially empty.  

 
datalocations.dat 
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Encrypted binary file storing connection strings (connections to data stores). All database project 
details (their names and descriptions) are stored in the data store itself. Once you connect to a 
data store, the database project(s) within the store are listed allowing you to choose a log in – 
unless there is only one database project in which case, it logs you directly in. 

 
localbrahms_v1.config 
 

 
User specific configuration file holding background image mode, tag highlight colours and a few 
other settings. Data are stored in JSON format. 

 
Columns 
 

 
Visible column definitions are stored here as in the species file examples: 

 
The .dgc extension refers to Data Grid Column. These files can be exchanged with other v8 users. 
Also stored are files with .lcv extensions. These store your used last column view per table. 

 
Exports 

 
Any files exported from BRAHMS are stored here. This includes Excel and CSV files. 

 
RDE 
 

 
RDE files are stored here by default – but you can set up separate RDE storage folders. 
 

 
Each .rde file is a self-contained SQLite database with the RDE file metadata, the data itself, 
image links and edit history. 

 

Choosing a different folder to Documents/BRAHMS 

On some networks, it may be preferable to choose a different folder to Documents\BRAHMS as the default 

working location for storing those files normally stored in Documents/BRAHMS. For example, in some cases, 

especially where roaming profiles are used, the Documents folder may cause problems with file access if the 

path has hidden components. 

In these cases and/or you prefer not to use your Documents folder, you can copy a small txt file to the BRAHMS 

software folder which includes a valid path name. The file must be called UsersFolderRoot.txt.  

 

BRAHMS software folder with a UsersFolderRoot.txt file in place. 

An example entry is C:\BRAHMSROOTFOLDER. In this case the folder would be created (if it is new) on the 

user’s local C drive. The path could also refer to shared network drive which may use drive letter or UNC file 

path. In this case, all users who are using the same BRAHMS software client will have a subfolder created 

within selected network folder. The subfolder names will reflect the user identity. 
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Troubleshooting on logging in 

          

 

If the copy/deploy BRAHMS install zip is opened using the Windows default extraction, this may block access to 

some BRAHMS files. When logging in, you may see a message similar to the left-side screen above. The solution 

is to delete your BRAHMS software folder and then again open the zip file you have downloaded using 7z 

https://www.7-zip.org/download.html or another utility. Another possible explanation is your security system 

(e.g. anti-virus) requires you to include brahms.exe as a trusted exception. 

If the error is similar to the right-side screen above, you need to download the Microsoft Visual c++ 

redistributable as on:  

https://aka.ms/vs/17/release/vc_redist.x64.exe for a 64 bit system   

https://aka.ms/vs/17/release/vc_redist.x86.exe  for a 32 bit system 

(This will work for 2015, 2017, 2019, and 2022 versions) 

 

 

 

 

  

https://www.7-zip.org/download.html
https://aka.ms/vs/17/release/vc_redist.x64.exe
https://aka.ms/vs/17/release/vc_redist.x86.exe
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Data stores and databases 

The difference between data stores and database projects 

The data store refers to the location of your data. It is a physical store in a database management system 

separate to BRAHMS itself. For example, you may opt to store your data in MSSQL Server, PostgreSQL or 

SQLite. Each of these is a database management system. 

 

How many databases in a store? 

A given data store may include more than one database project. If a single store has multiple database projects 

(left below), the data are not mixed. If you open a data store with more than one database, the first thing 

BRAHMS does is ask you to select which database you want to open. You could also create a new store for each 

separate project (right below). The choice is an institutional matter – the result is very similar. 

 

A single data store may include many separate database projects (left).  Alternatively, projects may opt to create a separate 
data store instance for each database project (centre). For improved integration, related data can be combined in a single 
database project in a single store (right). 

One database for all? 

Storing museum data of different types in separate databases may not always be the best option. Consider that 

you want to query on all collections or taxa from a selected area or collected during a certain period or by a 

selected collector – based on all preserved animal and plant records, living collections and fossil records. If 

these data are combined in the same database, this is possible. But if the data are separated in different 

databases, it is harder to get the combined results. You would have to somehow combine the data after 

querying separate databases.  

BRAHMS is designed to store and integrate data across collection categories. There is no limit to the number of 

records and in any case, if you want to query only the Anacardiaceae or Hymenoptera, you can do so. 

Note that if data are stored in separate databases, it is possible to connect these to a single web portal via 

BRAHMS Online, thus combining the queries there. 
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SQLite requires no installation 

One of the advantages of SQLite (= ‘Local file system’ in the BRAHMS documentation) is that it requires no 

installation. SQLite datastores can be copied onto your workstation or server either as an empty store or 

containing one or more databases. After linking your BRAHMS software to the store, you are ready to go.  

When you install BRAHMS, it comes with an empty SQLite store file called brahms.db. This is created in your 

Documents\BRAHMS folder when you log in to BRAHMS after installation. If it is missing in that location, an 

empty brahms.db file is always created.  

The demo conifer database is provided as an SQLite store. SQLite is also used for all RDE files. 

MSSQL Server and PostgreSQL need an extra step 

If you are planning to use one of these stores, you first need to install the required software. This is something 

that you would normally have done by your IT section. However, PostgreSQL and MSSQL Server Express are 

free and can be easily installed by yourself on your local PC. 

Once the server store software itself is installed, BRAHMS has an option to create the necessary data structures 

directly from the Data Connections form. However, on an institutional server, you may need administrative 

access to MSSQL Server or PostgreSQL to do so. The procedures to do this are discussed in this guide. 

 

Multi-user access 

All data stores and databases within them can be used for multiple user access. Other than the terms of your 

BRAHMS licence, there is no restriction on the number of users that can simultaneously access a given 

store/database. 

 

Simultaneous edits of the same data by two or more users are discussed in the section on Edit conflicts. 

Choice of store 

SQLite is intended for small to medium sized projects. It is portable and the entire data store is easily moved 

from one location to another by copying a single file. BRAHMS always uses SQLite for RDE files which are 

designed to be entirely portable, operating on a server or from a memory stick.  

SQLite is less suitable for large multiple-user projects. Such projects will use MSSQL Server or PostgreSQL with 

appropriate security and maintenance. Having said that, SQLite can store millions of records – refer to 

https://sqlite.org/about.html.  

 

Data Store Licensing Notes 
SQLite Free Provided with BRAHMS. Used for the default personal data store, 

the demo database and all RDE files. It is possible to download the 

https://sqlite.org/about.html
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SQLite database browser but this is not a requirement. See 
https://sqlite.org/index.html. 
   

MSSQL Server Express Free 2008 R2 or later see e.g. https://www.microsoft.com/en-gb/sql-
server/sql-server-downloads will function but not strongly 
recommended for large (tables with > 500,000 records), multiple 
user databases. 
 

MSSQL Server Licence required 2008 R2 or later see e.g. https://www.microsoft.com/en-gb/sql-
server/sql-server-downloads – scalable to any size. 
 

PostgreSQL Free 9.3 or later see e.g. https://www.postgresql.org/ - scalable to any 
size. 
 

 

Current options for data storage in BRAHMS v8. 

 

https://sqlite.org/index.html
https://www.microsoft.com/en-gb/sql-server/sql-server-downloads
https://www.microsoft.com/en-gb/sql-server/sql-server-downloads
https://www.microsoft.com/en-gb/sql-server/sql-server-downloads
https://www.microsoft.com/en-gb/sql-server/sql-server-downloads
https://www.postgresql.org/
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Data connections 
If you have problems connecting to a database, refer to the Troubleshooting section at the end of this section. 

Introduction 

The BRAHMS software is independent from any data store you choose to link to. To allow BRAHMS to access 

data, you need to add at least one data connection. Data connections have a name so that you can identify 

them. They also have properties that describe the connection. An example connection name could be ‘BRAHMS 

on Server 1’. The properties of the connection would include the type of data store, its physical location or 

address and, when needed, access permission details. 

 

You may have one or more data connections. Connections may be to different types of store in different file or server 
locations. When you install BRAHMS, a default SQLite connection is added. This is called ‘Personal’ and the location is in your 
Documents\BRAHMS folder. Each user has their own personal data store. 

All connection details are stored in the encrypted file datalocations.dat which is located in your 

Documents\BRAHMS folder.  

Data Connections, Servers and IT help 

If you plan to store your data in a locally stored SQLite file, you don’t need any IT support. However, for larger 

institutions with restrictions on access to servers, inevitably, you will need to have someone to provide 

access/permission to a server data store. Access to server databases is an institute level matter. As a project, 

we can advise on storage strategy. But to implement this, you may need support from a server administrator or 

your IT section. 

SQLite connections 

When you install BRAHMS, an initial connection is auto-added to an empty SQLite data store. The connection 

name is “Personal”. The data store has a default location in your Documents\BRAHMS folder and the data store 

name is brahms.db. Initially, this is an empty file with no database projects. To create a database (or databases) 

in this store, you will use the database manager. 

SQLite connections require no special permissions to use. They do not need the installation of any extra 

software. In summary, you simply browse to locate the database file. This file can have any name but it will 

have an extension ‘.db’ as in brahms.db or mydatabase.db.  

 

You can create a new SQLite store and/or browse to locate an existing one. 
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To create a new SQLite store, Select System > Manage Data Connections > New. Provide a name for the 

connection. The connection provider will be Local filesystem (SQLite). Choose Create a new file and choose the 

folder location and file name as prompted. 

To connect to an existing SQLite database, copy the file you have been given (e.g. ‘sampledatabase.db’) to any 

accessible folder location. Select System > Manage Data Connections then New entering a suitable connection 

name (e.g.  ‘My Sample Database’). Select the Browse for an existing file… option to locate the file. Save this 

and then close the form. Finally, select System > Sign out then log in once more choosing the connection name 

you added above. 

 

Creating a PostgreSQL connection and database 

Creating a PostgreSQL database and the connection from BRAHMS to it involves a few steps. The way 

PostgreSQL manages the security for database connections is different to MSSQL Server.  

Assuming you have installed PostgreSQL, you should be able to do everything else from within BRAHMS. Please 

follow the steps carefully.  If you need to install PostgreSQL on your server or on your local PC, see 

https://www.postgresql.org/download/ or similar. 

The task here is create a new database and the required database connection to your PostgreSQL server, 

wherever this may be. 

• For the following steps, you can be logged in to any BRAHMS data connection including the SQLite 

personal database. 

• As a first step, select System > Manage Data Connections… then New. 

• Choose a Connection Name. This name will appear eventually in your BRAHMS login form as a data 

connection option. 

• Choose the PostgreSQL Data Provider as the Connection Provider. 

• Then select Create… to initiate the process. 

 

The first steps are shown above. 

 

 

 

 

 

 

 

 

 

On the Create form, the settings will be similar to the above. The purpose of this step is to create a PostgreSQL 

database – not a BRAHMS database. Confusing? It is a bit - but PostgreSQL needs to have an underlying 

https://www.postgresql.org/download/
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database created before we can go on to the next step. If you can pass this security test, you are well on the 

way to creating the new database. 

The Server Name here is the standard representation of the IP address of ‘localhost’ on your local PC. If you are 

creating a connection on another server, the server name entry will be the Domain Name or IP address of the 

server that is hosting PostgreSQL. 

The Server Port as shown here is the standard port used to connect to a PostgreSQL server. Note that while 

this value is configurable by the administrator of the server, it is unlikely to have been changed. 

The User ID and Password entered above will be the credentials of a user who has permission to create a 

PostgreSQL database. Normally, this will be so called PostgreSQL ‘superuser’. The superuser will have been 

established when PostgreSQL was installed. This user name and password is only needed to create a new 

connection. It is not otherwise used by BRAHMS. 

Note: it seems that if a user with permission to do so (e.g. the superuser) uses PostgreSQL admin tools to alter 

table structures, any other user credentials may be re-set. 

Use the Test option provided to check your connection works. Assuming it does: 

The next screen asks for another User ID/password – this is a bit confusing. The user ID and Password added 

here should be different to the superuser for security reasons. You can create new ones if necessary. This user 

ID/password  will be added as a Login/Group Role ‘account’ on the PostgreSQL server and these credentials are 

then used to connect to the server and to create the actual BRAHMS database structure in a next step. 

 

Assuming you have permission to do so, you can select an existing or add a new user ID /password here. The 

password you add above must have a minimum of 6 alphanumeric characters to enable Add User. 

 

 

When entering a Database name, you must keep it lowercase and with no spaces. 

In the next stage as shown above, choose a lowercase name for the PostgreSQL datastore – do not include 

spaces. This is not the name of the actual BRAHMS database – rather just a server store name. Once you select 

Create this Database, BRAHMS will proceed to set up an empty BRAHMS database/store inside PostgreSQL. 

This store will have all the BRAHMS tables, views, indexes,  etc. 
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If this step is a success, you can then Finish and move to the final step.  

Use System > Sign Out and then, on the BRAHMS login screen, choose your new connection name as added 

above in step 1. 

When you first log in to BRAHMS, you can use Windows or BRAHMS Authentication. If using  BRAHMS 

Authentication, do not forget the username/password you select as this will be added as the default log in 

credential. You can of course then proceed to add further users and passwords. 

After this stage, you can use the BRAHMS options to import data from XML or to create one or more new 

empty database projects in the new PostgreSQL datastore you have just created. If creating a new database 

project, this is where you add the database name e.g. “Conifers of the World”.  

 

            

The above images show the steps as they build up in the PostgreSQL manager. The first image is before we start. 

The middle image shows the addition of a new account name here called ‘BRAHMSUSER’. The final image is 

after the creation of a new database (perhaps better called ‘data store’ here called ‘mybrahmsdb’. Note: you 

don’t need to have access to the manager to create a database. 

 

Creating a MSSQL Server connection and database 

The processes to create a connection to an MSSQL Server database are broadly similar to those for PostgreSQL 

and can be done from the Data Connections option.  

This example, which uses the express version of MSSQL Server, assumes you are creating a database on your 

own PC and thus can avoid having to use a DBA login and/or set up additional access rights.  You can easily 

install MSSQL Server express on your local PC. When doing so, we advise you also install the MSSQL 

Management Studio. If you have doubts, consult your IT colleagues. 

If you are using the licenced full version of MSSQL Server, you will probably be connecting to this on another 

server and in this case, will have to check that you either have the access to create a new store or that this is 

done for you and you are able to establish the connection. 

• For the following steps, you can be logged in to any BRAHMS data connection including the SQLite 

personal database. 

• As a first step, select System > Manage Data Connections… then New. 

• Choose a Connection Name. This name will appear eventually in your BRAHMS login form as a data 

connection option. 

• Choose the MSSQL Data Provider as the Connection Provider. 

• Then select Create… to initiate the process. 
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Choose a connection name and set the provider to MSSQL 

           

Depending on how you installed MS SQL Server, you may be able to use Windows Authentication or you may choose to use 
MSSQL Server authentication to access the server and create a new database. For example, if you installed SQL Express on 
your own PC, and you are not connecting to this from another PC/location or over the network – then windows 
authentication can be used. In most cases SQL Server authentication will be the best choice. 

The test should lead to a ‘Test Connection Succeeded’ message. Note the format used to refer to your  local express server. 

To create a data store, the User ID/password usually are the credentials used by the DBA (Database 

Administrator) with permissions to create a database and user accounts on the server.  

 

 

Provide a lowercase, no spaces name for the database and then Create this database 

 

 

Successfully created 
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You can leave the User ID and Password blank if you are creating a database on your own PC and there are no 
administrative restrictions. Test Connection will complete the process. 

• You can now sign out of BRAHMS and log in again – choosing the store name you provided e.g. My 

Museum Datastore. You can choose Windows authentication. If you choose BRAHMS authentication, the 

system will ask you to enter a user name and password. Don’t forget these. 

 

 

 

 

On the first login, the Project Manager form will open. Choose New and enter a description of the project as prompted. Once 
completed, you can choose Load Project to open the new project in the newly created data connection. 

Where the username is BRAHMS and the password (SomePassword) should be set to something suitable. The 

first create statement sets up a login and the second adds that login to the database owner’s role of the 

BRAHMS database.  Once this is completed, you can setup and test a data connection from BRAHMS.  
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Sharing data connections 

The connections that a user has and can thus choose from on their login screen, come from the file 

datalocations.dat. This file is stored in the user’s Documents\BRAHMS folder. However, in an institution with 

many users, the database administrator may want to share a data connection for all users on the network. This 

is done using the Share option on the Data Connections form. This creates an encrypted file storing the 

connection string. This file is added to the Shared folder which is found in the BRAHMS software folder. Any 

connections added to the Shared folder will be available to all users accessing BRAHMS from the same software 

folder. Shared files are named with the data connection title e.g. 'Oxford Database.dat'. 

 

VPN access and Remote Logins 

If your connection string contains the appropriate entry for the server name, you can set up connections 

allowing users to log in from outside your institution. The connection is made over the internet. There may be 

an additional security requirement such as VPN login. The server administrator may also want to register the IP 

address of the user. Note that the MSSQL Server would have to be enabled for VPN access. 

 

 

An example server name for a connection which would allow someone with appropriate access to log in from any location. 

Another tactic is for a user to make a remote desktop connection to a server. Once connected in this way and 

with appropriate permissions, the user could clearly log in to BRAHMS and access the data store. Remote 

desktop connection approach is not recommended for large numbers of same time users unless the server is 

especially well resourced. 

 

Troubleshooting 

If you have installed the BRAHMS software on your PC and can’t find a database to open, this means that the 

local ‘data connections’ file on your PC has no data connections or there is a connection but it is not available. 

If you had a successful connection before, this may have been from another copy of BRAHMS on a different PC 

with its own data connection setup. Data connection details are stored on your PC and are not stored in the 

database or software. Note that on networks, data connections can be shared by adding the connection to 

shared folder in your BRAHMS application. 

The default Data Connection for any BRAHMS installation is the one called ‘Personal’ on the login screen. 

Unless this has been somehow edited, it will point to the file brahms.db located in your Documents\BRAHMS 

folder. This connection does not require any special installation – it comes with BRAHMS. 

What is brahms.db? This is a complete BRAHMS database structure template in SQLite format. The brahms.db 

file delivered with BRAHMS is empty – it has no actual databases in it – but they can be created/imported.  
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If there are any problems with logging to personal, please the steps below. Unless you have been provided with 

another database, your best bet for initial testing, is to connect to the demo conifer database. Then you at least 

have a system to practice on.  

• Log out of BRAHMS, go to your Documents\BRAHMS folder and delete the single file brahms.db. 

• From https://herbaria.plants.ox.ac.uk/bol/brahms/support/conifers - download the demo database for 

BRAHMS 8 and store this zip in your Documents\BRAHMS folder. This is the conifer demo database. 

• Open this zip file to your Documents\BRAHMS folder. This will create a brahms.db file which contains the 

conifer database. You can delete the zip file. 

• Now log into to BRAHMS again – choosing the data location Personal.  

• Choose BRAHMS Authentication and use the user name Demo and password demo (in lowercase). These 

are the default log in details for the conifer demo database. 

 

NB. If the log in results in the prompt: ‘Would you like to auto-update now?’, simply say Yes and proceed to log 

in again. This prompt would only occur if your software is more updated than the conifer demo as available on 

the website. 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/support/conifers
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The database manager 

Introduction 

The database manager is accessed by selecting System > Manage Database projects. While the Connections 

Manager manages connections between the BRAHMS client and your data store (e.g. an instance of MSSQL 

Server or PostgreSQL, the Database Manager manages the databases in the current data store. A given data 

store may have one or several databases - in most case, one. 

This manager provide tools to:  

• Create, edit and delete database projects from the current data store 

• Import a database from a BRAHMS XML folder 

• Export data to a BRAHMS XML folder 

The following section assumes you are already logged in and connected to a data store. 

Creating a new database project 

Log into the default personal store. If the Database Manager form does not auto-open, select System > 

Manage Database projects. On this form, Select New and enter the Project Title and a few details as 

requested.  

 

Creating a new project 

If you create more than one database in the same store, when you next log in to this connection, you’ll be 

asked to choose which database to load. 

Import a database from XML 

The import option imports data in BRAHMS XML format to a new, empty data store of your choice. An example 

is the XML folder provided for the conifer demo database or any database exported from BRAHMS v7. The 

conifer XML can be downloaded from: https://herbaria.plants.ox.ac.uk/bol/brahms/support/conifers. These 

data can be imported into a new SQLite, PostgreSQL or MSSQL Server database.  

You cannot use this option to add data to an existing database. 

The XML data is always provided as a series of files in a single folder. One of the files is named 

DatabaseProject.xml, When you select Import, as show below, you will be asked to locate this file. 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/support/conifers
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Sample BRAHMS data transfer XML folder 

 

 

Choose Import to pull in data from an XML folder. This option can only be used in a newly created, empty 

database. 

 

 

With the demo conifer database, you can choose Import Everything – in fact the edit history for this database is 

not provided in the XML folder. 

 

 

The data are imported with progress shown on the status bar. 

Export an entire database to XML 

The Export option on the Database Manager form is used  to export all data from a selected database. This 

option does the reverse of the Import tool described above. It creates a folder of XML files is a designated 

folder. Refer to the section on Exporting databases. 
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Connecting to the demo database 

Introduction 

The demo Conifer Database is available on:  https://herbaria.plants.ox.ac.uk/bol/brahms/support/conifers 

 

The conifer database has been provided by Aljos Farjon, RBG Kew. The conifer database includes all published 

conifer names with nomenclatural details, IUCN conservation codes, TDWG geographic distribution codes, 

species descriptions and more. It also includes specimen data across the group, almost all referenced for 

mapping. The database also includes sample living collections data from Oxford Botanic Garden.  

The database has been used as the basis for:  A taxonomic monograph on Pinus for Latin America (Farjon, A. & 

Styles, B. T., 1997. Flora Neotropica Monograph 75, The New York Botanical Garden; A World Checklist And 

Bibliography of Conifers, Aljos Farjon, 1998; A Monograph of Cupressaceae and Sciadopitys, Aljos Farjon, 2005;  

A Handbook of the World's Conifers. Publication: 2010; An Atlas of the World’s Conifers, an Analysis of their 

Distribution, Biogeography, Diversity and Conservation Status, Aljos Farjon and Denis Filer: 2013. 

 

Importing the demo database as XML 

Refer to the instructions provided in the section above on Import a database from XML. 

Connecting to the SQLite database 

Rather than import the XML, you can also download a ready-made SQLite version of the same database. 

Download and open zip 

• Download the SQLite file from https://herbaria.plants.ox.ac.uk/bol/brahms/support/conifers 

• Open the zip to create the file brahms.db  

• Copy the file to your Documents\BRAHMS folder overwriting the default brahms.db file 

• Log into Personal using the credentials:  

Authentication:  BRAHMS Authentication 
User name:  Demo (not case sensitive) 
Password:  demo (lower case) 

https://herbaria.plants.ox.ac.uk/bol/brahms/support/conifers
https://herbaria.plants.ox.ac.uk/bol/brahms/support/conifers
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Connect to conifers in a different location 

If you prefer to set up an entirely new connection to conifers, perhaps on a shared drive thus allowing multi-

user access, follow these steps: 

• Copy the downloaded demo database file to any folder location. You can optionally rename the file 

from brahms.db, for example to conifers.db.  

• Select System > Manage Data Connections… then New and enter a connection name such as Conifer 

Database. The Connection Provider will be the default Local Filesystem.  

• Use Browse for an existing file to navigate to the database file and then select Save and then Done. 

• Sign out. When you next log in, change the Data Location to ‘Conifer database’ or as added above. 

 

Browse to locate the downloaded conifer.db sample database - then save. 
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Managing user accounts and permissions 

Introduction 

Users and database permissions/access information are included and copied within a given data store. Thus, if 

you copy a personal data store or an MSSQL Server .bak file to another location, the user information will also 

be included. Passwords are encrypted.  

Do not copy a database to another user with only a Windows login as they won’t be able to use that. Include at 

least one BRAHMS login option. RDE files do not require user login details. 

View and edit the database project members list 

The database project members list is opened using System > Manage Users and Permissions. This User 

Management table lists all users with their database memberships. Users registered in the user list who have 

no database memberships will not be listed in this table. A user with access to three separate database projects 

will have three entries. 

 

The database members table lists all users with database membership(s).. There is one entry per user per database project. 
Thus, if the data store includes 2 database projects and a user has access to both, the user will be listed twice in this list. 

As well as providing the user name, this list indicates whether they are a system administrator, and their 

project role as manager or user. In Edit mode, the Project Role can be changed. The names and other fields in 

this grid can be searched and filtered as in any other data grid. Passwords are encrypted and cannot be seen. 

Note that the System Admin? option cannot be edited from this screen as this is a property of the user rather 

than database membership. 

Editing the user list 

Adding and editing users 

To edit the user list, select the User List option above the database membership grid. This option is only 

available to System Administrators.   

 

 

To add new user account, select the New user… option.  The tab Add BRAHMS User asks you to add in the 

name details and whether they are Admin or not. The other options, Add Windows account and Add Domain 

User do not require that you add a user name/password as this information is known by the windows/domain 
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account. Select Finished after adding the name entry. Login authentication methods are further discussed 

below. 

A note on passwords 

Passwords are case sensitive and encrypted. If you forget a password there is no way to visualise it. The only 

solution is to get the system administrator to use the reset password option when editing a user entry. 

 

Passwords can be reset by the system administrator. 

If you are copying a database to another user, optionally delete your Windows/Domain account entries as 

these will be of no use elsewhere. Certainly, you need to make sure you add at least one BRAHMS user log in 

(ideally with Administration status) so that the user can log in. This is why the demo conifer database is 

distributed with the BRAHMS log in user: Demo + pw: demo. 

Assigning database access to a user 

Having connection access to a data store does not mean that you can open the database(s) within it. To have 

access to a database project or projects within a store, you must have access permission.  

 

In the above example, a data store includes only one available project. To provide the currently highlighted user (not visible 
on this screen) access to this database project, use the Add-> option. 

Thus, the task of the System Administrator (or in this case also the Database Manager), once users have been 

added to the user list, is to ensure they are given access to the appropriate database project(s). 

Users roles 

A user may be designated as an Administrator, Database Manager or a User. Access rights vary in each case. 

When adding a new user, you can make that user a System Administrator by selecting that option on the new 

user form. Administrators have access to all options including adding and editing the user list. 

A user can also be made Database Manager. This means that the user has access to the entire database and 

can assign user access to databases they manage. 

 

To set a user as a DB Manager, select Edit mode and then use the dropdown in the Project Role field. 
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Login authentication methods 

Three types of user login account are available. It makes no difference which is used to the options available in 

BRAHMS after log in. The login method does not influence the access and permissions settings.  

BRAHMS User 

The user can log in from any work station using a BRAHMS user name. Must enter user name and the password. The default 

Admin level user name and password for the sample conifer database is Demo + demo. These credentials are distributed 

with the conifer database. 

Local Windows Account  

This is windows authentication on the user’s local workstation. No user name or password needed when logging in using 

Windows Authentication as you have already logged in to your PC. 

Domain User 

Database administrators can add users based on their Active Directory domain accounts. To do this, when adding new 

users: 

Select the Add Domain User tab. The Domain name is the name of the domain as per your active directory setup. The User 

name and password will be the username/password for anyone who has access to search the active directory.  

Once these details have been added, the available User Login Domains can then be loaded using the  Load option. There 

may be more than one. If the User Domain you want to use is not included (this happens on some Active Directory setups), 

you can type it in. 

 

Using Surname to Find, you can then select and add users. 

Issues with adding users and using domain login 
Please note that in the current BRAHMS version, when a user logs onto their PC (not BRAHMS), it is necessary that they log 

in using the same casing for the domain and the user name as is listed in the BRAHMS user list.  Or put differently, make 

sure that the user entries are added to the BRAHMS user table in the same case that they typically log in using. This 

limitation is likely to be removed in a forthcoming software update. Also, if your user’s PC log in name is different to the 

actual domain name, when registering users, as on the above screen, you can edit the value displayed in the User Login 

Domain text box when adding new users. 

Access and permissions 

Introduction 

This section refers to access and permissions within a selected project. Each user can be assigned access rights 

to a selected database project. The same user may have different access rights in different databases. 

Permissions can only be edited by the system administrator or database manager (for databases managed).  

With larger projects where there may be many users, the need to control access and editing rights to specific 

categories of data becomes ever more important. For example, only some users may be able to edit your 

central species list – while others may only be able to view and query this list. 

The permissions and access settings can also be used to simplify the entire system for users who do not need to 

see the entire range of menu options. For example, a volunteer working on entering new museum accessions 

may have a BRAHMS interface that only shows the Rapid Data Entry menu. 
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A set of permissions can be created and saved as named permissions set. This set of permissions can then be 

assigned to other users.  

Permissions influence the following features: 

• The modules or components of modules that a user sees – modules can be completely hidden. 

• Where access is provided, this can be set as Read Only or Read and Modify. 

• Where Read and Modify access is given, additionally, users can be assigned access to Add, Mark records 

for deletion and Remove records marked for deletion. 

• Additional features can be edited e.g. the ability to Merge records or Edit map points. 

Editing user permissions 

Open the User Management table using System > Manage Users and Permissions - then select the 

Access/Permissions option. 

 

With the User Management table open, select the Access/Permissions option as shown here. 

Options are divided across three tabs: 

 

Tab1 for Modules and Data: In this example, a permissions set ‘Sample profile’ has been created. For example, the user has 
Read Only access to the Taxa module. Full access is provided to the Geographic module including the ability to Edit, Add and 
Delete records. On the other hand, in Preserved specimens, this user can Add and Mark records to delete but not finally 
delete those records. Various other settings have been provided.  

Tab 2 for specific actions: Various further settings can be edited per user profile. 

Once you have edited the settings, you can enter a name for this set of permissions in the Apply As text box. 

This will be enabled when you enter a permission set name. You can assign this set to other users.  

 

Note that the permission set name appears in the user grid. 
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Tab3 for Events: the options here control which users have permission to edit plant events. 

 

Access permissions to RDE folders 

Access to Rapid Data Entry folders is discussed in the section on Assigning permissions to RDE folders. 

 

System broadcasting 

The option System > User Notification… can be used to send a message to all currently logged in users, as long 

as these users are using the same client software. While this feature can be used to distribute any message to 

users, one of its key purposes would be to advise users to log out so that the system can be updated. 
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BRAHMS setup options and language 

Introduction 

Setup options are accessed from System > Options… The options are gradually expanding, those currently 

available are listed below. Note that user permission options are used to define user level access and 

permissions. 

System background 

To set your BRAHMS application background image, select System > Options > Background Image. You can 

display background images from your own image gallery choosing the relevant BRAHMS setup option. 

 

(NB The Bing image of the day option has been removed for now until we can clarify potential copyright issues) 

Language 

BRAHMS is international with respect to the interface and the storage of data. Translatable resources files are 

used to manage interface components. This means that the entire system is easily translated to any language. 

 

 

 

All system text that appears in the BRAHMS application is drawn from translatable resource files. If you require a different 
language, you can request this from the BRAHMS project. 

Formats for taxa names and authors 

You can control how author names appear in calculated species names. For example, you may want to exclude 

authors or only include the lowest ranked epithet author name. 
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Note: If author names are excluded by default, you can override this on a name by name basis using the Force 

Author options found on the main Species form: 

 

No force:  Alnus incana subsp. rugosa var. occidentalis 
Force all:  Alnus incana L. subsp. rugosa R.T.Clausen var. occidentalis (Dippel) C.L.Hitchc. 
Force last:  Alnus incana subsp. rugosa var. occidentalis (Dippel) C.L.Hitchc. 
 

Your institution code 

 

Registering the code of your institution. This is used in the system as your default code. 

Shared folder locations 

Certain files can be shared between users. These include saved columns views, reporting templates, documents 

and images. Thus if your project create a useful reporting template for labels, you can make sure other can use 

this reporting template. By default, the share folder is the subfolder provided within the application folder. 

Shared folders should be accessible to all users. For further information on sharing column views see section on 

saving views. 
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Mapping 

The mapping tab is currently used to enter the location of the exe files for GIS options. By default, BRAHMS will 

try to locate the GIS installations using your computer’s registry entries but sometimes, this is not possible. The 

settings here assure that BRAHMS can locate the software. 

 

GIS exe locations. 

Modules 

The settings here can be used by individual users to control the main menu options they see. Note that the 

database manager may apply restrictions using the Access and Permission settings. The access and permission 

settings override the user module settings. 

Banner image 

The selected banner image appears through the system for example on all form headers. The image is stored in 

the file banner.jpg in the software Branding folder. After changing this file, log out of the system then re-login. 

     

 

 

An example banner in use. 

 

Supressing form banners 

As form banners use up screen space, it can be convenient to hide these banners by default rather than hiding 

the banner manually from the opened form. 
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All forms have a Show Banner option. Form banners are on by default. Use the set-up option provided to hide banners by 
default. 

Background image 

Use the settings here to choose the application background image.  

         

Choose your background image setting. Unfortunately, Bing image of the day is restricted to developers die to 

copyright restrictions. Using My images,  you can register as many images as you wish to display in a cycle. You 

can use the controls at the bottom of the main application window to pause of step through your images. 

 

Font settings 

The settings here control the font name and size used through the system. 
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Choose any font and text size. You can restore the default settings. 

  



BRAHMS v8 introduction and guide  56 | P a g e  

Grid Options  

• Adjust tag colours for dynamic record colours  

• Choose your preferred data grid line options 

• Suppress column header sorting 

 

Tag Colours 

Tagging and editing tag colours are discussed in the Tagging section of this guide. 

 

Data grid line options 

 

 

Alter the appearance of your data grids. 

 

Column sorting 

 

Further information is provided in the section on sorting records. 
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Data grid fundamentals 

Introduction to data grids and their performance 

Data grids present data from your database tables on your screen in spreadsheet format. The grids come with a 

context enabled menu ribbon and toolbar options, rather like MS Office applications. The grids include data 

from the currently selected table but they also pull in data from related tables as required. For example, with 

Collection Events, many of the data columns you see are from related tables such as the taxa, geography and 

people tables. By default, data are not presented in any recognisable sort order.  

Some data grids display data from many related tables. These table relationships and the data they present on 

your screen are managed by various layers of the BRAHMS system starting with the DBMS itself where the 

tables, their indexes and relationships are managed and then ending up as data on your screen. One of the 

functions of BRAHMS is to gather these data together, correctly related, and allow you to browse through your 

data.  

 

A typical data grid, here from collection events. The data in this grid example come from several tables: Tags are stored in a 
user-specific tag table; collector names come from the people/name-strings table; and the taxa fields some from the family, 
genus and species tables. 

As well as using the resources of the computer storing the database, often a server, these activities are 

optimised to take advantage of the resources of the workstation you are working on, notably the available 

RAM. With large databases, the data should be stored on an adequately resourced server. With personal 

databases, the database and BRAHMS software are likely to be on the same computer. 

Clearly, the system cannot bring all the data from large tables into view or into your workstation memory at 

one time. There may be many millions of records in a single table. Rather, it pulls data from the database store 

as you move up and down the data grid. The process used is called data virtualization. In fact, more data are 

pulled from the database than you can see at one time and this smooths out the process of browsing. 

If you page down through a large table, you will periodically see a small triangle of points displayed in the 

bottom right corner of the data grid. This indicates that the system is pulling more data from your database and 

supplying these data to the BRAHMS data grid. If you rapidly page up or down through the data, the data 

triangle appears more frequently. If the triangle seems to spin for a longer period, it implies the server is busy. 

 

The data access triangle indicating that the system is busy pulling new data from your database into the grid. 

If you are working with large tables, for example those with > 500,000 records, you will experience longer 

delays if you attempt to drag the grid vertical scroll bar up or down. This behaviour is well documented in 

virtualized data grids. In practice, it is not normally necessary to use the vertical scroll bar. In any case, to locate 

data effectively, you should use one of the filter/query options. 
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Working on a small screen? 

Note: if you are working on a small screen, toolbars may collapse in the manner shown below. 

 

Normal screen. 

 

Small screen. Where toolbars are collapsed as with Tag, Calculate and Import/Export above, clicking on the 

toolbar option lists the hidden toolbar options. 

Using data grid tables 

Opening and closing tables in data grids 

By default, BRAHMS uses versatile data grids with context sensitive toolbars to browse, locate, select, sort, 

edit, query and analyze your data. Data tables are opened using a single click on the selected menu entry. The 

use of forms is discussed in the editing section. 

• On the Taxa menu, click once on Families.  

When a table opens, the toolbar will usually change to Data Tools as this is where you will likely find what you 

need to do next. For taxa specific tools or if you want to open another taxa table, return to the Taxa menu - or 

another menu option as required. 

• To close a table, select X on the table Tab (as displayed above the data grid).  Alternatively use Alt+X 

Opening multiple tables 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple   

You can open and utilise different tables at the same time. The task here is to open the main family, genus, 

species and collection events tables. 

• On the Taxa menu, click once on Families.  

• Return to the Taxa menu and click on Genera. Repeat this now for Species. Note that each time you open 

a table, the Data Tools toolbar is activated – so you have to return to the Taxa menu.  

• Finally, on the main menu, select Collections and choose Collection events. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple  
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Each table has a tab which can be selected to view the data in that table. 

With the opened tables organised in this way, the problem is that you can only view one table at a time. The 

next task explains how to resolve this. 

Docking tables 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple   

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#opendocklink  

 

To view the tables opened in the last exercise at the same time, you can use the docking and undocking 

features. Each table can be detached from its centrally docked position and docked to the side, above or below 

another table – or dragged off the application to a different monitor. Forms, images, external web sites, maps, 

query tools and more are all dockable. 

Positioning tables and other items takes a little practice as there are many potential docking options. It also 

depends on how many monitors you have available. The tasks here assume only one monitor – but if you have 

two or more, take advantage of these to display tables fully undocked. 

• Using your mouse, drag table tabs to undock them. This can take a little practice to grab the tab correctly. 

When you drag any table to undock it, a series of yellow ‘docking boxes’ appear. The challenge is to drop 

the table on one of the docking options – the central box will redock the table as it was. 

• As a first try, drag the genus and species tables and re-dock by placing and releasing your mouse pointer 

over one of the yellow docking points.  

 

Here the genus table has been undocked and is floating above the other tables. And the species table is about to be docked 
to the right. 

• You can repeat this process with the collection events table, docking elsewhere - or move it to a different 

monitor. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple  
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#opendocklink
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The various tables rearranged with collections events dragged off the main application 

 

   Dock position options vary depending on the windows opened. Some experimentation is required. 

Setting grid appearance 

System Fonts and grid lines 

As discussed in the System settings section, you can configure grid font, text size and grid lines using the 

options on  System > Options . 

 

Header wrapping 

You can optionally wrap column headers when the column width reduces. Header wrapping suits some users, 

not others.  

 

If enabled by default on System > Options > Grid Options, a user can always override header wrapping using the 

option provided on the Grid Tools toolbar. 

 

An example showing header wrapping. 

 

Navigation and function keys 

Navigation 

There are a few tricks to learn to move efficiently between columns and rows in BRAHMS data grids. Most of 

the functions used in v8 are similar to those used in Office applications such as Excel. 
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BRAHMS draws data from the data store into the grids, and presents your data with smooth scrolling and low-

lag data virtualization, storing as much data as possible in memory.  As you scroll up or down, BRAHMS 

retrieves the relevant data to memory and refreshes the opened grid. 

• Select Collections > Collection Events to open the events table.  Activate the grid by clicking in any cell. 

The default is read-only mode, nothing can be edited. 

 

Action in non-edit mode Keys 

  

Move to the next / previous column Right / Left Arrow 

First/Last column Home / End keys 

First/Last row CTRL Home / CTRL End 

Next /Previous row Down / Up arrow 

Scroll up and down PgUp / PgDn 

Select or activate a column or cell Click in the cell 

  

  

Action in edit mode Keys 

  

Move to the next / previous column TAB / Shift TAB 

Next /Previous row Down / Up arrow or use Alt+Arrows in memo or numeric fields 

  

 

Function keys template – keyboard short cuts 

You can see the Function Key assignments by selecting Shift+F1 which opens the F Key template. Before 

selecting Shift+F1, click anywhere in a data grid. Sort list of functions by clicking on columns. 
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Adjust, save and share grid column views  

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#columnviewvideo  

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#columnviewvideo


BRAHMS v8 introduction and guide  63 | P a g e  

Adjusting data grid views 

When you open a table, the default data grid fields will be visible. You can adjust the field views using the 

Column Management options.  With any table opened: 

• Select Grid Tools > Manage Columns…  .  

 

The Column Management Tool allows you to select visible columns. 

Note that on this form you can use the Select/Deselect all option to quickly edit the selections. For example, 

you can deselect all and then choose the columns you want one by one. Also note the Filter option which is 

useful to quick locate fields in the list. 

Another handy option is the Hide Current option on Grid Tools – this hides the currently selected field. If you 

click on this option again, it will hide the next column in the grid. 

 

You can also right-click on any of the column headers. This opens a dialogue form with options to show hidden 

columns and alter the column order. 

Saving data grid views 

Multiple data grid views can be saved per table. Once you have designed a useful selection of fields, you can 

save this using the Save As option on the bottom of the Column Manager form. This will ask you to provide a 

name for the saved view. You can also save views using Save Layout on the Grid Tools toolbar.  

Default view file types and folder location 

By default, all saved view files are stored in your Documents\BRAHMS\Columns folder. In this folder, you may 

find the following file types: 

• .lcv files are for your last column views, one per table. 

• .dgc file are for your saved data grid views. 

 

 

Deleting data grid view files 

To delete any data grid view, go to the view file folder location and simply delete the physical view file. 
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Sharing saved grid views 

As an institution, you will likely want to set up commonly used grid views for different tables and share these 

with all system users. To do this, you simply copy the grid view files from the default Documents\BRAHMS 

folder into the BRAHMS application folder Shared/Columns. 

 

Views moved to the BRAHMS application Shared\Columns folder will be available to all users. These views have (shared) 
appended to the view name. 

Selecting a saved view 

On the Grid Tools toolbar, all saved views are listed and can be selected using the Layout dropdown. Here you 

will find, together with any views you have saved: 

• Default Columns: returns the grid view to the system default. 

• Last Auto-Saved: shows the view selected when you last closed the table. 

 

Sorting records 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#sorting 

The ability to sort records, aside from being vital for reporting, is also useful to simply locate records and to find 

errors.  

Column sorting 

Enable column sorting 

With column sorting enabled, you can quickly sort data grids by clicking on a column header or, as discussed 

below, select multiple headers. However, in very large databases, you may want to prevent users ‘over-clicking’ 

on column headers, sometimes when they simply want to select a column rather than sort. 

Column sorting can be enabled/disabled by default for all users using System > Options > Grid options 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#sorting
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Enable column sorting by default by setting the option on System > Options > Grid options. 

 

If disabled, a user can override the default settings using the options provided on the Grid Tools toolbar. 

 

Sort on single or multiple columns 

If enabled, tables can be sorted on single columns by clicking on the header, Shift + Clicking on multiple column 

headers or using the Sorting Tool. 

• Select Taxa > Genera to open the main genus table. 

• Click once on the Family column header to sort A-Z. Click the same column header again to sort Z-A. Click a 

third time to remove the sort.  

• You can combine as many columns as needed using Shift + Click on columns headers. 

 

 

Sort by Last Added and Last Modified 

You can quickly sort of the records in the current table most recently added or modified using the options 

provided on the Sort menu. These records will come to the top of the table. 

 

Select one of these sort options to see the most recently added or edited records. 
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Sorting species in Natural Order 

Species records can be sorted so that the names come in AZ order regardless of which epithets are added.  

 

 

         

The names on the left are sorted by genus + species. Those on the right are sorted using the Natural Species Sort option. 

 

               

 

Saving complex sort commands 

• Now open the Sorting tool. Here you can add fields of any type to create complex sorts. You can save 

complex sorts using the Save option provided. 
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Using the sort form, any combination of character, numeric, date and logical field can be selected to sort your records. 
Complex commands can be named and saved for future use.  

Sorting collection events by collector and number 

Collection event field numbers are alphanumeric and thus, by default, sorting the field number column AZ gives 

an incorrect sort order. 

    

As can be seen here on the left, sorting these Wilson, EH collections on Field Number gives a bad result. This is resolved 
using the calculated field # Field Number (sortable) shown on the right which pads the number field with zeros.   

• To display this field, select Grid Tools > # Calc Fields 

• You could now sort the collection events table on the Collectors + Field Number (sortable) fields but in 

reports, still refer to the column Field Number. 

Date sorting 

You can sort records on the audit fields Created By, Created On, Last Modified By and Last Modified On and 

such sorts are useful for a variety of purposes. When you add a new record, the data grid is auto-sorted on the 

Created On field. But you may find it useful to sort on this field (click on field header) at other times, perhaps in 

combination with other fields. 

If you want to sort collection events by date, sort on year, month and day in that field order (shift-clicking on 

fields for multiple selections). 

 

Tagging functions 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#tagging 

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#tagsandmaps  

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#tagging
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#tagsandmaps
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What are tags? 

Tagging refers to the addition of a single character to the TAG field. This field is available in all tables in the first 

position. Tagging has multiple uses throughout BRAHMS with record selection and grouping. While the default 

tag symbol is *, you can tag records with different symbols or numbers. Each of these can be assigned a colour.   

Tags are user-specific, thus one users’ tags do not interfere with those of another working in the same table. 

This is achieved by holding tags in a related table that includes the table name, the record GUID, the tag 

character and the user ID. 

 

Select System > Options >Grid Views/Highlighting to edit the default colour options. 

How to tag and untag individual records 

You can use the toolbar option (large tick icon), press F6 and or, if you are not in Edit mode, double-click a 

record. If you are in Edit mode, you can double-click in the Tag field. 

 

 

Clicking on the Tag toolbar option (or the F6 key) adds the selected symbol to the TAG field. The tag toolbar dropdown 
provides further options. 

 

Tag all, counting, filtering, clearing and inverting tags 

The Tag toolbar dropdown provides a list of handy tagging options. 
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Transfer tags Copy tags to child or parent records, e.g., species tags can be copied to all collection events, 
specimens and det history records. Or you could tag all species of tagged collection events. 

Count tags A simple count of all tagged records.  

Filter on tagged Show only tagged records 

Tag all Tag all records in table – respecting any filters 

Clear all grid tags Remove your tags from all tables – does not respect filters 

Clear current grid tags Remove your tags from the current table – respecting current filters 

Invert tags Tagged records are set to no tag; records that had no tag are tagged * 

Tag with Choose tag symbol from list 

 

Tag groups 

You can manage and save your tagged records using the Tag Group Manager. This allows you to save tags for 

any table to named tag groups. You can create as many tag groups as you need per table.  See examples on 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#taggroups. 

 

 

To create a tag group in any table:  

• Tag the records using one or more tag symbols. 

• Select Tag > Tag Groups on the Data Tools toolbar. 

• Select New Group and add a Group name at the top of the form. Then Save the new group. 

• Ensure the new group entry is selected in the left side pane of the form and then select Save Tags. This will 

add the tag details to the newly created group. 

• Close the Tag Group form. 

• You can restore these tags at any stage later on using the Load Tags option. 

 

Creating a new tag group 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#taggroups
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An example of Tag Groups. In this example, records with Red list code EN VU and CR have been tagged with the symbols 1, 2 
and 3 respectfully and these tagged records have been saved to a group called ‘Red List EN VU and CR taxa’ 

Tag Transfers 

The ability to transfer tags between related tables opens up numerous options for record selection and 

processing. In summary:  

• You can copy tags DOWN from a table to all the child records in related tables, optionally extending this to 

all descendant child records in all related tables. 

• You can copy tags UP from a table to all the parent records in related tables, optionally extending this to all 

ascendant parent records in all related tables. 

Select Tag > Transfer tags on the Data Tools toolbar. 

 

The transfer tags option. 

 

Example 1. Tag some species records and then transfer the tags DOWN to all collection events and garden 

accessions of those tagged species. Or extend this to all specimens, determinations, garden plants, seed 

records, etc. 

Example 2. Tag some species records and then transfer the tags UP to all genera of those tagged species. Or 

extend this to all genera, families and higher classification records for the tagged species. 
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Example 3. You may have created a tag group in your species table for ‘Medicinal plants’ or ‘Native species’. 

Having restored the relevant tags to your species table, it would then be possible to tag all living plants in a 

garden database that are medicinal or native. Equally, you could tag all collection events and the specimens. 

Example 4. Creating a checklist for species in a map area. In collection events, you could use the map search to 

select collection event records. After tagging all the records in the grid (auto-filtered to the map search area), 

these tags could be transferred up to the species table. In the species table, you could now select the tagged 

records and use these to build a checklist. 

Tag matching records  

Using the Match/Transfer option, you can tag records in the open table that match criteria in a selected Excel 

XLSX table. This option is described in the Match/Transfer data section.  

 

Record Zoom and Cell options 

Zoom option 

The Zoom option displays the contents of the current record as a vertical list of fields and data values in a side 

window. This is a handy way to see all the data added to the current record. You can select to include or 

exclude fields with no values.  

It also provides a useful way to navigate to data grid columns - double-clicking on a field name locates the 

column. If the column is not currently visible, it will be set to visible. 

 

 

The Record Zoom window. Double clicking on any field name in the Zoom window (here Family) locates the selected column 
in the data grid. 

Cell option 

The Cell option on the Zoom dropdown opens a docked window displaying the value of that data field. The 

window content updates as you move field or record. Also see the copy options in the section Copying cells and 

records. 
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Here, the Zoom window is opened but filtered to show fields including the text ‘col’. Also, the Cell Zoom window is opened 
and conveniently docked below the Record Zoom. 

Column summaries 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#colsum 

List values with totals for the selected column 

The column summary option lists the different values in the selected column and providing the total number of 

records per value.  

• Select Collections > Collection events.  

• Locate and click in the column # Full Name and then select the Summary option on the Data Tools toolbar. 

 

Here, the summary shows the number of collection events per species. Moving to a different column will update the 
summary – assuming Auto-update on column change is selected. Click on the summary columns to sort by field name or 
count. 

You can now open any table and test this function in any column. As you click through different columns, the 

summaries auto-update unless the form option Auto-update on column change is disabled. 

 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#colsum
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Application of filters 

The Column Summary tool also allows you to select values to filter on. You can select one to many of the values 

in the summary list then Apply Filters. 

  

The summary option can also be used to apply filters on one or more selected values. 

 

Value merging 

The summary tool also allows you to merge ‘same data’ values, typically where there are multiple entries (e.g. 

spelling errors) of the same value. Value merging is discussed in a separate section. 

Multi-Column Analysis 

The multi-column analysis tool allows to select any columns that are set to visible in your grid view and then 

total up the number of records for each combination of records. Thus, if you choose family, country and year, 

the totals will be the number of records (in the current table) per different family+country+year combination. 

The Setup/Designer tab provides option to select and adjust columns including column order. 

 

An example in the species table. You can sort and filter on the analysis results. The results can also be exported 

to Excel. Using the Filter option, you can filter the main data grid to the selected analysis row values.  

See below on how this tool can be used to mark record duplicates. 
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Locating and marking duplicated records for deletion 

Over time, your database may build up a number of duplicated records which you may want to remove. This 

does not refer to the word ‘duplicate’ in the sense of duplicated collections (specimens, plants seed, and the 

like) but rather to records where the same information has been entered more than once.  

Duplication can happen for a variety of reasons. The simplest reason is that a record is accidently added more 

than once. Another cause would be if an RDE file has been imported more than once or there may have been a 

problem where an RDE had to re-imported. With some categories of data, BRAHMS prevents duplication – but 

in other cases, it is not possible. An example would be with plant event records. 

You can use the multi-summary tool to identify duplicated records in any table by selecting all the data 

columns you wish to compare. The tool totals up the number of records that share exactly the same values for 

all the fields you include in the summary. If the Count is > 1, then the data are duplicated based on your 

selection of columns.  

Bear in mind that if you select too few columns, the duplication is not necessarily a true duplication. For 

example, if your choose family + genus + species name in the collection events table, the count will reflect how 

many collection event records have the same family + genus + species. However, if you choose e.g. Collector + 

number + Day + Month + Year + Genus + Country – and still have duplication, this may suggest there is a 

genuine  duplication. 

Once the multi summary is complete, you can use the Mark Duplicates option to mark duplicated records for 

deletion (i.e. adds * to the DEL field). This only takes place for records where the Count value  is > 1. And then 

you could proceed to delete these records in the standard way. 

 

Use Mark Duplicates to flag up records for deletion. 

Note that you can use the Filter option to auto-filter to records in the grid that match the current selection. 

This is a useful way to check that the process has worked as expected for you. 

 

Here, the filter is used to find the 3 identical records in the main grid where they can be examined. 

Tree views  

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#treeviews 

Tree Views provide an excellent way to locate, explore and filter data as well as tracking down spelling errors. 

The Tree View designer allows you to create and save your own views with up to 10 hierarchical levels, and as 

many views as you need per table. Once opened, you can then use the locate and filter options offered, for 

example 'filter on selection' when you click on any tree level. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#treeviews
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This example shows a single level view to explore by genus. With 'Filter on selection' selected, clicking on a Tree View entry 
filters to that value and updates any linked data, in this case, the map. The windows have been docked and re-sized. 

• In the demo Conifer database, select Collections > Collection events - select the Tree View option on the 

Data Tools toolbar. Default trees are provided for some tables. 

• On the form, select Tree View Designer and choose Genus. You can construct views with any fields you 

need, and in any order. 

• Optionally name and save this view – or simply load the view using the option provided.   

• Select the option Filter on selection at the bottom of the form. Clicking on and genus will now set a filter 

to that name. Click on a genus to set the filter. 

• Now, on the main menu, select Maps and choose ArcGIS in BRAHMS. This will draw a map of your selected 

genus based on the available collections. Do not restrict to Tagged only. 

• Clicking on a different Tree entry will now update your data grid and map. 

 

 

By default, the Tree View and the Map are docked together. You can drag the lower screen Tree View tab to separate it and 
arrange your windows as shown in the example above. 

Saving data to Excel or CSV 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#exporting  

Data are easily exported to Excel spreadsheets using the Tag -> Excel or CSV options on the Data Tools toolbar. 

Exporting works only with tagged records and will export the currently selected columns. 

In this task, export specimen data from BRAHMS, sorted by family and species name, restricting the export to 

some columns and the filter selection to holotypes. 

• Select Collections from the main menu and choose ‘Preserved Specimen’ using the Category drop down. 

• Select Specimens to open that table.   

• Now select Grid Tools > Manage Columns and here you can remove any columns you don’t want to export 

and sort the table as wanted.  

• Locate the Type Category column and enter ‘Holo’ or ‘holo’ in the filter bar to apply a filter on Holotypes.  

• Select Tag > Tag all 

• You can now use the Export option to save the tagged records. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#exporting
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Using the grid filter option to restrict to specimens that are holotypes. This example from the Conifer database also restricts 
to China.  

You can list all saved files using the View option on the Export Data toolbar section. 

Copying cells and records 

Copy records 

In data grids, you can click on a record to select the record. You can use Shift Click to select groups of 

contiguous records or CTRL Click to select individual records – the same as in other packages.  Selected records 

are displayed in a shaded colour. Copy the selection using Ctrl+C. You can then paste Ctrl+V these records 

elsewhere, for example to Excel. Be sure to select the correct paste option to format the data appropriately. 

Copy Cells 

You can copy the value of a cell to the clipboard using the toolbar option Copy Cell Value. The short cut key for 

this is Ctrl+K. This is a handy way to copy GUID and other data values. 

 

Note that by using Windows Key + V, you can list recently copied data values on your clipboard. You may have 

to allow Windows to do this. 

 

Use Windows+V to expose data recently copied to your clipboard. 

Data grid right-click menu 

A right-click on the data grid provides access to a handy list of options that are otherwise available on the Grid 

Tools and Data Tools toolbars. 
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Short cut menu opened using a right-click anywhere in the data grid. Some options relate to the current column or cell value. 

Field level help 

While some default field level help is provided with BRAHMS, for convenience, as from v8.5.1, projects can add 

and edit their own field help text. With any grid opened, use the shortcut Ctrl+I or select Grid Tools > Field 

Help. The field help form stays open and updates as you switch fields in the data grid. 

Adding or editing help text can be useful if you want to advise users on your own data standards, rules and 

formats – or simply provide guidance on what data to add to a specific field. 

If a user has permission allocated on the System > Users & Permissions > Specific Actions > Editing Tools > Can 

edit field description text, then that user would be able to edit the field level help text using the Edit 

Description option provided at the bottom of the text form. Note that Admin level users can always edit the 

help text. Editing text will overwrite the default text that may have been provided with BRAHMS. 

 

The field help form also provides key details on the selected field properties such as its physical table name, 

max size and read-write status. 

Field level text is stored in your database and is visible to all users. As this help text is stored in your database, it 

is never overwritten when you update the software. Thus, it is equivalent to data in any other table. 

 

Editing help text for the field Commemoration Category in the main plants table. 
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Find, Filter and Query 
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#datagridfilters  

 

Introduction 

Filter and query are one and the same thing in BRAHMS. They restrict the data in the opened table using one or   

a combination of selection criteria. You can then view, report, map, analyse or export these data.  Procedure 

you can use to filter/query and locate your data are described in this section. 

Quick filter options 

Filter to show your own edits 

To show only those records you (as the currently logged in user) have edited, select the Filter option dropdown 

Show my edits only. This will add to any other filters you may have in place. 

 

 

Restrict to tagged 

The Show tagged only option (see above screen) filters on tagged records adding this filter to any other filters 

you may have in place. 

 

Display active filter criteria 

 

 

 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#datagridfilters


BRAHMS v8 introduction and guide  79 | P a g e  

Queries using the data grid filter bar 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#explore 

Use Shift +F1 to open help with grid filter options. 

• Open the main file collection events table using Collections > Collection Events.  

• Enter values into the top filter row as shown below. You can use operators =, <, >, <=, >=  to combine 

values using capitalized AND/OR statements.  

• You can also use keywords NOT =Null (or use <> NULL) to show non-empty strings or =NULL to show empty 

strings. 

 

Using the grid filter row, you can add values to as many columns as needed. 

 

Setting a barcode range using the grid filter row. 

• You can use * to select ‘starts with’ and ‘ends with’, thus: 

   

 

Setting a filter where collector name starts with ‘ter (left) or includes ‘ter’ (centre) and right, where the genus ends ‘illa’. 

 

 

 

  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#explore
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Grid filter-bar syntax examples 

 

Press SHIFT+F1 to open help option for F keys and grid filter syntax examples. 

 

Using Conditional Operators in filter-bar searches 

 

Column Range Filters 

This option, found on the Query tool drop-down, can be used on any non-boolean column to filter on a range 

of values. Perhaps its greatest use is when searching on dates and date ranges (see below in date filter section). 

However, it can also be used in numeric and character fields. Caution with the ‘Number’ field in Collection 

Events as this is in fact a character string field. 
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An example filter on a range of collection years. The range tool auto-adds the grid filter row entry. In this 

example, if ‘Range includes the entered values’ is not selected, it would search 1891 to 1898. 

Date filters 

Date filters can be complicated as dates added by BRAHMS also include a time element as shown below: 

 

Using the exact 19/10/2021 in the grid filter row will not work because of this time element. You can type in 

“>= 19/10/2021 AND < 20/10/2021” – but that’s pretty tiresome. Thus for date filters, the easiest way is to use 

the Query drop down ‘Column range filter’ option.  
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The Column Range filter option being used to select a date range. When selecting dates, you can manually type 

dates in using the above format, or use the date lookup.  If ‘Range includes the selected values’ is not selected, 

this will exclude the actual values entered – i.e. > 01/01/2011 rather than >= 01/01/2011 etc. 

 

 

An example date filter applied using a date filter. The time element is ignored. 

 

You can also directly use the grid filter row using commands with syntax: 

< 1995-01-01 AND <> NULL will filter to any non-null dates before 1 January 1995. 

= 1992-04-29 will filter to this exact date but only if there is no time element. 

< 1994-08-30 AND > 1994-08-15 will filter to records lying between these two values. 

<= 2015-08-30 AND >= 2015-08-01 will filter to records lying between and including these two values. 

Note that AND is in CAPS. 

 

Queries using Selection and +Selection 

You can set filters on current cell values using the Selection and +Selection options.  

• Open the main file collection events table using Collections > Collection Events.  Set a filter on a cell value 

by clicking on the value and then the Selection toolbar. This option overrides any previous filters. 

• You can add multiple cell-based queries using the +Selection option.  As soon as you select Selection 

rather than +Selection, the filter will be again restricted to a single value. 

 

Using the Selection toolbar options. 

Building and saving more complex queries  

Designing queries 

• Select the  toolbar option to open the main Query Tool. 

Using the main Query tool form, you can design and save your own queries. Queries, which generate visible 

SQL commands, can mix and match fields of any type.  Each command you add is saved unless you remove it 

from the list. You can then selectively enable and combine the one-line commands and optionally name and 

save combinations of commands. 
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• Use the various drop downs to add the query command(s) you want, using Add to add the command to 

the command list. The AND/OR settings should be adjusted if necessary. 

• Use Apply filters to run the query. 

 

An example Query Tool form with previously used commands, three commands enabled. You can name and save a 
combination of query commands. The Query Tool form can be undocked and dragged off the application. 

 

 

A further example Query Tool form with previously used commands, three commands enabled.  

 

Saving a query 

To save a query, you must provide a name and use the Save option. 
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Sharing query commands 

When you save a query with a given name, you will see the query listed under ‘My Saved Queries’. Here you 

can Share the query by selecting the Share tick box. Note that you can opt to show/hide queries submitted by 

other users. 

 

Multi-Value (list) searches 

 

The Multi-Value Search enables you to copy or enter a list of values to locate and tag records in the current 

table. For example, you may have a list of species names, plant accession IDs, collector numbers, publication 

years, barcodes or transaction IDs that you wish to locate. 

Rather than searching for these one by one, the data items can be manually added to the multi-value search 

area or pasted in from a list you may have  - e.g. a list of values in a Word doc or an Excel column. NB. You can 

use this for barcodes but bear in mind, there is an additional barcode search option on the Collections menu 

toolbar. 

 

Help is provided when using this option. 
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Use Run Search to initiate the search, confirming your search as prompted. 

 

 

Search results are summarised with the values found and not found. Found values are tagged. If there is more 

than one value located, all values are tagged. Use the ‘Show Tagged records only’ option to apply a filter on your 

results. Prefix values with ## to exclude from the search. 

 

 

In this example, a list of Plant IDs is copied from an Excel sheet. 
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Barcode searches 

Barcodes can be used to locate records quickly and uniquely. In the main collection event or specimen tables, 

enable the barcode search toolbar using the Barcode Search option on the Collections menu. 

 

In this example, 6 records have been located using the barcode search option. Barcodes would be normally be scanned into 
the search field using a barcode reader. However, you can also manually type or paste in barcode values. 

As barcodes are scanned, assuming located, they are tagged with ‘B’. The number of B tagged records is 

indicated. As tags are user-specific, you can scan/tag barcodes without interfering with another users’ tags. 

To view the selected record(s), use the filter option provided on the barcode toolbar. 

 

In this example, 5 records have been located. Note that the filter option adds ‘=B’ to the tag grid filter box. If you continue to 
search for new barcodes with the filter on, the newly located records are added to the filtered list. 

 

Executing an SQL command 

 
In the current version of BRAHMS, the SQL features are under development. These will be extended to create a 
saved table of SQL commands with restrictions and command guidelines that include field selection. SQL 
commands will only be available to selected users. 
 
 
The ability to use SQL commands and functions directly in BRAHMS opens up a further dimension of editing 
flexibility. It is never essential to manually issue SQL commands as discussed here. However, if you do, it can 
make certain types of task much easier, for example, when editing all of the records in an RDE file. Using SQL 
commands can speed up some editing tasks enormously. 
 
For example, imagine in an RDE file with several 100 records, you want to replace all occurrences of the text 
‘SN’, ‘sn.’ and ‘No number’ in the NUMBER field to a uniform ‘s.n.’ value. With the correct SQL command, the 
task can be done in seconds. 
 
Meanwhile to test the concept and see what’s coming: 
 

• Select Taxa > Species to open the main species table. 

• On the Data Tools toolbar, open the main Query Tool and select the SQL tab. 

• Edit the command area to: UPDATE species SET Taxstatus = '!!!' WHERE taxstatus = 'accepted'  
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(Note the use of single rather than double quote marks) 
 

• Select the Execute SQL option on the form. 

• After doing this, select Refresh Data on the Data Tools toolbar – this will update your view of the data. 
 

 

To reverse this edit, 

• Edit the command area to: UPDATE species SET Taxstatus = 'accepted' WHERE taxstatus = '!!!'  

• Again, select the Execute SQL option on the form and Refresh the data. 
 

The completed SQL command tool will be available in the next BRAHMS release. We may initially restrict its use 

to RDE tables. 

A more complex example which uses tags follows. This example sets the Boolean field NOTONLINE in the 

specimens table to True (1) for all tagged records: 

update specimens set notonline = 1 from specimens as sp inner join (tags inner join brahmsusers as bu on 

tags.brahmsuserid=bu.brahmsuserid AND bu.username = N'myname') on sp.specimenid = tags.recordid 

In the above example, the username ‘myname’ must be set to a BRAHMS user log in username. This is because 

tags are user-specific. The field NOTONLINE can be set to null, 0 (false) or 1 (true). Also be careful when using 

single quote marks not to use special quotes as generated by Word. Also note that to make the command more 

readable, the tables can be assigned shorter names. Thus ‘specimens as sp’ and  ‘brahmsusers as bu’. This is 

not necessary but can make complex commands more readable. 

By adjusting the table and field to edit, you can use the same command structure elsewhere. Thus: 

update collectionevents set collectionyear = 1850 from collectionevents as ce inner join (tags inner join 

brahmsusers as bu on tags.brahmsuserid=bu.brahmsuserid AND bu.username = N'myname') on 

ce.collectioneventid= tags.recordid 

Using the SQL screen, the SQL command can be split up on different lines to make more readable. 
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Find anything – anywhere 

When you open any data grid, you can use the Find option to locate any text or a number in any grid cell. Cells 

that include your text are highlighted in yellow.  

• To test, in the open database, select Collections > Collection events.  Click anywhere on the data grid to 

activate the Find option and then select this to open the Search box. Ctrl+F also opens this option.  

 

Using the search box navigation arrows, you can move to the next or previous matching cell.  Alternatively, use F3 or 
Shift+F3 to move forwards and backwards respectively. Press Esc to clear the search and Esc again to close the option. 
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Calculated fields 

Introduction 

Many BRAHMS database files include calculated fields (# fields). These store summaries of information about 

records in these tables, usually numeric totals or formatted text strings. Calculated fields are mostly not auto-

updated. Rather you must periodically use the Recalculation Scripts option provided on the Management 

menu to recalculate all or a selection of these fields. 

Examples of numeric and string calculated fields are:  

• # collection events per country in the country table 

• # images per species in the species table 

• # specimens per collection event in the collection event table 

• Species full name in the species table added to # Full name 

• Text date formats in RDE for specimens 

• Gazetteer summaries in RDE for specimens 

Calculated fields are read-only and are displayed using a different column header colour. The field name 

headers start with # as in ‘# Collections’ and ‘# Full Name’. 

You can display # fields individually using the standard column selection options on Grid Tools > Manage 

Columns. Alternatively, enable all # fields at once using the toggle option Data Tools > # Calc Fields.  

Tables can be sorted and filtered using calculated fields and these fields can be included in reports.  

 

Examples of calculated fields 

 

Some example calc fields in the main Families table. 
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An example of calculated fields in the main country table 

Updating calculated fields  

Running from BRAHMS 

Calculated fields can be updated individually or for the entire database using the options provided under 

Management > Recalculation Scripts. Here, you can see all the calculated field options for the entire database 

including when the fields were last updated. 

 

An example data grid showing a few of the recalculation fields 

You can apply filters on this data grid to see only those fields in one or a selection of tables. 

 

Recalculation fields for the main species table 

Updating using a Scheduled Windows Task 

You can set up a scheduled Windows task to update all BRAHMS calculated fields by executing the command 

line:  

brahms.exe -recalc   

You could set this up as an automated scheduled task using the Task Scheduler , thus ensuring your calculated 

fields are up to date.  

Note. This will only work on those connections that have been shared to the application’s ‘Shared’ folder where 

you are running brahms.exe from. Shared connections will exist in the shared folder as .dat files. For help on 

sharing connections, refer to the section on Data Connections > Sharing data connections. 
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When you run brahms.exe – recalc, there is no immediate feedback. However you can see the calculations 

being auto-updated if you open Management > Recalculation Scripts and watch the ‘Last Run On’ field or see it 

running in your task manager.  

 

Adding calculated fields to reports 

This separate topic is discussed in the reports section of this guide. 
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Adding and editing data 

RDE vs Database 

You can add new data records directly to your database or, alternatively, add new records to Rapid Data Entry 

(RDE) files and then transfer these data to your database. If you are adding just a few records, it’s usually easier 

to add directly to the database. For bulk additions, use RDE. 

Edit mode 

Data can be added and edited in RDE and in your main database tables. By default, tables are opened in read-

only mode. To enable Edit mode, select the Edit option on the Data Tools toolbar or enter Ctrl+E. 

The behaviour of the data grids changes slightly in Edit mode. For example, you will find that TAB and Shift TAB 

are needed to move through the fields rather than the left and right arrows. 

Data are auto-saved whenever you exist a field or change a row. If you do not see the change in your grid, use 

the Refresh Data option on the Data Tools toolbar. 

Details on how to use lookup functions are provided in a subsequent section. 

Adding records 

New records are added using the Add option on the Data Tools toolbar. You can add a single blank record – or 

add new records in batches as offered on the Add drop-down. Each new record is assigned a GUID primary key 

(not visible unless selected). Adding batch records is especially handy in RDE – and can be faster. 

 

New records can be added one by one or on batches.  

Editing larger text fields 

Larger text fields (known as memo fields in v7) can be edited in the data grid itself or, by clicking on the field 

edit icon, in a separate text editor window.  

 

Longer text fields can be edited in the data grid or in a separate text editor window. 
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Large blocks of text can be added and edited using the Text Editor. You can paste or drag and drop text to the Editor with no 
limit on text length or character set. Aside from the click-icon, you can use Ctrl+M or Ctrl+T to open the text editor. 

 

You can also increase row height to edit large text fields in the data grid without opening a separate text editor. 

What cannot be edited? 

Some fields in data grid and forms cannot be edited. Mostly, these will be fields that are visible but belong to 

another table. In some cases, these fields will have specific lookup functions, an example is the species #Full 

Name field in collection and accession files. But in other cases, data from related tables must be edited in the 

relevant file. Examples are the species table fields Habit and Growth form which can be viewed but never 

edited in the living collection accession file. 

Audit fields 

When new records are added the audit fields Created By and Created On are filled. When a record is edited in 

any field the fields Last Modified By and Last Modified On are updated. These fields cannot be edited but can 

be used to apply filters and sorts. 

 

The Audit fields are auto-updated as you add and edit data. 
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An example filter on the Created On field. When filtering on dates, use a valid date format. You can use functions as here > 
01/01/2009 AND <= 10/01/2009. 

 

 

Viewing add/edit dates and name of person adding/editing in the main species file. You can sort on any of these columns 
and also use the Summary tool as shown here for the created-on date field. 

Data forms 

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#speciesformvideo  

 

Forms are provided for most of the main grids. As well as being used for data editing, they also provide options to list 

related records and calculated fields. The data on forms update as you navigate to different grid records. Forms can be 

docked (default) as you like and re-sized. All form text is translatable. 

In order to edit data on forms, you need to be in Edit mode. If you are not, data will not be saved and lookup options are 

not enabled. 

      

The form icon indicates if you are in Edit mode or not. 

 

Most forms have the option to edit data and then Save or Cancel the edits made. Once any edits have been made, the form 

is given a red surround. 

As an example, select Taxa > Species and then select the Form option on the Data Tools toolbar. This opens the 

species table form, by default docked right. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#speciesformvideo
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Data can be viewed and edited using grids or forms. Forms can be resized, docked or dragged to separate monitors. 

 

 

Summary of collections on the main species form. 

 

Find and Replace 

The Find and Replace tool on the Edit dropdown works in text columns that are not read-only. 

 

The Find and Replace tool. 
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Find replace actions can be restricted to tagged records. They also respect your current filter settings. Thus if 

you have a filter on a family name, only records in that family would be edited. Find replace edits are recorded 

in the Edit History table. 

 

 

An example in an RDE file adding in a country name to all records. 

Find and Replace options: 

• The 'With' term will be substituted for the 'Replace' term exactly as entered. 

• Optionally restrict edits to tagged records. 

• To replace null or empty values leave 'Replace' blank. To replace with a null value, leave 'With' blank.  

• The 'Replace' term can contain '%' wild cards:  

o '%term%' is equivalent to 'contains term';  

o 'term%' is equivalent to 'starts with term';  

o '%term' is equivalent to 'ends with term'.  

• To match only whole words, include spaces - for example '% term %' would locate 'term' only when 

prefixed and suffixed by a space.  

• To use a '%' character in the 'Replace' term you can double it. Thus, to find the text '100%' you should use 

'100%%' as the 'Replace term (or '%100%%%' for 'contains 100%' 

Deleting records 

Marking records for deletion 

Records are first marked for deletion using the Delete option on the Data Tools toolbar or the default F7 key. 

This adds * to the DEL field and displays the record in a strikeout font. Repeating the action for a record marked 

for deletion will un-delete it.  You can manually add * to the DEL field or, with appropriate permissions, use an 

SQL function. For example: UPDATE species  SET DEL = '*' WHERE taxstatus = ’uncertain’. This would mark the 

records for deletion. You could reverse this using the command UPDATE species  SET DEL = ' ' WHERE taxstatus 

= ’uncertain’. Or simply use the toolbar option Delete > Clear Del tags. Records only marked for deletion are 

fully recoverable. 

Removing records marked for deletion 

To remove records marked for deletion, a second step is required. Deletion cascades to delete linked child 

records. Thus, if you delete a species that has linked collections, specimens, text and common names, these too 

would be deleted. The system advises you of the consequences of a deletion. 
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The species table with several records marked for deletion. To finally remove these records, select Delete > Remove records 
marked for deletion. This leads to a message box that lists the consequences of deletion. As a rule, deletion of a record leads 
to the deletion of all its child records. 

         

In the above examples, the deletion of the species or the families would also delete the records listed in the message boxes. 
The deletion of three accepted family names in the demo conifer database would lead to the deletion of all the records as 
reported 

To test deletion in the conifer demo database, select Geo > Gazetteer. Optionally, you may could set a field view to include 
the # Collections and # Species together with the locality name. 

 

 

• Locate the gazetteer ‘Bat Dai Son’ in Vietnam - mark for deletion. Then select Delete > Remove records 

marked for deletion. 

  

Deleting this gazetteer record would result in the deletion of several collection events and their specimens and dets. 
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Merging data 

Merging values 

To merge different data values that represent the same thing, use the merge option provided on the Column 

Summary tool. This option does not merge records, rather it simply ensures that the different values you select 

are edited to the selected value. You could do this manually, record by record – but the column summary tool 

provides a convenient way to see and tidy such errors.  

This option does not work on read-only fields. This includes those fields that are visible in a table but are in fact, 

related from another table. Thus, if you see multiple spellings of a collecting place name in the collection event 

table, make the necessary edits in the gazetteer table. 

 

In the above gazetteer table example, there are two spellings of Alpes Maritimes as Major Admin names. The two values 
have been tagged - and to double check the records, a filter has been applied to the data grid records using the option 
provided on the Column Summary form. 

The Merge to Selected option, in this case will make both spellings the same (Alpes Maritimes). Records 

themselves are not merged. The option can be used to merge many values at the same time. The currently 

selected record is deemed to be correct value. 

Merge values or merge records 

Merging values is useful in data fields where the data you are merging have no child records. Examples are 

multiple spellings of Habit or Red List codes in the species file and multiple spellings of a major area name in 

the main gazetteer table. However, whenever a record had the potential to have child records, the records 

themselves should be merged. As examples, this would apply to multiple entries for higher classification, 

family, genus, species, collector, country, gazetteer, garden areas, and institute names. The sample principle 

applies to merging collection events, plant accessions, plant plants and seed records. In each case, any child 

records, after a merge, would belong to a new parent record. 

Merging records 

Merging records is where 2 or more records are joined into one together with any children records. A typical 

example would be where there are two identical genera in the genus file, perhaps linked to different families. 

Merging these records means that all taxa connected to the incorrect genus or genera will be moved to the one 

you select. Another example would be merging place names (joining all collection events); merging species 

(potentially joining many types of records). 
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The genus Acacia, added 3 times under three families are merged to a single entry under the selected family. 

 

Match/Transfer data – Excel to BRAHMS 

Matching data introduced 

The Match/Transfer option on the Data Tools toolbar can be used to match data between the currently 

opened table and a selected Excel xlsx file. You can use this option to: 

a) tag records in BRAHMS that match those in the XLSX file.  

b) transfer selected columns from the xlsx file into BRAHMS based on your match criteria. 

Please note: this option CANNOT be used to add new records to any table, only to update existing records. 

To add new records, check the Rapid Data Entry (RDE) functions and/or add data manually. 

Also, see below section on matching across tables - if you are matching data using a match field from another 

table (e.g. using specimen barcode to update collection events) 

 

 

The Match/Transfer option has multiple applications to match and import data. 

NB: you can also use the BRAHMS Multi-Search tool to simply tag matching records. 

If you have an Excel .xlsx file and you want to know which records in this file also occur in the opened BRAHMS 

table, you can use the matching tool. Matching allows you to choose the fields to match on. In some cases, 

there may be an obvious field to match on – for example a barcode (given that barcodes should be unique in 

your database). There may be other cases where you have a unique matching code, for example PlantID or a 

species code inherited from another database and stored in BRAHMS. Also see the section on GUID matching 

below. However, in other cases, your Excel file may have a series of fields to use to match on, for example 

Family + Genus + Species + Subspecies + Variety + Cultivar. Another example may be Collector name + field 

number + collection day/month/year + Country. The challenge is to choose the most appropriate match 

criteria.  

Bear in mind that you may or may not be looking for a 1:1 match – this depends on your objectives and in 

particular, if you are planning to match and then transfer data. 
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A worked example of matching – specimen table 

The following example illustrates how you can match data from an Excel .xlsx worksheet and the opened 

BRAHMS table. You can substitute this example with data from any .xlsx file you may have – in any BRAHMS 

table. 

• In the conifer database, select Collections and under the Category Preserved specimens, select 

Specimens.  

• As there may already be tagged records in your data file, it may be worth using Tag > Count 

tagged to quickly check. 

• Tag some records with barcodes and then save these tagged records to Excel. Note that the data 

saved to Excel will be those columns that you had in your current view. In this example, you may 

simply choose to export the barcode field to Excel. 

• Select Tag > Clear current Grid Tags. 

• Select Match/Transfer on the Data Tools toolbar and locate your Excel file as prompted. In this 

example, you can match the records using the barcode as shown below. 

 

 

 

After selecting Match Excel to your data, the match success is reported. The number of matches is also reported. 

The matched records in your database table will now be tagged if this option is selected. 

 

Here, the example is only matching on the 
barcode. Note that the actual field name in 
SpecimenBarcode. You can use the Remove All 
option to unlink all the possible match fields 
and then manually choose. Note however that 
you could choose to match on all fields which 
in this case (as the data were exported directly 
from BRAHMS), would give the same result. 
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A worked example of matching – species table 

If you do not have an obvious, single match field such as barcode, you can choose those fields that you consider 

will give the best match. In the below sample, records in the main species table are matched using multiple 

fields Genus, Species, Species Author, Subspecies and Subspecies Author, Variety, and Variety Author. 

• In the conifer database, select Taxa > Species.  

• As there may already be tagged records in your data file, it may be worth using Tag > Count 

tagged to quickly check. 

• Tag a select of records and then save these tagged records to Excel. Note that the data saved to 

Excel will be those columns that you have in your current view.  

• Select Tag > Clear current Grid Tags. 

• Now select the Match/Transfer option on the Data Tools toolbar and locate your Excel XLSX file 

as prompted. In this example, you can match the records using the taxa fields as shown below. 

• To further illustrate the matching process, open your saved Excel file and edit the data to make 

one of more records obviously not match. 

 

 

One record has been edited to force a non-match between this Excel file and the database. 

 

To illustrate the importance of appropriate 
matching, the same Excel file used above is here 
matched on collection year. Because the specimen 
table in BRAHMS has many collections from e.g. 
1974, all have been matched. It may be that you 
want to tag all records from these years – in which 
case, this would be the correct choice. But not if 
you plan to transfer data (see below). 
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In this example, of the available fields in the Excel data file, only some are selected. In fact, as these data were exported 
from BRAHMS for this exercise, all the fields could be selected – or only #Full Name and the result would be the same. The 
matched records will now be tagged in your database. 

GUID matching 

If you are exporting data from your own BRAHMS database with a view to editing these data and transferring 

these edits back to BRAHMS, one useful trick is to include the Record GUID when saving to Excel. This field is 

unique and thus guarantees a 100% unique record match. 

 

Including the Record GUID means you can easily match records on this single field. This can only be used if the data are 
being matched with the same database.  

 

Matching across tables 

You may need to update data in a table where your Excel file only has a matching field from a related table. A 

good example of this is updating fields in your Collections Events table based on specimen barcodes. The 

specimen barcode is not in the Collection Event table itself and thus cannot be used directly for matching. The 

approach here is as follows (this example applies to the collection event/specimen tables): 

a) Open the specimen table and ensure both the Collection Event GUID and Barcode fields are visible. 

b) Export these two columns to Excel for tagged records. 

c) The next step is to add the Collection Event GUID to the excel table with the data you wish to transfer 

to Collection Events. As this table has the barcode, you can use the Excel VLOOKUP() function or 

another Excel merge method as suits) to add the Collection Event GUID to your data transfer Excel 

table. VLOOKUP is not further discussed here but there is plenty of help available online. 

d) Once this step is completed, you can match import the data to collection events using the Collection 

Event GUID to match. 
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Transferring data 

In matching records, you may only be interested to know which records match and to tag these matches. 

However, you may also want to import data from the external Excel file into the current BRAHMS table.  This is 

achieved by ticking the Transfer option for those fields you wish to transfer. Note:  

• Any field selected for transfer is not used for matching. 

• The Overwrite option, if selected, will force overwrite existing values. If not selected, only blank/null 

fields are updated. 

 

In the above example, the excel file is matched on a selection of taxa fields. Three fields have been selected for transfer, 
forcing an overwrite. Also note that the Excel file includes some differently named fields (e.g. “Habit (from John)”). These 
have been appropriate mapped to the correct field in BRAHMS. 

 

 

The data provided in the Excel file have now been added to BRAHMS. 
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Excel to BRAHMS field matching 

When importing data from Excel, for example into an RDE file or when using the Match/Import tool, BRAHMS 

has to know how to map or match your Excel columns to the correct fields in BRAHMS. For example, you may 

have a field in Excel with the column heading ‘Decimal Latitude’ that you want to go to the standard BRAHMS 

field ‘Latitude’. Or you may have a field in a different language such as the Portuguese ‘País’ or the Chinese ‘国 

家’that you want to map to the BRAHMS column ‘Country’.  

You could edit your Excel fields to have standard BRAHMS field headings. But this is not very useful as:  

• you would need to do this for each Excel file and  

• you would have to know the correct BRAHMS field names in each case.  

The good news is that field matching is managed by the Excel to BRAHMS template file 

ExcelColumnMatchTemplate.csv which can be found in your BRAHMS folder. This is a basic file with two 

columns, one for the Excel column heading, the other for the BRAHMS column heading. 

 

An example matching template ExcelColumnMatchTemplate.csv showing a selection of match fields. 

You can edit this file directly, adding or removing entries. However, BRAHMS automatically updates the 

template when you use matching. Allowing BRAHMS to update the template guarantees that the BRAHMS field 

names are correctly assigned.  Note: 

• Multiple variations for the same field may be given, all pointing to the correct BRAHMS field. 

• If you open this file directly in Excel, you may find that some Excel fields with accents are displayed 

incorrectly. However, if you open the file using Notepad, they will be displayed correctly. 

Managing edit conflicts 

An edit conflict occurs when one user displays data in order to edit it, and then another user updates the same 

data before the first user's changes are written to the database. In this case, there is a danger that whoever 

updates the database last overwrites the other user's changes. Although in practice these conflicts are quite 

rare, in systems with many same-time users working on the same type of data, they can occur. 

While it is not possible to prevent users trying to edit the same record, BRAHMS will prevent these conflicts by 

not saving data that has changed since it was retrieved. Typical example: 
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• User A opens the species table including a record on Passer domesticus. User B also accesses the same 

record. Thus, both users have the same record in their respective data grids at the same time. 

• User A saves a change to the record. The edit is now in the main database but is not displayed in user B’s 

data grid (unless by chance, user B decided to us the Refresh option).  

• User B edits the same record on Passer domesticus and saves it. However, the last modified date/time in 

the database is now later than that which user B started with which enables the system to issue a warning 

and prevent user B overwriting the edit made by user A. 

 

 

In the event of an edit conflict, the system issues a warning as above. 

 

Data verification 

Introduction 

Data verification allows users with access to this function to mark records with a verification status. This 

function can be used for all records in any table. Records can have multiple verification status entries. It is 

possible to review the status of records, optionally restricted by status code and/or the user who provided the 

status. 

Providing permission to edit status codes 

Users must be given permission to edit status codes by the database administrator(s). This setting is found on 

the main Permissions form opened by selecting System > Manage Users and Permissions and ensure the 

settings are applied appropriately for the selected user. 

 

Setting permissions for record verification on the permissions form 

 

Editing verification status codes 

Verification record status options will normally be added to the BRAHMS Lookup List table. This means that 

users will have to select one of these values from the record verification form dropdown. If entries are not 

made here, users will be able to freely add their own status codes. 

You can add as many status options as you like. To add or edit these, select Management > Lookup lists. 

Entries must be added here with the Field Name set to RecordStatus (case sensitive).  
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Adding some Record Status values to the lookup list. 

 

Adding and deleting verification records 

In any open table, open the verification tool using the Record Checks option on the Data Tools toolbar. The 

Verified By name (current user) cannot be edited. Select a Record Status and optionally add a comment – using 

Add Verification to add the record. Use Delete Verification to remove a verification entry. 

 

A given record may have multiple verification records. Records are sorted with the most recent at the top of the list. 

Reviewing verifications 

The verification history for individual records can be seen by opening the Verification History tool window and 

moving through the data grid. However, to review all records with a verification entry, you can use the 

following procedure to tag records: 

Open the Verification History tool and at the bottom of the form, select a ‘Tag records having’ setting. This may 

be records with ‘Any Status’ entry or it may be restricted to a selected Status code. You can choose the tag 

character to use, optionally clearing all existing tags beforehand. 

 

An example where all records with a Map Error status code will be tagged with ‘!’ 
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Records with map errors have been tagged with ! It is also possible to tag records that have different status codes using 
different tag symbols and thus record highlight colours. 

 

 

Track and reverse changes 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#edithistory 

Introduction 

All database changes, including those made in RDE files, are tracked in an edit history table. This feature tracks 

all record editing; who made the changes and when, together with the original and edited values. All changes, 

including those in long text strings, can be reversed using the Undo option. 

 

By selecting the Edit History option, all edits for a record can be seen together. 

 

Field level changes and undo 

The Edit History Form Field level tab lists the edits made to the current field. Here, you can use the Undo option 

to reverse edits – opting to go back as many stages as you have recorded. 

 

Example Edit History screen showing the Field History tab. The Undo option is on the far right. 

Accessing the main edit history table 

All record additions, last edit dates and edits are centrally recorded in the Edit History table. To open the 

central edit history table, Select Management > Edit History. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#edithistory
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An example screen with a column summary on the Record Type column. There are two categories of Action: Create and 
Update. In this screen shot, a grid filter has been set to show updates only. 
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Custom fields 

Introduction 

BRAHMS databases and the tables they contain are provided with a defined structure. However, as well as 

choosing the data columns you see in your data grids, you can add new data fields specific to your project, 

selecting the field name, type and size. These custom fields become a permanent part of your database unless 

you subsequently opt to delete them. This also applies to RDE files. 

Custom fields and database migrations 

Often, when databases are migrated into BRAHMS from other formats, the migration leads to a number of 

custom fields. These fields may subsequently be deleted if you find the data are not needed – or alternatively, 

they may be moved to a standard BRAHMS storage field if one is available. 

Adding custom fields 

As an example, open the main species table or another table you may prefer. Select Grid Tools > Manage 

Columns. On this form, you have the option to add Custom Columns, choosing the field name, type and size.  

If the field is of type Text and you set Max. Chars to NULL or 0, this creates a text field with no maximum length 

(equivalent to a v7 memo field).  You can set the default position of these fields using the Up Down Top Bottom 

options. 

 

Adding a new field for text storage, max size set to 25 characters. 

When adding new fields, you can assign the field to a group – as discussed below. 

Editing custom fields and assigning groups 

Custom fields can be edited and/or deleted from the Column Manager Editor tab. Here, all custom fields for 

the current table are listed You can edit the field names by double-clicking on the field name then editing it. 

You can also assign a field to a named group. The sort order of custom field groups and the fields within them 

can be adjusted. When viewing or editing data using a form, your custom fields will be presented within your 

assigned groups. 
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Using the Editor tab options, you can list and remove custom fields for the current table.  

Custom field names 

You can assign any name to your custom field headers – for example they may include spaces and be cased as 

in ‘My New Field’. However, in BRAHMS itself, these fields are given a different table storage name such as 

Str01, Str02, Int01, Bool01, Date01. The actual names are displayed when using the custom field editor.  

Custom field data in grids and forms 

Data in custom fields can be edited in the same way as all other fields. You can also add lookup lists. 

 

Custom fields appear in your main data grids, assuming they are selected for inclusion in your data grid view. They have a 
different font to standard fields. 
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Custom fields can also be edited on forms. When using forms, your custom fields are organised into field groups.  

Viewing custom fields for all tables 

All custom fields from all tables are registered in a central table opened using Management > Custom fields.  

 

Snapshot of the central custom fields table. 

 

RDE files and custom fields 

In the case of RDE files, when you run the importer, the system checks for custom fields. If there are custom 

fields added to the RDE file and these are not already registered in BRAHMS, you are offered the chance to 

register from the RDE import wizard. If you do not register the field(s), the data in those fields will not be 

imported. 
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Exporting data from BRAHMS 

Introduction 

Data can be exported from BRAHMS is a variety of ways as summarised here. Using one or more of these 

methods, you can export all data from BRAHMS into one or more formats.  

Export to Excel or CSV 

You can export tagged records from any table to Excel or CSV using the options provided on the main Data 

Tools toolbar. Exporting works with tagged records and will export the currently selected columns in the 

current sort order. You can view all exported files using the View option. 

 

 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#exporting  

 

 

This example exports selected columns from a specimens table filtered on holotypes. Excel files can be opened 

directly after export. 

 

Export an entire database to XML 

The Export option on the Database Manager form is used  to export all data from a selected database. This 

option does the reverse of the XML Import tool. It creates a folder of XML text files in a designated folder. 

This option export all data from all tables in your database including all custom fields and setup options. 

Using the export tool, you can export data from one database in any store type and then transfer the database 

to a new database in any other data store. For example, you could transfer your database from SQLite -> 

PostgreSQL or from PostgreSQL -> MS SQL Server. 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#exporting
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An example folder created by the Export to XML function. Large tables are split up in a numbered series, for 

example specimens_000.xml, specimens_001.xml, specimens_002.xml, … each file a fixed number of records. 

 

Darwin Core Archive exports 

You can create Darwin Core Archive (DwC) files currently from the main specimen and taxa tables. These files 

adhere to published DwC standards.  With specimens, the occurrence.csv is provided with eml.xml and 

meta.xml files in a single DwC Archive zip. Further extensions are being added to the DwC option to cater for 

variations in export requirements. This will include the ability to add further standard and custom fields and 

provide the output heading required. These files can be submitted to Symbiota, GBIF and similar data 

networks. 

 

DwC output options are available for taxa and specimens. 

 

 

Example DwC output as created from BRAHMS. 

Exporting using reports 

You can design reports to export data to different formats, for example to word, PDF, Excel and others 

including of course printers. Reports are used to export data from specific tables as managed by BRAHMS. 

However advanced users can also access and control the reporter directly, setting up data connections to any 

set of related tables. 
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Aside from printing, reports can be exported in the above listed formats. 

 

Exporting to GIS  

As discussed in the mapping sections of this guide, you can export data to your preferred GIS such as ArcMAP 

or QGIS. The data passed to the GIS are those data that you have selected in your data grid view. 

Accessing your data store directly 

IT staff can access any BRAHMS data store directly. Data are strongly documented with meaningful table and 

column names. You can access and query your data without restriction. You may wish to write software 

applications against the database. 
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Lookup fields and values 

Introduction 

Why use lookups? 

Rather than typing in data values, wherever possible, an existing value can be selected from a dictionary or list 

already in your database. Why type in a species name when it’s been entered before? As well as speeding up 

data entry – this also reduces typing errors and enforces data standards.  

In the ideal world, you would have as much clean and useful data as possible added to your database from the 

start. One of the challenges when creating a new database or optimising an existing one is locating and 

importing useful data – or tidying up your existing data and thus increasing its value.  

In practice, your data dictionaries tend to grow over time, gradually becoming more valuable. In some cases, 

relevant data such as lists of taxa and places or the more obvious standard lists such as IUCN Red List status 

codes or Habit categories can be imported from other sources, perhaps as exchanges with other BRAHMS 

projects. But in others, you can gradually develop lists and refine these as you go.   

In summary, having well-organised tables of lookup fields and data values is an invaluable asset for healthy 

database development. 

Two categories of lookup in BRAHMS 

Two main categories of lookup are used in BRAHMS:  

a) All of the large tables have their own specialized lookup option, for example, for taxa, geographic and 

collector names.  These lookups are discussed in the relevant manual sections such as that for finding 

taxa names.  

b) Lookups that use data stored in your central lookup fields table. This single table holds lookup values 

for any data field that you have opted to register in your lookup dictionary. Examples are habit, 

language, colours, specimen categories, map accuracy codings, biome types, etc. 

This section focuses on the use of the central lookup fields table. 

The central lookup field list 

Introduction 

The central lookup list is used throughout the database and across all tables. Any field registered in the lookup 

list will be available in your system with the lookup values you add.  

The lookup list consists of two related tables, one storing the list of registered fields with relevant settings for 

these fields. The other table holds the actual lookup values for each registered field. 

To open and edit the central lookup field list, select Management > Lookup Fields. 

 

The lookup Fields table stores a list of all registered lookup fields and provides a mechanism to edit their properties and the 
lookup values. The Lookup table does not store values for taxa, places, collectors and the other main tables as these already 
have their own special lookup functions. 
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Example entries in the lookup field list filtered on ‘threat’ – these are 2 of the fields used for conservation assessments. 

Description of the Lookup Fields table structure 

Field name  
Tag Standard BRAHMS tag field. 

Del Standard BRAHMS deletion field. 

#Field values Calculated field: number of lookup values for a field. 

Field Name The name of the field. 

Must Choose User must choose one of the lookup values – no free text entry. If this option is not 
selected, the user can choose a value but also add a new value. 
 

Must Choose in RDE As above but applies only to the field when in an RDE file. 
 

Use Append mode Multiple lookup values can be selected. 

Append separator Separator between multi-values, e.g. a comma or semi-colon. 

Not Nullable Null values are not permitted – thus the use must select a non-null value. If this is not 
selected, the user can set a field to null. 

Default value If Null values are not permitted, a default value should be added. 

Field Comments General notes about a field. 

Audit fields Added when and by whom, last modified when and by whom. 

 

The above listed field settings allow you to refine and control how users will use the lookup fields. Note that these settings 
can be controlled to allow different rules for the same field in the main tables and in RDE. 

 

Which fields to register as lookup fields? 

The decision on which fields to add to your lookup list is a project level or personal one. There are no hard and 

fast rules. However, fields that have a large number of value options, for example more than 1000 are unlikely 

to be good candidates. Also, although you can add a ‘notes’ field (e.g. Habitat Text) as a look up, as notes will 

almost always be different, you may not find this useful. However, if you have a common occurrence of some 

note values, you could selectively add these to the lookup list and then ensure that these can be edited in the 

table. However, bear in mind that presently, the max length of a lookup list value entry is 128 characters. 

 

Registering a lookup field 

To add a new field to your lookup list, select Management > Lookup Fields and the use the Add option on the 

Data Tools toolbar.  
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Selecting a column to add to your lookup list. 

• Select the Type first. This tells BRAHMS which table you are listing fields from. 

• Fields already registered are not listed in Add field Column dropdown. 

• The same field may be used in multiple tables but it will only be registered once in the lookup list. 

Thus, the settings and values added for a given field will apply in all tables where that field exists.  

• Only character fields are listed. Excluded are date, Boolean and numeric fields. Calculated fields are 

not available. It also excludes fields like Tag, Del and Audit fields. 

• As a rule, A) do not add lookup lists for fields that have their own specialised lookups. For example, do 

not add a lookup for the fields ‘Species’ or ‘Species Author’ in the species table. B) avoid adding 

lookups for fields that have a very large number of values as these tend to slow up activities in that 

table. 

When you select a new field value, the existing data values for the new field are listed on the form together a 

count of the occurrences of the values. You can use these existing values to help develop your lookup list - 

selecting some (Add ->) or all (Add All) of the current values to your lookup list. 

 

In the above example, the LLORIGIN field is not yet registered in the lookup list. This data column already has many values in 
the Collection Event table. These are listed here with a count of the number of occurrences per value. At this point, you could 
choose to some or all of these values to develop the lookup list for this field. You can also add new values by typing them in. 
Bear in mind that the existing values may include entries that you do not want to include in your clean lookup list. Rogue 
values (e.g. spelling variations) ideally ought to be edited in the data table at some stage. 

 

 

Manually adding a new value to the lookup list.  
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The order of lookup values as presented when you are selecting a value is controlled by the Sort Order field. 

You can adjust this order on the values form using the Move Up and Move Down options. 

Default lookup value and sort order 

When defining a lookup field and it’s values, you can select a default value and you can also choose the sort 

order for your values. 

 

Editing lookup field values 

 

Use the Show Field Lookup Values option to list values currently registered for a field. 

 

 

To edit values, ensure you are in Edit mode and then select the Edit Values option. 

 

When editing values, you can add new or remove values and alter their sort order. 

 

Listing all lookup values 

To list all lookup field values across all fields, select the Lookup Values option on the Lookup Fields drop-down. 
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You can save these data to Excel or print using a custom report. 

Adding lookups for custom fields 

Lookups can be added for custom fields in the same way as for any other field. Where possible, custom fields, 

as well as being available in data grids, are added to a special tab on forms. 

 

Field value table 

Field name  

Tag Standard BRAHMS tag field 

Del Standard BRAHMS deletion field 

Parent value Some lookup values exist in a hierarchy of values e.g. plant events 

Sort order The list order for the lookup values 

Value The lookup value itself 

Value description A description of the value 

# Values Calculated field: number of values for the current field 

Field Comments Other comments 

Audit fields Added when and by whom, last modified when and by whom 

 

Deleting a lookup field 

Entries can be deleted from the lookup list in the normal way – mark for deletion and then remove. When you 

delete a record, all associated lookup values are deleted. 

 

Editing lookups directly from the database tables 

Rather than editing the lookup fields and values from the Management menu, a convenient way to register 

and edit these values is when you are working in a data table. Here, you can use the Edit option dropdown Edit 

Lookup Values on the Data Tools toolbar. A non-Admin user needs permission to do this. 

. 
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Use Edit Lookup Values on the Edit dropdown to create or edit lookup lists when you are editing a data grid. 

This opens the same edit options described above. 

Importing lookup values from Excel 

Look up values can be imported from Excel tables.  Some tables are provided by the BRAHMS project for a 

range of data categories. But you can also develop your own lookup lists. For example, you may have lists of 

values for biomes, soil types, insect wing colours or flowering stages. Rather than adding these manually to 

your lookup list table, you can import them from existing Excel tables. 

For Excel imports, use Management > Import from Excel. The format for the xlsx file is as follows: 

 

Your xlsx table must include the columns FieldName and LookupValue. The fields SortOrder and 

ValueDescription are optional. 

The field names themselves must be the same as the physical table fields and these are often different to the 

‘friendly’ names used in the data grids and field lists options. A good way to get the correct name is to manually 

add a lookup value and check the Field Name value added to the lookup grid.  

 

        

When importing, ensure that minimally, you have the Field Name, Abbreviation and Value fields matched as shown above. 
The right screen shows the data in the Excel table ready to import. 
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Using lookups 

Activating a lookup 

Firstly, you need to be in Edit mode. Once in Edit mode, you can activate a lookup using the F9 or Ctrl+L keys or 

by using the Lookup option on the Data Tools toolbar.  

 

In edit mode, fields that have lookup functions are indicated with the lookup icon as shown here for the genus and author 
fields. 

           

Fields that have values in your lookup table (see below) have a drop down or lookup button added to the field. 

If you are using a form, the lookup is activated by clicking on the relevant lookup button next to the field or by 

using a dropdown. Whether you have a dropdown or button depends on the field in question and also on the 

lookup field settings. For example, taxa and author names always have a button as these consult special lookup 

functions. Fields which are set to 'append mode’ lookup (see below) will have a button allowing multi-value 

selections. 

 

Single value selections and dropdowns 

As soon as you add any entries for given field to your lookup list – and you are in edit mode, the data field in 

the data grid and on the form displays as a dropdown rather than a free entry text box. Depending on the 

settings in your field list table, users will be forced to choose one or more values or also be able to type in new 

values. 

        

 

In the left side example, no entries have been registered in the lookup list for Provenance Type. Hence the field can be freely 
edited. The right-side example shows the field after one or more entries have been registered and the user is forced to select 
one of the dropdown options. 

Multi-value selections 

If an appropriate field is set to Append mode, this means that you can select multiple values to add to the field. 

These will be separated by the designated separation character. 
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In Append mode, the lookup button assembles the existing values to a list box where they can be selected. 

 

  

Multi-value lookups can also be used in the data grids. 

 

Transferring lookups from one database to another 

1. Open the database with the good lookup settings. 

2. Select Management > Lookup Fields > Lookup Values (drop-down option). Tag all records and export 

tagged to a suitably named Excel file using the Export Tagged option. 

3. Select Management > Lookup Fields. Tag all records and export all records to Excel. 

4. Log in to the new db. Select Management > Lookup Fields > Management menu again > Import from 

Excel. 

5. Step through the import wizard - all the field setting in the Wizard should be correctly matched. Complete 

the import. 

6. Again, select Management > Lookup Fields.  

7. This time, select the Match/Import tool on the Data Tools menu. 

8. Locate the Lookup Field file exported above in step 3. The match settings should be as in the screen below, 

matching on fieldname, transfer and overwrite all others. 

 

Using the Match/Import tool 
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Rapid Data Entry 
A sample RDE file for herbarium specimens is provided here  RDE_Bolivia_JRIWood.zip. 

 Note: if you have problems seeing RDE files in your manager, refer to the RDE troubleshooting section. 

Introduction 

While data can be entered directly into BRAHMS, RDE is recommended for entering larger numbers of records 

and also as a first step when importing or transferring data from other software packages such as Excel. RDE 

files are entirely separate mini-databases linked to your main BRAHMS database.  

As well as storing data. RDE files can store images and have the same functionality as your main database files 

to track and undo changes. 

 

 

RDE is perhaps the most widely used BRAHMS component and databases are often built through the importing of different 
RDE files.   

RDE data are stored in portable SQLite databases. Although RDE files appear and are used as one single table, 

behind the scenes, they in fact comprise several related tables which allow you to link images to the RDE 

records and also keep track of all edits. RDE file have a ‘.rde’ file extension. 

You can store data in one or more RDE files and use these data to create summaries, maps, reports, manage 

images, and in general, use many of the BRAHMS tools and functions.  Some users continue to work in RDE as it 

does all they need. However, RDE files are more like Excel spreadsheets with BRAHMS features. A series of 

separate RDE files does not constitute a database. Data held in separate RDE files cannot be combined for 

reporting or mapping - unless the RDE files are merged into a single large file – a process which is possible but 

inefficient for long term data management. Most projects gather or add data to RDE files – and then transfer 

these files into their database. 

Portable and flexible 

RDE files are completely portable. They can be copied to any PC and/or exchanged with other users. You can 

store them on memory sticks and open the file(s) from there from any BRAHMS database. 

https://herbaria.plants.ox.ac.uk/bol/Content/Software/v8/RDE_Bolivia_JRIWood.zip
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An example of RDE files stored on a USB drive. 

RDE files are also flexible in that you can add new custom fields and choose default field views – exactly as you 

can in the main database tables. 

RDE file categories 

RDE files are available for different categories of data. Currently these include: 

RDE file category Used for entering or transferring 

Gazetteer Geographic data only – names of places. 

Taxonomy Taxonomic data only – names of all taxonomic ranks. 

Specimens Collection events including taxonomy, geographic data and fields for museum specimens. 

Observations Observations – collection events only. Note that observations can be added to specimen 
files leaving the physical specimen related fields blank. 

Plant Accessions Botanic garden accessions only. 

Plants  Botanic garden accessions with extra fields for plant records derived from the accessions. 

Plant Events Botanic garden plant events – things that happen to plants over time, observations, 
inventory, checking, etc. 

Entity Names Adding plant entity data – yet to be documented. 

 

This list is likely to be extended for other data categories. 

Managing RDE files 

Introduction 

The option Rapid Data Entry > RDE File Manager opens the RDE file manager. This table lists all the RDE files 

that you have access to. This will include files in your default storage folder Documents\BRAHMS\RDE and files 

in other RDE folders that have been registered and that you have access to. 

 

A sample RDE manager showing files located in different folders. 

Normally, you will create an RDE file for a particular task, for example, for logging data from a field trip, 

entering data for selected specimens, gathering data for a botanic garden inventory, etc.  If working in a larger 
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museum, your project may have numerous RDE files stored across different folders each of these with different 

access permissions. 

 

Manager option What it does 

Toggle Archive Flag Set Is Archived true/false 

Hide archived files Do not list archived files 

Refresh List Force update RDE list from your BRAHMS/RDE folder 

Open Open RDE file to view/edit (or double-click the file name in the manager) 

Delete Physically delete an RDE file 

Edit Edit details about the RDE file (meta data) 

Copy RDE Make a copy of an RDE file 

Create RDE Create a new RDE file of a selected category 

 

 

Registering RDE folders 

Open the RDE Folder Manager using the option provided on the RDE toolbar. 

 

Registering a new RDE folder 

RDE files can be stored in any registered folder. New folders are added using the Add option. Folders can use 

UNC paths or drive letters.  Only project/database administrators have access to the folder management 

options. Administrators can also assign access permissions to one or more non-admin level users. 

 

Assigning user access to RDE folders 

All users with access to the RDE module, regardless of their database role, have access to their default 

Documents\BRAHMS\RDE folder. Beyond this, non-admin and non-manager users need to be given access to 

folder(s) by the system administrator or database manager. 
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Non-admin/manager users are list on the left and can be moved to the Assigned Uses list on the right. 

To assign user access to an RDE folder: 

• Ensure the folders you wish to share are added to the RDE manager folder list. Clearly the folders have to 

be accessible to your user(s). NB: Only non-Admin users are listed. Admin level users have access to all 

folders by default. 

• You can provide many users access to the same folder. 

Designing and creating new RDE files 

Introduction 

Designing and creating new, empty RDE files with the correct field structure is a key aspect of the data capture 

process for many projects. This section explains how to create new RDE files with the optimal design for 

different RDE data categories.  

Each category of RDE (specimens, living collections, seed accessions, etc.) is provided with a set of fields you 

can choose from when designing and saving your own templates. Once you have designed templates, these can 

then be made available to all users.  You may wish to restrict the ability of non-admin users so that they must 

create their own RDE files from one or more pre-designed project templates. This helps standardise RDE data 

file structure and use across your project. 

Setup options 

Under System > Options > Rapid Data Entry (RDE) > RDE Creation, you can choose which RDE file create 

options are available to users by default: 

a) RDE file creation Wizard which provides access to the file designer/column manager 

b) Select from pre-defined project templates. 

c) Both of these options. 

In addition, by setting user-level permissions, you can fine-tune which users have access to the available 

options. Note that Admin users always have access to both the Wizard and pre-defined templates. If mostly, 

you want standard users to only use pre-defined templates, de-select Show the RDE Creation Wizard here and 

then you can override that for particular users as needed in the user permission settings. 
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Setting up RDE file creation options. 

The RDE Templates Folder should be a shared folder that all users who are creating new RDE files (using the 

templates option) have access to. You can add all your RDE template files into this folder.  

 

User permissions 

With User System > Manage Users & Permissions > Access/Permissions > Specific Actions, you can set the 

permissions for individual users to access the RDE file creation wizard and/or template selection only. 

 

Showing part of the Specific Actions tab when editing user permissions. This user can only access RDE templates 

that have already been designed and made available. The user is unable to use the RDE Create Wizard. 

 

Creating RDE files using the Wizard 

A user that has appropriate permissions can design new RDE file templates using the RDE Create Wizard. After 

choosing the category of RDE data, the fields to include can be selected from the standard RDE field list. 

Custom fields can also be added if needed. 

 

You must first select an RDE file category and name. The RDE file will be created in the designated RDE folder. 

 

 

 

 

 

 



BRAHMS v8 introduction and guide  128 | P a g e  

 

The RDE file Create Wizard allows you to select any fields from the list provided – also to add custom fields. The 

new file is given a name and saved to a registered RDE folder. 

 

Creating RDE files from pre-existing templates 

 

 

A user with no access to the Wizard will have to choose one of the pre-designed RDE templates available in the 

list. All RDE files stored in the designated RDE templates folder (see above) will be listed here. Note that the new 

RDE file will be created in the designated RDE folder. The folders a user has access to are discussed in the section 

on access to RDE folders. 

 

Deleting RDE files 

If an RDE file is deleted from your computer, it will auto-disappear from the manager list. If you use the 

BRAHMS delete option in the data grid, this will also delete the physical file from your computer. 
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RDE files can be deleted using the standard two-step delete function. But you can also delete the fil from your PC using your 
file manager. RDE files moved to a non-registered folder will not be listed in the manager. 

Opening and adding data to RDE 

To open any RDE file, double-click on the file name or use the Open option on the RDE toolbar. As with all other 

tables, you need to switch to Edit mode to be able to edit the data. To optimise RDE entry, you will use your 

lookup up lists as described in the section Using and editing lookup lists. 

It will also be useful to be familiar with the keyboard shortcuts as described in the section Grid navigation 

basics and keyboard and function keys. 

 

 

In Edit mode, all data in the RDE file can be edited. Use the Edit History option to view and optionally undo any edits. 

 

 

 

 

Quick Value Selection Tool 

 

When you are in an opened RDE file which already has data added, you can use the Quick Data Selector tool to 

help add or update data values in the file. 

Once opened, and you are in Edit mode, the tool lists all values in the currently selected column. These values 

are only listed from the current RDE file, not the main database.  

• The Filter option on the Data Selector is used to locate he required value. 

• Double-click on a value adds the value to the RDE field. 

• Set the Clear filter option to clear filter when you move column/row. 

• Auto-move to the next field or row after making a selection. 
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The Quick Data Selector tool can make working in RDE files more efficient. The data values listed auto-update as you move 
columns. 

Force lookups for selected fields in RDE 

To prevent users adding incorrect entries to RDE fields, you can enforce lookups for certain fields and field 

groups. To do this, select System > Options > Rapid Data Entry > Forced Lookups.  Here you can select a data 

group e.g. Taxonomy Group and within that group, enforce lookups to the level you wish. For example, you 

may allow free text entry for specific epithets – but not for family/genus names. Similar options apply to other 

categories of data. 

Settings apply to all users.   

As an example, if you enable Taxonomy Group and select Genus Names, this means that genus names or higher 

rank cannot be freely edited. However, species epithets can be freely added. If you select Taxon Name 

Epithets, the user would be unable to freely enter any species level text – they would have to use a lookup. 

 

 

 

With these settings, a user could freely add new species and place names  but not family, genus and country 

names. The other groups shown here have not been restricted. 

Optimising data entry using RDE 

The following points can be considered to optimise data entry in RDE files: 

• Ensure that the visible fields and their order in the file is optimal for your project. 
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• RDE is more efficient when you can use lookups. If your database has good dictionaries of species, 

geographic and collector names – together with other custom lookups, data entry will be faster and 

more reliable. With good lookups, you are then in a position to force selection for a defined list or 

allow the data entry person to add new entries.  

• The Quick Value Selection Tool is very handy in RDE. This tool lists all the values in the current RDE file 

for the current column allowing rapid selection of a value. The tool window can be configured in a 

number of ways to speed up data selection. 

• Use F4 to copy the last field and Ctrl+F4 to copy an entire record. In general, learn to use the short cut 

keys provided in Shift+F1. 

• If adding map data, open the ArcGIS map window (ideally on a separate monitor) to see your map 

data dynamically update and easily check for map point errors. 

 

 

 

 

Importing to RDE from Excel tables 

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#lcexceltorde   

Data and images can be imported from .xlsx tables into RDE using the Excel Data Import Wizard. This tool 

allows you to locate and open an Excel .xlsx file, then match the columns in the file to your opened RDE file. 

The matching between Excel and RDE columns can be adjusted as necessary to pull in as many fields as 

possible. This process also allows you to import data from custom fields – assuming the custom fields have 

been added to your RDE file. It also means that field names in foreign languages can be mapped to the 

standard names. 

         

The above screens show the matching process and the data processed and ready to import to RDE 

 

The data now transferred into the RDE file. 

Excel to RDE field matching 

When importing data from Excel into an RDE file, BRAHMS has to know how to match your Excel columns to 

the correct fields in BRAHMS. For example, you may have a field in Excel with the column heading ‘Decimal 

Latitude’ that you want to go to the standard BRAHMS field ‘Latitude’. Or you may have a field in a different 

language such as the Portuguese ‘País’ or the Chinese ‘国 家’that you want to map to the BRAHMS column 

‘Country’. The process of field matching is described in the section on Excel to BRAHMS field matching. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#lcexceltorde
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Excel to RDE matching and transfer 

As well as append data to an RDE using the Excel to RDE importer, you can also add data to existing RDE 

records using the Match/Transfer function. For example, you may already have an RDE file with many records 

and then acquire some useful additional data you would like to add to this RDE file. As long as you can match 

the records in RDE to those in the Excel file, you can do this. 

Adding images to RDE files 

You can add one to many images to each record in your RDE file. Images can be dragged onto the standard 

image viewer or imported from Excel worksheets.  

When importing from Excel, this will add one record per image to your RDE file. An example use is when 

digitizing data from specimen labels. Thus, a folder of specimen images (with label data) may be imported to an 

RDE file, the images can be opened in RDE, perhaps using a second monitor, and the data from the labels 

added to the file. 

All aspects of image management including RDE related topics are discussed in the images section of this guide. 

Copying/ Renaming RDE files 

You can copy an RDE file with or without data and also rename an Rename an RDE file. Additions or changes 

made here will be updated in your RDE manager list.  

RDE file import analysis 

RDE file ‘analysis’ refers to the process of quality control, allowing you to assess data in your RDE file that are 

new to BRAHMS. This refers to the data that would be imported and distributed to the various different 

BRAHMS tables as the RDE file is imported. This applied to all categories of data, examples are family, genus, 

species, country/place names, collections etc.  The checks made depend on the category of RDE file you are 

working with. 

 

The analysis phase reports on progress – it large RDE files, this may take a while. 
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At the end of the analysis phase, you can see what exists and what would be added. You can filter on the report 

grid as useful, for example, adding “N” to the Status filter row will show new records. 

After analysis, you may prefer to go back to edit the data rather than import the data. 

 

Transferring RDE files into BRAHMS 

Following on from the above analysis phase, using Next you can then opt to proceed to the next stage. If your 

RDE file includes custom fields (non-standard fields) that have not been registered in your database, you can 

register these now. If you do not, these data will not be imported. 

 

Optionally register custom fields. This form shows fields that are in your RDE file but are not registered in 

BRAHMS. 

Selecting Next again will take you to the Import page. Here you can opt to start the import. This stage adds the 

RDE data to the various main database tables, providing feedback as it proceeds. Large RDE files will take some 

time to process. 
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The final stage of importing transfers the data into BRAHMS. 

 

 

After the import is completed, you will see and can save the import report. 

 

In summary, when you import an RDE file, the system checks the data and populates the various related tables 

in BRAHMS. For example, if your RDE file includes a family name not already stored in BRAHMS, that family 

name would be added to the family table. Data can easily be edited in BRAHMS after import. However, as a 

rule, it is always better to try to remove the ‘big errors’ prior to importing, for example mis-spelt country, 

family or genus names. 

 

A closer look at RDE files for collection events and preserved specimens 

To create a new RDE file, refer to the section on Designing and Creating new RDE files. 

RDE files for specimens, be they animals, plants, fungi, microorganisms or any category of natural history data, 

share a number of features in common. This section lists a few points to consider when planning data entry. 

RDE files for specimens are fundamentally collection event records storing the collector and field number; the 

collection date and place; the identification (albeit preliminary); and descriptive texts under various headings. 

A record may be an observation or another type of entry with no physical specimens. In this case, the record 

will have no entry in the Institute code field. If the record has no entry in the Institute code field, it is 

considered to be simply a collection event record with no physical specimens. And if the file is transferred to 

BRAHMS, it will add collection event records – but it cannot add specimens. 

 

Match criteria when importing 

When importing an RDE file category ‘Specimens’, the file will consist of collection event records, optionally 

with physical specimens. Collection events are compared and matched with records already in BRAHMS using 

the following criteria: 
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GazetteerId* + FieldNumber +Prefix + Suffix + Collection Day + Month + Year + 
Locality Notes (Sometimes LocalityNotes may be the only difference in location data) 
 

If there is more than 1 match on the above, then SpeciesId is also used. If there is still more than 1 match, 

Collectors** (uppercased) are also used.  If there is still more than 1 match, the matches are ordered in 

descending order of the specimen count and then BRAHMS takes the first match (i.e. the one with most 

associated specimens). 

*The gazetteer ID itself is generated for new CountryName + MajorAdminArea + MinorAdminArea + 

LocalityName. 

** Collectors are generally left to the end for evaluation as their exact text matching tends to be less reliable 

that numbers and dates etc. 

For Specimens, if the collection event is found to be new then all associated specimens are assumed to be new 

and no further matching takes place. Otherwise, specimens are matched on all of: CollectionEventId + 

Museum/herbarium code + SpecimenAccession + SpecimenBarcode. 

 

Specimens and the Institute code 

If the RDE file has a museum code (or equivalent) in the Institute code field, this implies that the collection 

event record has a physical specimen stored at that location. When these data are transferred to BRAHMS, the 

event will be added together with a specimen record. Certain fields in the RDE file are clearly part of the 

specimen record – rather than the collection event itself. These fields, any of which may not be available, 

include Specimen category, Barcode, Accession#, Folder and Box barcodes and several fields related to type 

status. Any of these fields, if added, would be stored in the specimen table – linked to the collection event 

itself. For more details about specimens and their determinations, refer to the section Collection events, 

Specimens and Determinations. 

Adding multiple specimens per collection event 

If you want to add multiple specimens per event at one time – for example, you have knowledge that the event 

resulted in several specimens (duplicates in the botanical world), you must copy the collection event record 

and then edit the Institute code for each different specimen. You may also know the specimen category, 

barcode and accession # for each specimen – and these data can be entered as available. Specimens may have 

type status (holotype, isotype, etc.) and, as discussed further below, may have more than one determination.  

When the data are transferred to BRAHMS, only one collection event will be added (see match criteria above). 

If any collection event criteria used in field matching are different, the system will add a separate collection 

event record. RDE records are easily duplicated down using Ctrl+F4 – then edited as required to change the 

fields that apply to the different specimens. You may have more than one entry for the same museum code. 

Adding multiple determinations per specimen 

Importing RDE files for living collection data 

Introduction 

Living Collection RDE files are designed to batch add data for accessions and plants – and also to transfer data 

from other formats via Excel. 

Although these files import in the same way as other RDE files, a number of special conditions arise. Living 

collection RDE files may include data for the accessions and also the plants themselves. Given that there may 

be more than one plant record per accession, the RDE file has to correctly link these data. 
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Create a new RDE file 

 

To create a new RDE file, refer to the section on Designing and Creating new RDE files. 

 

Import data from Excel to RDE 

If you have data in MS Excel to transfer to BRAHMS – this can be done using the Import from Excel option on 

the RDE menu. Refer to the rules for accession and plant numbering below. 

 

This process is also described on the video: 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#lcexceltorde  

Manually adding data to an RDE file 

Once you are Edit mode, you can freely add data to your RDE file. To speed up data entry, it is always useful to 

have as many lookup lists as possible in your database. Editing lookup lists is described in the section on 

lookups. Thus, rather than type in a value, you will be able to select it from a lookup function. 

 

An example RDE file with data added. 

 

Rules for accession and plant numbering in RDE files 

In general, accession and plant numbering are controlled by your system format settings option for living 

collection accession numbering. In RDE files the following rules apply: 

Accession numbering 

1. If the Accession # is blank, it will not be imported. 

2. If the Accession # field starts with “RDE”, this is a signal to the importer to auto-generate the next available 

number for the current database. The Accession #s must however be made unique, for example using ‘RDE1, 

RDE2, …’ or ‘RDE0001, RDE0002,…’,  ‘RDEabc,…’  or as you wish.  

3. On importing, the RDE Accession #s are converted to the numbering system assigned in your configuration 

setting. Thus ‘RDE1’ may be converted to ‘2019-00050’ and RDE2 to ‘2019-00051’. 

4. If you add an Accession # entry lacking the text string ‘RDE’, such as ‘12345’ or ’2019-100’, it will be added as 

entered, assuming it is new to the database. If it is not new, it is not added. 

5. As described below, you can repeat an Accession # in the RDE file if you have multiple plants to import. Note, if 

repeating an accession entry (i.e. multiple plants), the accession details need only be entered in the first record. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#lcexceltorde
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Plant ID numbering 

1. If the Plant ID field is blank, no plant record is added for the accession. 

2. If the plant ID field is set to ‘*’, a plant record will be added for the current accession and the Plant ID will be auto-

calculated using ‘2019-100*1’,  ‘12345*1’, etc. 

3. If the Plant ID is added as a string as in ‘0012345’ or ‘2019-50*1’, it will be added as entered, assuming unique. 

4. If the Accession # is repeated in the RDE file, for example, there are 3 records all with Accession # ‘RDE0001’, and 

each record has Plant ID set to *, this would result in one accession record with 3 linked plant records.  

Adding Garden code/name to your RDE file 

Before importing your RDE file, you must ensure all records have a garden code/name entry. This is because all 

accessions are linked to a garden. Clearly, this is required for single and multi-site projects.  Any records that do 

not have a garden code/entry will not be processed by the RDE importer. An RDE file may contain records for 

more than one garden/site. 

 

If all entries in the RDE file are the same, use a standard lookup option to select the garden for one record, for 

example the first record, then use the function Autofill Garden… to add the same entry to all records.  

 

Transfer all or restrict to tagged 

Once your RDE file is ready and with the RDE file still open, select Rapid Data Entry > Transfer RDE to 

BRAHMS… 

 

 

 

At this stage you can optionally restrict the transfer to tagged records. 

After running the analysis which creates an import log which you can view/print, you can proceed as prompted 

by the Import Wizard to import the data. 
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The analysis reports on the status of your RDE file import. In this example, everything in the above list is new to the database 
and will thus be added to the relevant dictionary. 

Importing custom fields from RDE 

If your RDE file includes non-standard fields, you will be asked to register these. These fields will be auto-added 

to the main plants table structure and the data transferred there. 

 

Registering custom fields. 

 

 

The complete import history for a given RDE file can be viewed form the RDE manager after the RDE file is closed. 
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Images in RDE files 

Linking images 

You can link 1:many images to each record in RDE. Images can be stored in any accessible folder. Images are 

viewed and linked using the Images option on the Data Tools toolbar. This opens the Linked Image Viewer. 

Images can be dragged onto the viewer – or you can use the Link option provided. The images and the image 

link details are stored in separate tables in the RDE file. Bear in mind that behind the scenes, RDE files are in 

fact mini databases with several related tables. 

As discussed in the section Images from Excel, images can be imported from Excel along with other data. 

     

An RDE record with a linked specimen image and another record with 2 habit images. 

 

Importing images from a selected folder 

If you have a folder of RDE images, you can import these to an opened RDE file – creating one new record per 

image in the selected folder. 

 

To append images from a selected folder, use the Import Images option on the Rapid Data Entry toolbar. 
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Example: opening an RDE file, mapping and printing labels 

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#labelstoppt 

Reporting in BRAHMS provides almost limitless power to generate lists, labels, charts, cross-tabs and more. You 

can print reports directly from BRAHMS or send the outputs to documents, excel, pptx and elsewhere. 

You are encouraged to experiment with report design and you can also open and use a sample provided for 

printing basic museum labels. Clearly, each institution has label design preferences, hence, it will be necessary 

to learn how to use the report designer. 

This example opens an RDE file of specimen data prepared by J.R.I. Wood (Oxford) from his field work in 

Bolivia. To proceed with this task: 

• First download the file RDE_Bolivia_JRIWood.zip and open the zip to the folder Documents/BRAHMS/RDE.  

The zip file includes an RDE file of specimens and a report template sample for labels. 

• Log onto BRAHMS – choosing any project and select Rapid Data Entry > RDE File Manager. This will list any 

RDE files located in your BRAHMS\RDE folder. 

• To open the RDE file, double-click on the RDE manager entry ‘John Wood Collections 2018’. 

• Explore this RDE file using the Column Summary option on the Data Tools toolbar and, optionally, you 

could design a Tree View. 

  

• To map the file, select Mapping > ArcGIS in BRAHMS. Initially, if no records are tagged, no points will be 

plotted. To map the entire file, remove the mark from Tagged only on the map toolbar.  

 

The RDE file mapped with the Tagged only option de-selected. If you now tag some records, you can use that option to 
restrict the map to tagged. 

To produce some labels, you will need to tag some records as the reporter only works with tagged records. If 

you wanted to print labels for the entire file, use the Tag all option on the Tag dropdown – otherwise manually 

tag some records. 

An example Tree View 
designed to show 
geographic data 
including locality notes.  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#labelstoppt
https://herbaria.plants.ox.ac.uk/bol/Content/Software/v8/RDE_Bolivia_JRIWood.zip
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To open this report, select Reports then File > Browse and locate the report file ‘RDE specimen labels.mrt’ which was 

provided in the zip file downloaded above. 

 

To view the labels, select the Preview tab. 

 

  
 

On the Preview tab, you can choose various output options including MS Word. If exported to MS Word etc., your labels can 
be edited prior to printing. 

If you wanted to explore reporting options more fully, you could now select File > New and choose one of the report 
wizards such as standard report wizard. In no time, you can create a new report template such as the one shown above. 
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Example: importing taxa from Excel or IPNI to RDE and BRAHMS 

This exercise demonstrates how you can pull in a list of taxon names from Excel or IPNI to RDE – and then 

transfer these data into a BRAHMS database. The exercise starts with an import from IPNI (International Plant 

Names Index) but you can substitute the IPNI approach with an Excel file as discussed in the next task. 

• While logged in to any database, select Rapid Data Entry > RDE File Manager.  

• Again, select Rapid Data Entry and choose Create RDE … be sure to choose the category ‘Taxonomy’ and 

giving the RDE file a suitable title.  

• You can adjust the default columns or add new ones if needed but otherwise, proceed to Finish to create 

the new file using the defaults. 

• Open the file (double-click your new entry) and from the Rapid Data Entry toolbar, select Import Data 

from IPNI.  

• Enter the name of a genus at the IPNI prompt (or a different search criterion as needed) - then Search.  

• Once the name list is assembled, select Import BRAHMS records to RDE. There will be a delay as the data 

are transferred into the RDE file – if you have a lot of records, this may take some time. 

 

 
 

 

   

Showing the data searched using IPNI for the genus Vatica - and then transferred to RDE. 

The next stage, should you wish to do so, is to transfer these RDE data into your database. Normally, before 

doing so, the data would be checked and edited appropriately. This is one of the functions of RDE. If you are 

logged into the Conifer demo, you can import the data there. 

• With the RDE file opened, select Rapid Data Entry > Transfer RDE to BRAHMS. You can use the option 

Analyse RDE file first but in fact, the analysis always takes place when you run the transfer option.  

 

 
After running the Data Analysis, you can review the 
Import Report and apply filters as here showing subsp.  
This indicates these records are new to BRAHMS. 

 
 

     

  

The import log includes more detail and can be saved to a 
text file. 
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Before deciding to transfer the RDE file into your database, you can also use the option Show analysis flags on 

the RDE menu. This displays a series of Boolean flags indicating the status of the data about to be imported. If a 

record is ticked, this means it’s a new entry. You can set filters on these flags using the grid filter bar. 

 

  

The RDE analysis flags indicate the same information provided in the report with new entries flagged up in the various tick 
boxes. You can use the grid filter row to set filters, for example, to show new families.  

Once satisfied the data are good to go, you can then Select Next on the import tool and select Run to 

Import the data. 

 

 

 

Showing the data now added to the main species table, here sorted by Created on. 
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Example: importing your own sample data using RDE 

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#importingfromexcel 

This exercise encourages you to work with your own data, perhaps a list of taxa or better still, some specimens. 

These may be animal or plant data, whatever you have. The task is to transfer these from an Excel XLSX table 

into a BRAHMS Rapid Data Entry (RDE) file. Your data can be for any of the categories currently listed in the 

RDE manager when you create a new RDE table. 

• Select Rapid Data Entry > RDE File Manager.  

• Click again on the Rapid Data Entry menu and then choose Create RDE ... choosing the appropriate 

category. If you want to add collection data, this will be Specimens.  Give your file a Title such as Field trip 

2018 or My Orthoptera collection.  

• On the next step of RDE file creation, you choose the default fields to display in the RDE file. You can also 

add custom fields using Custom column Editor on the left part of the screen. You can alter the default field 

order at this stage using the Move column options (clicking to the left side of the field to move to activate 

this). 

 

 

If you now double-click on your RDE file, it will open as an empty file.  

 

The yellow row at the top of this empty RDE file is the grid filter bar - not used for data entry. 

At this stage you can switch to Edit mode and manually add records. But in this example, we discuss how you 

can import data from and XLSX file. The next steps assume you have some data in a XLSX file to import. We 

recommend at this stage that your XLSX file has a maximum of about 1000 records for testing.  

On the Rapid Data Entry menu, select Import from Excel… This opens the Excel import wizard. You can select 

the XLSX file and then match the columns between your XLSX and your RDE files. 

 

Adding custom columns to a new 
RDE file. Note that setting the char 
size to 0 for a text field create a max 
length character field. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#importingfromexcel
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As an example, the RDE file includes a field Latitude which is matched to a field LAT in the XLSX file. By matching the fields, 
you will import the data correctly. Where fields have the same names, they should be auto-matched. 

Of course, the data have to be broadly in the correct format before transferring to RDE. For example, collection 

event dates are stored in the 3 numeric fields Collection Day, Collection Month and Collection Year. So, if your 

XLSX file has this in a date field, you would need to convert the data to 3 numeric fields first. Also, for mapping, 

map data in the Latitude and Longitude fields should be decimal format and negative for South and West. 

Troubleshooting 

If you have old versions of RDE files (data structures out of date) within your RDE folders, these may prevent 

you from seeing any RDE files – including new ones. In such cases, please delete the old RDE files and the new 

RDE will appear in your RDE file view. Old RDE files may have been created in a testing phase. 
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Mapping your data  

Introduction 

Mapping options include dynamic links to the in-built ArcGIS and externally, by passing data to ArcGIS, Google 

Earth, DIVA, QGIS and GeoCAT.  

You can map your data directly from BRAHMS as long as the data table includes the equivalent of Latitude and 

Longitude fields. Currently, this applies to all collection events, the botanic garden plant tables and the 

equivalents of these in RDE tables. Mapping options are provided as follows: 

Map option Installation required Must be online Base maps required 
 

BRAHMS ArcGIS API No Yes No 

ArcGIS / ArcMap Yes No Yes 

QGIS Yes free No Yes 

Diva GIS Yes free No Yes 

GeoCAT No Yes No 

Google Earth Yes Yes No 

Download details for any required software and base maps are provide below. 

The choice of mapping tools depends on your objectives. For example, the built-in ArcGIS API is especially good 

for viewing and editing data, locating errors, map searches, certain calculations, and creating map images that 

can be added to reports. If your objective is to produce high quality maps for publication, you will likely choose 

QGIS, Diva or AcrGIS. Links to Google Earth are being developed mostly for analysis. GeoCAT is used to 

calculate EOO and AOO. 

The main mapping changes in v8  (coming from v7) are the addition of the in-built ArcGIS API; the map location 

editor tools; and that all map point data are stored only in decimal degree format. Data entry in different units 

is reviewed below. 

Map points 

All map points for latitude and longitude are stored in decimal degree format with negative values for South 

and West. We no longer use the v7 NS and EW fields. However, as with v7, you can choose to add data in 

Degree Minute Seconds (DMS) Decimal Degrees (DD) or Decimal Minute (DM) format. Point data can be 

entered to 10 decimal places. The resolution of points can be stated using the coded LLResolution field. These 

codes can be used to select map points and also to control the format of calculated map text strings. 

Mapping related fields 

Field Notes 

Latitude Latitude of the point 

Longitude Longitude of the point 

LLResolution Coded resolution of map data ranging from 1 to 8 (optional) 

LLOrigin Coded origin of map data (optional) 

LLDatum Geodetic Datum value e.g. WGS84, NAD83 

QDS * Quarter Degree Square value e.g. 2830CB 
 

# DGMS Calculated field for labels e.g. 16° 19' 59.998" N, 96° 35' 59.999" W 

Tag Standard BRAHMS field – but can be used to control which records are plotted 
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Cultivated Standard BRAMS field – can be used to control which records are plotted 

 

* http://www.ngi.gov.za/index.php/what-we-do/maps-and-geospatial-information/41-sa-mapsheet-referencing 

 

Sources of vector and raster base maps and other map layers 

There are numerous sources of map data available on the internet. http://www.diva-gis.org/Data  has 

numerous layers with global coverage. Excellent raster and vector maps are also available on 

http://www.naturalearthdata.com/features/. 

       

Global raster and vector map data are freely available on http://www.naturalearthdata.com/features/ and 
http://www.diva-gis.org/Data as well as on many other sites.  

You do not need to download base maps and layers if you are using the in-built BRAHMS ArcGIS mapper, 

Google Earth or GeoCAT. 

Thus as an example, if you wanted a vector (line) map for the world country outlines, you can visit 

https://www.naturalearthdata.com/downloads/ and choose Cultural (large scale data for the most detailed 

map) and download the Admin – 0 Countries file. There are many types of base map available for download 

under the cultural, physical and raster sections and you can pick and choose as relevant. 

Once any downloaded data are extracted (always a good idea to organise your base map data in well organised 

folders), you can use these data to draw layers in e.g. QGIS or Diva.  Examples are provided in the relevant 

sections below. 

Adding and editing map points 

Introduction 

The map location editor can be used in RDE and in the main tables for collection events and botanic garden 

plant points. This can be tested in the RDE file opened above. You can use the map location editor to add a new 

map point or edit an existing one. You need to be online to use this feature in BRAHMS. 

The editor opens an online map form which updates as you move through the data grid. Records with existing 

Latitude and Longitude points will be mapped using a single point on your selected base map. A right-click on 

the map resets the point position and either auto-saves this to the grid or awaits conformation with via the 

Save option. 

Although data in BRAHMS are always stored in decimal degree format, you can manually enter data in degrees 

minutes and seconds or in decimal minute formats. However, the ability to select or edit the point on the map 

reduces the need to type in data. 

 

http://www.ngi.gov.za/index.php/what-we-do/maps-and-geospatial-information/41-sa-mapsheet-referencing
http://www.diva-gis.org/Data
http://www.naturalearthdata.com/features/
http://www.naturalearthdata.com/features/
http://www.diva-gis.org/Data
https://www.naturalearthdata.com/downloads/
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Opening the map point editor 

To open the map point editor, you can either use the standard lookup in the Latitude or Longitude fields or 

alternatively, use the Map point editor option on the map toolbar. This latter option can be used from any field 

in the current record. It does not require you to be in edit mode although you do need edit rights. 

 

Once opened, the location editor can be used to edit points and altitude in your data grid 

 

The map location editor displaying the current point, set to Auto-save. In this mode, a right-click on the map will update the 
Latitude and Longitude values in the data grid without using the Save option. This screen has no zoom and is displaying the 
entire globe. 

           

 

The same point displayed at very different zoom levels. 
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Location editor settings 

Setting Notes 
Base map Choose base map that best suits the editing task in hand. 

Auto-zoom on/off If selected, as you move to different records, the map zooms to the current point using your 
zoom scale setting. 

Zoom to marker Zoom to current point based on your Zoom Scale setting. 

Zoom Scale Choose the optimal zoom setting. Maximum shows a world map. 

Reset Zoom Reset the zoom, if adjusted, to your current setting. 

Map units Select the entry mode for manually editing data.  

Lat Long checked Mark a record as ‘map checked’. 

Auto-save If selected, a right-click on the map will adjust the point and save the map point change. 

 

Selecting the optimal zoom level 

The optimal zoom level will vary from task to task. You can adjust zoom by double-clicking the map, using your 

mouse wheel or using shift + drag box around the area of interest. The speed of screen update depends on the 

number of map tiles the system needs to download. As a rule, the closer you zoom in, the slower the system 

will respond as you move to new records. Also note that different base maps influence speed. Some 

experimentation is needed to check the optimal settings. 

 

Sorting by collection date or by latitude + longitude 

If you sort the data grid by collection year then month then day, you can then scroll down the data grid to 

follow a collector’s itinerary. This can be a useful way to resolve collection locations and field number sequence 

errors. 

If you sort the data grid by latitude and longitude, as you scroll down the grid, the points will follow the 

geographic sort. 

 

Location searching 

The internal Map Point Editor, dynamically connected to your data grids, has a location search tool. Localities 

can be searched for by name or part of a name, adding a region or country to help improve the results listed. 

Clicking on the suggested locations list adds a blue suggestion marker to the map. A right-click on the map adds 

the map reference to the data grid. The location search is very similar to that provided in e.g. Google Earth. 

 

 

Calculating distances with the Map Point Editor 

It is often necessary to adjust a map point position based on a distance measurement, for example where 

collection locality notes say '20km west along route 249'. This is done using the internal Map Point Editor 

Distance Measurements option. Distances can be calculated in different units and the corrected point can be 

auto-added to your data grid. 

https://herbaria.plants.ox.ac.uk/bol/Content/Projects/brahms/images/hires/MapLocationSearching.PNG
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After drawing a polyline, a right-click on the map will update the data grid map reference.  

 

Mapping using the ArcGIS API 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#mapping 

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mappingvideo  

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#gardenmapping 

 

Introduction 

The in-built ArcGIS API provides a wealth of handy mapping features which you can take advantage of without 

installing any further GIS software. However, you do need to be online. Some advantages of the in-built ArcGIS 

tool:  

• No installation required;  

• data points are highlighted on the map as you browse through your data grid;  

• clicking on a map point tags records ‘M’ in your data grid, an excellent way to locate errors;  

• maps are auto-updated as you apply grid filters;  

• calculation of Extent of Occurrence (EOO);  

• selectable base map including world imagery;  

• map tagged only or map all, exclude cultivated records; 

• apply map point colours based on tag colours; 

• search maps;  

• save map as a png file and import to a document.  

 

 

Preparing some sample distribution maps  

• Select Collections > Collection events then select the Mapping toolbar followed by ArcGIS in BRAHMS. If 

no filter is applied, by default, this will plot all tagged records. To plot records, tagged or not, adjust the 

Tagged only option.  The map window can be dragged to another monitor and made full screen size. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#mapping
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mappingvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#gardenmapping
https://herbaria.plants.ox.ac.uk/bol/Content/Projects/brahms/images/hires/MapEditorDistance.PNG
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A map displaying all conifer collections (no filters applied). The setting here does not restrict to tagged records and a dark 
gray base map is selected.   The current record (Kenya) is hightlighted on the map. 

 

 

Here, a filter set on New Zealand with the base map set to World imagery, the point colour has been changed and the 
current grid record is highlighted. 
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In this example, the collection events are docked below the species table which is set to show accepted names only. The Taxa 
menu Link Grids option has been selected. Thus, moving to a new record in the species grid will update the collection events 
and the map. 

 

An example using the main query tool to define a rectangular grid area. This is a useful way to save a commonly used search 
similar to ‘grid box’ searches in version 7.  

 

 
This example, taken from The Morton Arboretum database, shows gardens plants filtered on Plant Status = ‘A’ (Alive) and 
Planted Year before 1995. The Column Summary shows the number of plants per taxa. 
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Map point tagging 

Using the Toggle tag option, you can click on map points to tag ‘M’. These may be error points that you want to 

check. Your can then use the map Filter toolbar to filter your grid to the M tagged records. 

 

Clicking on map points with tag mode enabled, you can selectively mark-up map point then filter your data grid. 

 

Map searches 

Using the Draw search area option on the Map toolbar, you can drag a search area and then use Search drawn 

areas to apply the search filter. 

 

This example shows a map searched directly using the search tools. The data grid is updated accordingly. The Column 
Summary tool, here docked left, is displaying the number of collection event records per taxa within the selected area.  

 

Map Auto-Zoom 

By default, maps will zoom to display the boundaries of the selected data points. However, it can also be 

convenient to disable Auto-Zoom to be able to display species distributions on a fixed area. 
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With the ArcGIS Auto Zoom disabled, you can plot different taxa without changing the current base map area. 

 

Map point colours 

 

You can respect record tag colours by selecting the Use Tag Colours option on the map itself. Tag colours can be defined 
from System > Options > Tag Highlight Colours. 

 

Locating and editing map errors – some hints and tricks 

Most museum or garden databases with geo-referenced data include errors. Map data errors have many 

potential causes and correcting these if often a priority for projects. 
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The above map is from a gathering of data mostly from Brazil. The errors look a lot worse than they are as the 

vast majority can be fixed by simply adjusting the north-southing and/or the east-westing of the points. This 

would be done by ensuring any points known to be ‘west’ have negative longitude value. 

a) Set a filter 

b) Use a map search plus SQL command 

  

 

Setup for ArcMap, QGIS, DIVA 

 

While BRAHMS does it best to locate these programs in your computer registry, some installation locations are 

harder to find. Thus, you can explicitly link the start-up exe or bat files for these GIS packages. 

Select System > Options > Mapping to hardwire the locations of the start-up files. 

 

 

Setting GIS start-up locations. 

Mapping using ArcMAP 

Introduction 

If you are an ArcGIS/ArcMAP user and have this software installed on your local PC or network, you can 

connect from BRAHMS, passing data to new or existing map projects. As discussed below, assuming the 

BRAHMS data output file is added as a data layer in your project, the map points will be added to your map 

dynamically. 

Map points and the arcmap_data.csv file 

Map points in BRAHMS are stored in main collection events file, the living collections table and in the main 

gazetteer - together with other map related fields. When you create maps, the relevant data from all tagged 

records are used to create the csv file arcmap_data.csv. As discussed below, this file can be included in your 

map project. 

The arcmap_data.csv file includes fields gathered from BRAHMS, these depending on the category of data 

being mapped. 
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A selection of the fields available in the arcmap_data.csv 

 

Data fields passed to ArcMAP 

When you plot data to ArcMAP, all of the fields in your currently selected field view are passed in csv format. 

You can include standard and custom fields. The fields Latitude and Longitude must be included. 

 

RecordID and data editing 

The Record ID is the GUID identifier of the record in BRAHMS. This means that selected data can be edited 

using GIS tools and then transferred back to BRAHMS, updating the table accordingly. For example, you may 

have used some tools you have added to or developed in ArcMAP to check and adjust map points. By exporting 

the revised Latitude Longitude points together with the GUID, you can then easily update your database using 

the Match/Transfer tool. This would equally apply to data returned from a hand held device. 

 

Opening a new or saved ArcMAP project 

To open ArcMAP, use the ArcMAP option on the Maps toolbar. Note that this option will not be enabled if you 

have selected Tagged Only and no records are tagged. Mapping output will respect filters. Thus, you can set a 

filter (in the example below a country name) and/or restrict to tagged records. 

 

 

The ArcMAP option will not be enabled if you have selected Tagged only but have no tagged records. 

    

Opening ArcMAP with no project selection. Right. Selecting an existing project (default). 
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Here, an existing project has been opened and using the  Add Data option on the ArcMAP toolbar, the BRAHMS output 
file arcmap_data.csv is located. Note that you may need to register this data folder so that ArcMAP can locate your csv data 
file. 

 

At this stage, you could open this table by right-clicking on the csv and select Open. The next step is to correctly register this 
csv data file as a map layer. To do this, right-click on the csv and select Display XY Data. 

 

 

Ensure the Longitude and Latitude fields are correctly selected. Using the Edit option, set the Geographic Coordinate System 
as required – the default used by BRAHMS is World WGS 1984. 
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With arcmap_data.csv correctly registered, the point data passed from BRAHMS with automatically update when a new 
map is produced.  

 

 

The above map produced from the Red Butte Garden database was created by applying a filter to their garden locality 
named ‘Floral Walk’ and plotting directly to ArcMAP. 
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Mapping using QGIS 

Introduction 

Video samples are provided on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos  

QGIS is a mapping package – freely available on https://www.qgis.org/en/site/ (or just search for QGIS). 

BRAHMS can connect and pass data to QGIS – but you have to install the QGIS software locally first.  

Map points and the qgis_data.csv file. 

Map points in BRAHMS are stored in main collection events file, the living collections table and in the main 

gazetteer - together with other map related fields. When you create maps, the relevant data from all tagged 

records are used to create the csv file qgis_data.csv. As discussed below, this file can be included in your map 

project. 

The qgis_data.csv file includes fields gathered from BRAHMS, these depending on the category of data being 

mapped. 

Fields passed to QGIS 

When you plot data to QGIS, all of the fields in your currently selected field view are passed in csv format. You 

can include standard and custom fields. The fields Latitude and Longitude must be included. 

 

RecordID and data editing 

The Record ID is the GUID identifier of the record in BRAHMS. This means that selected data can be edited 

using GIS tools and then transferred back to BRAHMS, updating the table accordingly. For example, you may 

have used some tools you have added to or developed in QGIS to check and adjust map points. By exporting 

the revised Latitude Longitude points together with the GUID, you can then easily update your database using 

the Match/Transfer tool. This would equally apply to data returned from a hand held device. 

 

Opening a new or saved QGIS project 

To open QGIS, use the QGIS option on the Maps toolbar. Note that this option will not be enabled if you have 

selected Tagged Only and no records are tagged. Mapping output will respect filters. Thus, you can set a filter 

(in the example below a country name) and/or restrict to tagged records. 

 

The QGIS option will not be enabled if you have selected Tagged only but have no tagged records. 

    

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos
https://www.qgis.org/en/site/
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Opening QGIS with no project selection. Right. Selecting an existing project (default). 

 

 

Having opened a new project and added a map layer (here a global raster map), the next step is to add the data 

points layer as exported from BRAHMS in the qgis_data.csv file.  

To do this, select Layer > Add Layer > Add Delimited Text Layer. Here you can locate the file qgis_data.csv. The 

X and Y fields should pick up Longitude and Latitude. 

 

Once added, you can save the project with the registered data layer.  

Once the csv file has been registered, any new map you plot from BRAHMS using the saved project will display 

the points from the supplied csv file. 
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Decimal point separators 

The default for latitude/longitude values uses points as decimal separators. If you use commas, make sure you 

select the QGIS option as below: 

 

 

 

 

Mapping using Diva GIS 

If you have diva installed (www.diva-gis.org/download), you can plot maps there using the same procedures 

used in v7. Unlike QGIS, it is not possible to pass and plot the map points directly. Instead, after opening Diva, 

you need to pull in the map points as discussed below.  

Once Diva is opened (you may have chosen a saved project with existing map layers): 

Add the map layer(s) 

• In DIVA, select Layer > Add layer and locate a .SHP file to plot.  

• Select one or more vector or raster SHP files.   

• To select a different area on your base map, use the   toolbar and drag a rectangle on your map. 

This can be done at any stage.  

• To change the properties of a map layer such as the thickness of the map coastline, double-click the 

small map layer rectangle in the left DIVA margin and then dbl-click the small rectangle on the 

resulting properties form and set the layer properties as prompted. Note that these actions can be 

carried out on any layer listed in the left margin. 

 

Add your map data points as a layer 

• To add your map data, select Data > Import points to Shapefile > From Text file (TXT).  

• Click on the Input file option and locate the map file that you created above. The default input map 

name is divagis_data.txt located in your Documents/BRAHMS folder. The field delimiter is a comma. 

            

Once you are at this stage, select Apply on the Diva form and your points will appear. 

http://www.diva-gis.org/download
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Mapping to Google Earth and GeoCAT 

Assuming you have installed Google Earth on your PC, you can plot map directly using the option on the 

Mapping toolbar. GeoCAT is online and requires no installation. As with other mapping options, be sure that 

the Tagged only option is set as needed. 

 

 

 

 

Mapping to Google Earth 

 

             

The species Pinus balfouriana plotted from the demo conifer database. Clicking on the data points displays selected field 
values. 

 

Mapping to GeoCAT 

 

The species Pinus balfouriana plotted to GeoCAT from the demo conifer database.  
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Reports and report templates 
Best to use a large monitor and a mouse when working with report design. 

 

Introduction 

Rather that providing a fixed set of reports, BRAHMS provides tools that allow you to design and save your own 

report templates. These templates can then be used to produce almost any imaginable report output starting 

from basic lists and labels to more complex designs with indexes and calculated summaries. Video links are 

provided on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos. 

BRAHMS is dynamically linked to a third-party reporting tool called Stimulsoft. We chose this as it is rich in 

reporting features and many of these can be controlled from within BRAHMS. Those interested to explore to 

full extent of its capabilities are encouraged to refer to https://www.stimulsoft.com/en/documentation/online/user-

manual/ or to download from: https://admin.stimulsoft.com/documentation/Stimulsoft_Reports_User_Manual.en.pdf.  

While the design steps in the examples that follow may seem daunting, once mastered, you will be able to 

design almost any report you need. It’s satisfying to conquer reporting and it makes your database efforts all 

the more worthwhile.  

Quick lists using Print Preview 

This option is separate to the main reporting tool. While it lacks the flexibility of the main reporter, this is a 

useful way to produce quick lists from the opened table, respecting any filters set and columns selected. Unlike 

the main reporter, this option does not work with tagged records – although you can set a filter on tagged 

records.  

 

 

Harking back to an earlier 
version of BRAHMS published 
in 1996… a short article 
published in Oxford Plant 
Systematics 4. This early 
version ran under MS DOS… 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos
https://www.stimulsoft.com/en/documentation/online/user-manual/
https://www.stimulsoft.com/en/documentation/online/user-manual/
https://admin.stimulsoft.com/documentation/Stimulsoft_Reports_User_Manual.en.pdf
https://herbaria.plants.ox.ac.uk/bol/Content/Projects/oxford/ops/ops4.pdf
https://herbaria.plants.ox.ac.uk/bol/Content/Projects/oxford/ops/ops4.pdf
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An example print-preview report with filters. It’s best to restrict to a small number of columns otherwise the 

report wraps to new pages – even if you choose landscape mode. Keep columns as narrow as possible. 

 

The Report Manager 

Introduction 

The Report Manager (updated v8.1) is opened when you select Data Tools > Reports. The manager allows you 

to create and/or edit report templates; run reports; and register/unregister your templates. Only users with 

permission can create and edit templates. Most users on networked systems will use the Run option to use 

report templates that have already been designed. 

Templates that are shared will be visible to all users. Thus, if you are a database manager/administrator, you 

can create and register (import) all the standard reporting templates you need for your users. Other users do 

not need to open the report designer – they will select the required report and run it. This will process all 

tagged records.  

 

The Report Manager for a user that has create/edit permissions showing the various edit options on the right 

side. 
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Transfer reports from v8.0 to 8.1 

When upgrading from v8.0 to 8.1, projects with existing report templates (.mrt files) should register these in 

the new Reports Manager. Open the Report Manager in the relevant table and use the Import... option. This 

option allows you to select your existing template mrt files and provide report names and descriptions. The 

Option T/F Flags option may be enabled so that you can define Additional Report Data/ table relations. 

  

Registering a report in the Report Manager. 

Reports that are Shared will be visible to all system users. The Additional Report Data option is only enabled 

where relevant. 

Note garden plant label mrt files should also be registered in the plant labels list as in v8.0. If plant label reports 

are also registered in the Report Manager, they will also be available for general reporting as well as via the 

specialised plant label print options.  

 

Report create/edit permissions 

Admin level users will always have the ability to create and edit report templates. For other users, you can 

assign permissions as below: 

 

System > Users and Permissions > Specific actions. A user that does not have these permissions assigned will only 

be able to run existing report templates as registered in your Report Manager for any given table. 
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The Report Manager as seen by a user that does not have create/edit permission. 

 

Report template storage and the import/export options  

When you design a new report template, the design is stored in a BRAHMS database table. This is a change of 

behaviour from earlier BRAHMS 8 versions where the templates were stored as external physical .mrt files. 

If you have existing .mrt files, use the Import option to register these report templates. If you want to create 

.mrt report template files from your registered reports (e.g. to send to another project), use the Export option. 

Sharing report templates 

If you share a report template, all users will see and be able to use this report template. If you do not, it will 

only be visible to the user that created it. 

Report templates 

A report template is a report design file. Each template is a single file with a. mrt extension. In the latest 

BRAHMS versions (May 2022 onward), the templates are incorporated into your database and are not stored 

as external .mrt files.  Templates can be given any sensible name (‘My RDE label’, ‘Genus Index’, etc.). They can 

be shared with other users.  

Report templates are associated with a category of data and must be used with that category of data. If you 

design a report template for use in RDE specimen tables, it would not be possible to use this template in 

another type of RDE file or in the main database. Once designed, a given template can be used as often as is 

needed against any data in the appropriate table. For example, a report template designed for a specimen RDE 

could be used for any specimen RDE file you create.  After creation, templates can be edited as needed. 

When you open the reporter, you can choose the template to use from the File options – recently used or 

browse to locate. 

 

The reporter is accessed from any table using the Reports option on the Data Tools toolbar. NB the Print Preview option is 
an entirely separate and more limited tool for creating quick tabular summaries based on your current field selection. 
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The Icons on the left side are used to create reporting ‘bands’ and add other features such as images to your report. The 
menu at the top includes the main design, layout and preview options. The lower Properties tab displays all the available 
properties for the currently selected item (here the page properties). The Dictionary tab (not selected here) displays the 
available data table(s) and fields. 

 

 

Using the Setup Toolbox, you can add 
many more tools to the let margin and 
further explore the reporter capabilities. 
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Preparing a basic taxa list 

This preliminary example creates a tabular report with the family, genus and species names, but only printing 

the family and genus names when they change. Most of the steps in this example are discussed in more detail 

in the next report example. This first example uses minimal formatting. 

Tagging the records for your report 

The reporter is opened from any data grid using the Reports option on the Data Tools toolbar. When you open 

the reporter, BRAHMS only passes data from tagged records - thus, be sure to tag records to process before 

you select Reports. If you want to process all records in the current file, you must tag all the records.  

 

 

• On the main menu, select Taxa > Species then use Tag > Clear Current Grid Tags. 

• If you want to restrict this report to show only names where Taxon Status is Accepted, apply the 

appropriate filter. Then select Tag > Tag all (you can use any character). 

• Select Reports to open the report designer. 

 

 

 

 

The report designer, with the Dictionary tab selected, open and ready to use. 

It’s always a good idea to save your report design from the outset, giving it a sensible name. Then you can just 

use the top left Save option as you proceed. 

Adding the data to your report 

• Select the Dictionary option and drag the Species table icon onto the report surface. This opens a field 

selection form. 
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• Select the fields FamilyName, GenusName and CalcFullName and sort these as shown above. 

 

This will add a DataSpecies report band as shown above. You can already Preview this list. After previewing, 

return to the editing mode using the Page tab. Previews may take some time to generate. 

Next, adjust the field widths. 

• Click on the FamilyName entry within the band and reduce the width by dragging the right edge or using 

the properties tab Width option. Resize the other fields allowing less space for the family/genus names but 

more space for the full species name. The widths can be refined later. You can also set field widths using 

the Position properties for the fields. 

The next stage is to sort the data appropriately. Note that sort commands are stored within the report itself. 

• To sort the data, double-click on the top of the newly added data band and choose the Sort option. 

• Use Add Sort to add sort entries for the FamilyName and the CalcFullName. 

 

As the CalcFullName includes the genus, it is not necessary to add genus to the sort list. 

 

Previewing the report will now display these data correctly sorted. 

In order to print the Family and Genus names only when they change: 

• Click on the {Species.FamilyName} field on the report and then select Properties. 

• Under the Text Additional options, set ProcessingDuplicates to ‘Merge’.  

• Repeat this for the GenusName. 

 

If you Preview now, you will see that the edited fields appear once per name.  

The table will look better if all the fields are aligned at the top of the cells. To do this: 

• Select the fields one by one or shift click to select all three. Then use the Align Top option on the Home 

toolbar. 
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Using the Align Top toolbar option. 

• Save and Preview the report. 

Finally, for this basic list, set the font of the family and genus names to Bold by selecting these two fields and 

using the B font control on the main toolbar. Increase the font size slightly for the family and genus. 

 

A sample of the final report. You could easily save this to a Word document using the Preview Save option. 

Conditional formatting examples 

The following general examples illustrate how you can use conditional formatting in reports for Text, Numeric 

and Boolean fields. These examples are based on an RDE specimen file where the table name is 

RdeCollectionEventRecord. Note – you can use IIF() or ternary expressions. 

Text field – example printing literal strings 

In this example, the condition is looking for a specific museum code ‘ABC’. Note the use of ‘==’ rather than ‘=’. 

This is because ‘==’ is required to set / compare a value. You can use ‘!=’ to mean ‘not equal to’. Conditional 

formatting can use the IIF() function where you have a condition following by the action when the condition is 

satisfied and then by the action when it is not. Thus: if the condition is true, print the first item, if not true, print 

the second item. In this example, both items are literal strings in quotes – however they could also be variables 

Museum code: {IIF(RdeCollectionEventRecord.MuseumCode == "ABC", "ABC", "Not ABC")}   

Text field – example printing variables 

In this example, if the museum code is ‘ABC’, it prints the collector name + number. If not ‘ABC’, it prints the 

species name. 

{IIF(RdeCollectionEventRecord.MuseumCode == "ABC", RdeCollectionEventRecord.Collectors + ' ' + 

RdeCollectionEventRecord.FieldNumber, RdeCollectionEventRecord.CalcFullName)} 

 

Text field – ternary example 

The type category is conditionally printed followed by some HTML to create a line break. The condition is that 

the TypeCategory != "" (i.e. is not blank). Ternary conditions use a ‘?’ which equates to ‘then’ and a colon which 

equates to ‘Otherwise. 

{DetHistory.Specimen.TypeCategory != "" ? DetHistory.Specimen.TypeCategory + "<br/>" :  “”} 
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Numeric field 

In this example, the number 3 is not enclosed in quotes as it is not text. Note that ‘==’ is used as above. This 

example does not use IIF(), rather a construct known as a Ternary Operator: variable = Expression1 ? 

Expression2 : Expression3 which is a shorter code expression. 

Month name is: {(RdeCollectionEventRecord.CollectionMonth == 3) ? "March" : "Not March"} 

Boolean field 

When using yes/no fields, you can use the format as below. This example is based on a custom field named 

‘IsNative’. 

Boolean example: {(RdeCollectionEventRecord.IsNative == true) ? "Native" : "Not Native"} 

 

Adding calculated columns 

Introduction  

There may be cases where you want to add calculated fields to your report. Calculated fields can be added to 

your report templates – these fields do not exist in your database or RDE tables, rather they are only 

represented in the report template. A calculated field will have an associated expression which calculates a 

numeric or text value based on other data values in your table. Simple or complex calculated field expressions 

can be prepared using language similar to C#. 

The example used here is to convert the decimal latitude and longitude values in an RDE file into a readable 

text string showing degrees, minutes and seconds. However, bear in mind that you can use your own 

calculated field(s) in any table for many different purposes. 

 

Adding calculated fields 

In the open report template, with the Dictionary tab and the relevant data table selected (in this RDE example, 

RdeCollectionEventRecord), right-click on any data field and select the option ‘New Calculated Column’. 

 

Adding a new calculated column 
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Giving the new column a name and adding the expression 

When adding a calculated column, you provide the physical field name and can also give a different alias name. 

The alias name defaults to be the same as the field name. The expression can refer to one or more fields in 

your table including other calculated fields. Example expressions are provided below. 

Adding expressions to calculated fields – an example 

While not for everyone, those with (or with access to someone with) programming skills will be able to take full 

advantage of adding simple or complex expressions. Note that expressions may include conditional clauses. 

 

 

In this example, a calculated field called ‘LatDegree’ is added with an expression to hold the degree value of the 

field Latitude. The expression used is:  (int)Floor(Abs(RdeCollectionEventRecord.Latitude)). The expressions use 

functions that are taken form the report function list which in turn are based on C# functions. The ‘Int’ in this 

case is a ‘cast’ which is a standard programming method (in e.g. C#) to convert formats, in this case to a simple 

integer value. 

 

 



BRAHMS v8 introduction and guide  173 | P a g e  

RdeCollectionEventRecord.LatNS == ‘’ ? ‘’: RdeCollectionEventRecord.LatDegrees + "° "+ 

RdeCollectionEventRecord.LatMinutes + "' " + RdeCollectionEventRecord.LatSeconds + "\" " + 

RdeCollectionEventRecord.LatNS 

This calculated field called LatDMS is used to hold the final calculation to display in the report. 

 

Calculate a map reference DMS text string from a DD value 

Using the procedures explained above, here in an RDE file, you can convert RDE file Decimal Degree values such 

as 51.333333 -117.583333 to the text string such as 51° 19' 59" N 117° 34' 59" W 

 

Inserting an example into you own report template 

Below, you can find field and expression text taken from a completed report XML template. Rather than adding 

your own calc fields and writing your own expressions, you can copy this example text and add it to your own 

report – and use this example to see how it works. 

By doing so, it will add all the required calculated fields and expressions to your RDE report template. It looks 

nightmarish… but this is code generated by the reporter and you can easily copy it your own RDE specimen 

report template. Here are the steps to take. (NB. this assumes you have already created an RDE specimen 

report). 

1. Open your RDE specimen file and then open the main Reporter. 

2. Use the Export option to export the report to a saved .mrt file. 

3. Locate the mrt file and open it using a basic text editor such as notepad or notepad++. You will see that report templates are stored 

in XML format as shown below: 

 

4. Locate the start of the RdeCollectionEventRecord Columns section as shown above. Go to the bottom of this section 

 

Here the last entry in the column section is for the VernacularName. This is followed by the closing tag 

‘</Columns>’. 

 

5. The next task is to copy and paste in all the column values as listed below. These should be pasted in 

just above the closing </Columns> tag.  

6. Save the text file in your editor. This will update your exported .mrt report file. 

7. Return to the Report option in RDE and then use the Import option to import your updated mrt file. 

You will be asked to provide a new report name. 

8. If you now edit the new report and open the dictionary, you will see all the new calculated fields with 

their expressions.  
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Displaying the new calculated field(s) in your report 

You will not necessarily want to display all the newly added calculated fields. In the example given, most of the 

fields have been added to simply the calculation, storing the intermediate values in their own fields. For 

example, there are separate fields to store the calculated values for latitude degrees, minutes, seconds, 

microseconds and orientation (N or S). While you may want to print these values in your report, it is more likely 

that you would add the final assembled calculation for latitude which is added to LatDMS. All these repeated 

for longitude calculations. 

In this example, the new fields you will normally want to display in your report design are LatDMS and LonDMS. 

As with any other fields, these 2 fields can be added as expressions {RdeCollectionEventRecord.LatDMS}   and 

{RdeCollectionEventRecord.LonDMS}. You may combine these in a single report expression separated by one or 

more spaces - thus leading to an output such as:  51° 19' 59" N    117° 34' 59" W 

 

 

Calculated field column values to copy into your RDE report 

Refer to the instructions above. 

     
<value>LatNS,LatNS,System.String,RdeCollectionEventRecord.Latitude_x0020__x003D__x003D__x0020_null_x0020__x000D__x000A__x00
3F__x0020__x0022__x0022__x0020__x000D__x000A_:_x0020_RdeCollectionEventRecord.Latitude_x0020__x003C__x0020_0_x0020__x0
00D__x000A__x003F__x0020__x0022_S_x0022__x0020__x000D__x000A_:_x0020__x0022_N_x0022_</value> 
          
<value>LonEW,LonEW,System.String,RdeCollectionEventRecord.Longitude_x0020__x003D__x003D__x0020_null_x0020__x000D__x000A_
_x003F__x0020__x0022__x0022__x0020__x000D__x000A_:_x0020_RdeCollectionEventRecord.Longitude_x0020__x003C__x0020_0_x002
0__x000D__x000A__x003F__x0020__x0022_W_x0022__x0020__x000D__x000A_:_x0020__x0022_E_x0022_</value> 
          
<value>LatDegrees,LatDegrees,System.Int32,_x0028_int_x0029_Floor_x0028_Abs_x0028_RdeCollectionEventRecord.Latitude_x0029__x00
29_</value> 
          
<value>LonDegrees,LonDegrees,System.Int32,_x0028_int_x0029_Floor_x0028_Abs_x0028_RdeCollectionEventRecord.Longitude_x0029__
x0029_</value> 
          
<value>LatSeconds,LatSeconds,System.Int32,_x0028_int_x0029__x0028_3600.0m_x0020__x002A__x0020__x000D__x000A__x0028_Abs_
x0028_RdeCollectionEventRecord.Latitude_x0029__x0020_-
_x0020__x000D__x000A_RdeCollectionEventRecord.LatDegrees_x0029__x0029__x0020__x0025__x0020_60</value> 
          
<value>LonSeconds,LonSeconds,System.Int32,_x0028_int_x0029__x0028_3600.0m_x0020__x002A__x0020__x000D__x000A__x0028_Abs
_x0028_RdeCollectionEventRecord.Longitude_x0029__x0020_-
_x0020__x000D__x000A_RdeCollectionEventRecord.LonDegrees_x0029__x0029__x0020__x0025__x0020_60</value> 
          
<value>LatMinutes,LatMinutes,System.Int32,_x0028_int_x0029__x0028_3600.0m_x0020__x002A__x0020__x000D__x000A__x0028_Abs_
x0028_RdeCollectionEventRecord.Latitude_x0029__x0020_-
_x0020__x000D__x000A_RdeCollectionEventRecord.LatDegrees_x0029__x0029__x0020__x002F__x0020_60</value> 
          
<value>LonMinutes,LonMinutes,System.Int32,_x0028_int_x0029__x0028_3600.0m_x0020__x002A__x0020__x000D__x000A__x0028_Abs
_x0028_RdeCollectionEventRecord.Longitude_x0029__x0020_-
_x0020__x000D__x000A_RdeCollectionEventRecord.LonDegrees_x0029__x0029__x0020__x002F__x0020_60</value> 
          
<value>LatMilliseconds,LatMilliseconds,System.Int32,_x0028_int_x0029__x0028_1000m_x0020__x002A__x0020__x000D__x000A__x0028
_Abs_x0028_RdeCollectionEventRecord.Latitude_x0029__x0020_-
_x0020__x000D__x000A__x0028_RdeCollectionEventRecord.LatDegrees_x0020__x002B__x000D__x000A__x0028_RdeCollectionEventRec
ord.LatMinutes_x0020__x002F__x0020_60m_x0029__x002B__x000D__x000A__x0028_RdeCollectionEventRecord.LatSeconds_x0020__x0
02F__x0020_3600m_x0029__x0029__x0029__x0029_</value> 
          
<value>LonMilliseconds,LonMilliseconds,System.Int32,_x0028_int_x0029__x0028_1000m_x0020__x002A__x0020__x000D__x000A__x002
8_Abs_x0028_RdeCollectionEventRecord.Longitude_x0029__x0020_-
_x0020__x000D__x000A__x0028_RdeCollectionEventRecord.LonDegrees_x0020__x002B__x000D__x000A__x0028_RdeCollectionEventRe
cord.LonMinutes_x0020__x002F__x0020_60m_x0029__x002B__x000D__x000A__x0028_RdeCollectionEventRecord.LonSeconds_x0020__
x002F__x0020_3600m_x0029__x0029__x0029__x0029_</value> 
          
<value>LatDMS,LatDMS,System.String,RdeCollectionEventRecord.LatNS_x0020__x003D__x003D__x0020__x0022__x0022__x000D__x000
A__x003F__x0020__x0022__x0022__x000D__x000A_:_x0020_RdeCollectionEventRecord.LatDegrees_x0020__x002B__x0020__x0022__x0
0B0__x0020__x0022__x002B__x0020__x000D__x000A_RdeCollectionEventRecord.LatMinutes_x0020__x002B__x0020__x0022__x0027__
x0020__x0022__x0020__x002B__x0020__x000D__x000A_RdeCollectionEventRecord.LatSeconds_x0020__x002B__x0020__x0022__x005C
__x0022__x0020__x0022__x0020__x002B__x000D__x000A_RdeCollectionEventRecord.LatNS</value> 
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<value>LonDMS,LonDMS,System.String,RdeCollectionEventRecord.LonEW_x0020__x003D__x003D__x0020__x0022__x0022__x000D__x00
0A__x003F__x0020__x0022__x0022__x000D__x000A_:_x0020_RdeCollectionEventRecord.LonDegrees_x0020__x002B__x0020__x0022__
x00B0__x0020__x0022__x002B__x0020__x000D__x000A_RdeCollectionEventRecord.LonMinutes_x0020__x002B__x0020__x0022__x0027
__x0020__x0022__x0020__x002B__x0020__x000D__x000A_RdeCollectionEventRecord.LonSeconds_x0020__x002B__x0020__x0022__x00
5C__x0022__x0020__x0022__x0020__x002B__x000D__x000A_RdeCollectionEventRecord.LonEW_x0020_</value> 
 

 

 

 

      

 

 

 

 

Preparing a species list with page set up and conditional formatting 

This example is based on the sample conifer database as it has Red List data (IUCN codes). But you may use 

another database as appropriate. Or replace the IUCN field with another as suits. 

Tagging records for your report 

The reporter is opened from any data grid using the Reports option on the Data Tools toolbar.  

 

Be sure to tag records to report on before you select Reports. If you want to report on all records in the current 

file, you must tag all the records.  

• On the main menu, select Taxa > Species then use Tag > Clear Current Grid Tags. 

• Apply a filter to show only names where Taxon Status is Accepted. The easiest way is to click on the word 

Accepted in the Tax Status field and then on Selection on the Data Tools toolbar. You can choose a 

different filter if appropriate. 

• Now select Tag > Tag all (you can use any character). 

• Finally, for this first stage, select Reports to open the report. 

 

The report designer is now open and ready to use. 

Report bands 

Report bands, central to report production, are like containers, each with a different function. Examples bands 

are Page Header and Footer bands (similar to Word Document headers and footers); The Title band which is 
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printed once at the start of a report; Header and Footer bands which are associated with your Data band (an 

example use is to print table report column headers); Group Headers and Footers (an example use is to print a 

Family name at the start of a list of taxa in that family); and the Data band which will output data for each row 

in your BRAHMS data grid. There are other bands but these are the key ones. As well as adding content to 

bands, they are highly configurable with formatting features. 

Adding a title band 

As a first step with the report design, add a title band with some text. All the band options are listed down the 

left side of the blank report screen. The title band icon is show below. 

 

If you hover over this icon, the tooltip text explains its function.  

• Click once on the icon and then click on the report surface – or drag the icon onto the surface.  

Either way, you should see the Title band added to your report, and extended to the full-page width. If you 

wanted to delete the band, selected it and press the Delete key. By default, the band will fix itself to the top of 

the report. You can increase the band height by dragging the lower edge of the band down or by editing its 

properties. 

You can refer to and edit the properties of this band by clicking on it then choosing the Properties option on the 

lower right side of the designer. A Right-Click on the band provides further options including access to its 

Properties. For example, the properties can be used to format the band background with a gradient colour fill. 

To add text to this band, you must add a text box component using the Text icon.  

• Again, click or drag this icon and create a text area in the title band. You can create the text area anywhere 

on the report surface then later, drag it to the Title band.  

When you add the text box, this auto-open the text expression editing tool. You can type the required text into 

the Expression area and save using OK. 

 

Click or drag the Text icon to create text box inside the Title band and add a report title. 

Clearly, there are a few tricks to learn here. Once added, you can re-open the text editor by Double-clicking the 

text box.  

Formatting options for the text box itself, and the text it includes, are found on the Home menu, the Layout 

menu and/or in the Properties options for the text box. For example, to centre the text box in the title band, 

use Layout > Align > Centre horizontally. But to centre the text within the text box, use the Home > Alignment 

options. 
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Add an image to the Title Band 

To add an image or logo to the Title Band, select the Image toolbar option on the left list of icons and click in 

the title band. The image can be positioned and re-sized. In the image properties options listed on the right 

pane, select the AspectRatio to ensure the image keeps the correct shape if re-sized. Also, you will need to 

select Stretch to ensure the image is re-scaled to fit the size you choose for the report. 

 

Title moved to side with the font edited and an image added to the Title Band. Adjust the properties as suggested above. 

Saving the report 

At this stage, it will be best to save your report design work. Use File > Save, choose any folder and give your 

report template a name. You could at this close and then re-open the report to continue editing. To open a 

saved report, choose File and you will see your recent reports or be able to browse to locate them. Unlike with 

v7, there is no central reports manager file. Report files can be exchanged with other users. 

Adding page numbering  

In this example, you can add page numbering to a page footer - similar to a Word Document footer. You could 

equally add to a page header. 

Click on the left margin Page Footer icon then click on the report surface (or drag the icon as above). The footer 

ban will by default auto-locate to the bottom of the design surface page. NB. you may need to scroll down to 

see this.  

The page footer band is different to a data summary footer. Scroll down 
to see the added band. 

As with the Title band, the properties of the Page Footer band are 

highly configurable.  

To add the page number using the format ‘page of total pages’: 

 

• Select the Dictionary option on the left panel and choose System Variables. Here locate the entry 

PageNofM. 

• Drag this variable onto your Page Footer band. It will be added into a text box feature. 

• Use the various formatting tools to align the text and set the font features. Ensure the text box width is 

enough to show the text. 

If you Double-click the text box to open the text editor – and then choose Expression, you will see that the 

variable PageNofM is enclosed in braces as in {PageNofM}.  

 

 

In this example Page Footer, the line tool has been used to add a horizontal line below a further text box and the page 
numbering. The items are positioned appropriately and the colour and font adjusted. Some experimentation is needed. 

Save your report design before proceeding. 
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Adding the data band 

The data band is the most important band as this is the link between your data and the report. This band can 

be added in two ways, either using the data band icon on the left side or by using another approach from the 

Data Dictionary. Here, the latter option is used. 

• Select the Dictionary tab. Here you will see the current BRAHMS data table listed. 

• Drag the Species table icon onto the report surface (not the yellow Species container icon above it). 

•  As you drop this onto the report surface, a dialogue opens offering the chance to select which fields 

to include. At this stage, only select the 3 fields: CalcFullName, IUCN and ProtologueCitation. There are 

other ways to add data fields to the data band but this is a convenient method for now. 

• Adjust the field order using the arrows provided to move the ProtologueCitation above IUCN. 

 

 

When adding the Data Band, you can also select the fields to include. The selected fields can be adjusted later if necessary. 

The properties of the Data Band can be adjusted as with the others. To do this, ensure you click on the Data 

Band itself rather than either of the text boxes within it. Then choose the Properties tab. There are numerous 

properties for data bands but at this stage, it’s not necessary to alter these unless you wish to experiment. If 

you click on either of the text boxes within the Data Band, you can then set the properties of each text box, for 

example the font.  

 

By default, each field is given equal space. This can be adjusted to give the species name a lot more space than the 2 letter 
IUCN code. You can drag the field edges to re-size or use the properties options to set the widths. 

 

Here, the field widths have been adjusted. Also, the text for IUCN has been adjusted right using the align tool. 

 

By double-clicking on the IUCN field, it becomes possible to add literal text to the expression. In this example, 

the expression {Species.Iucn} has been enclosed in square brackets [{Species__Tagged_.Iucn}] which will print 

e.g. [VU]. NB Be sure to add any text outside the { }. 

However, the square brackets need to be supressed if there is no IUCN Red List value. Otherwise you will end 

up with the ugly [] appearing in your report. This can be achieved by adding the following syntax to the 

expression (You can copy the full expression and paste this into your report): 
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{IIF(Species.Iucn != "", "[", "")}{Species.Iucn}{IIF(Species.Iucn != "", "]", "")} 

The handy IIF function is used to control what is printed. Looking more closely at {IIF(Species.Iucn != "", "[", "")}, 

this translates to …  if the Species.Iucn field is not blank (‘!=’ means not = to), then print “[“ otherwise print “”. Thus here, 

the function is used twice for the [ and the ] brackets. 

The height of the data band controls line spacing in your report. The width of the individual text boxes can be 

adjusted. 

Save your report design before proceeding. 

Also see: https://forum.stimulsoft.com/viewtopic.php?t=3825 

Other format examples: 
{(registrant_data.phone_number == null) ? "" : registrant_data.phone_number} 
{IIF((registrant_data.phone_number == null),"",registrant_data.phone_number)} 
{IIF((registrant_data.primary_name == registrant_data.participant_name),"",registrant_data.primary_name)} 

 

Adding a Group Header 

Group header bands are used to group data by one of more fields. In this report, it will be useful to group the 

data by family name. To add a data grouping header: 

• Click once on the Group Header icon and then click on the report surface – or drag the icon onto the 

surface.  

• If the newly added band is below the Data Band, drag the band up and release it above the Data Band. 

You now need to assign a what is termed a ‘condition’ (in this case a data field) to the Group Header band and 

also, add the data field to include in the report. 

• Firstly, to add the group ‘condition’, double-click on the band to open the data source (in the case the 

species table) and choose the field FamilyName. You will then see this added as a ‘condition’ in the band 

header. When you add a text condition, the default sort for he grouping is AZ Ascending. 

• Secondly, add a text box to the group header band. Double-click this, choose a Data Column and add the 

FamilyName. 

 

The Group Header Band showing the Condition Species.FamilyName and with the FamilyName added to a text box as a 
printable field. The family name font and position has been adjusted. 

 

Progress this far 

 

https://forum.stimulsoft.com/viewtopic.php?t=3825
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Sorting the data 

Separate to the group sorting, the data in the data band will need a sort order added. This can be one or more 

data fields added to the data band but in this case, the report only has to be sorted by the CalcFullName. 

• Double-click on the top of the Data Band (not on one of the text fields it contains). 

• Choose the Sort option and then choose the field CalcFullName. 

  

The sort option being used with the Data Band. 

• Use the Preview option to check your report – and it’s a good idea to Save the report design again. 

Adding a condition to the data band 

For this report, you could optionally colour the reported records depending on the Red List values, for example, 

printing the CR, VU and EN categories taxa in different colours. To do this, it is necessary to add one or more 

Data Band ‘conditions’. Conditions can be used in a wide variety of ways –this example sets a row highlighting 

condition.  

• Click on the Data Band header to select this. Take care to select the band rather than one of the fields it 

contains. Then select the Conditions option on the toolbar. 

• Select Add a condition choosing the Highlight Condition option. 

• Set the Column value to Species_Tagged_Iucn 

 

Three highlight conditions added to the field Species_Tagged_Iucn 

 

 

Adding a border box around the data band 

If you now select the Rectangle option on the left side toolbar, you can carefully position and size a rectangle 

with the required line style and colour to fit around the data band items.  

 

Detail showing the red dotted rectangle. This was set to red for this screen but edited back to a light grey colour. 
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Close up of report detail. A rectangle has been positioned in the data band surrounding the three fields – and the line style 
properties adjusted. 

Combining text with date fields 

Here is an example of how you can combine literal text with datetime fields,  

Date Record Created: {LivingCollection.AddedOn.ToString("dd/MM/yyyy")} Date Last Modified: 

{LivingCollection.LastModifiedOn.ToString("dd/MM/yyyy")} 

To achieve: Date Record Created: 10/01/2020 Date Last Modified: 05/03/2020  

How to upper case a data value 

To upper case a data value, use the function ToUpperCase() as in the example here: 

{ToUpperCase(LivingCollection.FamilyName)}   

Print report or save to a document 

In Preview mode, you can choose the required output, either printing directly or saving the report to one of 

several file formats including Word and Excel. One advantage of saving to a document is that the report can be 

further edited prior to final printing. 

 

 

The final report layout 
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Designing a specimen label 

Following on from the previous section on creating a list report, creating a label report template introduces a 

few new aspects to report design. This example assumes you have mastered the basic of opening the reporter 

and creating report bands. Unlike the list report above, this report template will only have a Data Band. The 

Title, Page Header and Group bands are not needed. Designing labels introduces the use of page columns, the 

ability to combine fields in expressions, the use of HTML tags, conditional clauses and the use of calculated 

fields. 

The example here reviews label production in the main specimen table. You can design a label in an RDE file 

using the same steps but the field names will change to an RDE prefix. You cannot design a single label 

template for both RDE and the main specimen tables. 

 

Tagging the records for your labels 

To create labels for preserved specimens, you have to open the main specimen table and tag the appropriate 

records.  As introduced in the previous section, the reporter is opened using the Reports option on the Data 

Tools toolbar.  

 

• On the main menu, select Collections and select the category Preserved specimens. Now open the main 

Specimens table. Use Tag > Clear Current Grid Tags and then tag the records to produce labels for. 

Create the report template page layout 

• Select Reports to open the report.  

Assuming you wish to print labels in two columns: 

• Select Page > Columns and set the value to 2. This would also be the time to set the paper size if 

necessary. 

• In the lower left pane, select the Dictionary tab and drag the Specimen table icon (not the yellow drum) to 

your report design surface. By default, this will position itself at the top of the left column. 

• When you drag the specimen data source, you will be offered the chance to select fields. For this report, 

do not select any fields at this stage. 

• Drag the Data Band down to increase its height. The precise height can be adjusted later to obtain e.g. 6 

labels per page. To help visualize the layout, add a rectangle to the report using the rectangle icon on the 

left side. Size this to almost fill the data band area. 

 

Here, the report page (left) has 2 columns, a Data Band has been added for the Specimen data source. A rectangle has been 
added to provide a visual reference. This rectangle may be removed later. The Preview (right) at this stage displays the 
rectangle layout. 
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Adding text for the top of the label 

Assuming you want to include some text to the top of the label, perhaps “Flora of” or your herbarium name, 

follow these steps: 

• Click or drag the Text icon onto the Data Band. You can now edit the contents of the text box and set 

properties such as font, text size, alignment and colour. 

• To edit the content of the text box, double-click the Text Box or click on the Text Box then select the Text 

button at the top of the Properties options. 

• Use the Home menu options to set font, size and other basic features. 

      

The text is centrally aligned within the text box and the text box itself is centred horizontally using the Layout menu option. 

Adding data fields 

The label design starts by looking at taxa names which present the most complex part of the label design. 

The easiest way to add a data field is to select the Dictionary tab in the lower left pane, expand the Specimen 

options, and then to drag the required field to the design area. This process adds the data field within a text 

box. The alternative is to add a text box and then insert the data field. This is possible, but there are more steps 

to take. 

• Drag the field FamilyName from the dictionary to the label surface. Adjust the position of the text box and 

set the various properties as required. You will want to set the font to about 10 point.  Make sure the text 

is adjusted left. 

  

The start of the label template with the family name added. Note that the final positioning can be done towards the end of 
the design process. 

Combining field names in a text box 

Some elements printed on labels require that data from more than one field is combined into a single text box 

expression. For example, genus + species + author. Multiple fields can be added to the same text box to create: 

{Specimen.GenusName}{Specimen.SpeciesName}{Specimen.SpeciesAuthor} 

• Drag the first field name (GenusName) on to the report design. This will 

create the initial text box. Then drag the fields SpeciesName and 

SpeciesAuthor to the same text box. The reporter will prompt how to 

append these fields with a series of positioning icons – choose the one 

with the small red hatched box to the right of the black hatched box – this adds the field to the last added 

field. 

• Once these 3 fields have been added, double click the text box and then choose the Expression options.  
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The reporter will auto-trim these fields, removing trailing spaces between the fields. However, you must add a 

single space as in: {Specimen.GenusName} {Specimen.SpeciesName} {Specimen.SpeciesAuthor} . Although you can add 

this now to learn and test, this string will be replaced with a more complex one given below. 

Using HTML tags 

In order to print the species name with possible infra-specific names together with 

authors, part in italic font, part not, it’s possible to add some simple HTML mark-up 

tags. The ability to add these tags opens up options for setting multiple font settings 

within a single expression. The available tags are listed below the dictionary entries. 

HTML tags can be manually added to your expression. 

The tags are always enclosed in angle brackets <> and they are placed outside the {} 

braces. There must always be an opening and closing tag. Thus, using the italics tags <i> and </i>, you can add: 

<i>{Specimen.GenusName} {Specimen.SpeciesName}</i> {Specimen.SpeciesAuthor} This will print the genus and 

species names in italic font but not the author name. 

If you are using HTML tags, you must ensure the text box property AllowHtmlTags is selected. 

 

Using conditional clauses to print the full taxa name  

When printing species names with infra-specific elements and/or cultivar names, it is necessary to add some 

conditional clauses. For example, if there is a subspecies name, you will want to print the text ‘subsp.’ or ‘ssp.’ 

before the name - but not if the name is blank. For cultivars, you will want to add quotation marks. 

One way to apply conditional clauses is to use the IIF() function. This function evaluates a Condition, and if the 

Condition returns true, the expression will return Value1. If it returns false, it will return Value2. The syntax != 

in programming means ‘not equal to’.  Note also that all programmatic components are enclosed in { }. 

IIF(condition, return value if true, return value if false) 

An example: {IIF(Specimen.Subspecies != "", "ssp.", "")} 

Here, if the field Specimen.Subspecies is not equal to blank, it returns “ssp.”, otherwise it returns an empty 

string. Using this, you can now develop the complete expression for all possible species epithets as follows: 

 

 

Specimen table Collection event table 

<i>{Specimen.GenusName} </i> 
<i>{Specimen.SpeciesName}</i>  
{Specimen.SpeciesAuthorName}  
{IIF(Specimen.Subspecies != "", "ssp.", "")}   
<i>{Specimen.Subspecies}</i>  
{Specimen.SubspeciesAuthorName}  
{IIF(Specimen.Variety != "", "var.", "")}  
<i>{Specimen.Variety}</i>  
{Specimen.VarietyAuthorName} 
{IIF(Specimen.Forma != "", "f.", "")}  
<i>{Specimen.Forma}</i>  
{Specimen.FormaAuthorName} 
{IIF(Specimen.Cultivar != "", "'", "")} 
{Specimen.Cultivar}{IIF(Specimen.Cultivar != "", "'", "")}  
{Specimen.CultivarAuthorName} 
 

<i>{CollectionEvent.GenusName} </i> 
<i>{CollectionEvent.SpeciesName}</i>  
{CollectionEvent.SpeciesAuthorName}  
{IIF(CollectionEvent.Subspecies != "", "ssp.", "")}   
<i>{CollectionEvent.Subspecies}</i>  
{CollectionEvent.SubspeciesAuthorName}  
{IIF(CollectionEvent.Variety != "", "var.", "")}  
<i>{CollectionEvent.Variety}</i>  
{CollectionEvent.VarietyAuthorName} 
{IIF(CollectionEvent.Forma != "", "f.", "")}  
<i>{CollectionEvent.Forma}</i>  
{CollectionEvent.FormaAuthorName} 
{IIF(CollectionEvent.Cultivar != "", "'", "")} 
{CollectionEvent.Cultivar}{IIF(CollectionEvent.Cultivar != "", "'", "")}  
{CollectionEvent.CultivarAuthorName} 
 

 
 
 
 

Using this expression avoids printing ssp. or var. or f. when there are no names of these ranks. You can replace 

“ssp.” with “subsp.” or as required. Also, the function encloses cultivar names in single quote marks. Cultivar 

names are not printed in italic.  
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It looks complex – but in any case, you can simply copy this entire expression to the species name text box in 

your report – replacing the {Specimen.GenusName} {Specimen.SpeciesName} {Specimen.SpeciesAuthor} that you 

added above. 

 

The text box area can be sized appropriately later – it does not have to be large enough to see the entire expression in 
design – only on display. If your HTML tags are not correct, make sure the text box property AllowHtmlTags is selected. 

 

 

On the left, a fictitious name entry with all epithets and all authors. The name shows the correct format and fonts. 

 

Adding geographic data and other notes fields 

Geographic data can be added field by field (Country, MajorAdminName, MinorAdminName etc. ) allowing you 

to format the data exactly as you wish. Alternatively, take advantage of the calculated field 

CalcFullGazetteerText. This calc field includes all fields from country to place name with locality notes, pre-

formatted. It does not include the map reference. 

• Using the same methods as above, drag CalcFullGazetteerText from the specimen dictionary list to the 

design surface. 

• Size the text box to be large enough (height) to include the longest text you will encounter. 

• Important - select the property WordWrap (under Text Options). 

NB. To print fixed size labels and thus, a constant number per page, easy to guillotine, the text box should be 

sized deep enough to fit the longest text you expect for the field. The alternative is to size the text box for e.g. 

one line – and set the property CanGrow to true. However, if you opt for CanGrow, the labels will most likely 

not be equal size in the columns. WordWrap is import though, otherwise, text over one line will not be visible. 

You can combine CalcFullGazetteerText and CalcLatLongText in a single text box adding the HTML tag <br> 

between these to create a new line.  

{Specimen.CalcFullGazetteerText}<br>{Specimen.CalcLatLongText} 

 

Some example output including the taxa and geodata. 

Further items could be added to the same text box as used for the geographic data including text notes for 

habitat and the specimen description. 
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{Specimen.CalcFullGazetteerText}<br{Specimen.CalcLatLongText}<br>{Specimen.HabitatText}  {Specimen.PlantDescription}  

The way you decide to arrange this will depend on personal preference. You may wish to include line breaks 

with <br > or just spaces between items. Remember, if you are using HTML tags, you must ensure 

AllowHtmlTags is selected in the Properties. Some trial and error testing will be needed to get the correct text 

box sizes and fonts. 

Adding collector name(s), field number and date 

In this example, the collectors and field number are added to a shared text box. Drag the field 

PrincipalCollector and FieldNumber from the dictionary to the label surface to create a single text box. To do 

this: 

• Open the data dictionary on the left side and expand the Specimen Data Source. Drag the 

PrincipalCollector field to the design surface and roughly position and resize the text box.  

• Now drag the FieldNumber on top of this text box. A red box appears and a small form opens to request if 

and how you wish the fields to be joined in the text box. Choose the option with the small red shape to the 

right of the grey shape. 

          

 

By editing the properties of the text box expression, you can now add a space between these fields and optionally add a text 
string such as ‘No. ‘. 

• Finally, drag the field CalcLongCollectionDate to a new text box. Position this to the right. You may want to 

right align the text. 

 

The label as above designed. 
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The same exported to a Word document. 

Adding barcodes 

The most detailed description is available on https://www.stimulsoft.com/en/documentation/online/user-manual/ in the 

section Report Internals > Barcodes. 

You can add a wide range of barcode types and control how these are displayed. 

 

Use Insert > Barcode to add the barcode expression, choosing the setting as required. 

 

 

 

Dbl-click the expression to open the settings. Select Show Label Text to also write the readable text. The data field is added 

to the Code variable. 

 

https://www.stimulsoft.com/en/documentation/online/user-manual/
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Adding dates in RDE and main tables 

To add a readable date in RDE specimen files, you can use the expression which is based on the separate 

numeric day, month and year fields: 

Date: {RdeCollectionEventRecord.CollectionDay} {DateSerial(2020, RdeCollectionEventRecord.CollectionMonth, 

1).ToString("MMMM")} {RdeCollectionEventRecord.CollectionYear} 

This expression would print e.g.  ‘12 January 2021’ 

In the main tables, you could use a similar expression (replace the table ‘RdeCollectionEventRecord’ with 

‘CollectionEventRecord’. However, you also have access to two calculated date field formats # Collection Date 

(Long) and # Collection Date (Short). 

Designing a label for plant tags 

The example here provides some tips on how to create a 3 x 1.5 inch label tag for plants. Clearly, you can adjust 

the label dimensions and precise content to suit. This example here is based on the barcoded plant ID tags used 

by the Marie Selby Botanical Gardens in Sarasota, Florida for labelling their living collections. 

The labels are produced for all tagged records in the main plants table in BRAHMS. 

 

The challenge is to create a label width 3 x 1.5 inches and to include some fields describing the wild origin. 

 

In your Living collections plant table, after tagging the plant records to print labels for, choose Reports on the 

main toolbar.  

        

When prompted, select No to the Restrict report data and select both options on the Additional Report Data 

form. This will provide you to access to fields that may not be in your current field view and/or may be in the 

related accession and collection events tables. 
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It is not that obvious where to set the report dimension units. To set these to inches rather than metric, on the 

Properties tab, choose Report at the top and then choose Inches for the Report Unit as shown above. 

 

 

Using the Page settings, you can set the page size (= label size) taking care with Margins. If the default margin 

settings are not edited, especially on rather small labels, you may end up with a very limited design surface. 

 

 

In this report, the Data Band is created using the LivingCollection data source. Following examples in earlier 

reports, you need to create a data band by dragging the LivingCollections data source header onto your report 

surface. 

The field expressions used in this report are as follows: 

{LivingCollection.CalcFullName} 
{LivingCollection.FamilyName} 
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{LivingCollection.Accessions.WildOrigins.CountryName} {IIF(LivingCollection.Accessions.WildOrigins.MajorAdminName 
!= "", ": ", "")}{LivingCollection.Accessions.WildOrigins.MajorAdminName} 
{IIF(LivingCollection.MaterialCategory == "Restricted", "Restricted Distribution", "")} 
 

Note that some of these expressions are using the IIF() function for conditional formatting. Also note that some 

fields are being pulled in from ‘WildOrigins’ (= CollectionEvents). 

 

 

For the barcode, note that the Code entry is set to the field name to use and that the Label text is shown. 

However, if you want more control over the positioning and font of the Plant ID, do not tick Show Label Text. 

Rather, add ‘LivingCollection.PlantId’ as a separate expression on the report. 

Finally, if you want to print a box to highlight text such as ‘Restricted Distribution’, one way to do this is as 

follows: Add an image which in this case is a filled blank rectangle. Then set a Condition in this image as shown 

below. The text box expression for MaterialCategory as cited above will then be set to a white font colour. 

 

Adding a condition to control when the image is enabled. 

 

 

Conditional printing of restricted material text. Note the Plant ID here is printed above the barcode. 

Another issue to keep an eye on is the Data Band New Page Before property. If you have trouble with your 

labels aligning on the printer, tick this option. 
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Controlling report output using a numeric count field 

Using the report designer, you can add a report template design feature to control how many labels (or other 

categories of report) are printed per record. For example, you may want to print 3 herbarium labels for one 

record but only 1 of another.  

The print counts can be controlled by using any numeric field available in your database, as long as that field is 

included in the report data. As it happens, the Collection Events table has a standard field for this which is 

named 'Labelcount' – but you could equally use another numeric field including a custom field.  

 

In the above example provided by SANBI, South Africa, the record with field number 112 has been printed 3 

times and that with field number 15395 has been printed once. 

 

Overall label design view 

The above design screen shows the overall layout of the printed sample above. The actual label content is not 

important here. The features that are required to produce multiple labels per record are as follows: 

1. A second data band (DataBand2) is added as is assigned the correct Data Source. In this example. 

‘DetHistory’. 

2. The first data band (DataBand1), which includes the actual label design expressions, has no Data 

Source assigned. However, this first data band is assigned a ‘Master Component’ which is DataBand2. 

This is assigned by double-clicking on the DataBand1 header and choosing the option Master 

Component. 
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3. In the ‘Before Print’ event of DataBand1, add the text 

‘DataBand1.CountData=DetHistory.Specimen.CollectionEvent.LabelTotal’ where LabelCount is the field 

control the print number. In this example, the labelcount is coming from the table CollectionEvent – 

but in a hierarchy from DetHistory and Specimens. The Before Print event is found by clicking on the 

DataBand1 header, selecting Properties and then selecting the Event Properties icon as shown below: 

 

Preparing a transaction list 

This example shows in summary how to produce a transaction packing list for loans, exchanges and similar. 

Transaction reports use the same techniques are the previous examples. One difference is that they refer to 

two separate data sources – the transaction record itself and the linked specimens. This requires the addition 

of two data bands. 

 

 

The Title band includes a logo, some constant text entries plus a few fields taken from the transaction record including the 
address summary (sent to/received from), the transaction number, a calculated summary of the transaction and the 
‘attention of’ field. 

 

A data header and data band have been added to list data from the LinkedSpecimens data source. Fields can be chosen as 
required. 

The data dictionary has 
entries for the transaction 
record itself as well as the 
linked specimens. 
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A partial sample preview of a transaction.  
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Image management 
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#images  

 

Introduction 

Images can be linked to any record in BRAHMS. You can link multiple images to the same record. Information 

about your images is listed in the central images table.  For example, images could be linked to species, 

entities, collection events, specimens and living plants. However, you may also consider linking images to 

people, places, garden locations, other taxa ranks such as families and genera, in the latter two cases, these 

would be representative images.  

The images themselves may of any image file type – and may be registered in BRAHMS as physical file paths or 

as URL links. If a registered image cannot be located, the system will be unable to display it. Typically, images 

are of preserved specimens (insects, herbarium, fossils), illustrations and habit shots such as garden or wild 

collected plants/animals. But equally, they may be images of maps, people, landscapes, etc. 

The links between images and data records in BRAHMS are maintained in a separate table which is not one you 

can open. This table holds the GUIDs of the image records and the GUIDs of the data records to which the 

images are linked. 

Images can be viewed from the main image table itself file, clearly one image per record, and/or from any 

other table where records have image links. 

Image copyright 

Image copyright text can be stored and presented in one of 3 ways: 

• A default text for all images can be added under System > Options. 

• Copyright text can be added to the image table. 

• Copyright text is extracted from the IPTC image header if this is available.  

The priority is that the IPTC header will be used if available, then the image record data and finally, if neither 

available, the default copyright text. 

 

 

A default image copyright can be added for all images – but these settings are overridden if copyright details are 

added to individual images. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#images
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Viewing images 

The image viewer is opened from any BRAHMS or RDE table using the Images toolbar option on Data Tools. 

 

 

If any images are linked to the current record, these will be displayed in the viewer with thumbs in the lower 

part of the form.   

The image viewer has a number of controls below the main image: 

 

 

Options, left to right: 
 

• Flip image horizontally, Flip image vertically 

• Rotate left 90 degrees, Rotate right 90 degrees 

• Reset 

• Open image in your default image viewer 

• Fit content within bounds 

• Fill bounds with content 

 

There is also a zoom/pan image explore option: 
 

Image viewer function keys: 
 

• Shift + Mouse Wheel: zoom 

• Ctrl+ Mouse Wheel: pan 

• Alt + Mouse Wheel: drag rectangle to zoom 

 

 

The slightly obscure icon bottom right is used to open the View Finder. This provides a zoom/pan image explore option. 
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The View Finder in use. 

 

Manually linking images 

Images can be linked to or unlinked from any record in BRAHMS when using the Image Viewer. As an example, 

linking images to a species record:  

• Select Taxa > Species and then on Data Tools, select Images… to open the Image Viewer. 

• Here, you can either use the Link button or drag image(s) to the Image Viewer.  

 

To link images to a record, you can drag the image (or images) from your file manager onto the BRAHMS Image Viewer. 

 

 

Alternatively, use the Link option at the bottom of the image form. Use Unlink or Unlink all to remove the link(s). 
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The main image library 

The main image table in BRAHMS is opened using Images > Image Records. Images themselves are never 

added to your database, inflating its size. The image table only stores references and meta data about the 

images.  

Field name Notes 
Image file The file name of the image 

Directory The folder location of the image file 

Image URL The full URL of the image 

File Type The type of image file 

File Size The image file size 

Image Type User defined classification of your images (scan, painting, illustration, etc.) 

Image Caption Free text 

Foto Prefix Used to further reference an image source 

Foto Number Used to further reference an image source 
Foto Suffix Used to further reference an image source 

Priority Numeric value to indicate image priority within your project 

Image Date Date image taken  

Copyright Free text 

Not Online Yes/No field to optional prevent uploading 

Comments Free text 

Uploaded to BOL by Who uploaded image to BRAHMS online 

Uploaded to BOL on Date image uploaded to BRAHMS online 

Audit fields Standard fields for who added/modified image record 

 

Image table fields. 

Image folders 

 

 

 

 

Image file metadata 

Images may have additional information embedded within the image files themselves – data stored in the 

image header. These data are exposed when you view images directly in the image library. 
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The image data is likely to include a lot of camera settings but also data such as image date/time, copyright, keywords and 
GPS data, depending on your camera facilities and settings. 

 

Image location and file names 

Images may be located in any location including in media libraries and cloud servers. Images may be referenced 

in any standard way include UNC paths. Rather than referring to physical file names, you can also refer to URLs. 

Using URLs implies your images are accessible online. The great advantage is that you will be able to view the 

images even if you do not have access to server path, for example, you may be using BRAHMS in a different 

location or country.  

It is good planning to think through your image file naming strategy. Avoid using spaces in image file names as 

these are not easily managed if you are publishing images online. Image file names can use different languages 

and international character sets. 

     

File names may used any language script. 

The following are examples of valid file names and URL paths: 

C:\Myimages\00015343.jpg 
H:\SharedDrive\Images\00015343.png 
\\myfilestore\MuseumFiles\InsectImages\AASY00ww4046_12089.jpg 
http://medialib.naturalis.nl/file/id/L.2436411/format/large 

 

Using image URLs 

You can store images as URL references, the advantage being that your images can be viewed from any 

location. 

  

Images accessed from the Naturalis Museum media library. This BRAHMS database has over 5 million image records. 
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Importing images and image links from Excel  

If you have many images to link to data in BRAHMS, it will more efficient to use the Image Import Wizard tool 

rather than manually linking the images via the Image Viewer. This tool has been designed to make it as simple 

as possible to link your images to any record in any BRAHMS table. 

To use this option, all you need is an Excel (xlsx) table that has a column with the image file names (or URLs) 

and one or more columns that will allow you to match the records to your data records in BRAHMS. 

The Image Import Wizard tool has two key functions: 

a) to import images and image meta data into BRAHMS, matching your excel file image field names with 

those used in BRAHMS. 

b) To link the images to the appropriate records in the currently opened BRAHMS table, using your 

selected record matching criteria. 

 

To open the image import wizard tool, select Import/Link images on the Data Tools toolbar. 

 

 

 

 

 

 

In the top image matching section of the form, you can match your 

Excel columns with the appropriate image data column(s) – these are 

the image data that will be imported and linked to matched data 

records.  

As a minimum, the Image File name or a URL is required: If the filename 

also contains the full directory /folder path there is no requirement to 

match the folder separately as it will be automatically separated from 

the filename. All other image fields are optional. 

If URL entries are added to the Image File field, these will be treated as 

URLs and processed accordingly. 

Note. The image import can be processed even if the image files are not 

currently accessible. 

In the lower section, you can match your Excel columns to BRAHMS data 

record columns – this controls which images will be linked to which records.  

Ensure the columns selected match the correct records in your database. For 

example, if you are linking images to specimen records based on the 

barcode, ensure the Excel file has a column with the barcodes. In the 

example here, the match is made between the Excel field ‘Plant Name’ and 

the BRAHMS field # Full Name. Any field or series of fields can be selected. 

Note. Make sure any columns you want to use in matching are visible in the 

grid before using this tool. 
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Importing images from Excel - examples 

Image import example 1 

 

 

Snapshot of a sample Excel file with demo image details and also a field to use for record matching, in this example ‘Species 
name’. Note that the imagefile field includes the full path name of the images. In other cases, file and directory names may 
be held in separate fields. 

 

 

In the above example, the user has matched the image fields to be imported. Note that it is not necessary to 

add the Directory name - in this case, the image file includes the full path. The records are being matched using 

an excel field called Species name and this has been matched to the BRAHMS field #Full Name. 

 

Image import example 2 

 

 

The excel file here includes barcodes that can be used to match to records in the BRAHMS specimen table. The other fields 
such as family, genus, sp1, in this case, need not be used for matching as the barcode is sufficient. The image file and 
directory names here are held in separate fields. 
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The selected image and matching settings. 

Note that record matching may involve using several fields – you can select any group of fields that you feel will 

match records correctly. You may have exported data from BRAHMS to Excel including the record GUID – and 

this on its own would be sufficient. 

 

As the data are imported, the Status is updated. Status options are: 

• Unmatched: the importer is unable to match the data to a record in the current BRAHMS table. For 

example, a barcode cannot be located. 

• Matched: the importer is able to match the data to a record in the current BRAHMS table. However, it is 

unable to add an image as the image data are not correctly available in the Excel file. Note that the image 

file itself is not be accessible, this will not stop the import. 

• 2 Matched: (2 or more) the importer has located more than one potential record match and the process 

cannot proceed. 

• Imported: the image is successfully added to your image table and the image linked to a data record. 

• Exists:  the image data have already been added and will not be added again. 

Importing images from Excel to RDE files 

As discussed in the RDE sections, images can be transferred from Excel files to RDE. When transferring RDE files 

to BRAHMS, the RDE image data are added to the main database. 
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If your Excel file includes image references as physical file names (path + file name) or URLs, these can be 

imported to and viewed in the RDE file. If there is more than one image, the entries should be comma or semi-

colon separated or on different lines. 

 

By default, BRAHMS checks for the fields Imagelist or Images and auto-selects either if they are available. Otherwise, you 
can select the image field using the field selector provided.  

 

In the above Excel table, the column Imagelist includes physical file and URL references. 

Viewing image links 

You can view all image record links in your database using the Image Links menu option. 

 

The image links table with a filter applied. Data courtesy of The Morton Arboretum. 
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Document management  

Introduction 

Multiple documents of any type can be linked to any record in BRAHMS. This could be a PDF material transfer 

agreement or collection permit linked to a specimen, accession or transaction; a protologue description linked 

to a species; a sound file linked to an animal entry; or perhaps a video or slideshow linked to a botanic garden 

greenhouse record.  You can also link URLs as documents. These may be references to documents that require 

user permissions to view, for example, as stored in SharePoint.  

 

Linking pdf, docx, wav, pptx and xlsx documents to a species record. Media and documents can be opened using the Open 
option or double-clicking on the linked entry. 

Documents,  document folders and database links 

Documents are managed under the Images/Documents menu option. All linked documents, including URLs, 

are registered in the main documents table. Folders are auto-registered in a separate folders table. You can 

also view and filter on all document links for your database. 

 

The main Images/Documents menu. 

 

 

Document folders in use are listed in the folders table 
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In the document links table, the Record Identification field indices which record the document is linked to. 

 

 

The option Document Links shows all links between documents and records in your database. 

 

Editing document links 

In any record, you use the Documents toolbar option to open the Linked Documented editor. In Edit mode, 

drag documents on to the window or use the Link option. Double-click a link to open the document. You can 

copy a linked document to all tagged records. 

 

Viewing and editing document links. 
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Dynamic Weblinks 

Introduction 

You can dynamically link your database to external websites as provided on the WebLinks toolbar. WebLink 

options will soon be configurable in BRAHMS, allowing you to add the websites that you find most useful. 

WebLinks are available from many of the BRAHMS tables, especially when there is a species name in the table.  

Examples 

• Select Taxa > Species to open the main species table. 

• Select Weblinks > Google Images or WebLinks > POWO (Plants of the World Online) 

 

    

In this example, the POWO website has been opened on Podocarpus taxifolius, a synonym of Prumnopitys montana. Moving 
data grid records auto-updates the open weblink page.  The species form is opened on the synonyms tab and the various 
windows are docked. 
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An example with 2 weblink sites opened at the same time. Linked weblink windows can be dragged to different monitors. 

 

 

 

Examples with the ant genus Acromyrmex, top Google Images, lower using AntWeb. 
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Biblio module and Literature 

Introduction 

You can store references of any category (books, journal articles, websites, etc.) and then link these to any 

record in your database. For example, you may want to link a book, a book chapter, a report or journal article 

to a species or to a selected text entry for a species. 

As discussed below, reference entries can be stored as complete reference text strings with no attempt to 

divide the text into the component fields – or you can store the reference using the separate fields for author, 

title, journal, pages, year, etc. 

Page numbers can also be added to the record that links a database record to the literature entry. Thus, you 

might enter the details for a book or manuscript once as a reference for many species. The record that links the 

species to the book will include the page numbers and other details about the nature of the literature link. 

Adding and editing literature entries 

Select Biblio > Literature List to open the main table for literature. On the same Biblio menu, you will find table 

of literature categories and journal listings. 

 

Viewing reference entries in the main literature table. 

The Full Reference field can be used to quickly add a complete reference string – without needing to add data 

to the separate fields – although data added to separate fields provides greater control. The Full Reference 

field is auto-updated from the other fields IF an entry is made in the TITLE field. 

 

Linking literature entries to data 

Literature links are created using the Literature option on the Data Tools toolbar. 

 

This option allows you to select any item from your main literature list and link this to the current record. You 

can link multiple literature links to any record, optionally adding the relevant page/plate numbers, the link 

status (for example ‘Synonymy’) and comments. 
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An example showing the Literature link option opened. This option lists all existing links for the current record and allows 
you to add/remove links. 

 

Linking literature to taxa text entries 

Literature links to taxa text descriptions can be made directly in the Taxa > Taxa Descriptions table. 

 

In Edit mode, use the form Edit option to edit the text and/or literature links. 
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The species form Text option – with the edit option in use. Here, you can add/edit the text entries as well as linking literature 
entries. 
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Personal names and authors 

Introduction 

Under the Management menu, you can find options for managing the centrally used tables for People, 

Assembled name strings and the Address book. The section explains the use of these 3 tables within BRAHMS.  

 

Management menu name/address options 

People table 

The people table is opened from Management > People. You can add names to this table individually, filling in 

fields as available. This table is used to store names of people such as collectors, taxa and reference authors. It 

is also used to store taxon author abbreviations. 

The people table itself is a stand-alone table. It has no relations to other tables in the database. Thus, names 

here can also be deleted with no impact on the rest of your database. You can develop a clean list of people 

names and use this list to help construct assembled name strings (see below). 

 

Fields such as Title and Forename are optional. When storing taxon authors, the field Abbreviation must be added. Other 
fields such as Staff Member can be added and have their uses for filtering. 

As this table is stand-alone, you can safely delete any entries with no impact elsewhere in the database. The 

main function of the people table in BRAHMS is to help you create assembled name strings – as discussed 

below. 

Assembled name string table 

Introduction 

The assembled name strings table is opened from Management > Assembled name strings. This list is 

effectively used as a lookup list for names and name combinations. It is used for the following lookups: 

Collectors, Additional Collectors, Determined by names, Taxa authors and Reference authors. 

Recent changes to table relations in BRAHMS mean that, as with people names, you can safely delete 

assembled name strings without having an impact on the assembled names as stored in BRAHMS. This is 

because all text is stored in the tables themselves. This has been done to simplify table relations in BRAHMS. 
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Looking up assembled names 

When you are adding or editing, for example, a collector name or a species author, use the lookup tool to open 

the Assembled-Names Selector. If the name or name combination for not exist, you have a number of options: 

a) You could simply type the new collector or author name into the table you are working in. 

b) You could decide to register the new name or name combination in the assembled names table. 

 

 

An example looking up a collector name. In this case, the name wanted is available in the assembled name list. 

 

 

An example looking up an author name. In this case, the name (combination) wanted is available in the 

assembled name list. 

 



BRAHMS v8 introduction and guide  212 | P a g e  

Creating new assembled names 

If the name you want is not in the assembled names list and you want to register it there rather than just type 

it in, you can add the new name or name combination using the Create option 

 

Using the Create option, you can choose names on the left panel which are listed from your People table – and 

add one or more names to the right panel, building a new combination. 

 

If the person name is not registered in your people name list, you can add this: 

 

Adding a new person from the Name List Creator form. 

 

Taxa author names 

Selecting an existing author or author combination 

As described above, if the author string required already exists, you can locate and select this using a lookup 

option in the author field you are editing. 
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Creating and formatting new authors or author combinations 

If the author name or name combination does not exist in your assembled names list, you can type it in to the 

author field or register this as a new assembled name entry. BRAHMS can help you correctly format complex 

author name combinations. 

 

 

 

Here Gordon has been set as the Basionym author and the ‘ex’ option selected for Hildebr. creating the string (Gordon.) 
Lindl. Ex Hildebr. 

 

 

Note how the string is now formatted when the authorship options are edited as above. 

 

Misapplied, ambig. and Hort. Entries 

Quick options are provided to select the entries ‘misapplied’, ‘ambig.’ and ‘hort.’ As author entries. 
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Using sensu and adding suffix text 

Author selections can be prefixed sensu and have a suffix added: 

 

Use the formatting options provided to create a string such as sensu Carrière 1890. 

 

Is Author 

Note that the Assembled Name strings table has a flag to indicate whether an entry is an author string or not. 

This field is used to filter selections when selecting author strings. 

 

Is Author can be updated manually of by using the option to update all tagged records. 

Updating Assembled Names from the Summary Tool 

If you have collector, author or detby names added to your various tables, you can check these are registered 

in the assembled names string table using the Summary Tool option ‘Ensure Name List Entry’. 

 

In this example, the species table has filter to restrict to accepted Podocarpaceae names. The Summary toolbar 

option ‘Ensure Name List Entry’ has been selected. This option checks all the author names as uniquely listed in 

the summary tool are available in the assembled names list. If not, they will be added. 
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A closer look at taxa and related data  
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#addingspeciestext  

Introduction  

BRAHMS has separate tables for Higher Classification, Families, Genera and Species, the latter including infra-

specific names and cultivars. All ICN and ICNCP ranks are covered. There are also separate tables to store 

author names, common names, plant uses and text descriptions. 

The main taxa tables 

Higher Classification 

The higher classification table, by default, stores taxa names from Kingdom through to Order. Further 

taxonomic levels can be added as custom fields. 

 

You can define further custom higher classification taxonomic levels as needed for particular taxa groups. 

Families and genera 

The family and genus tables, in addition to storing the names of families and genera themselves can be 

extended with custom fields as needed by your project. Each name can be assigned an authority and be linked 

to publication details. Further nomenclatural fields are available such as taxon status, validity, legitimacy and 

nomenclatural notes. There are further fields for common names, museum location code, specialist name(s) 

and more.  

 

Institutional codes such as the family and genus herbarium codes can also be viewed in the species table. For 

taxonomic projects, families and genera may be assigned types and may have synonym links. These tables also 

have various calculated fields to display totals for linked collections, images, seed accessions, living plants, etc. 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#addingspeciestext
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Managing columns in the genus table. If entirely new fields are required, these can be added as custom fields. Data fields 
are also inherited and displayed from the higher classification and family tables. 

Species and lower ranks 

Species and infraspecific names are stored in the species table. A wide range of default fields are available from 

ranks between genus and species such as genus section and series through to all the infra-specific, grex, trade 

and cultivar names. As with the other tables you can extend the table by adding further taxon levels as custom 

fields.  

 

A selection of fields available in the main species table. If entirely new fields are required, these can be added as custom 
fields. Data fields are also inherited and displayed from the higher classification, family and genus tables. 

Multiple Classification Systems 

Introduction 

You can implement ‘multiple classifications’ for family genus relationships in BRAHMS. This makes it possible to 

link a genus name to more than one family. There is no limit to the number of classification systems that can be 

adopted. This feature was initially developed in BRAHMS v7 with Naturalis (Netherlands) and has now been 

incorporated into BRAHMS 8. This approach may be required by herbaria where there is more than one family-

genus system in use. In the case of Naturalis, the herbarium consists of a merger of the previously separated 

Leiden, Utrecht and Wageningen herbaria where the genera were curated under different family names.  
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All databases have a default system known as ‘Default’. Most projects will not need to adjust this or add any 

further classification systems. However, for some, it may prove useful for curation and/or for publication 

purposes, to cite genera under different family names. 

Adding a new classification system 

New family-genus classification systems are added using System > Options > Taxa > Classification Systems. 

Using the Add option, you can add a new system and assign this a name.  In databases with a large number of 

genera, this process may take a few minutes to complete. 

When you add a new system, behind the scenes, the ‘family-genus’ table is updated with copies of all genus 

names, initially linked to the default family name. 

 

If using multiple classification systems, you can choose one as the default for all users. Otherwise, the default 

entry (named ‘Default’) is used. 

Assigning a preferred classification system per user 

In the user table, opened using System > Manage Users & Permissions, you can assigned each registered user 

a default classification system. This system will be used as that user’s classification system through the system. 

Note that you can also set whether a user may switch to a different classification system when logged in. 

 

The user table allows you to set the classification system used per user and whether they can switch systems or 

not. 

 

Switching classification systems 

The main Taxa menu includes a dropdown menu listing the available classification systems. Users, with 

permission to do so, can easily switch system. The selected system will remain in operation during the log in 

session unless changed. When the user logs in again, that user’s default will be selected.   
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Selecting/switching classification systems when logged in. 

Note that when a classification system is selected, data will appear in the selected family-genus system 

throughout BRAHMS. 

 

Browsing all family-genus links 

By selecting Taxa > All Genus-Family links, you can review all links, using filters as appropriate. You can also 

edit the family name for the selected genus. 

 

Editing Family-Genus links 

There are 2 ways to edit family-genus links: 

• In the main genus table, use the standard lookup for the family. This will set the family name for the 

selected genus for the user’s currently selected classification system. 

• In the main family-genus table, you can adjust the family name for a genus in the selected 

classification. 

Deleting a family or genus 

When you delete a genus name, this will remove the name under all family classifications. 

When you delete a family name, this would delete any genera linked to that family name – as well as any data 

associated with those genera. Thus, if you have a family name that you wish to delete, make sure that there are 

no general linked to that name in the family genus table. 

 

Importing taxon names via RDE 

When importing RDE files for taxa or any other data that have taxon names (e.g. herbarium specimens or 

plants), if a new genus/family name is added, this will be added for all classification systems. You would then be 

able to edit the classification as appropriate for newly added genera. 
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Finding names and using taxa lookups 

Family names 

 

Family lookup. 

When looking for a family name, for example in RDE or in the main the genus table, typing in the Find box 

selects matching family names - pressing Enter or double-clicking on the selected record selects the family at 

the top of the list and adds this to your data table. Note that you can also use the yellow grid filter boxes. 

Choosing a family will also add ranks above the family name (Order and higher classification fields) if these are 

available. 

Genera 

 

Genus lookup – you can add a few letters of the family and genus to locate the name quickly. 

When looking for a genus name, for example in RDE or in the main the species table, typing in the Find box 

selects matching genus names -  pressing Enter or double-clicking on the selected record selects the genus at 

the top of the list and adds to your data table. Note that you can also use the yellow grid filter boxes. Choosing 

a genus name will also add ranks above the genus name (Family and higher classification fields) if these are 

available. To optimise searching, you can add a few letters of the family and genus names. After some practice, 

you can learn to enter the minimum number of characters to reach the required record. Clearly, the more 

extensive the taxa dictionaries are, the more letters you will need to enter to select the correct record. 

Species names 

 

Species lookups – you can add a few letters of the genus and species epithets to locate the name quickly. 
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With species lookups, you can add a few genus and species epithet letters, experimenting with the optimal 

selection to get to required record. The right-side example is searching on the species epithet alone. Bear in 

mind that the yellow grid filters can also be used. As the species table is more complex than most, there are a 

number of other rules to consider to help locate names quickly, all requiring a little experimentation. As a rule, 

you can enter any part of any name epithet to locate a name. If you are explicitly looking for a plant cultivar 

name, add a single quote before the name or part of the cultivar name. 

As these data are hierarchical, if you know the species, it is not necessary to use a lookup in the family or genus 

field as the species lookup will add data to all these fields as well as higher classification. 

 

 

Entering parts of name epithets, as shown above, can locate a name quickly 

 

 

An example using a single quote to locate cultivar names starting with ‘whit 

 

Here some genus letters have also been added.  
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In this example [whit locates all name with trade epithet that include [whit 

Adding a new species 

You can add new species to your database either directly or via Rapid Data Entry (RDE) files. RDE is normally 

used when you have many new names to add. In this example, add the new names directly into your database 

using the data grid and/or the species form. 

If the new names are in families or genera not yet stored in BRAHMS, you need to add these first. For example, 

to add a new genus:  

• Select Taxa > Genera and then use the Add option on the Data Tools toolbar to append a blank record.  

• Select Edit on the Data Tools toolbar to switch to editing mode – then type in the new genus name.  

• To select the family name, use the lookup function (F9 key) in the Family field. 

• Now select Taxa > Species and then use the Add option on the Data Tools toolbar to append a blank 

record. Enable editing mode by selecting Edit on the Data Tools toolbar. 

• New data can either be added directly to the data grid or using the species form opened using the Form 

option on the Data Tools toolbar. 

• Using either the data grid or the form, add a few new species records, adding as much detail as you want.  

Editing a species author name 

For further details on this process, refer to the name strings section on Editing taxa author names. 

Author name abbreviations are stored individually in the main People table. However, the author name 

compilations that link to taxonomic names come from the ‘Assembled name strings’ table. Both tables can be 

opened under the Management menu. Authors of taxa may consist of formatted combinations of names as in 

‘(Poepp. ex Endl.) Tiegh.’.  You can edit names from the grid or from the species form. Author names are held in 

a separate table and thus cannot be edited directly in the grid or form. You have to use a lookup function. 

• Select Taxa > Species to open the species table and locate a species to edit. Ensure you are in Edit mode. 

Go to the species author field and in Edit mode, press the F9 key to activate a lookup. 

Synonyms 

A name may have one or more synonyms. Synonyms may, optionally, be marked with an appropriate taxon 

status (e.g. Syn or Synonym) and be assigned to a synonym category (homotypic, heterotypic, basionym as 

examples). The calculated field #Syns shows the total number of synonyms linked to a name. 

The easiest way to make one name a synonym of another name is to use a lookup in the field Synonym Of. 



BRAHMS v8 introduction and guide  222 | P a g e  

 

In this example, Podocarpus currentname has 2 synonyms. The name P. oldname1 also has 1 synonym linked. 

Synonyms can be also listed and edited from Synonyms tab on the species form. 

 

Synonym links can also be edited from the Synonyms tab on the species form.  

Using the ‘G tag Syn. Group’ option, all taxa records in the current synonym group are tagged ‘G’, regardless of 

any filters you may have in place. The adjacent Filter option will filter the main taxa grid to G tagged records. 

You may use this option to tag multiple species synonym groups. The drop down on the ‘G tag Syn. Group’ 

option provides additional option to clear G tags for the current synonym group or for all G tagged records. 

Further details about synonyms can be added to the text fields Synonym Note and/or Nomenclature Note. 

 

Common names 

 

Common names can be linked to family records and to the main taxa table. A taxon entry may have numerous 

common names across its range and each these can be recorded with notes about name origin, meaning, 

language and folklore. Common names can be listed directly by open the common names table – or by using 

forms on the main species/entity tables.  Names can be added directly to the table and/or from the forms. 
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The common names table has the following structure: 

Field name Notes 

Tag Standard field for tagging records 

Del Standard field for deletion 

CollectionEventId Link to a collection event (and thus location/species) 

SpeciesId Link to a taxon name 

EntityId Link to an entity 

Common name group 
 

Names can be organised into groups 

Common name The common name 

Homonym Differentiate between identical names 

Name rank A numeric code to rank names by preference 

Suppress A flag to suppress (offensive) names when publishing 

Language The language of the common name 

Dialect The language dialect 

Source The source of the name 

Etymology 
 

The meaning of the name 

Interview Notes on interview (e.g. with local people) 

Folklore 
 

Name folklore 

Comments Other comments 

GeoNote Geographic notes (especially where no linked collection event) 

Audit fields Standard audit field (who/when added/edited) 

 

Text descriptions 

Free text descriptions can be stored and linked to different taxa levels (currently family, genus, species and 

infra-taxa). Text can be added under any category such as Description, Distribution, Ecology, Uses, 

Conservation, Taxonomic notes, etc. You may want to store several descriptions for a species – from different 

sources. Each entry can be linked to a reference source. 

With the species form open, select the Texts tab. You can add new entries as well as edit or delete existing 

entries. 
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To add a new entry, use the button adjacent to the species name. 

All text entries are stored in a special table which you can also edit directly using Taxa > Taxa descriptions. 

 

Further taxa options 

Name editor 

The name editor allows you to update all or tagged dependent names. For example, you may have a species 

named maxima in the genus Cattleya which is incorrectly spelt or has to be changed for another reason. The 

species may have dependent names (subspecies, varieties, formas, cultivars or ranks). This tool allows you to 

edit the name of the species (or any other selected rank below genus) for all or tagged records. You would use 

the tagged option if you were separating names into different groups. 

 

A hypothetical example where the species named maxima in a particular genus could be quickly edited for all dependent 
names, in this case, a series of cultivars. 

Orthographic checks 

This tool provides a way to quickly check names that have potential spelling errors. It does this by sorting 

names A-Z and then checking for names with the number of character differences you select in the Match 
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Tolerance setting. Records which vary with 1 character are tagged 1. Those with 2-character differences are 

tagged 2, etc. After processing, a filter is set to show the tagged records. 

 

An example check showing records with 1- and 2-character differences. It is then the decision of the person checking the 
data if the differences are valid or mistakes. 

 

Taxonomic Name Resolution Service (TNRS) 

 

The TNRS service provides another mechanism to check names. His is run from the main species table using the 

TNRS option on the Taxa toolbar. 

 

To use this option, Tag the names to check, Select the TNRS option on the main Taxa menu and copy the names 

from the generated BRAHMS text area into the TNRS Names to Check box. 
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Listing all related taxa names using from the Infra+ tab 

From the main species table, use the Infra+ tab on the species form to list all names with the same species 

epithet within the current genus. Here, you can also access descriptive text linked to any of the taxa in the list. 

• Select Taxa > Species and then open the species form – then select the Infra+ tab. 

           

Note that you can restrict the names listed to selected ranks. The fields displayed in the grid can be adjusted using a right-
click on the grid header. The Taxon Descriptions option opens any text descriptions as available. 

            

Extend tags to related infra taxa 

The option Extend tags to related infra taxa will tag all records of names that belong to the same species as 

any currently tagged records.  

      

In this example, all records of Abies Alba have been tagged based on the tagged record in the left screen. 

 

Tag synonyms of tagged records 

The taxa menu option Tag synonyms of tagged records tags synonyms of any tagged records.  

    

In this example, synonyms of Dacrycarpus kinabulensis have been tagged. 
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Collection events 

Introduction 

Collection events refer to the data describing an item found in a specific place usually by a known person on a 

known date. A collection event many result in physical specimens (living or preserved). An event may also refer 

to an observation, a literature citation or any other source of data. Collection events themselves are not 

physical specimens.  

To access collection events, select Collections > Collection Events on the main menu. 

 

Some records from a typical events table. Events keep track of the collector(s), field number, collection date, locality as best 
known, descriptive text about the location, habitat and the item itself and the identification the item is known by (the 
‘selected determination’). You will not find an accession number or barcode as these belong to physical specimens. Many 
other event fields are not visible in this screen. 

 

The collection events Form provides access and editing tools for linked specimens and their determinations. With this event 
for a plant collection, there are 6 specimens distributed to various herbaria. The specimens are types with the holotype at 
Leiden. Each specimen may have 0 to many determinations. 

Collection categories 

The Category option on the Collection toolbar is used to further define the toolbar options for preserved 

specimens, living collections, seed banks and others. In all cases, data for the events themselves are stored in 

the same table.  
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Selecting a specific collection category alters the toolbar menu options. 

Links to living collections and seed accessions 

Collection events are also used to record the wild origin for living plants and the collection passport data for 

seed accessions. For example, in a botanic garden, if the wild origin of a plant is known, the living accession 

entry will be cross referenced to a collection event. 

Geographic data, maps and elevation 

The collection event location will be defined as accurately as possible. Details gathered from older specimens 

may be rather vague, to country level while these days, collections are often geo-referenced with pinpoint 

accuracy using a GPS map reading.  

Locality names and the gazetteer table 

Collection events link to an entry in the main gazetteer or places table which is opened and edited using Geo > 

Gazetteer. The gazetteer table stores a link to the country table and then the names of major and minor 

administrative areas and a locality name if known. Map and elevation data can be added.  The gazetteer record 

may only have a country name – the other data may be unknown and left empty. 

The collection event record has a link to the gazetteer locality. In the collection event table itself, you can store 

locality notes and map/elevation data. Map and elevation data stored here always take priority over these data 

in the linked gazetteer record. 

 

Map data 

The use the map editor is discussed in the relevant map section. 

 

An example showing units in DMS (form banner) but stored in Decimal degree format. 

Elevation 

Elevation data are stored in m and if added to the grid, should be added in m. units. NB a new editor is being 

added to allow m or ft. On the Map point editor, elevation can be added in m or ft and if using ft, the data are 

auto-converted to m. 
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An example where the altitude is entered in ft but stored in m. 

 

Selected determination 

Collection event records include a species identification – and this name is known as the selected 

determination. An event may have one or more specimen vouchers – and each of these in turn may have one 

to many determinations. The name you choose to use for the event can be selected (see below under 

Determinations). 

Projects and expeditions 

The Projects/Expeditions table stores details on the start and end dates, funding, team members, deadlines 

and notes about projects and expeditions. Each entry can be assigned a short text code. 

This table is mostly used to group together collections linked to a funded project - or all collections (preserved 

and/or living) made on a named field trip or expedition. An expedition may take place over a number of years.  

 

Collection events can be linked to Project/Expedition records. The project/Expedition fields: Category, 

Project/Expedition Code, Project Name, and Team can be viewed in any table that has a relation to collection 

events including the Plant Accession and Plants tables. 

 

Collection events can be linked to Project/Expedition records. They can be also be viewed in related tables including plants 
and preserved specimens. 

 

Project/Expedition records are linked to collection events using a lookup on any of the relevant Project/Expedition  fields. 
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Museum and herbarium specimens 

Preserved specimens 

Specimen records 

If a collection event leads to vouchers being taken, these specimens will eventually be deposited in a 

museum/herbarium collection. They may be formally mounted and incorporated to the collection. Examples 

are birds, insects, fungi, ferns, higher plants – or indeed any form of preserved natural history collection.  

Each specimen is linked to one collection event. Many of the fields seen in the specimen table data grid are 

inherited and displayed from the collection events table. However, others are specific to the specimen 

including the category of specimen, the institute code where it is deposited, accession number, barcode and 

various other fields including details for type material. 

 

The options for specimens are available when you select the category ‘Preserved Specimen’ on the Collections menu. 

Adding/editing specimens 

Specimens can be added to the specimen table directly using the standard Add option on Data Tools. 

 

Adding a specimen directly to the specimen table. 
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Alternatively, you can add a new specimen when using the collection events form. 

 

Specimen form 

The specimen table has its own form. This can be used to add/ edit specimen records and their determinations. 

 

The specimen form has tabs to list all determinations and view/edit custom fields. 
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Duplicates 

Sometimes, material is duplicated to more than one institution, especially the case with plant material. In this 

case, there will be two or more specimen records linked to the same collection event but with different 

specimen level details (where deposited, barcode, etc.). There is no limit to the number of duplicates you may 

store for a single collection. 

 

A collection with 4 specimens deposited at different institutions. The related event record is stored once. Only one of the 
specimens has a barcode. 

Specimen and type categories 

          

These lists are held in separate tables.  

Museum boxes and folders 

 

Some museums (including herbaria) organize material in boxes which may have barcodes and location details.  
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Example list of barcoded boxes with a filter set to show contents with Lichens. Screen taken from Naturalis herbarium 
database. 

 

In herbaria, specimens are organised into folders – and these folders themselves may be barcoded and 

registered in your database. The folders may be in a known box.  Individual specimens can be associated with a 

folder.  

 

 

Example list of folders. Folders have a species name content and often have a geographic region. Screen taken from 
Naturalis herbarium database. 

Determinations  

Introduction 

The identification of a specimen may change. An expert in the taxa group may provide a new name, perhaps on 

a museum visit or by returning a loan. When a new determination is provided, a determination record is added 

to the specimen. This is better than editing the existing determination record as it ensures that previous dets 

are maintained.  

A collection with several specimens may accumulate different determinations linked to each specimen. A 

decision must be taken as to which name to select as the correct one. This is referred to as the selected det and 

the name is stamped into the collection event. 
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Editing specimen determinations 

The collection event form includes options to add, delete and edit determination records. 

 

After adding a new determination record, you have the option to set this determination as the ‘current determination’ of the 
specimen. Also, using the option Set as Selected Collection Event Det, you can choose the determination as the name to use 
for the collection event itself. 

To access the determinations table directly from the main collection menu, ensure you have the category 

‘Preserved Specimen’ selected then select the Determinations option. 
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BRAHMS for Botanic Gardens 

 

Introduction 

The living collections module within BRAHMS manages data and related media for botanic gardens, arboreta 

and other horticultural projects.  The module, which already takes advantage of all standard features to edit, 

query, report, map, export and publish online, adds comprehensive features for garden accessions and plants 

and their management. As these data are fully integrated within BRAHMS, it becomes possible to develop a 

comprehensive system for both management and research.  

Taxa 

An infrastructure of taxa from higher classification to infra-specific levels, cultivars and hybrids. 

Storing synonymy, common names, trade names, groups, series, grexes, patent IDs, descriptions, 

native distribution, hardiness, shade tolerance, water requirements, conservation status and further 

horticultural details. 

Gardens 
Garden name(s) and details, especially useful for multi-site projects where each garden/site may 

have its own configuration requirements. 

Garden Layout 
Garden locations are recorded from defined garden areas or theme zones down to pinpoint map 

locations with options to record bed, grid numbering and map shape files. 

Institutions 
Comprehensive lists of institutions and addresses of suppliers and donors or those receiving material 

through purchase or transaction exchanges. 

Accessions 
Storage of accession records including details of the type and quantity of material received, who and 

where from, the original or derived source, and the initial identification.  

Propagation 
Propagation details for all plants including cuttings, grafts and seed - linking this to production 

propagation to supply garden plants. 

Plant records 
Storing plant records, linked to accessions, with all details of plants in the garden from planting out 

to their disposal, loss or death.  

Plant events 
Events for plants. Examples are plant maintenance and stock-checks; name changes; observations on 

leaf flush, flowering, fruiting, disease and cause of death. 

Plant requests Requests are logged in the plant management requests file with their ongoing status.  

Label requests A table showing label requests, pending or otherwise, used to control label print runs. 

Transactions The management of incoming material, exchanges and other transaction categories as defined. 

Collection 
Events 

Details about what was collected when, where and by who. Collection events are used to record the 

wild origin of plants and other collected material such as herbarium specimens. An herbarium 

specimen or other material with garden origin will have an event linked to a garden plant. 

Vouchers Vouchers and related materials can be stored for  wild collections and/or established garden plants.  
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Images and 
Documents 

Images and documents associated with Accessions, Plants, Vouchers, Transactions, etc. These can be 

physical files or media library URLs. 

Legal/Permits 
Details of all permits and related documentation for the accession, use and exchange of material, 

evidence of due diligence and restriction requirements. 

   

Summary of the key components used in the living collections module. 

 

 

 

The key tables and relationships associated with the Living Collections module. 
 

Getting started with the living collections module 

There are a number of procedures to consider to get started and to optimise your use of this module: 

Import default living collection lookup lists  

You can import (from Excel) commonly used lookup values related to living collections. These will be added to 

your custom lookup dictionary.  

The Plant and Accession tables have many fields suitable for use with custom lookups. You can use these to 

speed up and standardise data entry and editing tasks. By defining custom lookups, you can force users to 

select from pre-defined lists rather than type in free text. An example would be with plant status codes where 

you may establish a list with values Alive, Lost, Dead, Disposed and Not Found.  Another example is with 

Provenance Type. Most gardens use a standard coding system: W, G, Z, U.  As these are single letters, frankly 

it’s faster to type in the letter rather than use an elaborate lookup. However, you will probably not want a user 

to add an incorrect value such as ‘Y’ and the lookup system can also prevent wayward entries by enforcing 

selections. Different projects have their own coding system. Normally, you will want to ensure that if a value is 

selected, it comes from your list of options rather than being entered as free text. This keeps the database in 

good shape and avoids multiple entries that refer to the same thing. 
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Most gardens share a common set of lookup values for many standard fields, for example U W G or Z for Provenance Type. 

Details on managing lookup lists are provided in the section on Lookup lists. 

Accession and Plant ID numbering  

The setup options for these are discussed in the relevant sections below. 

Keeping your species data in good shape 

Information about taxonomic names from higher levels down to infra-specific ranks is provided in the main 

taxa section of this guide.  For botanic gardens and horticultural projects, the priorities for name management 

tend to be different to museum and research projects. There is a greater emphasis on storing names of 

cultivated plants, hybrids, common and trade names for families and species, succinct descriptions of the 

natural distribution of taxa and their horticultural properties.  You can store as many facts about species as you 

want. For example, you can add multiple common names, conservation status, CITES and red list details, range, 

habit and hardiness.  
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Accession records 

Accessions vs Plants 

        

Left. An Accession may lead to several garden plants. Right. A selection of the fields available in the main accession record. 

Accession records include details of the type and quantity of material received; from who and where from; the 

‘received as’ species name; its wild origin if known; and other details about the material, as available.  

To see all the fields available, the best procedure is to select Collections > Accessions, assuming the Category 

‘Living collections’ has been selected, then select Grid Tools > Manage Columns. Here you can scroll down the 

entire field list.  An accession record is always one species. Once processed and propagated as needed, perhaps 

over several years, an accession will then potentially lead to one or more garden plants.  

Accession numbering 

Accession numbering systems vary from project to project. A common approach is to use a sequential number 

combined with the accession year, for example 2015-01, 2015-02, …. 

Accession number formatting is controlled from the settings on System > Options > Living Collections > 

Accessions. Here, you can opt for free text entry (no rules) or choose from a set of rules to define numbering. 

These rules apply when new accession IDs are added to the system. 

    

Left. Choosing the overall format for incrementing accession numbers. Right. Some further settings such as padding and 
adding a prefix. The preview shows how your numbers will appear. 

 

Adding a new Accession record 

To add a new Accession record, open the main Accessions table on the Collections menu and use the Add 

option. You can optionally do this with the form opened. The Accession ID will be auto-calculated depending on 

your configuration settings. The number of fields you add is optional but minimally, you should add the species 

name. For this it is best to use the lookup for the Received As Species name as this will also set the Current 

Species Name which can be edited if different. 
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Locating a species is efficient, even when you have many 1000s of names. Refer to the section on locating species names for 
some hints. 

 

If you want to record determination edits more formally, use the Identification tab on the Accession form. Here, you can 
record multiple names for an Accession, with details of who provided the name changes. 

Source/Wild origin 

The source/wild origin of an accession can be registered from the Source/Origin Tab on the accession form. 

This links the accession to a an existing or a new collection event. The accession record also has text fields to 

describe the origin. 

 

Supplier/donor details 

The names and address of institutions, plant and seed suppliers, and others you have links to are added to the 

main address table under Management > Address Book. The table can be edited directly in the data grid 

and/or using the form. 
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An example entry in the Address Book 

 

A section of the Accession table form showing the lookup option for supplier names. 

 

Calculated fields for accessions 

As with many other tables, the Accession table has some handy calculated fields which can be updated using 

the Recalculate option on the Data Tools toolbar. Calc fields can be selectively enabled using Manage Columns 

or you can view them all using #Calc Fields on the Grid Tools toolbar. 
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An example showing some of the # calculated fields in the main accession table, here sorted by the total number of linked 
plant records. 

 

Plant summaries per accession 

A quick way to view all plant records for a given accession is to use the Plant Summary tab on the Accession 

form. This a provides a summary of the accession origin and a grid list of the plant records.  

 

The visible plant list fields can be adjusted by right- clicking on the grid header. Grid filters can be used. 

 

Gardens, Garden locations and plant locations 

Introduction 

The garden location setup allows for single and multi-site gardens. 

Garden plants can be linked to a garden location record. These location records are in turn linked to garden 

records thus creating a hierarchy. Gardens and garden locations can have map references and map shapes files, 

the name of the responsible curator and other details as appropriate.  

 

The way the garden location tables and fields are used varies by project. Different gardens have their own way 

of classifying the locations, their purpose and sub-divisions. 
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Gardens 

The gardens table is opened using the Gardens option on the main Collections menu (when in living collections 

mode).  As discussed below, you can associate a user with an entry in this table, restricting their access to data 

from other gardens. 

 

The Garden table is essentially a list of gardens used by your project. A single garden site will have one entry here. 

Field Name Notes 

Tag Standard tagging field 

Del Standard deletion field 

#Images Calculated field: number of linked images 

Garden Name Name of the garden site 

Garden Code Code if one is provided 

Garden Status Status code 

Curator Name of area curator 

Comments Comments 

Audit fields Standard audit fields 

 

 

Restricting access by garden 

In multi-site projects, they may be a requirement to restricted access and editing rights on a user by user basis. 

For this purpose, the main User table has options to manage these restrictions if required. 

Under System > Manage Users and Permissions use a lookup option to associate a user with a selected garden 

name/code. If you select Allow Garden Section, that user would be able to override the selected garden name. 

Otherwise, the user will be restricted to see and edit data from their assigned garden. 

 

 

 

Garden localities 

The garden localities table is opened using the Garden Locations option on the main Collections menu (when 

in living collections mode). These records can be linked to the garden entries as discussed above using a lookup 

in the Garden Name field. Localities can be classified into functional areas, categorised into zones and assigned 

a garden locality code. Further fields are defined below. 
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Locations can also be assigned a Locality Classification which can be used to indicate the overall purpose of the location. The 
examples above are provided by The Morton Arboretum. 

 

 

Using locality table form, you can list plants per location. A Right Click on the form grid header allows you to choose the 
visible fields. Moving through the main grid updates the plant list. 
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Using locality table form, you can map plants per location. Moving through the main grid updates the map. Various options 
are provided to filter plants on the form. The garden locations form can also draw shapes (garden areas) based on the file 
name added to field KML File. 

Field Name Notes 

Tag Standard tagging field 

Del Standard deletion field 

#Living Alive Calculated field: number of linked plants with status Alive (or equivalent) 

#Living Other Calculated field: number of linked plants with status other than Alive 

#Families Calculated field: number of families in location (from plant record links) 

#Genera Calculated field: number of genera in location (from plant record links) 

#Taxa Calculated field: number of taxa in location (from plant record links) 

#Wild Derived Calculated field: number of plants with Provenance Type = W 

#Cultivated derived Calculated field: number of plants with Provenance Type = Z 

#Images Calculated field: number of linked images 

Garden Name Name of the parent garden (from Garden table) 

Garden Code Garden code – optional (from Garden table) 

Locality Classification For example, Landscape collection, Horticultural collection, … 

Garden Area Name Name of a garden sub-division 

Garden Location Name Name of the garden location 

Garden Location Code Location code if one is provided 

Location Status Status code 

Aspect Location aspect 

Grid Location grid reference 

Latitude/Longitude Map reference fields also with datum, resolution, origin… 

Elevation Min and Max altitude 

KML file Shape file 

Prefix Text prefix for area name (can be used in e.g. reports) 

Curator Name of area curator 

Comments Comments 

Audit fields Standard audit fields 

 

Plant table location fields 

In addition to the above location options which store details about garden areas – more precise details are 

added to the plant table itself. Different gardens have their own system for recording plant locations using up 

to 6 subarea fields which can be defined using the configuration option.  
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An example Plants table showing some of the location fields, sorted by Location name + Grid + Sub Grid. NB. Use Shift Click 
on header fields to sort on multiple fields. 

Field Name Notes 

Garden Name From Gardens table  

Location Name From parent garden locations table 

Subarea 1 As configured (see below) 

Subarea 2 As configured (see below) 

Subarea 3 As configured (see below) 

Subarea 4 As configured (see below) 

Subarea 5 As configured (see below) 

Subarea 6 As configured (see below) 

Sequence Sequence (e.g. for inventory or trail) 

Latitude /Longitude Map reference 

Elevation Min/Max altitude 

Garden Location Notes Free text 

 

Garden location subareas 

The plant table itself has 6 plant location properties that can be used to manage plant locations in your 

gardens. These fields are, by default, named Subarea 1 - 6 and sit below Garden->Area->Locality in the location 

hierarchy. You can rename some or all of these fields to suit your own purposes. You can also disable (remove) 

these fields from use in grids and forms or make them visible or hidden as required in data grid views. For 

example, your garden may use a grid location system so you may want to rename Subarea 1 to 'Grid' and 

Subarea 2 to 'Sub-grid'. You might then disable the other Subarea fields.  

 

 

Configuring the plants table locality fields. 
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Plant records 

Introduction 

The main plant file stores details of all plants that are or have been growing in the garden with details including 

the plant status (alive, disposed, etc.) planting date, garden location, vouchering, label requirements, 

identification changes, commemoration or sponsorship details, and mortality details.   

Plant records in turn are linked to an accession record which holds all the information about the origin of the 

plant, the supplier and/or wild origin, its propagation history and the species/identification.  

 

Plant numbering 

 

 

Plant numbering is treated in a similar way to accession numbering although there are several different 

options. For example, you can use the Accession ID as the basis for the Plant ID or you can use various types of 

incrementing numbers such as Plant year + Incrementing sequence for that year. Plants can use numbers or 

letters when in sequences. 

 

 

Editing the plant table 

Adding new plant records 

When adding new plant records directly to BRAHMS (rather than via RDE), you open the main plants table and 

use the Add option. It is important that you have checked and edited the setup options under System > 

Options > Living Collections. The options here control how new plant IDs are calculated. 

When adding a new plant, the first step is to choose or add a plant accession record – using the lookup 

provided at the top of the Add Plant form. 
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If adding a new accession, you will be directed to another form that allows you to enter all aspects of that 

accession including species, supplier, wild origin, order dates, etc. 

You can add data for 1 or more plants at the same time by editing the ‘# Plants to add’. Field. 

 

The upper part of the add plant form allows you to enter the plant garden location for each plant you are 

adding. Note that the Subarea fields are configured from System > Options > Living Collections. In this 

example, 3 of the 6 maximum  subarea fields are in use. 

 

The lower part of the form provides the means to print and/or request labels. The labels listed here are as 

entered in your main Labels table. 
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Editing plant records 

Opened from Collections > Plants - assuming the Category Living collections has been selected. In Edit mode, 

all non-lookup fields can be edited directly in the grid or on the form.  

 

A plant grid with a filter set on a single Accession. This Accession has several clones planted in different grid areas. Only a 
selection of the available plant table fields is visible in this screen. Field views are set using Grid Tools > Manage Columns. 

 

The Plant table form opened. As there have been unsaved edits, the form has a red surround and the Save Changes option is 
enabled. This form has several tabs with different functions. 
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Plant status 

Introduction 

The plant status field is a key data field in the plants table as it informs whether a plant is alive/active or 

otherwise. The process of editing this field is often referred to as deading/resurrecting plants. Deading is when 

a plant is deemed to be dead, lost or otherwise disposed of. Resurrecting is when a ‘dead plant’ is re-

discovered and/or found to be alive.  

Configuration for Alive status 

As certain calculations refer to the plant status code, BRAHMS has to know which code you use to represent a 

living plant in the plant record Living Status field, for example ‘L’, ‘A’ or ‘Alive’. To edit this code or text, select 

System > Options > Living Collections.  

 

Setting status codes for accessions and plants. The code for living plants is used by BRAHMS with a number of calculations 
and settings. The code for dead/disposed is less important in this setup bearing in mind that you may have several codes 
representing dead, disposed, not found, etc. 

Hide dead plants by default 

The option Default to displaying living plant records only is used to hide non-living plants by default when the 

plant table is opened. This setting can be over-ridden when in the plants table itself. 

 

When working on the main Plant table, you can override the default setting to view living plant only (if this has been 
selected). 

Registering status values in your lookup list 

You should the values you want to use to the LivingStatus field in your Lookup dictionary. There is no limit to 

the number of values added, the simplest approach being to add one value to represent living and another for 

dead. However, you may wish to refine the codes for non-living, for example lost, disposed, etc. You can use 

codes or words up to 15 characters in length. 

 

An example lookup with just two entries. To understand how to edit these values, refer to the section on editing your lookup 
lists. 
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Registering reasons for changing plant status 

Separately to the living status codes themselves, you need to register the reasons for changing plant status. 

When editing plant status, often referred to as deading and resurrecting, the system enforces you to provide a 

reason. The reason you provide may be simply be ‘Deading’ and ‘Resurrecting’. On the other hand, you may 

wish to provide a more detail list of options. 

 

 

 

Example entries added to the lookup list. 

Confirming or changing plant status  

The plant status field cannot be edited directly in the data grid. This is to enforce users to provide a reason for 

the edit. Thus, a small form is used to add the change reason and optionally, add some additional notes. It is 

also useful to record who made the edit and when. All changes to this field are logged as plant events, thus 

keeping a record of all status changes made to a given plant. To edit the status, you can:  

• use a lookup in the data grid field; 

• use the option provided on the Plant Form;  

• use the Dead/Resurrect tool on the main Collections menu. 

Each of these options leads to the same tool to edit plant status. However, when accessing the tool from the 

plant form, you can only edit the current plant record. Accessing the tool using either of the other options 

allows you to edit the current or all tagged records. 

 

The Plant Status option on the main Collections menu. 
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In this database, the status codes used are L for Live/active and D for dead/inactive. You can apply a change to a single 
record or skip through all tagged records. When editing tagged records, you can set the status change reason for each plant. 

 

 

You can also use this option to confirm plant status. If the plant status is not edited, the Change button stays as Confirm. A 
plant status event confirm event is added. 

 

 

All plant status changes are recorded as plant events. The Events tab on the plant form can be set to show status changes 
only. 

Plant stock quantities and adjustments 

Plant stocks refer here to the quantity of individual plants for a given Plant ID rather that the number of plants 

in an accession group. A single Plant ID may refer to a group of plants which may subsequently be split up and 

planted out to different locations, thus receiving their own plant IDs. Some plants may also be distributed in a 

transaction to another garden or institution. Alternatively, plant stock levels may be adjusted for other reasons 

such as death or loss. 

Plant stock data fields 

Plant stock quantities are stored in the plant table fields: 

• Initial Stock: refers to the initial number of plants represented by a single plant ID record 

• Stock Removed: the amount a stock deducted in one or more activities (splits, transactions) 

• Remaining Stock: a calculated field based on the above fields. 
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Column selection in the plants table with a filter on ‘stock’. 

 

 

A series of plant records showing stock levels with a filter set to initial stock > 5 

 

Manually adjusting stock levels 

You may need to manually adjust stock levels following stock checking. This is done using the Stock Check 

option on the Collections Toolbar. 

 

 

 

Reasons for altering stock levels can be entered. You can process a series of tagged records. All adjustments are added to 
the plant events table. The adjustment reason can be free text or selected from a list. 

Note that you can add free text to the Adjustment Reason if the Management custom field lookup field setting 

is not set to Must Choose. If you use Append Mode, you can add multiple reasons. 

Adding stock adjustment reason lookup values  

To add a list of stock adjustment reasons and thus allow selection from a drop-down list on the adjustment 

form, select Management > Lookup Fields > Add. For the data Type, select ‘System’ and choose the Column 

‘StockChangeReason’. You can manually add reasons here. Alternatively, using the Management menu Import 

from Excel option, you can import the reasons from an Excel file (see below). 
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Sample Excel file listing reasons for plant loss or stock change. Lists like these can easily be imported to your 

custom lookup lists using Management > Lookup Fields > Import from Excel. 

 

Plant locations in garden 

A description of plant location data is provided in the Garden Areas and Locations section. 

Moving tagged plants 

To change the location of a single plant, you can simply edit the location data from the plant table grid or form. 

To move multiple plants from one location to another, it will be quicker to tag the plants to move and then 

select the option Tag-> Move… on the main Collection toolbar. 

 

The tag -> Move option is only enabled if one or more plant records is tagged. 

 

An example plant move form. When plants are moved, the Tag is updated to ‘M’. 

 

Managing plant identifications 

Verification of names 

Name verification is important as it provides visible details about when a plant identification was verified – 

together with the quality of the verification. Verifications vary in their reliability, for example, they may be 

based on sterile material rather than fertile. 

Verifications are added as plant events. The most recent verification record is also added to the plant table 

itself as shown below: 
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All verifications are added to the plant events table and can be viewed from the plant form: 

 

Note that the Events tab has the option to restrict the event list to Verifications only. 

 

Setting up the events lookups for verifications 

In order to use the verification system, you must set up the plant event lookups following the pattern below. 

You can change all the values except the EventType must be ‘Identification’. 

 

LookupValue ParentCategory FieldName SortOrder 

Identification  EventType 1 

Full Verification Identification EventGroup 1 

Partial Verification Identification EventGroup 2 

Sterile Material Partial Verification Event 1 

No Specialist Partial Verification Event 2 

Poor specimen Partial Verification Event 3 

By specialist Full Verification Event 1 

Unambiguous species Full Verification Event 2 

 

 

Editing verifications 
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Verifications are done using the Verify Name… option on the Collections menu toolbar. If name verification status is 
changed, you can request new labels if required. The verification form also has a Change …  option top right providing 
access to the name change form. 

 

Changing identification 

The identification (i.e. taxa name) of a garden plant is held in the parent Accession record. If an Accession has 

multiple plants cloned across a garden, these will have the same identification. If you edit the identification of 

an Accession record, this will change the name of all plants related to that Accession. 

Within the plant table itself, there are further plant identification options. These allow you to: 

a) Confirm a plant ID is correct (true to name). 

b) Edit the name of the plant(s) belonging to the Accession. If there is more than one plant, they will all 

be changed. 

c) Decide that a one or more plants linked to an Accession has/have the wrong name and separate 

it/these to a new Accession.  

 

 

If a name is confirmed, a confirmation event is added to the plant Events table including the date and confirmation person. 
All plant events, including confirmations, are listed from the Events tab. 
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If changing a plant name, appropriate warnings are given if there is > 1 plant linked to the same Accession. If there are > 1 
plants and you opt to split the Accession, a new Accession record is auto-added with the newly selected species name and 
the selected plant is linked to this new Accession.  

 

Bulk name changes 

In the event that a species name is changed in the main taxa table, this may require that one to many living 

collection accession records are also changed. The species change may impact on all or only some of the 

related accessions. For example, a species may become a synonym of another name or it may be split to 

different taxa. 

To update accession records, open the living accessions table and select the Bulk Name Changes option on the 

Collections menu toolbar. 

 

Bulk Name Change form 

Using the options provided opposite the existing name, you can lookup the name to be changed, set that name 

to the name of the current accession record, and filter the accessions to the currently selected name. 

After selecting the New Name, you can then select Change to update the accession identifications for all or 

tagged records.  
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A prompt asks you to confirm the name change. 

When accessions are changed, the records are tagged ‘N’ and a determination record is added for each edited 

record. Also, the relevant plant records are tagged ‘N’ and a name change event is added to each plant. The 

plant record tags can then be used to control label printing as required. Plants are edited regardless of their 

living status.  

 

Collecting vouchers from garden plants 

Specimens may be collected from garden plants for reference, checking identification and for other research 

purposes. Links can be created between the garden plant and the Collection Event tables allowing you to track 

which plants have vouchers.  Vouchers may be of any type (herbarium specimens, DNA, wood samples, fruit or 

flower specimens, etc. These links are cross referenced within BRAHMS. 

A given garden plant may have many vouchers collected over time. The flowering and fruiting status of 

collections can be added, thus helping you to determine if further collections should be made. 

Vouchers are linked to plants using options provided on the Living Collections Plant Form Identification tab. 

 

The plant table and form showing the Identification > Plant Vouchers tab. This plant has 5 linked vouchers. Options are 
provided to Link and Unlink vouchers. In this example, a filter has been set on the calculated field #Voucher Total to show 
plant records with >= 3 vouchers. 

Linking vouchers will open the form to locate a collection event. If the collection event has 1 or more linked 

specimens, these will all be added to the plant – voucher list.  

 

Plant Location Summary  

The field ‘Plant Locations Summary’ shows a list of all plant locations for the current accession. Although you 

can list plants on the plant form, this field is a useful guide to see where else a plant occurs in your garden. 



BRAHMS v8 introduction and guide  258 | P a g e  

 

The Plant Locations Summary field lists plant location codes (including subareas) for the current accession.  

 

Last event/request date and edit category 

The Last event/Request date and group fields are useful indicators of what a plant was last assessed. The 

‘group’ refers to the group category of the event or request. 

  

Filtering of the last Ev/Req. date may be a useful way to select plant for inventory checks. 

 

Linking plants to a transaction 

With the main plants table open, select Collections > Link to Transaction. 
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Using this form, you can select plant IDs one by one, to link to the selected transaction. You can select an 

existing transaction or add a new one. Using this form, you can deduct from plant stock using the Dispatch 

Quantity field. However, if you tick ‘This material in NOT plant stock’, the function does not deduct from plant 

stock. This may be appropriate when e.g. distributing seed. You can also auto-link all tagged records to a 

transaction. The restriction status of plant material is displayed on this form. 

 

Calculated fields for plant records 

The species and plant tables have a number of plant-related calculated fields refreshed using the Recalculate 

option on the Data Tools toolbar. As with all tables, you can either selectively add calculated fields using Grid 

Tools > Manage Columns or switch them all on using #Calc Fields on the Grid Tools toolbar. 

 

An example in the main species table where the calculated fields #Living Alive is set to visible. This calculates the number of 
living plants per species. Calculated fields are updated using the Recalculate option on the Data Tools menu. 
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Sponsorship, commemoration and tributes 

 

Individual plants can have commemoration texts added.  

 

It would also be possible to design and save a data grid field view showing the relevant fields as shown here. This would 
allow sorting, filtering and rapid editing of these fields. 

 

Tagging in the plant table 

The use of tags in the plants table is fundamental to many operations. Tagging in general is described in the 

manual section on Tagging functions. A few example uses of tags are provided here. 

Using tag groups with plant records 

The Tag Groups function can usefully be used with plants to create groups of plants of special interest. Any 

selection of plant records can be tagged and this then used to create a named plant group. 

Tagging plants based on tags in other tables 

Another handy feature used throughout BRAHMS is the Tags > Transfer Tags tool which transfers tags from a 

table to any related tables. Thus, you may have a set of tagged records in the species table (perhaps restored 

from a tag group you have created such as ‘Native taxa’). You can then use Tags > Transfer Tags to copy the 

tags to all plant records of the tagged species. Read about transferring tags. 
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Creating a plant RDE file for the Gardens Mobile App 

In the main plants table, tag the records you wish to send to BRAHMS  garden app. This can be any group of 

plants. You may want to create more than one RDE file, for example one file per garden location. You have the 

choice of exporting existing events/requests for the selected plants - so that these can also be viewed in the 

app.  Existing images are not exported. You can restrict existing events/requests by date range. You can also 

restrict plants to those with a status representing ‘alive’.  If you have tagged one or more records in the garden 

localities table, you can also use the option to Export all plants of tagged locations.  

Once created, the next task is to copy your RDE survey file(s) to your device. 

 

For further information, refer to the garden app documentation. 

 

 

Plant Events  

Introduction 

Living collection plant event records are used to record things that happen to plants from their accession 

through to death or disposal. Examples are plant status changes, plant movements, fertilizing, mulching, 

https://herbaria.plants.ox.ac.uk/bol/Content/Projects/brahms/images/hires/tagtransfers.png
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making safe, spraying and tree surgery.  You can also store observations such as flowering and fruiting times. As 

each event has a date, these can later be reviewed and used to analyse phenological and other patterns.  

Events are stored in a separate file linked to the main plant file.  A plant record may have many registered 

events, sorted chronologically. Although stored in a separate table, all events can be quickly listed from the 

main plant form. 

The events table is often the largest and most actively edited table in the living collections module. The choice 

of which events to record is entirely a decision for each project.  

Event categories and other fields 

Events are categorised in a user defined, 3-level hierarchy:  

PlantID 
 

The event record displays some fields from the parent Plant file including the ID itself, the species 
location. 
 

Event Types This is the top grouping level – thus there will usually be a small number of entries. Examples 
are Inventory, Maintenance and Observation. 
 

Event Groups These are division of the main event types. Thus, for maintenance, you may have entries such as 
Fertilizer, Herbicide and Mulching  
 

Events These are the final category which would be, for example, the different types of mulching such as 
bark-chips, pine-needles or limestone. 

  

Event Date 
 

Separate into Day Month and Year fields.  

Result Where relevant, a text or numeric entry relating to the event, for example a measurement. 
 

Event Person Who carried out the event 
 

Event Notes Text description of event 
 

Audit fields Added by, Added When, Last edited, Last Edited by 

  

  

 

 

Registering your event categories in the lookup list 

Entries for all three levels should be registered in your lookup list 

 

Sample lookup list entries for plant events. 

Typically, the top-level Event Type will consist of a short list. One of the entries may be ‘Maintenance’. This is 

the top level in the event hierarchy. Note that the Field Name is set to EventType and there is no entry needed 

in the Parent Value field.   
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Event Groups are also registered in the look up list. Each entry has an Event Type as a parent. The parent event 

type is added to Parent Value field as shown above. The example here lists entries for ‘maintenance’. One of 

the maintenance-related entries is ‘mulch’. Note that for ‘mulch’, the Field Name is set to EventGroup and the 

Parent Value is set to ‘Maintenance’. Finally, the entries for the field Event are listed, here for ‘mulch’. Note 

that the Field Name is set to Event and in this case the Parent Value is set to ‘mulch’. 

This set up will then allow you to correct use the lookup options when adding and editing events. 

Editing Plant Events 

Events can be edited directly from the main Plant Events table opened using Collections > Plant Events. 

 

Events can be added and edited directly in the events table. If you add a new record, you are prompted for the plant ID. 
Several fields from the plants table are displayed but cannot be edited in the events table. 

Alternatively, you can edit events using the main plants table form - Events tab. 

 

When using this form, events are listed for the current plant record and these update as you move through the data grid. 
You can add and edit events here too. 

       

When editing events, the lookup option for the event entry uses a hierarchical value selector. The top Find option allows you 
to enter efficient strings and with some practice, you can minimise typing to locate the required entry. The example here 
uses ‘m’ to restrict to maintenance, ‘c’ to restrict to chemical and then ‘h’ to find herbicide. Clearly, how you search will 
depend on the values added to your look up list. 
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Creating an RDE table for plant events 

While events can be added directly to the database, if there are many events to add, it will be faster to use an 

RDE file plant events file. This is a spreadsheet which can be edited, checked and then imported to your 

database. The process of using RDE (Rapid Data Entry) is described elsewhere in this guide. 

There are two ways to create RDE plant event files: 

a) Create a file directly in the RDE manager using Rapid Data Entry > Create new RDE file, choosing the 

category ‘Plant Events’. 

b) In the main living plants table, use the tool Tag -> Events RDE which can be found on the Collections 

menu. 

The advantage of using the collection tools option Tag -> Events RDE is that the RDE file is created pre-

populated with the plant records you want to record data for. 

• Open the main plants table using Collections > Plants (this assumes the collection category is set to ‘Living 

Collection’. 

• Tag the records to include. Typically, this may be for a selected garden area. To do this, apply a filter for a 

selected garden area (or several garden areas) – and then use Tag > Tag all.  

• You can now use the Collection menu tools option Tag -> Events RDE. 

 

Use Tag -> Events RDE to create an RDE file pre-populated with the plant records you want to work with. This file can then 
be edited with the event details (observations, maintenance, annotations, status checks, etc.). After checking, the file can 
then be transferred to BRAHMS. 

Transferring Event RDE files to BRAHMS 

When you import a plant events file to BRAHMS, the new events will be added and linked to the correct plant 

records based on the Plant ID. If the Plant ID is not located, the event record will not be imported. 

As well as adding events with the event type, group and event, RDE event files can also be used to: 

• Change plant status (Alive, Dead. Lost, etc.) 

• Change plant identification 

• Indicate that a label is required 

Importing Plant Events from Excel 

Event data for plants already stored in BRAHMS can be imported to the events table directly from an Excel 

spreadsheet. The events can be of any type/group. Ideally, the event hierarchy options you use will the same as 

those registered in your BRAHMS lookup list. 

To match to plant records in your database, the excel table must include either the plant record GUID or the 

Plant ID. If a match cannot be made on one of these columns, the data cannot be imported. 

 

The Import Events option is found on the Collections toolbar when the Plant Events table is opened. 
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The Import  Wizard allows you to match all the fields that you wish to import. In the above example, there is no 

GUID so matching will use the Plant ID.  

 

 

 

 

 

The pre-import screen showing that one plant cannot be located and thus, the data for that record will be 

ignored. 

 

Plant requests 

Requests (plant actions requested) can be logged in the plant request file. Request lookup selections are 

managed in the same way as events, replacing the Field Name as appropriate. As the lookup lists for requests 

and events may differ, these are added to the lookup list separately. Requests can be edited directly from the 

main Plant Requests table opened using Collections > Requests. Alternatively, you can edit requests from the 

main plants table using the Requests tab on the form. 

 

 

  



BRAHMS v8 introduction and guide  266 | P a g e  

Producing plant labels 

Introduction 

As a rule, two main categories of labels are produced in botanic gardens: engraved labels and those printed on 

special paper/plastic for potting and similar, both of these often on specialised printers. Both categories may 

have several sub-types based on the precise type of label needed, including label size. This section discusses all 

aspects of label production from the initial request to the final production.  

Some key points: 

• Using the in-built reporter, labels can be printed directly from BRAHMS or saved to one of several formats 

such as Excel or PDF. These reports will be based on one or more report templates that you design. 

• Data for labels can alternatively be exported directly to Excel, based on one or more data grid column 

views. Such exports may be required for certain types of engraving printers. 

• You can add as many label categories as you need, each associated with a report template or a data view. 

These are stored in a dedicated Labels table. 

• Labels are often required, not only for new plants but when plants change name, have their name verified, 

or are split to new areas. The tools that offer these functions in BRAHMS include a direct link to label 

production for the relevant plants. 

• Labels can be printed directly or alternatively, added to a central label request table. Direct printing by-

passes the label requests table. The enabling of direct printing is an option in the labels table.  

• There is a concept of ‘deferred label printing’ which is used when the print job has to take place after a 

certain action is completed. For example, if you are adding new plants or splitting stock, the new Plant IDs 

must be created before the labels can be produced. 

• Permissions can be assigned on a user by user basis as to who is allowed to request labels. Thus, a garden 

with many horticultural staff may wish to restrict this function to selected users and thus more tightly 

control the build-up of e.g. engraved label requests. 

• Labels added as requests are processed from the request file and their status changed from pending to 

processed. 

 

Setup options and label types 

As a first step, you need to register your categories of label in the Label table. Select Collections > Labels to 

open this table. This assumes you are using collection category ‘Living Collection’. 

 

Some example entries in the label table. 

The report output template (.mrt) files and/or any data grid column view (.dgc) files must be stored in the 

application’s Shared\Report Templates folder. The order labels are present on BRAHMS forms can be 

controlled (see below). To link .mrt or .dgc files, use a lookup in the Output Template Filename field. 
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When using a lookup, select the file type you are looking for (.mrt or .dgc) 

 

The reporting options integrated with BRAHMS are described in the reporting section of this guide. 

 

You can design multiple reporting templates for different categories of label and either print directly or export to different 
formats. 

Permission settings 

A permission setting is provided on the User Access and Permissions form, Specific Actions tab to allow a user 

to request labels. 

 

If this option is not set, users will be able to use direct label printing but will not be allowed to add requests to 

the label request table. 

 

Requesting labels 

Label requests can be made directly when adding new plants and also using the Request labels… option on the 

Collection tools menu when the plants table is opened. 

Adding new plants 
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Your label categories, as registered above, are listed on all forms that have a link to label printing, here Add Plants. Labels 
are listed in the order as specified in your label table. You can choose the number of labels to print per label category per 
new plant. 

 

 

The Print/Request labels… toolbar option in the plants table allows you to run through all  or all tagged records, choosing 
the label requests. You can also apply the same request to all tagged plant records. The Request option can be disabled on a 
user by user basis by adjusting the user permissions. 
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When direct printing is enabled, the print option appears on the label form. 

 

Processing label requests 

When labels are requested, they are added to the plant requests table. The requests table can be opened in a 

special mode for processing label requests.  

 

Pending label requests are displayed in this table together with the label type and quantity. 

To process these pending requests, select the Print labels… option. 

 

 

The print option asks you to select which category of label to print.  

Processing Report generated labels 

Assuming you have added the report template, that template will be added to the Output to text box and you 

proceed to print. Otherwise, you will have to use the lookup option to select a template. Labels can be printed 

directly or saved to one of several file formats. 

 

Processing Engraved label requests 
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Choose a label category for engraved labels. 

 

Selecting ‘Output to’ will prompt you to choose a saved .dgc file. Refer to the section on creating an engraved label view. 
Note that you need to change the file type selector to .dgc. 

 

 

After selecting Print, save the Excel file as prompted in the required folder. 
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Index Seminum  

Introduction 

For botanic garden projects, it is now possible to develop seed catalogues directly from BRAHMS. The Index 

Seminum catalogues can be built up based on accessioned and non-accessioned material for wild or cultivated 

plants. Facilities are provided to create named catalogue entries, often one per year, with descriptive data held 

under user-definable headings. An example may be your local growing and climate conditions. You can then 

link seed entries based on your current garden accessions, collection events and/or manually add details for 

non-accessioned material. Full reporting options are provided enabling you to format catalogue text headings 

and your selected seed entries, sorted and numbered appropriately. Reporting can be used to generate PDFs 

and other output formats. 

Adding a new Index Seminum 

 

Select the Index Seminum option on the Collection menu. After adding a new record, here, you can add in the 

Garden name, the index Year and Title, and up to 5 text headings and values. For example, you may want to 

add text describing the growing conditions and climate of your garden; special notes about the catalogue for 

the current year; contributors; and any other relevant details. All of these text headings and values can be 

formatted into your Index Seminum report.  

The table also has a form with tabs for the above data and a separate tab to list, add or edit seed entries. 

Adding index Seminum seed entries 

Seed entries can be added directly to the above form using the various lookup options provided. Note that you 

can add seed entries that are not accessioned in your database. For example, you can add an entry by looking 

up any species name registered in your species list. 

Typically, you will want to generate Index entries based on your existing Living Collection Accessions entries. To 

do this, tag the relevant Accession records and then choose the option Collections > Tagged -> Index Seminum.  

 

You can also use this Collections > Tagged -> Index Seminum from the Collection Events table. This would be 

useful if you have wild collected but non-accessioned seed to add to your index. 

Renumbering index entries 

On the main Index Seminum form, use the Renumber option to renumber the entries sorted by family + 

species name. 

Index Seminum outputs 

All data from the index can be exported to CSV/Excel in the normal way. However, you can also design report 

templates that format the index and index entries as you wish and save these reports to PDF, HTML, Word, etc. 

as well as printing them directly. 
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Images and Documents 

Images 

Images can be linked directly to species, garden plants or indeed, to any other database record. Physical image 

files can be stored in any accessible location. You can also link images as URLs.  Images can also be added via 

RDE and you can import images from Excel. For more details, refer to the image section of this guide. 

 

Image management is discussed in the image section. 

Documents 

Multiple documents of any type can be linked to taxa, accessions, plants or any record in BRAHMS. Examples 

are material transfer agreements, collection permits or perhaps a video or slideshow linked to a botanic garden 

greenhouse record. Refer to the section on linking documents. 

Adding phenological observations 

Introduction 

The phenology options enable you to record phenology events for individual plant records. These are indicated 

by adding the present or absence of a selected phenology event by date. Any phenology event can be 

registered, examples being flowering, fruiting, seed set and leaf flush. Phenology events can then be 

summarised by month. 

Setup options 

Register event lookup options 

Events in BRAHMS are stored in a 3-level hierarchy: EventType, EventGroup and Event. While not strictly 

necessary to register event look categories, we suggest you add EventType and EventGroup as described 

below. 
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Permissions 

Users can be given permissions on System > Manage Users and Permissions as follows: 

 

The permissions dictate whether a user can add or remove phenology traits. Any user with access to the living collections 
module can add/edit phenology data but not necessarily add/delete traits. 

 

Adding and deleting phenology events/traits 

To add a new phenology event, choose the date and select Present/Absent for the listed trait, optionally adding 

a short note. All measurements can be added as either Present or Absent. All events, including phenology 

events, are deleted from the plant form main Events tab. A user with the appropriate permission can add a 

new trait in the New Trait text box. 

 

Traits can be added and deleted from this form. 

 

Summaries and charts 

All phenology observations for a given plant can be listed from the Observations tab. These observations are 

stored as plant events and thus, can also be listed on the events tab together with all other events for the plant 

record. 

 

 

Observations can be listed and viewed graphically. 
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Mapping plants 

Mapping garden plants and their origin 

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#gardenmapping 

Mapping the location of garden plants only requires that your plant records have a latitude/longitude value. 

These can be entered in different units but are always stored in decimal degree format, negative for South and 

West. You can store these data with up to pin-point accuracy. 

Using the internal ArcGIS mapper, you can map the plant locations, dynamically linked to the data grid. These 

mapping options are discussed in the section on the ArcGIS internal mapper. You can also dynamically map 

your data to other GIS including QGIS, ArcMAP and DIVA GIS.  

You may have your own garden base maps to add as map layers – or use map layers available online including 

world imagery maps. If your map data are available on a map server, you can also add your own map to the 

ArcGIS API. 

 

 

Garden data plotted to ArcMAP and the internal ArcGIS mapper 

 

 

In this example from The Morton Arboretum, a filter is set on garden location ‘Morton East Woods’. The Betulaceae are 
tagged in red – and the map is set to map Tag colours. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#gardenmapping


BRAHMS v8 introduction and guide  275 | P a g e  

As with other map points, garden plant map points can be added or edited using the Map Point Editor. This 

function is described in the section Adding and editing map points. 

 

A right-click on the map moves the point and adjust the stored data point. 

 

 

Exporting to Excel and CSV 

Data from any table are easily exported to Excel or CSV files. 

Video: exporting to Excel/CSV  

 

 

Tagged records are easily opened in Excel or as CSV. 

 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#exporttoexcel
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Plant Requests, Scheduling and Ordering (RSO) 

Introduction to Plant Requests, Scheduling and Ordering (RSO) 

 

      

Succulent, Rudbeckia and Paphiopedilum production at CBG. Images provided by J. Hutchins, Chicago Botanic 

Garden (CBG). 

 

The RSO module has been developed in collaboration with Chicago Botanic Garden. 

The RSO options are used to manage requests from curators for new plants, be these seasonal/display or to be 

accessioned.  Accessioned plants are registered in the Living Accessions table while seasonal plants are not. 

Plant requests are submitted to a central RSO table where they can subsequently be processed in stages 

through to production/propagation/dispatch and optional garden accessioning. 

As discussed below, there are a number of processing stages from the request submission through to the final 

delivery of the requested material.  

Those responsible for scheduling and ordering the requests are able to optimise delivery dates to feed into 

propagation or production to meet required garden delivery dates. A curator may request a species that does 

not exist in the institutional species list - and this would require addition by someone with authority to do so. 

It becomes possible to streamline the ordering process by combining requests for different species and from 

different curators into single orders form a selected vendor. 

 

Action RSO Status 

Request is rejected by management Rejected  

Request is accepted  Pending 

Species are checked and confirmed Approved 

Vendors are checked and confirmed Approved 

Schedule date selected  Scheduled 

Order date selected Ordered 

Receive date selected Received 

Summary of RSO status stages. 

 

The RSO table and manager 

Introduction 

The main RSO table is opened using Collections > RSO when in living collections mode. Note that by default, 

archived RSO records are hidden. 
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The main RSO data grid. 

The RSO grid can be edited as with any other data grid. Some fields are read only. The RSO has a special 

Manager which is opened using the Show/Hide RSO manager option.  

Linked Propagation-Production records 

When new RSO records are created, a record is automatically added to the Propagation/Production (PP) table. 

This is linked to the RSO record with the same RSO/Propagation number. This provides a close integration 

between these two tables - and it also means that certain PP fields can be viewed and edited from the RSO 

table. These are mostly ‘forecasting’ (see below) fields. 

Data fields that are visible in the RSO table but are stored in the PP table can only be edited in the RSO table via 

the RSO Manager. In the RSO data grid, these PP fields are read-only.  

 

Plant requests – RSO data capture using Rapid Data Entry (RDE) 

Curators will normally submit plant requests in batches using RDE files. RSO RDE files are created and edited as 

are all other categories of RDE file. The following data fields are available in the RDE table for RSO submissions: 

Field Note 

RecordId Calculated RDE record number – not for editing 

Garden Name/Code Lookup to your garden name/code  

Requested By Person ordering plants – lookup to name strings table 

Requested For Garden Location/Area  Requested destination of requested plants 

Garden Project Name Link to Garden Projects table (see below) 

IsAccessionMaterial Is the material to be accessioned rather than seasonal/display only? 

IsPropagationMaterial Is the material going to require propagation? 

Is Wild Collected Is the material wild collected? 

Requested Material Bulbs, Seed, Plants, etc. 

RequestSpecies Requested Species – look up list or added as new 

RequestDeliveryContainer Lookup to container categories (see below) 

RequestDeliveryPlantsPerContainer Requested plants per container (normally 1) 

RequestDeliveryContainerQuantity Request number of containers 

CalcRequestDeliveryPlantsQuantity Calculated field based on containers x plants per container 

RequestedForDate The date the material required for final delivery to garden 

RequestVendor Requested vendor (may be adjusted by ordering team) 

RequestItemNumber Vendor catalogue number if known. 

RequestUnit Unit name e.g. Each;  One L pot;  Pack of five,  

RequestUnitCost Unit cost 

RequestUnitQuantity Requested number of units  

CalcRequestItemTotalCost Calculated cost of item 

ResearchCode Optional code for research of budget line 

Comments Additional notes 

 
 

Importing RDE files 

Once an RDE file is prepared, the curator responsible (or another designated to do so) will proceed to upload 

the data from RDE to the central RSO table in BRAHMS where the request will be processed by the plant 

scheduling/ordering staff.  

RDE file uploading is prevented if any of the following fields are null or have empty string values: 
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RequestedBy  
RequestedForDate  
RequestSpecies  
CalcRequestDeliveryPlantsQuantity  

 

 

Import analysis indicates how many new RSO records will be added. 

As part of the RDE import, new RSO/Propagation numbers are auto-assigned based on your configuration 

settings (see System > Options > Living Collections > Production/Prop . This same number is carried through to 

the propagation-production table. Note that there is an optional Auto-Archive RDE files on import feature. 

Once imported in this way, the records in the RSO table are assigned a status ‘Pending’.  A key next step is to 

check the species names as requested and approve the requests. 

Request Approval 

Species checks 

The next stage is Request Approval. Before approving submitted and accepted records, the species names 

must be checked using the Species Auto Match tool.  This tags with “!” any taxa that cannot be located in the 

main database taxa table. This may be an incorrectly added species or it may be a species new to the 

institution/botanic garden. 

 

The RSO manager Request Approval tab. Note that the Auto-match result is given in summary (e.g. ‘0 

unmatched species’) next to the auto-match button. In this case, all species have been located in the species 

table. 

When one or more species cannot be located, there are three choices: 

• Leave the record unedited and thus it cannot be further processed. You may choose to delete. 

• Edit the species name by selecting a correct name from the species table using the option provided. 

• Add a new species to the taxa table using the option provided. Note, you could, if needed, go to the main species 

table to further checks/add new record directly there – and then return to the RSO to re-run Auto-match. 
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When adding a new species, BRAHMS will parse out the submitted name as best it can. The name can then be 

edited and added to your main species list. 

Request Approval 

Once the names are checked, you can then ‘Approve’ the requests using the options provided. Approved 

names have their status changed to ‘Approved’ and they will disappear from the main data grid. Once the RSO 

Manager is closed, these records will be visible again. 

  

Also, at this stage, when records are approved, species default data, if available, is pulled into PP forecast 

fields. Default species propagation values are discussed below. 

Forecasting 

Forecasting – Production 

 

Propagation plug trays at CBG. Knowing space requirements in advance (forecasting) can be critical for 

planning. Image provided by J. Hutchins, Chicago Botanic Garden (CBG). 

Forecasting data, stored in the PP table, are visible in the RSO table. In RSO, they can only be edited via the 

manager. These fields are generally used to help order planning and scheduling. For example, it may be 

essential to have an advanced idea of the growth space, growth medium and temperature requirements for in-

coming plants.  These can be used to determine what greenhouse space will be used for a crop.  For example, a 

crop needing 60/55 day/night will need to go in a different house than one requiring 75/70.  
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The top part of the Forecasting form shows the Requested data. The main part of the form shows the Prop-Prod 

data, auto-filled with species default data values. The data shown above are fictitious. 

Data in the Forecasting form can be edited. The edits made here can be saved and copied to one or more other 

records using the Tick boxes and the Save options. For example, the Production Growth Media may be edited 

from the default in one record – and this edit applied to other records. Note that many of the values on this 

form will be provided from standard lookup lists. 

 

Forecasting - Propagation 

This is similar to the above form except that the data are limited to records being propagated and the form 

fields are for propagation data. 

 

Order scheduling 

Vendor matching 

On the Order Scheduling tab, the task is to run the Vendor Auto-match tool and to add and/or adjust vendors 

as needed. The vendor matching uses the ‘Requested Vendor’ and adds the result to the ‘Order Vendor’ field. 
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The Auto Match vendors tool checks the requested vendor names and marks up and new/unknown entries.  

Note that a Filter tool is available to filter the RSO records to unmatched vendors. To filter on any selected 

vendor, use the grid filter row. There are also tools to copy Vendor to tagged or to all (within a filter) records. 

In order to edit fields such as Order Item No, Order Unit Quantity and Cost, the data can be edited directly in 

the data grid when in edit mode. 

 

Order adjustments 

 

Various features are provided to help with the ordering process. For example, at this stage, the selected species 

can be adjusted. 

 

Scheduling Orders 

At this stage, the task is to add the order dates. The date added can be applied to the current record only, 

tagged records or all records. Bear in mind, filters are respected. The RSO status is changed to ‘Scheduled’.  
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Ordering and Receiving 

Ordering and receiving 

Order dates can be adjusted record by record, applied to tagged records or to all records. The RSO status 

changes to ‘Ordered’. 

 

When received, the records can be marked accordingly and the RSO status changes to received. 

Receiving Accessioned material 

The option here is used to auto-create new Accession records for material indicated as ‘Is Accession Material’. 

 

Re-ordering 

Material can be re-ordered using the options on the Reordering tab. 

 

Various options are provided to copy data when re-ordering. 
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RSO table field list 

Field Name Size Notes 

RsoNumber Char -25  

RSOStatus  RSO Status is a fixed list of options build into BRAHMS 

RequestedBy Char -128 Name of person requesting a plant 

RequestSpecies Char -255 Requested species (including infra names, cultivar, etc) 

RequestVendor Char -128 Preferred vendor 

RequestMaterial Char -50 Requested material e.g. seed, plants, cuttings 

RequestItemNumber Char -50 A catalogue number 

RequestUnit Char -50 Requested supplier product catalogue units, could be 'each', '2 
litre pot', etc. 

RequestUnitCost Dec 8,2 Cost per unit 

RequestUnitQuantity Int Number of units to order 

CalcRequestItemTotalCost Dec 8,2 Total cost of requested item  

RequestedForDate Date Date material required to be ready/delivered 

CalcRequestedForWeekNumber Int Week number of delivery 

RequestedForGardenArea Char -100 Material requested for where? 

RequestedForGardenLocality Char -100 Material requested for where? 

RequestDeliveryContainer Char -50 Requested delivery container 

RequestDeliveryPlantsPerContainer Int Requested number of plants per container, typically 1 

RequestDeliveryContainerQuantity Int Requested number of containers 

CalcRequestDeliveryPlantsQuantity Int Calculated total plants (containers x plants per container) 

RequestComments Char -255 General comments for this request 

IsAccessionMaterial Bool Is this material to be accessioned? 

IsWildCollected Bool Is this material wild collected? 

IsPropagationMaterial Bool Is the material to enter propagation? 

RequestApprovedBy Char -128 Request approved buy who 

RequestApprovedOn Date Date of request approval 

OrderItemNumber Char -50 Actual ordered item number (catalogue number) 

OrderUnit Char -50 Product catalogue unit ordered 

OrderUnitCost Char -50 Cost per unit 

OrderUnitQuantity Dec 8,2 Amount  ordered 

CalcOrderItemTotalCost Dec 8,2 Total cost 

ScheduledOrderGroup Int A numeric field that may be used to help group orders 

ScheduledOrderDate Date Scheduled date to order the item 

OrderedBy Char -128 Who ordered 

OrderedOn Date Date of order 

ReceivedBy Char -128 Who received 

ReceivedOn Date Date of Receipt 

Comments Char -max Further general comments 

IsArchived Bool Is the RSO record archived? 
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Production and Propagation 

Introduction 

 

Production and propagation data are stored in a single table which can be accessed and updated via the data 

grid or forms. As with all other tables, the fields displayed in the data grid are configurable. In this table, as 

there are many fields, using column selections may be especially important when working in the grids. 

The BRAHMS production propagation components deal with accessioned and non-accessioned (seasonal) 

material. Accessioned material is assigned an accession number and maintained in the system with garden 

plant records added as and when appropriate. Non-accessioned (display/seasonal) material is managed via the 

Request, Scheduling, Ordering (RSO), Production/Propagation (PP) and dispatch stages. While non-accessioned 

records are maintained in the system, beyond dispatch to display, no further records are kept. 

Prop-Prod records can have associated event records. These are similar to Plant event records. These events 

keep track of all actions for a given production or propagation line. Event lookups can be configured. 

Many fields have separate values for Propagation and Production, for example, PropLocation and 

ProdLocation. A full list of fields is provided in this guide. 

Propagation data primarily refer to the management of data for seed, cuttings and grafts. Each of these has a 

special set of fields and related form sections. 

Requests for new plants made by curators, including their Scheduling and Ordering is managed by the RSO 

module. Although this is separate to the Prop-Prod module, there are links between RSO and 

production/propagation. These links are explained in the separate RSO manual section. 

Trial numbers 

The prop-prod table has a field called Trial Number. This field is used to indicate a sequence of propagation 

entries for the same Accession. For example, if material is propagated from seed, there may be several 

approaches used to see which method is the most successful. The trial number is auto incremented when 

adding new records. This field can be ignored if not required. 

Plant Production 

Introduction 

Plant production deals with the growing on of plants from an initial stage until they are ready to be dispatched 

to the appropriate garden areas. For some species, the plant production period maybe relatively short. But for 

others, production may last for several years and involve several containers and/or location changes per plant. 

Plants in production are normally assessed and counted on a regular basis. 

The plant production table and the associated form are opened by select Collections > 

Production/Propagation. This assumes your collection data category is set to Living Collection. As this table 

includes many fields also covering propagation, when using the data grid, it’s important to set up and save one 

or more field views, using the standard tools to do so.   

Adding new production/propagation records 

For non-accessioned material, prop-prod records are added via the RSO module. For accessioned material, 

prop-prod records can be added via the RSO module or directly to the prop-prod table using the Add option. 

When adding a record directly, you must choose an Accession or Plant ID as prompted. 
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Adding a record directly to the prop-prod table for an existing Accession as type cuttings.  

 

Requested plant delivery 

A number of fields are associated with the plant production request. Aside from the actual species name itself, 

these include the requested delivery date/week number; delivery size/container size; the quantity of plants 

required; requested by and for who. These apply to both production and propagation. 

 

The Production Form  

The main form provides a summary of Accession data (for accessioned material) in top section. Below this, the 

initial Request details are provided in a collapsible section. Below this are the main tabs for Production, 

Propagation, Events, Accession and Search. 

Tab Function 
Production Add/edit Actual and Forecasted plant Production details. 

Propagation Add/edit Actual and Forecasted plant Propagation details. 

Events Changes made to PP values are added as events. 

Accession Options related to accessioned material including listing plants. 

Search Locate records in the PP table. 

 

 

Many of the fields on the production tab will have drop-down lookups. The location field headings are adjusted 

in your setup. Note that each project should populate their own lookup dictionaries. 
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The ‘Current Qty’ option opens a small form to update the plant quantity and auto-adds the Last Checked date. 

 

Actual vs Forecast fields 

The production-propagation table includes a number of fields called forecast fields. During the plant scheduling 

and ordering phases, these fields are optionally added as part of the process of predicting and recommending 

the resources and conditions that will be likely be required to produce the requested plants. For example, for 

planning purposes, it is useful to know how much and what type of growing space and containers will be 

needed in advance. The forecast field values may be adjusted for planning purposes and are then copied to the 

actual production fields when the material enters production/propagation. 

Production - Forecast tab 

 

The forecast field values can be transferred to Current using the option provided. 

Navigation and locating records 

By selecting the navigation tab, you can filter to and locate records using the Propagation or Accession number. 

The ‘trial number’ can also be used. 

 

The navigation tab allows you to locate PP records quickly. Filter selections on this tab are automatically 

reflected in the main data grid. 
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Events tab 

Each production record can have one to many events added over time. These can be added manually but also, 

events are auto-added when the production stock, location, container or temperature changes are edited. 

 

Plant production events are auto-added when form edits are made. They can also be manually added and 

edited. 

Accession tab 

Propagation records tab 

The Propagation records sub-tab lists all Prop-Prod records for the current accession 

 

 

Plant List tab 

The Accession > Plant List tab lists all plants for the current Accession – together with a selection of 

configurable fields.  
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Using the options on this tab, you can: 

• Edit the status of a selected plant record. This may include a plant assigned to a Propagation area. 

Note that a summary of plants and their status is also provided. 

• Create a new production or propagation entry for the current accession.  This will auto- link the new 

PP record to the accession. 

• Change the Status of the Accession record itself. For example, if all plants in production/propagation 

are dead – and there are no living plants for this accession elsewhere, the accession status can be set 

to dead/inactive (or as used in your setup). 

Accession tab 

This provides a summary of the current accession record with an option to go to the record in the Accession 

table. 

Plant Propagation  

Introduction 

New plant accessions (seed, bulbs, cuttings, living plants or another types of propagule) may be planted 

directly into a collection in the garden or kept in propagation to grow on before moving to a permanent garden 

site. Plant material, clonal or otherwise, may be collected from existing garden plants to further propagate.  

Seed propagation 

 

 

For seed propagation, the form provides a way to keep track of how seed is processed and the germination/emergence 
success rates. The number of days between stratification treatments and the % germination success are auto-calculated.  

The result % calculation is the % of the emergent seeds compared to the initial quantity (=seed sown). 

 

Cuttings propagation 

 

 



BRAHMS v8 introduction and guide  289 | P a g e  

Some of the fields provided for cuttings. 

 

Graft propagation 

 

 

Some of the fields provided for grafts. 

 

Extending the propagation table structure 

Using the Grid Tools > Manage Columns > Custom Columns option, you can extend the structure of the main 

propagation table, adding custom fields as needed. 

 

A text field ‘My Propagation Notes’ has been added and positioned below the field Propagation Number. 

 

Propagation to plants 

From the propagation table form, when in Edit mode, you can Add plants to the garden. This function uses the 

standard plant addition form which allows you to choose the number of plants, their location(s) and label 

requirements. When plant records are added, the Propagation Number is added to the plant record(s) – 

providing a link from the plant back to its propagation origin. 
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Generating new plant records directly from the propagation table. The Propagation Number is added to the main plants 
table, providing a link back to the origin propagation record. 

 

Adding propagation records from the plant table 

You can also add propagation records directly from the plant table. This would be used when gathering seed, 

cuttings or other material directly form plants in your garden. In Edit mode, select the Propagation tab on the 

plant form. 

This option allows you to select the propagation material e.g. cuttings and then opens the main propagation 

form. The parent plant is added to the propagation record.  Further propagation details can be added later by 

editing the propagation record in the prop table. 

 

Adding a propagation record directly from the plants table. 
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The parent plant ID is added to the propagation table. 

Events for Propagation and Production 

Introduction 

Propagation/Production (PP) records may also have events. These are similar to events for the main plant table 

in that each PP record may have 1 to many associated events. The events are organised in a 3 level hierarchy, 

as are plant events: Event Type, Event Group and Event. 

Adding PP events 

Certain PP events are auto-added when the PP records are edited. The auto-additions are for: 

• Location and sublocation changes 

• Container count change 

• Growth medium change 

• Day and Night temp change 

• Treatment change 

Events can also be added manually under any defined looks you may have. 

 

Defining lookups for PP events 

The lookups for PP events are defined in a simpler way than for plant events. NB. In future revisions, all event 

lookups will be defined using this new method. Please refer to the section below on Event setup. 

 

Setup options related to RSO and Production 

Production-Propagation Numbering 

Use System > Options > Living Collections > Production/Prop. to configure production/propagation numbering 

and sub-location headings. 
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 Note that the sublocation values themselves can be added as custom lookups. In the above example, Block and 

Row are selected as headings – but as with garden locations, they may have many values. 

 

Generating Lookup lists 

Many of the fields in the production/propagation table should be configured with lookup values. Lookup values 

standardise and greatly speed up data entry and editing and thus, it important these are added to your system.  

Lookup values can be added manually or imported from Excel, both procedures are explained in the manual 

section on lookups. Note that when importing lookups from Excel, the field names themselves must be the 

same as the physical table fields and these are often different to the ‘friendly’ names used in the data grids and 

field lists options. A good way to get the correct name is to manually add a lookup value and check the Field 

Name value added to the lookup grid. A list of the correct field names is provided in the field list section. 

Species defaults table 

This table is opened on the Taxa menu with one record per entry in the main species table. The values stored 

here are the typical values expected for a given species. These data help to speed up and standardise data 

entry for plant requests and in particular, the data for their PropProd entries.  

These data are pulled into the Prop-Prod table whenever an accepted RSO PP record is assigned a valid species. 

If data are edited in the species default table, the edited values would then be used when creating new RSO 

records but will not update values in existing RSO PP records. 
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The data in this example are entirely made up. 

 

Garden Projects table 

This table is opened from the main Collections menu when in living collections mode. It stores the names of 

garden projects. The function of this table is primarily for budgeting purposes so that when ordering new 

plants, they can be assigned to a ‘project’. Garden projects can optionally be grouped into categories, and they 

are usually associated with a curator. They may also be associated with a garden location. 

 

Example garden projects as provide by Chicago Botanic Garden. 

 

Production/Propagation Events 

When adding plant production/propagation events, you can set up the lookups from  Management > Grouped 

Values. These lookup values can be added in a 3 level hierarchy: Type, Group and Value. 
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Manually adding an event and selecting one of Event type/Event Group/Event the lookup values. 

 

Production/Propagation field list 

 

Field Name Size Notes 

PropNumber  Char -25  Numbering system can be configured under Options > Setup. 

PropMaterialType  Integer  None, Plant, Seed, Cuttings, Grafts, Culture, Division 

PropMaterialCondition  Char -255  Condition of material entering propagation 

         

RequestedDeliveryDate  Date  Material required for when – usually provided by curator 

CalcRequestedForWeekNumber  Integer  Calculated from requested delivery date (ISO format) 

RequestedDeliveryPlantHeight  Integer  Requested size of plant for delivery 

RequestedDeliveryContainer  Char -50  Requested size of plant delivery container 

RequestedDeliveryPlantsPerContainer  Integer  Number of plants per container when delivered 

RequestedDeliveryContainerQuantity  Integer  Number of containers to deliver 

CalcRequestedDeliveryPlantsQuantity  Integer  Calculated from above 

    

GrowOrganically  Logical  Simple logical field – yes/no 

PropagatedFor  Char -128  Name of curator the material is for 

PropagatedBy  Char -128  Name of propagator 

ScheduledStartDate  Char -20  A text field can be an actual date or e.g. ‘about mid-May’ 

    

Propagation trials ONLY     

PropTrialNumber  Integer  Used only for accessioned material, the value is auto-incremented 
for a given accession with multiple propagation records 

PropEndDate  date  Completion date, optionally added 

PropTotalDays  Integer  Calculated from the start and end dates 

PropResultPc  Integer  Calculated as per propagation category e.g. seed germination % 

PropResultQuality  Char -50  Text description of result quality 

    

Propagation forecast    Forecast fields are the best guess conditions when setting up e.g. 
to know how much space may be needed. These values can be 
maintained as entered but also transferred to Actual.  

PropForecastLocation  Char -50  Location where material is expected to be propagated 

PropForecastGrowthMedium  Char -50  Type of medium expected to be used 

1 PropForecastTray  Char -50  Type of tray/flat  

2 PropForecastContainer  Char -50  Type of container 
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3 PropForecastContainersPerTray  Integer Number of containers per tray 

4 PropForecastContainerQuantity  Integer  Number of containers 

5 CalcPropForecastTrayQuantity  Integer  Calculated from the above 2 values 

6 PropForecastQuantityPerContainer Integer Material quantity per container 

7 PropForecastQuantityInitial  Integer  Initially calculated from number of containers  x material quantity 
-  but can be edited. 

    

Propagation actual     

PropStatus  Char -10  User defined status codes - optional 

PropStartDate  date  Actual propagation start date 

PropBarcode  Char -20  Barcode for material 

PropLocation  Char -50  Where material will be propagated 

PropSublocation1  Char -30  Sublocation name headings can be configured 

PropSublocation2  Char -30  Sublocation name headings can be configured 

PropSublocation3  Char -30  Sublocation name headings can be configured 

PropGrowthMedium  Char -50  Medium used 

PropTray  Char -50  Type of tray (flat) 

PropContainer  Char -50  Type of container 

PropContainersPerTray  Integer  Number of containers per tray 

PropContainerQuantity  Integer  Number of containers 

CalcPropTrayQuantity  Integer  Calculated from the above 2 values 

PropQuantityPerContainer  Integer  Material quantity per container 

PropQuantityInitial  Integer  Initially calculated from number of containers  x material quantity 
-  but can be edited. 

PropQuantityCurrent  Integer  Current quantity on periodic checking 

PropDateLastChecked  date  Date of check 

PropFailureReason  Char -255  Text describing failure 

PropDayTemp  Integer   

PropNightTemp  Integer   

PropTreatment  Char -128  General text but can be more specific 

PropSeedsPerPlug  Integer   

SeedCover  Char -15   

RootingCompound  Char -50   

    

Propagation GRAFTS ONLY     

WarmCallusTemperature  Char -15   

WarmCallusLocation  Char -50   

EndWarmCallusDate  date   

WarmCallusDays  Integer   

ColdCallusLocation  Char -50   

ColdCallusTemperature  Char -15   

EndColdCallusDate  date   

ColdCallusDays  Integer   

Aftercare  Char -50   

GraftType  Char -50   

GraftWaxed  Char -50   

RootStockType  Char -50   

    

Propagation CUTTINGS ONLY     

CallusFinish  date   

CallusTemperature  Integer   

CallusDays  Integer   

CutType  Char -25   

StageOfGrowth  Char -25   

DaysToRoot  Integer   

HormoneCarrier  Char -50   

HormoneCarrierRatio  Char -50   

HormoneConcentration  Char -10   

HormoneFormulation  Char -20   

HormoneName  Char -50   

HormonePrepType  Char -50   

Wounding  Logical   

WoundingTreatment  Char -20   

WoundingType  Char -20   

Retaken  Logical   

    

Propagation SEED ONLY     

PreTreatmentType     

AcidType  Char -30   

AcidConcentration  Char -30   

PreTreatmentTemperature  Char -15   

PreTreatmentDuration  Char -20   

PreTreatmentOther  Char -255   
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PropQuantityInitialIsEstimated  Logical   

    

Production forecast     

ProdForecastLocation  Char -50   

ProdForecastTray  Char -50   

ProdForecastContainer  Char -50   

ProdForecastGrowthMedium  Char -50   

ProdForecastContainersPerTray  Integer   

ProdForecastPlantsPerContainer  Integer   

ProdForecastContainerQuantity  Integer   

CalcProdForecastTrayQuantity  Integer   

ProdForecastQuantityInitial  Integer   

    

Production actual     

ProdStatus  Char -10  User defined status codes - optional 

ProdStartDate  date  Production start date 

ProdBarcode  Char -20  Barcode for material 

ProdSublocation1  Char -30  Sublocation name headings can be configured 

ProdSublocation2  Char -30  Sublocation name headings can be configured 

ProdSublocation3  Char -30  Sublocation name headings can be configured 

ProdTray  Char -50  Type of tray (flat) 

ProdContainer  Char -50  Type of container 

ProdGrowthMedium  Char -50  Growth medium 

ProdContainersPerTray  Integer  Number of containers per tray 

ProdPlantsPerContainer  Integer  Plants per container 

ProdContainerQuantity  Integer  Number of containers 

CalcProdTrayQuantity  Integer  Calculated field 

ProdQuantityInitial  Integer  Initial production quantity  

ProdQuantityCurrent  Integer  Current quantity on check 

ProdDateLastChecked  date  Date of last check 

ProdFailureReason  Char -255  Text about failure 

ProdDayTemp  Integer   

ProdNightTemp  Integer   

ProdDayLength  Char -50   

ProdTreatment  Char -128  
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Mobile app for Botanic Gardens 

Garden app introduced 

The botanical gardens mobile app is used, in conjunction with BRAHMS desktop, to gather data and images for 

plants in botanic gardens or similar areas. The app, developed and licenced by Oxford University Innovation 

(OUI), runs on Android and iOS. 

Data for selected plant records are exported from BRAHMS to a special RDE file using the export tool provided. 

The RDE file is then transferred to the app and edited by adding plant events and requests, map positions, 

images and a few other key categories of data. Data are then returned to BRAHMS desktop where they can be 

reviewed and then submitted to BRAHMS, updating existing plant records, registering new plants and adding 

images. 

Functionality in the app includes data add/edit, query, field view selection, consult taxa online, geo-location 

and photography. Additionally, there are specific data options for stock level checks, requesting labels, plant 

moves, verifications, status checks and changes, adding notes and adding other general events and requests 

such as phenology events and propagation requests. 

The app has the capability to work both on and off line. Thus, you can gather data in garden areas that have no 

internet/phone signal. We recommend you use the app on 8 – 11” tablets but it can be used on smaller devices 

including phones of a sensible size. 

 

Installation of apk 

The brahms.apk file is ca. 25 MB.  Copy the brahms.apk to your device using Bluetooth, a cable connection or in 

any other way. Run the installation on your device. This will replace any existing software. For convenience, you 

can add the BRAHMS icon to the tablet home page. 

 

Transferring plant records data to app 

In BRAHMS, in the main plants table, tag the plant records you wish to send to the app. This can be any group 

of plants. You may want to create more than one RDE file, for example one file per garden location. You have 

the choice of exporting existing events/requests for the selected plants so that these can also be viewed in the 

app.  Existing images are not exported. You can restrict existing events/requests by date range. You can also 

restrict plants to those with a status representing ‘alive’.  If you have tagged one or more records in the garden 

localities table, you can also use the option to Export all plants of tagged locations.  Once created, the next task 

is to copy your RDE survey file(s) to your device. 
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The RDE file creation form. Once created, the RDE file can be copied to your device. 

 

RDE file database content 

When you create an RDE file for the app, the file includes: 

• Data from the selected plants records. 

• Optionally, all or selected events/requests already linked to these plants. 

• Lookup lists for all relevant fields, taken from your Lookup list table. 

• Label format names, taken from the main Labels table. 

• All garden locations. 

 

Copy RDE file to device 

After creation, the RDE file is auto-registered in your RDE manager. You can open and check the RDE file to 

check the data – although this is not necessary.  

Copy the RDE file(s) to your device using any method you like.  Bluetooth is convenient but you may also use a 

cable connection or email. When you copy the RDE file(s) to the device, they normally go to your device’s 

downloads folder. 

 

RDE File Manager for the app 

Existing Documents list 

When opened, the first screen you see is the RDE File Manager with a list of Existing documents. These 

documents refer to RDE files have already been registered or loaded into the app’s work space. 
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The app RDE File Manager. 

Load RDE from device to app 

Use LOAD AN RDE FILE to locate and register any RDE files that you have copied to the device but not yet 

registered within the app. Loaded RDE files will be added to your Existing Documents list.  When you load an 

RDE file you will be prompted as follows: 

 

This information is used to populate the various records where events and requests are recorded. 

 

 

Export 

Export is used when you have completed your editing tasks with an RDE file. Export creates a zip file that 

includes the selected RDE file and any images you have taken for the plants in that file. If there are a lot of 

images, the zip file will potentially be large. The zip file can then be cable-copied back to your desktop and 

subsequently processed. This is covered in a separate section in this guide. 

Delete 

Delete will remove the RDE file and any images associated with that file from the app work space. Do not 

delete the file until you have used the Export option. Otherwise you will lose the file and your images. 

 

A warning message is given when you use the Delete option. 

After exporting and copying the zip back to your desktop, it is your responsibility to delete any processed files 

in your device’s downloads folder. 
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Data that can be added/edited 

The following data can be added/edited. In some case this results in direct edits to the plant record, while in 

others, events and/or requests are added. 

Data Notes Updates Plant record Adds Event/Request 

Plant Status Confirm Confirm status of all selected 
records 

* * 

Plant Status Change Update status of all selected 
records 

* * 

Stock Levels Updating the remaining stock 
with notes. 

* * 

Plant Location Change to location including 
subareas. 

* * 

Name Verification  * * 

Label Requests Available label formats are as 
registered in your labels table. 

 * 

Comments/Curation 
notes 

 *  

Propagation Requests   * 

General Events Add events as registered in your  
BRAHMS lookup list. 

 * 

General Requests Add requests as registered in your 
BRAHMS lookup list. 

 * 

Map Data Lat/Long * * 

Images  Add image link  

New Plants  New Plant records  

    

 

Further details on data editing are provide below. 

 

Application main menu 

When you open an RDE file in the app, the menu appears in the top banner area with the RDE file name and 

some file stats. 

 

The main menu includes the options: 

• Grid View: open the RDE table in an Excel-like data grid with editing tools. 

• Map: display a map showing all plant records within the current filter group. 

• Images: display thumbs for all images linked to plants in the open RDE table. 

Data Grid View 

The Grid View is the main data viewing option, opened by default when a file is opened. The grid has the 

following key options: 

• Drag columns to change order. 

• COLUMNS: create and save a visible fields view.  
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• LOAD VIEW: select a saved field view. 

• To resize field width, drag header dividers. 

• Tap header once to sort AZ. Tap again to sort ZA. Tap a third time to remove sort.  

• Tap another column to sort on additional column. Sorts are additive. 

• Tap the Selected check box to select record(s).  This adds a red tick mark. 

• Use SELECT ALL/DESELECT ALL to tag/untag all records in file, within any filters you may have applied. 

• Use SHOW SELECTED/SHOW ALL to filter on/off on selected records. 

• Double tap any cell value to apply a filter on that cell value. Apply filters on multiple values.  

• Use ADD FILTER to manually add one or more filter settings.  

• Use REMOVE to remove filter(s). 

• A single tap on a record opens the detail of that plant. 

• The CLOSE RDE option closes the opened document. Data are auto-saved. 

In addition to these grid functions, when the grid is open, you have access to the ‘Act on selected’ functions. 

These are further discussed below. 

 

 

 

 

 

A grid view with some records selected and filters on the Living Status and Plant ID fields. 
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Selecting columns with options to Save the selection as new view. 

 

Plant Detail View 

To select and edit an individual plant record, use a single tap on the plant record in any field. This displays all 

non-null fields in the left hand panel. Across the top, there are menu options for Overview, Events, Requests 

and Images. Using the options on the right panel, you can add and edit the plant map location and add locality 

notes. 

 

In plant detail mode, after tapping on a record, you can edit and view events, requests, map data and images. 

Map data 

If the plant already has a map location, the map zooms to and displays that plant. In Edit Map Point mode, the 

map becomes full screen and a blue dot indicates your current location - this changes as you move about. A 

Zoom to current location option is also provided. Tapping on the map updates the plant position which you can 

then save. 

Also from the detail view, you can add Events and Requests. The lookup options for these will be as in your 

BRAHMS desktop. 

Images 

To take images, select Images > TAKE PHOTO. This uses the device camera as configured on the device and link 

image(s) to the current plant record. All images of the current plant are displayed as thumbs on the Images 

page. On most tablets, you have to select OK to confirm after taking each photo. 

To delete images, use the DELETE option. 
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Events and Requests 

In plant detail mode, you can create new records using the CREATE EVENT option. To edit an exiting event, tap 

on the event. To delete a record, swiping the record left exposes a DELETE option. The same applies to 

Requests. You can only delete events and request created on the app. 

 

 

Deleting records. 

 

Online checks for species 

Assuming you are online, you can check the current species online using the LOOK UP SPECIES option, currently 

provided with options for POWO, IPNI and Google Images. 

Functions for selected records 

Act on Selected 

Standard editing functions are available for selected records. These functions are listed in the below screen: 
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Change location 

You can edit the location details. The Subareas headings will be as defined in your BRAHMS location settings. 

Note that map references are adjusted separately. Lookups are available at all locality levels. 

 

 

Adjust Stock 

The remaining stock can be adjusted. If the remaining stock is higher than the initial stock, the initial quantity is 

adjusted up. Update plant record and adds a stock adjustment record to selected plant(s). 

 

 

 

 

Stock adjustments are added as events but also update the main plant record. 

 

Confirm Status 

Confirm status for selected plants. Adds a confirm event record to selected plant(s). 

Update Status 

Change the status of a plant. Status values are available as in your BRAHMS lookup list. Adds a status change 

event record to selected plant(s). 
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Request Labels 

Label formats are listed as in your Labels table in BRAHMS. 

 

 

Add Comments 

Add any curatorial notes. These data are stored directly to the plant comments field. 

Prop Request 

Add a propagation request event. 

Add Verification 

Add a plant name verification with verification type and notes. Updates plant record and adds a verification 

event record to selected plant(s). 

 

Create Event 

You can add events for any general events (Type, Group, Event) as stored in your BRAHMS lookup list. For 

example, Observation > Flowering > Full Flower. 

Create Request 

You can add requests for any general requests  (Type, Group, Request) as stored in your BRAHMS lookup list. 

For example, Maintenance > Tree removal. 

 

Mapping plants 

If you are working offline or in a area with a poor signal, you may want to fully zoom into the area you are 

visiting prior to going to the field. The map data are cached on the device. 

The Map option on the main menu will map all plants within the current filter group. Markers are colourer 

according to plant status with Alive plants coded bright green and all others orange/brown. 

Tapping on a marker displays details of that plant. Tapping on the details box opens the map editor. You can 

turn on all map labels using SHOW ALL LABELS but this only works if you have a smallish number of points 

and/or are well zoomed in. 
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Adding a New Plant 

When you add a new plant, the new plant Identifier default to PLANT01, PLANT02, etc. Plant IDs must be 

unique as any images linked to these plants will include the ID as part of the image name. You can add the basic 

details here. A locality name is required. Images may be linked and you can also add a map reference. 

Later on, when the RDE in being processed prior to transfer to BRAHMS, you can link the plant to an existing 

Accession - or add a new Accession. 
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The forms used for new plant records. 

 

 

Transfer RDE Data and Images to BRAHMS 
 

Copy and open RDE zip 

When you open an RDE zip returned from the app, this will add the RDE file and all associated images to your 

RDE registered folder. You can either overwrite the original RDE file or, if you wish, rename or move the 

original. In practice, there’s little point in keeping the original file. When you open the zip to your registered 

RDE folder, the RDE file will be listed in your RDE file list in BRAHMS.  

Images 

Before importing RDE files that have images back to BRAHMS, make sure that your shared image folder has 

been setup and is accessible. The shared images folder is edited using System > Options > Shared Folders. 

When the RDE file is imported, the images are physically moved from your default RDE folder to your shared 

images folder and registered in the BRAHMS images table in that location. This means that other users will be 

able to see these images from within BRAHMS. Later on, these images may be moved elsewhere.  

New plants and accessions 

If there are new plants, these will be at the bottom of your RDE file. As a first step, you need to ensure all new 

plants have an accession number. To add this, use the lookup function provided. New plants that have no 

Accession cannot be imported. 

 

The Accession Lookup is only enabled for new plants. Choose an existing accession or add a new one. 
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The transfer process  

Import reporting indicates the number of new events, requests and images for existing and new plants.  

 

Newly added plants must be assigned an Accession number. If you do add an accession, the plant will not be 

imported. 

 

 

 

 

 

The importer reports on the addition of events, requests, images transfers, image links and new plant additions. 
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BRAHMS for Seed Banks and Seed Conservation Projects 

Introduction 

The seed module, developed collaboratively with the Millennium Seed Bank at RBG Kew, has broad curation 

and research applications for projects that collect, store, test and distribute seed.  Seed accessions with 

passport and related source data, collection and/or seed accession permits, processing, weight/count 

calculations, viability/germination tests, storage and dispatch, related vouchers and images - are all fully 

integrated within BRAHMS.  Data can be quickly imported via Rapid Data Entry (RDE) files which in turn can be 

populated with data from Excel. All standard BRAHMS functions for queries, reporting, image/document 

management, calculations and data analysis can be used. 

The seed module aims to facilitate good seed management practice and to strengthen the ability of seed banks, 

small and large, to better coordinate their seed collection and distribution activities. 

 

Key features 

• Seed accession records including all passport and wild origin data can be managed with links to 

vouchers, project and legal agreement details, seed batch data, cleaning methodology and results, 

store bank location including duplication to other seed banks. 

• Seed counting processes including absolute and/or estimates via seed sample weights, incorporation 

of x-ray and/or cut-testing analysis to provide adjusted quantities per collection. 

• Germination test design including addition of multiple conditions and treatments. Germination test 

results are provided for both germination and viability percentages, including germination rate. 

• PDF files, Excel sheets and other documents can be linked to accession, individual plant, species and 

other records. Examples are material transfer documents and species level spreadsheets. 

• Images of seed or the plants in their original habitat can be added, together with voucher images as 

available. 

• Projects can extend the standard BRAHMS seed data file structures by adding custom fields - these 

then become a part of your database. 

• The Rapid Data Entry (RDE) module is used to capture new seed accessions and test data or to transfer 

data from other formats such as Excel worksheets. 

• Easy to export data to other formats such as Excel - for further processing. 

• You can design your own website and publish a virtual seedbank or online plant catalogue directly 

from BRAHMS sing BRAHMS WebConnect. For example see the RBG Kew MSBP Data Warehouse at 

http://brahmsonline.kew.org/msbp. 

 

 

Taxa 

An infrastructure of taxa from higher classification to infra-specific levels, cultivars and hybrids. 

Storing all specific epithets,  synonymy, common names, descriptions, native distribution, hardiness, 

shade tolerance, water requirements, conservation status and further details. 

Institutions 
Comprehensive lists of institutions and addresses of suppliers and donors or those receiving material 

through purchase or transaction exchanges. 

Seed 
Accessions 

Storage of seed accession records including details of the type and quantity of material received, 

who and where from, the original or derived source, and the initial identification.  

Agreements/ 
Permits 

The ability to link agreement documents and set restrictions with a legal framework as required for 

collection events, seed accession and any other relevant records. 

Seed cleaning Adding all cleaning steps with associated times and notes. 
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Seed tests Seed germination tests with their calculations and results. 

Seed 
Duplication 

A list of institutions where a seed accession is known to be duplicated. 

Processing Seed cleaning records together with their cleaning steps. 

Seed Storage Details on seed accession storage with quantities and locations/sublocations. 

Transactions The management of incoming seed batches and any outgoing transactions. 

Collection 
Events 

Details about what was collected when, where and by who. Collection events are used to record the 

seed collection site and its details.  

Vouchers 
Vouchers and related materials can be stored for seed accessions wild collections and/or established 

garden plants.  

Images and 
Documents 

Images and documents associated with Accessions, Plants, Vouchers, Transactions, etc. These can be 

physical files or media library URLs. 

Legal/Permits 
Details of all permits and related documentation for the accession, use and exchange of material, 

evidence of due diligence and restriction requirements. 

 

Summary of the key components used in the seed module. 

Setup options - lookups 

Before using the seed module, we recommend you check that you have the appropriate lookups as the seed 

module table have many fields that benefit from these. Examples are material collected, seed cleaning steps, 

tetrazolium staining results, seed test stages and treatments. You can enter lookups manually or import from 

Excel, Refer to the manual section on lookups. A sample lookup Excel table is provided on: 
https://herbaria.plants.ox.ac.uk/bol/content/Software/v8/seedmodulelookups.zip 

 

Seed accessions – overview 

Introduction 

 

The main seed accessions table is opened by selecting Seed Accessions on the main Collections menu when the  

Collection Category is set to Seed Accessions.  

Once opened, you can make use of all the standard toolbar options to select visible columns, sort, query and 

summarise your seed accession data. 

 

 

https://herbaria.plants.ox.ac.uk/bol/content/Software/v8/seedmodulelookups.zip
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The main Seed Accessions table opened with a selection of the available fields set to visible. 

 

Accession numbering and store bank 

Accession numbering is currently free text entry although automatic numbering options are likely to be added. 

Projects may only be storing seed for their own seed bank.  However it is also possible to collate data records 

from multiple banks. For this reason, the Store Bank is available as a field in seed accession records. 

 

Seed Bank and Seed Duplication 

It is possible to record the physical duplication of a seed collection to one or more seed banks using the 

Duplicates option. This option allows you  

 

 

Source/wild origin details 

These data describe the source of the seed collection including the location, date, collector(s), initial 

identification and other site details as required. The data are stored in a linked Collection Event record and can 

thus take advantage of all the possible collection storage fields – including any custom fields. 
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The Collection Event tab on the main seed form. 

Collection events may also have linked voucher material stored as specimens. You can add, edit and view linked 

Collection Events details from the seed accession form. Collection events details can also be added via RDE 

imports. 

 

A summary of the current event is provided on this tab. The -> Collection Event option opens the collection event 

table and locates the relevant record. To add a new event and/or to select an existing event, use Select Event. 

 

Batch numbers, supplier details and transactions 

Seed supplier details including supplier name and receipt date are now stored in a transaction record. Thus, if 

you have a batch of incoming seed accessions, these can all be linked to one transaction record.  This area of 

the guide to be expanded. 
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Seed identification and species data 

You can edit the identification of a seed accession from the data grid or the seed form. From the grid, use a 

standard lookup in any species related field. The Species tab on the seed form can also be used. The form has 

additional options to display a summary of the current species and an option to locate the current species in 

the main species table. 

 

 

Legal permits/agreements 

You can associate your seed accessions with permits or a selected category and assign a distribution restriction 

status, optionally with a legal framework.  

Your documented agreements/legal permits can be registered in the Legal Permits table which is opened on 

the main Management menu. Here you add titles, agreement start and end dates, restriction status, etc. 

 

Legal permit table example entries. 

 

You can link multiple agreements or the same or different categories to a single seed accession record. In the 

seed accession record itself, you can display the restriction status assigned both to the seed accession and its 

related collection event. 



BRAHMS v8 introduction and guide  314 | P a g e  

 

In the above example, the seed accession has Restricted status. The linked collection event has a ‘Restricted by 

agreement’ status. This status will apply to the original collection permit. 

For further details of permits, refer to the Legal permits and permissions section. 

 

Calculated fields 

As with other tables in BRAHMS, the seed accession table has a number of calculated fields. These can be 

periodically updated using the Recalculate toolbar option. Examples are #Dups Summary, #Test Total, # Last 

Test Date and #Best Ever Test %. 

 

Transfer to History (TTH) 

Use the TTH fields to effectively archive seed accessions. Reasons may be seed failed to pass a retest, seed 

disease, seed damaged, etc… 

 

 

 

Adding custom fields 

If BRAHMS does not include a data storage field that you need, you can add to your database, choosing the 

data type and field name. For example, you may want to add a new field to your Seed Accessions table called 

‘My Seed Notes’. The use of custom fields is discussed in the section Adding Custom Fields. 

 

Adding seed accessions 

You can add records one by one  using the standard Add option on the Data Tools toolbar. Alternatively, you 

can use Rapid Data Entry (RDE) to batch load records. When using the RDE approach, you can also import data 

from Excel spreadsheets. 

Manual entry 

To add an individual seed accession record, use Add to add records individually. You can in fact use the Add 

drop-down to add multiple blank records to the seed table. 
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The task then is to enter the details for the new record. In most cases, it will be easier to the seed form. When 

adding or editing data in Edit mode, you can use lookups for many fields including all those fields where you 

have registered lookups. 

 

Using Rapid Data Entry/Excel 

The use of RDE is discussed in the manual section on Rapid Data Entry.  

 

Processing and testing 

 

X-Ray data 

X-Ray details are added from the Seed Accession form Quantity Calculations tab. The count fields for Full, Part 

Full, Infested and Empty are enabled. The Total is a calculated value. These data are used to calculate the 

Adjusted Quantity as disucssed below.  If using a Cut Test, the X-Ray fields are disabled. 

 

 

Seed weights and counts 

Seed counts are calculated from the Seed Accession form Quantity Calculations tab. 

The seed accession table has 3 calculated seed count fields: initial Count, Current Count and Adjusted Account. 

These values are calculated by entering the appropriate data on the Quantity Calculations tab. 

The first step is to add the Sample Size and the Seed Weights. Weights will be added either as a single weight 

sample or as 5 replicate weight samples. In either case, the Remainder weight is added. 

Another consideration is whether these counts refer to seeds (the default) or to the Average number of seed 

per fruit. If using the fruits method (by adding a number to this field), the calculations are adjusted accordingly. 

When the weight values are added, the Quantity calculations are updated automatically – as are the Average 

weight, Standard Error, TPSW and Total weight. 
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In the above example, there are 5 weight samples of 10 seeds each, each weighing exactly 1 g amounting thus 

to 50 seeds and 5 g in total. There is a remaining weight of 20 g. 

 

 

In the above example, 

 

Moisture content 

Introduction 

Reliable monitoring of seed moisture status is important in the handling and processing of seed collections. To 

learn more about moisture content measurements, refer to the Kew MSB guide on Measuring seed moisture 

status using a hygrometer. 

 

Adding and editing moisture content records 

You can add moisture content test results using the Processing &Testing > Moisture Content tab on the main 

seed accession form.  

 

 

 

 

 

http://brahmsonline.kew.org/Content/Projects/msbp/resources/Training/05-eRH-moisture-measurement.pdf
http://brahmsonline.kew.org/Content/Projects/msbp/resources/Training/05-eRH-moisture-measurement.pdf
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Tetrazolium testing 

Introduction 

The Tetrazolium test measures potential germination – it provides a quick estimate of seed viability. With 

results within one to two days this test can be very helpful when time is a factor or for species which have very 

long germination requirements.  For further information on Tetrazolium Testing, refer to the Seed Check 

technologies fact sheet. 

 

Adding and editing Tetrazolium Test data 

You can add tz test results using the Processing &Testing > Tetrazolium tab on the main seed accession form. A 

list of staining areas would normally be added to your custom lookup list. 

 

Adding a Tetrazolium test staining result. 

Germination tests 

Introduction 

Different seed banks have their own procedures for monitoring seed viability. This section explains how 

germination test procedures are managed within BRAHMS. These procedures are those used by the Kew 

Millennium Seed Bank (MSB) and it is with their input that these procedures have been developed. 

Germination tests are normally carried out to monitor the viability of seed collections and to develop protocols 

for turning seeds into plants. Germination testing is often the most reliable way of assessing viability. For a 

detailed review of germination testing, refer to the Millennium Seed Bank document on Germination testing – 

procedures and evaluation. 

Test set-up – adding a new test 

New tests are added from the Seed Accession form tab Processing & Testing > Germination tests > test Setup. 

New seed tests are assigned a numeric ID by BRAHMS. At this stage, you are asked to enter the # replicates, the 

# seeds per replicate, the total number of predicted inspections and the inspection interval in days. When you 

add a test setup, the system prepares the test scoring table for you, as described in the next step. 

 

https://www.seedcheck.net/seed-check-tests/miscellaneous/tetrazolium-test/
https://www.seedcheck.net/seed-check-tests/miscellaneous/tetrazolium-test/
http://brahmsonline.kew.org/Content/Projects/msbp/resources/Training/13a-Germination-testing-procedures.pdf
http://brahmsonline.kew.org/Content/Projects/msbp/resources/Training/13a-Germination-testing-procedures.pdf
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Add a new seed test setup. 

 

 

 

Test set-up – conditions and dormancy-breaking treatments 

Each test can have 1:many condition/treatment records added. For an explanation of these, refer to the 

Millennium Seed Bank document on Germination testing: environmental factors and dormancy-breaking 

treatments. 

 

 

Adding conditions and treatments for a seed test. 

 

 

Scoring germination test results and calculations 

To enter or edit data for a test, switch to the Test Data tab. Here you can enter the test data from the 

designated number of reps and inspections. If you need to extend the inspection days, return to edit the test 

setup. 

http://brahmsonline.kew.org/Content/Projects/msbp/resources/Training/13b-Germination-testing-dormancy.pdf
http://brahmsonline.kew.org/Content/Projects/msbp/resources/Training/13b-Germination-testing-dormancy.pdf
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As test results are entered, a colour warnings are given where totals are erroneous.  

 

The above 20 seed replicate has in incorrect entry. 

The calculated results are displayed above the grid. The results include 

Sown, # Germ, Full, Empty, Infested, Mouldy, Abnormal, % Unused, % Germ, % Viable and MGT (Mean Time to 

Germination).  

The test can be Accepted and Passed.  

Seed Test data grid 

All seed tests stored in your database can be viewed from the main Collections > Germination Tests data grid. 

Here you can sort, filter and analysis all tests across accessions and taxa. 

  

Seed cleaning 

Introduction 

Seeds are cleaned to decrease bulk, reduce disease risk, and facilitate future use. Cleaning long-term 

conservation collections without causing physical damage and reducing seed viability requires care and 

expertise. To read more about seed cleaning refer to the Kew MSB guide on Cleaning seed collections for long-

term conservation. 

Adding and editing seed cleaning records 

Each seed accession may have one or more cleaning records added. Each cleaning entry records the initial and 

final state of the seed as well as the 1: many steps per cleaning record. The time of individual steps is recorded 

and totalled up in the cleaning record. 

 

http://brahmsonline.kew.org/Content/Projects/msbp/resources/Training/14-Seed-cleaning.pdf
http://brahmsonline.kew.org/Content/Projects/msbp/resources/Training/14-Seed-cleaning.pdf
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Lookup values for fields such as Initial State can be stored as custom lookups to standardise and speed up data 

capture. 

 

Seed storage and distribution 

Section to be added. 

 

Linking images and documents 

You can link any number of images and or documents directly to seed accession records, tests, collection 

events, species and any other record related to your seed accessions. For further details, refer to the relevant 

sections in this guide on image linking and document linking. 

 

Generating reports and exporting data 

You can design report templates for seed accessions and all related records including seed transactions. Full 

details of report design are covered in the reports section of this guide. 

All data export options including transfers to Excel, XML and Darwin Core are covered in the exporting data 

section of this guide. 
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Transactions – recording the movement of materials 
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#transactions 

Introduction 

Transactions monitor incoming and outgoing loans, gifts, exchanges, and other transaction categories as you 

define. They maintain a permanent record describing the movement of physical specimens, plants or other 

items. 

As well as providing longer term benefits that come from tracking the movement of collections, the transaction 

module has immediate practical uses: printing lists, pinpointing the whereabouts of particular collections; 

balancing specimen numbers in herbarium exchange schemes; listing loans overdue; and preparing transaction 

period activity reports. The module also provides a logical platform to record in-coming determinations. As 

specimens return from loans, revised determinations can be efficiently updated and fed into the main 

database.  

Frequently, the need to record which specimens are being dispatched on loan is an incentive to databasing 

collections, providing a realistic way to making a start with this often massive and daunting task and at the 

same time doing something of immediate practical benefit. To make full use of the transactions module you do 

not need to have a fully databased herbarium – you can start today. 

Herbaria using barcodes can make good use of these with the transaction module. Barcodes are used to select 

individual specimens. Barcodes: 

• Provide extra precision with the handling of collection materials. 

• Save time selecting collections for dispatch and recording returns. 

• Can be included on specimen lists providing an unambiguous specimen reference. 

Adding a sample transaction 

The demo database does not include transactions data but you can test by adding a dummy transaction record 

and linking some specimens to it. Normally, barcodes would be used for certain tasks here, for example 

selecting material to link to a transaction or marking material as returned. As you do not have the barcoded 

material, we can use alternative methods. 

• Select Collections > Transaction categories. This table includes the categories of transaction you wish to 

manage.  This example will choose ‘Loan requested from you - then returned’ therefore you don’t need to 

add a new category. 

• Select Collections > Transactions to open the main transactions table. Select Edit to switch to edit mode. 

You can enter some details into the grid using the F9 lookup key in fields such as Category and Institution 

Name.  You can also use the Form to edit the transaction details. 

 

• Select Collections and choose the Category Preserved Specimen from the dropdown. You can then select 

Specimens to open that table. 

• Now tag some specimens to link to the newly added transaction. You may want to use Tag > Untag first to 

ensure nothing else is tagged.  
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In this example, data grid filters have been added for Institute Code and # Full Name to select all specimens at FHO of 
Agathis ovata. These records have all been tagged using Tag > Tag all. 

• Finally, select the main Collections menu again and then use the option Tag -> Trans. This will link the 

tagged material to the selected transaction. You can see the result by returning to the transaction file and 

opening the form on the Data Tools menu. 

 

 

 

An example transaction with the form opened listed linked herbarium specimens. Data provided by Naturalis, 

Netherlands. Options are provided to return material manually or using barcode scanning. Determinations can 

also be edited here. 

 

  

Linked specimens listed on the main 
transaction form. Determinations can 
be edited here as material is returned. 

Barcode scanning is normally used to 
link/unlink material as well as mark 
material as Returned. 

Note also that images linked to 
specimens can be published to virtual 
loans via BRAHMS online. 
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Legal permits and permissions 

Introduction 

The legal permits and permissions facilities in BRAHMS, updated in BRAHMS 8.0.10, are used to help you 

adhere to and document current international regulations with respect to the collection, storage and 

distribution of your preserved and living materials. These may be international legal frameworks such as The 

Nagoya Protocol or individual agreements between institutions, for example a Material Transfer Agreement or 

Collection Permit. 

You can link multiple agreements to any record in BRAHMS together with accompanying documentation. 

Where relevant, the restriction status associated with an agreement is prominently displayed in your collection 

event, living accession, living plant and seed record data grids.  

Legal permits/agreements table 

This table is opened from Management > Legal Permits. The table has a comprehensive set of fields to add 

agreement details with the legal framework, agreement category and restriction status if applicable. 

 

You may define any category of agreement type – examples being  collection, import, export, phytosanitary, etc. 

Default values for permit types and restrictions 

 

Default Permit Categories Default Legal Frameworks Default Restriction Categories 

 

• n/a 

• Nagoya Protocol  

• Collection 

• Research 

• Import 

• Export 

• Phytosanitary 

 

• n/a 

• Nagoya (post 2014) 

• CBD (1991-2014) 

• Pre-CBD (before 1991) 

 

 

• Restricted 

• Not restricted 

• Restricted by agreement 

 

 

The default values provided from these lists can be edited under System > Options > Management > Legal 

Setup. As these are standard lookups, you can also edit the values in the normal way using Management > 

Lookup fields. The lookup field names are Permittype, RestrictionCategory and MaterialCategory. 
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The main system options form provides facilities to edit the default values for legal permits. 

 

Assigning legal and restriction status to records 

In the collection event, living accession and seed accession tables, the Legal toolbar option opens the Legal 

Permits/Agreement Links options. Using the top part of this form, you can select and add legal and restriction 

values to the current record. Use Update to update the record values. 

 

 

Adding agreements and related documents 

On the same legal form, use the Link option to link a specific agreement as stored in your agreements table. 

 

On the form, you can also add various notes fields for each linked permit. Due Diligence entries can be added for 

your permits and permissions entries. 
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In the lower part of the same form, you can link documents to the agreement records. Using the Linked Record 

tab, you can also link all record associated with the same agreement. 

 

Transactions and distribution status 

For each category of restriction status that you add, you can optionally assign a ‘No Distribution‘ status. Items 

with ‘No distribution’ status cannot be linked to transactions and/or warnings, when linking materials, are 

given. 

 

Assigning distribution status values. 

The Nagoya Protocol 

The Nagoya Protocol on Access to Genetic Resources and the Fair and Equitable Sharing of Benefits Arising 

from their Utilization (ABS) to the Convention on Biological Diversity is a supplementary agreement to the 

Convention on Biological Diversity. The Nagoya Protocol on ABS entered into force on 12 October 2014. It 

provides a transparent legal framework for the effective implementation of one of the three objectives of the 

CBD: the fair and equitable sharing of benefits arising out of the utilization of genetic resources thereby 

contributing to the conservation and sustainable use of biodiversity. See https://www.cbd.int/abs/about/ 

 

Species protection and legal status 

CITES, Red List and other notes about species are added to species records directly.  
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The main species table filtered on accepted names, sorted by family+ species. A column view named ‘red list’ has been saved 
and is here selected. 
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Publishing online with WebConnect 

Introduction 

Many projects are under increasing pressure to publish their data online or simply want to share their data 

with the wider community. This section explains how you can create and edit your own websites and upload 

your data and images directly to BRAHMS online. The module connecting BRAHMS to BRAHMS online is known 

as WebConnect. 

You do not have to a website techy to develop a basic website. However, the more knowledge you have, the 

more you can develop. WebConnect provides a blank blackboard upon which you can use any valid HTML, CSS 

and jQuery constructs. 

BRAHMS online  

BRAHMS online (BOL) is a unique website service created for the BRAHMS project.  It is used to publish 

BRAHMS databases online and/or to describe and promote your project.  BOL websites can be richly developed 

with text, images, hyperlinks, tables, file downloads and indeed any standard website feature. Websites can be 

linked to one or more BRAHMS databases and the online data query tools search these data and present the 

results in flexible text pages and data grids. You can see example screens and websites on: 

https://herbaria.plants.ox.ac.uk/bol/brahms/publishonline/bolfeatures and 
https://herbaria.plants.ox.ac.uk/bol/brahms/publishonline/websites 

 

An example of a content rich, BRAHMS online website: http://brahmsonline.kew.org/msbp - the website site design and 
data uploads were processed via WebConnect.  

BRAHMS online servers  

BRAHMS online websites can be can be developed and published on any computer where the BRAHMS online 

system is installed. You can create websites on the BRAHMS server located in Oxford (requires license) or on 

another server that has BOL installed. Many projects choose to install BOL on a server within their own 

institution.  

Server location influences the URL address of your website. You may want to install BOL on your own server 

and register a meaningful Domain Name System (DNS) for the server such as http://newworldfloras.org  and 

thus be able to have a URL such as http://newworldfloras.org/ericaceae. Read more on e.g. 

http://en.wikipedia.org/wiki/Domain_Name_System . 

https://herbaria.plants.ox.ac.uk/bol/brahms/publishonline/bolfeatures
https://herbaria.plants.ox.ac.uk/bol/brahms/publishonline/websites
http://brahmsonline.kew.org/msbp
http://newworldfloras.org/
http://newworldfloras.org/ericaceae
http://en.wikipedia.org/wiki/Domain_Name_System
http://brahmsonline.kew.org/msbp
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BRAHMS WebConnect  

WebConnect is the software that connects your BRAHMS system to BRAHMS online (BOL) allowing you to 

develop and edit websites and upload selected data and additional resource files. Using WebConnect, you can 

manage security settings, control access, logins and downloads. Web design uses bootstrap with each site 

having its own CSS file. WebConnect options are accessed in BRAHMS from the PublishOnline menu.  

Signing in 

To sign in to WebConnect from BRAHMS desktop, you need a username and password. The username and 

password are the same one you receive when you register on the BRAHMS website. Unless you have been 

assigned the role of Administrator within BRAHMS online, you will need to have been given manager access to 

one or more websites. 

 

 

If you have not done so, register on https://herbaria.plants.ox.ac.uk/bol/brahms/Account/Register 

 

Once you have registered on the BRAHMS website and have received your password, you can use these 

credentials to log in to WebConnect directly from BRAHMS desktop. To do this, select PublishOnline > Sign In. 

 

 

 

Your login screen will look similar to this one, assuming you are using BOL on the main BRAHMS server. If BOL is installed on 
another server, the BOL server address will be different. 

Once you have connected successfully, any projects you have access to will be listed in the Project dropdown.  

 

 

If you do not have access to any websites, it will not be possible to proceed. To gain access, the BOL 

administrator needs to link your login credentials to one or more website projects. 

https://herbaria.plants.ox.ac.uk/bol/brahms/Account/Register
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Managing website projects 

Create a new website project 

For users with administrative access, select New Project on the Publish Online toolbar. If you do not have 

admin access, ask the BOL administrator to create the website for you and give you permission to access and 

edit the website. 

 

The Project ID will be used to form the final part of the website URL on the BOL server. In this case, the website 

URL will be https://herbaria.plants.ox.ac.uk/bol/mymuseum. If BOL is installed on your own server, the URL will 

reflect that. You may also define domain addresses such as http://brahmsonline.kew.org/msbp 

 

Editing a project 

Description and access permissions 

The Edit Project options are the same as those found when using adding a new project. You can add a project 

description which may be useful for web browsers picking up your website details; the contact name and 

email; and a default image copyright message which is displayed under each data linked image. There are also 

options to: 

• Restrict downloads to users who are registered and logged in. 

• Restrict searching to users who are registered and logged in. 

If both these checkboxes are ticked access is restricted to signed-in project members only. With only one box 

ticked, access will not require project membership but will require the user to be signed in. 

You can also disable a project. If disabled, the project is taken offline but it remains editable through web 

connect.  

 

Project members 

The options on the Project Members tab allow you to control who has access to your database. Any user 

registered on the BRAHMS website can be added as a member or a manger. 

https://herbaria.plants.ox.ac.uk/bol/mymuseum
http://brahmsonline.kew.org/msbp
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A user added as a Manager will have access to edit the website details. You only need to add users as Members 

if you are controlling access to search your data online. When the two 'Restrict' checkboxes on the Project tab 

marked with ** are both ticked, members added here will have access to search and/or download data. 

 

Delete a project 

If you delete a project, this will delete the website together with all of its associated website design images and 

any related documents. This will NOT delete any databases or data images associated with the website. 

 

Website design 

Introduction 

Website design is based on a bootstrap/CSS framework directed at responsive, mobile-first front-end 

web development. You can also use jQuery. You can add multiple webpages and organise these in a 

hierarchical menu structure. 

Web pages are added to a data grid with one record per page. Each page will be displayed on your website 

menu – either as a main menu item or as a child record of a main menu item.  

 

Creating and editing web pages 

Opening the website editor 

To create and edit web pages, select Edit Web Pages on the Publish Online toolbar. This opens a data grid with 

one record per website page. 



BRAHMS v8 introduction and guide  331 | P a g e  

 

The above screen shows a newly created website project. By default, a page is added with menu text ‘Home’. The Page URL 
is set to ‘Index’ and the default language is ‘En’. On the right panel, the Live Site View displays the page online. 

Editing the HTML 

To edit the page, select View/Edit Page HTML mark-up at the bottom of the screen. This action opens up the 

text editing area into which you can add any html mark-up you wish, optionally basing this on a bootstrap 

framework. 

 

 

 

When text is edited the Save options are enabled. Once saved, the live website is updated. 
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An example page being edited for the BRAHMS home page. 

 

Adding new pages 

To add a website page, select New at the bottom of the data grid. Edit the Menu text and the page URL in the 

data grid fields. Do not use spaces in the URL. Pages can also have a page order which will control their position 

in the menu. They may also have a Parent Menu value. If the Parent Menu is left blank, the page will appear as 

a top menu item. If you add a parent menu value using the dropdown provided, the page will appear as a sub-

menu item of the parent page. Example uses of the Parent Menu option can be seen in the BRAHMS website 

example below. The Auth. Only and Members Only options are discussed below. 

 

 

Web Pages added to the main BRAHMS website showing the use of the Parent Menu field. Clicking on any record in the grid 
(=web page) will update the Live Site View on the right. 

 

Using CSS 

Please note that this guide is not intended to provide instructions on editing HTML or CSS. 
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Website layout and formatting can be controlled using the CSS (Cascading Style Sheets) file. CSS describes how 

HTML elements are to be displayed on screen, paper, or in other media and the correct use of CSS saves a lot of 

work.  The CSS effectively provides a Stylesheet for your website. It helps to separate document content from 

document formatting and styling, reducing website complexity and making it far easier to edit and change all 

your website pages at once.  

 

To open and edit the CSS file for your website, select the Project CSS tab next to the Live Site View tab. 

 

Website page images 

Introduction 

Some general points:  

• Image file names uploaded to websites should not include spaces or other strange characters. Underscores 

are OK. Thus not Clusia alba.jpg. Clusia_alba.jpg is OK.  

• Large sized image files (file size in bytes) take longer to load when someone views your webpage. Keep 

homepage images as small as possible without loss of clarity. Ideally less than 50K. High resolution images 

may be larger. HiRes images are discussed later in this document.  

• Uploading a large sized image and then forcing a smaller dimensions using HTML image tags to reduce 

image height/width is bad practice – better to resize the images before uploading.  

• Make sure the dimensions of your images are suitable – not just for your monitor.  

 

Banner image 

The banner (upper rectangular image area) is an important part of your website. This is composed of a single 

image with dimensions approx. 800 x 100 pixels. The final dimensions may vary but if it is too deep, you will 

waste valuable screen space and if too wide, it may not fit on some screens. Example banner images follow 

images 

Each of the above banner images is a single image named banner.jpg. The banners were designed using 

PowerPoint (or similar) with text, images and then the final image cropped out. You could easily design a 

banner using your word processor and cropping an image from the screen with the Windows snipping tool. Or 

equally, PhotoShop, PaintShop Pro, Thumbs+, etc. The banner image must be named banner.jpg. When saving 

your banner jpg, also save the original copy (e.g. ppt or word file.) you used to make this image to the same 

folder – in case you need to modify it. Store these files in your website development folder. 
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Other website images and documents 

 

 

Virtual search themes 

Virtual Search Themes are an optional property of your website are set by selecting Edit Project > Virtual 

Theme. Search themes allow you to link a database to a website but restrict the data that are 

visible/searchable. Thus, you may upload one large institutional database and then develop several specialized 

websites against that one database. For example, a museum database may include data for many plant and/or 

animal groups. You may have one website that  provides access to all the data. However, you may also design 

one or more separate specialized websites. 

You can add search themes for one or more families, genera, countries, major administrative areas or 

collectors in any required combination. An example would be  a website focused on the plant family 

‘Anacardiaceae’ with a virtual theme restricting searches to that family. Other examples: a single family/genus 

in a single country or multiple families/genera in a single country or a single family/genus in multiple countries 

or multiple families/genera in multiple countries. 

 

An example virtual theme applied to a website project. 

 

 

Uploading data from BRAHMS to BRAHMS online 

Introduction 

The following assumes you already have access to the BRAHMS online (BOL) system, either on your own server 

or on the BRAHMS project server. 

You can selectively upload data from your BRAHMS desktop database to BOL. Before doing this, you need to 

register a named ‘online database’. The database is separate to the actual website. For example, you may have 

created a website project with various web pages. This website may not necessarily be linked to a database and 

thus have an ‘Explore’ menu. After creating a database, before or after uploading data from BRAHMS desktop 

to it, you also need to link this database to your website project. Note that you can link more that one database 

to a single website project. 

Creating an online database 

After signing in to Publish Online as described above, Choose Manage Data. Note that these options are 

entirely independent to operations linked to website design. 
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Linking your database to your website project 

After creating a database, even before you upload any data, you can associate this database with a website 

project. To do this, select Edit Project and ensure that the correct Website project is selected. Most users will 

only have access to one project in any case – and this will be selected by default when you sign on to Publish 

Online. One the Edit Project form, select the Linked Databases tab. 

 

The list of databases shown on the left will be restricted to those you have permission to edit. Most users will 

only see their own database. Use the Link button to link the database to the select website project. The 

database name will be moved to the right panel. Select Save Changes as prompted. 

Once you do this, any data uploaded to this database will be available and searchable on your website from an 

Explore menu option. The Explore menu option is auto-added whenever there is a linked database. 

  

If a website project has at least one linked database, the website menu option ‘Explore’ is auto-added to the 

menu. The text ‘Explore’ can be edited as discussed in the section on the Explore menu. 

 

Explore menu 

When you have a database linked to your website project, this will add an ‘Explore’ menu option. You can edit 

the menu text by editing the Menu Text entry assigned to the Explore Page URL. 
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You can edit the default ‘Explore database’ to ‘Search’ or any other text you wish. 

 

Uploading data 

Introduction 

Data can be uploaded to your online database using the options on Publish Online > Manage Data. When you 

choose this option, the online database associated with your desktop BRAHMS database will be selected 

(assuming you have created a database as described above). 

 

 

The categories of data that may be uploaded are listed on the left of the form. The upload restriction options are 

on the right side. The settings in the above example will only upload tagged records from the species table. 

Description of any images directly linked to these species will also be uploaded. Image uploading is discussed in a 

separate section below. 

 

BOL upload fields in BRAHMS desktop 

The fields ‘Uploaded to BOL By’ and ‘Uploaded to BOL On’ are available in all relevant tables in BRAHMS 

desktop. Thus, you can easily see which data records have been uploaded – and by who. 

Upload restrictions 

Section to be completed 

 

 

Data Import History 

You can review all previous data uploads using the Manage Data > Data Import History. 
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The Data Import History lists all the xml files that have been uploaded together with their import status. 

 

Upload hierarchy 

When you upload data that has ‘parent dependencies’ that also must be uploaded, these data will be 

automatically uploaded. For example, if you are uploading specimen data, the species and collection event 

records that these specimens have as parent records will be auto-uploaded if they are not already online. 

 

 

Images 

 

Uploading images  

Details about your images (as linked to the data) are uploaded using the Images upload option. This option 

transfers details about the image file names, the links between images and data in your database, image key 

word if linked, image copyright and some other image details. If uploading data for large numbers of images, 

use the batch upload option provided.  

The image files themselves must be copied to the server and stored in the correct folder. The default folder on 

the server is brahmsonline\images\databaseID where databaseID is the ID of the database the images are 

linked to. Server image locations are discussed further below.  

BRAHMS online images can be viewed as a single image file or using the Zoomify image view. Zoomify must be 

licensed on the server. 

Server image folders 

By default, images linked to data on BRAHMS online, are stored in a special images folder as described in the 

BOL installation guide. However, you can choose to store images in different folders which is clearly convenient 

as:  

• it reduces the total number of images in any given folder  

• if you have images already on your server that are linked to your BRAHMS database, you do not need 

to duplicate these to any special BOL server folder  

BOL needs to know where to look for your images. This is done using a text (XML) file named LOCATIONS.XML 

that lists all of your image folders. This file is created in BRAHMS by:  

• Selecting Images > BRAHMS online Image Folders and adding all the folder names.  

• When in this file, selecting Tools > Generate XML file 

 

Section to be completed 
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The XML file must then be copied to the default images folder on your server. If using the BRAHMS server, the 

file should be emailed to the BRAHMS project.  

The only requirement for the paths listed in locations.xml is that they must be accessible to the web process 

(usually the Network Service identity), write/modify access is not required to the locations listed (write/modify 

access is required for the default database images folder only).  

Thus, the locations.xml file contains the paths to search for the online image files. A separate locations.xml can 

be created to indicates where BOL should look for any HiRes versions of the file (the only requirement is that a 

high resolution image has the same filename as its standard resolution counterpart).  

When a database image is searched for by BOL, the following sequence of events occurs:  

1. BOL looks in the default database images folder and reads a file called files.xml, this file is automatically 

created.  

2. The files.xml file is searched to see if it contains a path for the image file being sought, if a path is found the 

path is checked to see that the file still physically exists, if it doesn't still exist then that path is removed from 

files.xml and the search continues.  

3. Assuming the file is not yet found then the default database image file location is checked. If the file is found 

in the default location then that path is added to files.xml to speed up future access to the image.  

4. If the file was not found at step 3 then BOL looks for a file called locations.xml (see above) in the default 

database images folder. If this file is found then every listed location is checked until either the file is found or 

there are no more locations to check. If the file is found then the file path is added to files.xml for speedier 

access in future. If the image is not found after checking all locations listed then all checked locations for that 

file are logged to a file called missing.xml which may help track down missing images or image locations. Using 

Zoomify Zoomify ((http://www.zoomify.com/)) makes high-quality images zoom-and-pan for fas 

 

 

Using Zoomify 

 Zoomify ((http://www.zoomify.com/)) makes high-quality images zoom-and-pan for fast, interactive viewing 

on the web. BRAHMS online uses Zoomify to present images. When Zoomified, your images (e.g. .jpg files) are 

converted to .pff files. You can batch process images on the server using the Zoomify convert tool. The 

BRAHMS online server in Oxford has a licence to run Zoomify. A new licence is required for each server 

installation. Thus, if you have BRAHMS online installed on your server and you want to use Zoomify to display 

images, you will need to purchase a licence. The Enterprise license is recommended so that .pff files can be 

used rather than tiled files in a folder hierarchy which would be harder to manage (the .pff files keep the entire 

equivalent generated image tiles within a single file) - see http://www.zoomify.com/enterprise.htm for more 

details - the cost of an educational enterprise license is currently (2012) approx. US$195 (~$295 for 

noneducational). See also http://www.zoomify.com/support.htm#q_ZEv3 A folder showing some jpg images 

converted to pff files. 

 

Section to be completed 
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Database maintenance 

Re-indexing databases 

Re-indexing can increase the efficiency of a database, especially after heavy editing. 

SQLite databases 

Select System > Manage Data connections …, highlight a local file system (database (Personal, Conifers or any 

SQLite database you may have created) and then select Edit > Re-index. 

 

Re-index option for SQLite databases. 

 

MSSQL Server  

Select System > Manage Data connections …, highlight a local file system (database (Personal, Conifers or any 

SQLite database you may have created) and then select Edit > Re-index. 

Note however that for large databases with > a million records, we do not recommend running the re-index 

option from BRAHMS. Rather, you should set up a re-index task directly on the server. You may choose to run 

this task nightly. The query to run is: 

EXEC sp_MSforeachtable @command1="SET ANSI_NULLS ON;  
SET QUOTED_IDENTIFIER ON;  
alter index all on ? REBUILD WITH (FILLFACTOR=80, STATISTICS_NORECOMPUTE=ON);"; 
GO 

 

 

Execute the above query against the database to optimise. This could be set to run as an automated (overnight) query on 
servers. 
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Backing up your data 

Introduction 

Please note that OUI, the BRAHMS project and the BRAHMS software itself is not responsible for backing up your data. Data 

backup strategy entirely depends on the individual or institution using BRAHMS. If you sub-contract data storage to a third 

party (e.g. cloud storage), you may engage in an agreement with that third party that includes backup. For larger 

organisations with an IT department, usually, the IT staff will set up scheduled, automated backups. Individual users should 

make sure their back up procedures are robust. 

Backing up is the process of copying valuable files to a safe place in a systematic way.  There is only one way to 

absolutely ensure the safety of your data – rigorous adherence to a regular program of backing up of your data. 

It is a nuisance to backup but this is a much better alternative than the loss of your data.  

Whether you are storing your data in SQLite, MSSQL Server or PostgreSQL, you need to  ensure you have 

adequate back up procedures in place. This applies to individual researchers and large institutions alike. 

Be warned that some projects get their fingers burned badly before they take backing up seriously. Years of 

hard work can be lost in different ways - here are some possibilities: 

• A computer may be stolen.  

• A computer / server disk may malfunction or crash with loss of all data on that disk. 

• Files on a computer may be deleted by mistake. 

• Files may be corrupted by a hardware fault or a power failure. 

• Data files may be progressively damaged by an undetected software fault. 

• You may make one or a series of complex editing errors. 

Copy your files to a different disk/storage media. If you backup to the same storage media (e.g. your hard disk), 
all your eggs are in one basket.  Do not continually backup to the same backup file, thus overwriting the last 
backup. If you do this, you may end up overwriting a good backup with bad data. 
 

Creating backups - which files? 

SQLite files 

SQLite files can be used for BRAHMS databases and are used for all RDE files. BRAHMS SQLite files have a .db or 

.RDE extension. They can simply be copied to another media, optionally compressed. Your RDE files may be 

distributed across man different folders – and thus you need to make sure that active files are backed up. 

MSSQL Server – Express or Full version 

If you are running the free express version, it’s likely you will be responsible for your own backups. Express 

does not allow for automated backups in the same way that the full version does. With the full version, there 

are many options to create e.g. daily, overnight scheduled  backups or 2-hourly backups.   

Assuming you have not set up an automatic back up process, you need to use the Management Studio to 

create a backup. The backup is created using a right-click on your database name and choose Tasks > Back up… 

and this process will create a .bak file is the specified folder. The default settings will normally be adequate – 

thus you just need to select OK to create the bak file. There is a lot of help provided online. 
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The bak file you created can be compressed and then copied to your back up media. 

Bear in mind the advice provided in backup rotation and frequency. 

 

PostgreSQL 

The process for PostgreSQL is similar to that used for MS SQL Server. Please refer to PostgreSQL documentation 

such as https://www.postgresql.org/docs/9.1/backup.html  and https://www.geeksforgeeks.org/postgresql-

backup-database/  

 

Reporting templates and other files 

When developing your back up strategy, do not forget that you have other files to cover. These may include 
your report templates and saved column views 
 
 

Backup rotation and frequency 

Do not overwrite all your backups. Rather, keep a continuous record of your data as it changes right from the 
start in a growing series of archived backups. A continuous series of backups is your strongest defence against 
data loss. Should an unexplained, perhaps systematic error creep into your database, you may need to step back 
in time, backup by backup until you find the beginning of the problem. Rotate storage media in a sensible way. 
Always keep at least some regular backups that are not overwritten.  The frequency of backing up depends on 
the rate of data entry. If you are editing your main database every day, you may want to back up every day. RDE 
files should always be backed up after a data entry session.  
 
For larger institutions, back up frequency and rotation is normally automated using automated database 

backup procedures. For example, there may be a requirement to set up automated backup procedures that 

would minimise any potential data loss to a 2 hour period. 

https://www.postgresql.org/docs/9.1/backup.html
https://www.geeksforgeeks.org/postgresql-backup-database/
https://www.geeksforgeeks.org/postgresql-backup-database/
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Annex 1. Upgrading BRAHMS v7 to v8 

Checking your v7 database  

Please follow each of these steps carefully. Errors in v7 will cause the transfer to fail. 

• Your BRAHMS 7 version should be 7.9.14 (August 2019) or later. The version is displayed on your log in 

screen. Earlier versions must be upgraded. 

▪ Log into a copy of your v7 database. While not essential, it will be better to use a database copy as 

some minor changes are made to the database structure. 

▪ Select Admin > Project configuration > Indexing and make sure the setting is Machine rather than 

General. If it was General, switch to Machine and re-index your database. 

▪ Re-index your database. If any data errors are reported (e.g. month value 13), you should fix these 

now.  For example, you may get a message box indicating errors in some fields as follows: 

 

If you see such warnings (indicting incorrect numeric values), follow the screen message to locate the data and 

remove these errors. Such errors may cause the transfer to v8 to fail.  

The re-index in v7.9.14 or later checks for further errors and irregularities. For example, it may be that older v7 

databases have rogue link file records; rogue entries in the ‘people link’ file; or incorrect synonym links in your 

species file. Follow the screen instructions to correct reported errors. 

▪ Select Admin > BRAHMS tables, record totals and database integrity.  

If your database has any errors, these must be resolved before you transfer. If you do not remove these errors, 

the transfer will fail. If you need help with this stage, contact the BRAHMS project. 

Adding a database description 

Select File > Database manager and ensure you have added entries to the fields:  

DESCRIP (short description of your v7 database)   
COPYRIGHT (if applicable) 
TERMSOFUSE (e.g. “Data not for commercial use”) 
CREATEDBY (e.g. your institute or personal name) 
CREATEDON (this can be approximate) 

 

This information will be transferred to v8 and can be edited there later on. If these data are missing, the 

transfer will request that you return to v7 to edit one or more of these fields. 

Checking your v7 link files  

Link file fields (custom fields) are transferred to v8. This is a good time to look over your various link files to 

check if you have unwanted or redundant fields. You may want to remove any redundant link fields prior to the 

transfer although this can also be done in version 8. 

Checking text descriptions 

Taxa text descriptions from your v7 family, genus and species files are stored in a different way. Certain v7 

memo fields in these files have been moved to a new table in v8, the taxa text descriptions file.  

▪ The following fields are no longer stored in the v8 family and genus files themselves: DESCRIP, 

DISTRIB, DIAGNOSTIC, WEBLINKS, WEBNOTES, NOTES01-NOTES05.  

▪ The following fields are no longer stored in the v8 species file itself: DESCRIP, DISTRIB, WEBLINKS, 

WEBNOTES, USES.   
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These various memo fields are transferred to the new table in v8. However, before exporting your data, you 

must run the option Admin > BRAHMS v8 data transfer > Prepare taxa text for transfer to v8. Otherwise, data 

in the above fields will not be transferred. This option does not remove data from the v7 fields – rather it 

copies the relevant table in v7.  

Folder preparation 

Create a folder on your workstation to gather the v7 XML transfer files. Any folder name/location can be used. 

An example is c:\myv8xmlfiles. 

Creating the v7 xml transfer files 

Log into v7 in single user mode and select Admin > BRAHMS v8 data transfer >  Transfer data to v8…  

 

The v7 transfer form.  

This phase is where your data are transferred to XML 

files. Primary and foreign keys are created as new 

GUID fields. The file creation will take some time 

with large databases but you can watch the progress 

in your XML folder as the files build up. Large tables 

are split into multiple XML files numbered 000, 001, 

002, etc.   

The recommended settings are the defaults. 

However, if exporting a very large database for 

testing only, you can de-select the options Transfer 

track changes and Transfer record create details as 

these may significantly increase the export time. 

 

 

Select Process data to generate the XML files. Progress is reported as it goes through the various v7 tables. 

 

A sample of the types of file you can expect to see in your XML folder 

Choice of data store for your v8 database project 

With no further installation, you can transfer your v7 data into an SQLite data store. SQLite is more suited for 

smaller databases.  

If you are transferring a large database, it will be better to import your data to MSSQL or PostgreSQL. 

Instructions on setting up an MSSQL Server or PostgreSQL databases are provided separately.  

Although an SQLite data store can store more than one database project, we recommend that you create a 

new instance of the data store for substantial projects. Thus, while you could import your v7 database into the 
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default brahms.db SQLite data store or to the store holding the conifer database, it makes more sense to 

create a separate instance of the SQLite data store. 

Importing v7 xml transfer files to v8 

▪ Log into v8 using the settings as below – unless you have a BRAHMS username and password assigned. 

 

 

• Select System > Manage Database Projects … Then Select Import and navigate as prompted to locate 

the DatabaseProject.xml file in the XML folder created above.  

• If you want to speed up the initial import, you can opt to exclude Edit History data – bearing in mind 

that these data can be imported later on. Otherwise, select the default option Import Everything. NB: 

Edit History includes record addition date, added by and track changes details as recorded/available in 

v7. 

• Select Save to initiate the import. 

 

Importing progress is displayed.  

If the import process fails, you will have to delete the XML folder and start again. this implies that there was an 

unresolved error in your v7 database. The import process is all or nothing…. If you are unable to resolve the 

issue, contact the BRAHMS project. 

Once the import has completed, you can Load the project. The XML transfer files can be deleted. 
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Annex 2. Key differences between BRAHMS v7 and v8 
While derived from earlier versions of BRAHMS with respect to much of its functionality, v8 is an entirely new 

system with updated technologies and data store. BRAHMS v7 users will recognise many of the tools and 

functions in v8 as well as the broad layout of the menus. However, as listed here, there are fundamental 

differences between these systems. 

 

Topic Comments 
 

Project management 
 

The BRAHMS project now has additional management support from Oxford University 
Innovation (OUI) who provide licences for BRAHMS, ensuring users get the correct package 
and support. https://innovation.ox.ac.uk/licence-details/brahms/  
 

Museum management V8 is no longer restricted to botanical data. The concept of herbarium specimen is replaced 
by preserved specimen (i.e. museum specimen).  
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#nathistory  
 

Data storage Data are no longer stored in DBF and FPT files but rather in a choice of stores that are fully 
up to date with respect to technology and have no meaningful limit to table size. Current 
options are SQLite, MSSQL Server and PostgreSQL. V8 databases can store and cross 
reference millions of records. 
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#performancevideo  
 

International  
 

BRAHMS v8 is international with respect to the interface and the data. Data are stored in 
Unicode with no restriction on the character data stored across languages. 
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#language  
 

Temp files folders There are no longer any temp file work folders. Instead, personal files such as RDE files, 
saved files, column views and exported data are saved in your BRAHMS folder in 
Documents. 
 

Primary and foreign keys All table key fields use 32 hexadecimal digit GUIDs. They cannot be duplicated and thus 
remove the danger of duplicating primary keys. Database integrity is assured both by the 
BRAHMS software and by the DBMS. 
 

File and field names 
 

Table and fields names have been updated to be more meaningful. V8 is no longer 
restricted to 10-character field names. 
 

Modular system BRAHMS v8 has a flexible, 3-tiered and modular architecture opening up options 
for shared development. The user interface (UI) is independent of the services and 
data store access and therefore could relatively easily be substituted by other 
technologies such as a web-browser UI. 
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#modular  
 

Interface The new system uses ribbon toolbar technology (context sensitive menus and toolbars) 
similar to that used in MS Office applications – making it highly intuitive.  
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#v8menus  
 

Help Improved help is built into v8, backed up by online support and training video clips e.g.  
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#mappingvideo  
 

NULL values It is possible to store NULL values in all tables. 
 

Species table and field names The fields SP1, RANK1, SP2, RANK2 and SP3 have been dropped. V8 has separate fields for 
species, subspecies, variety, forma and cultivar. Formatted taxa names include the 
appropriate ranks. The size limit on these fields has been increased. 
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#taxonnames  
 

Higher level classification table  A new table is added for taxon ranks above family.  
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#taxonnames  
 

Extract files V8 does not have the equivalent of extract files. Instead, your selections are seen in the 
main tables after applying a query. 

https://innovation.ox.ac.uk/licence-details/brahms/
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#nathistory
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#performancevideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#language
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#modular
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#v8menus
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#mappingvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#taxonnames
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#taxonnames
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Queries and filters Query and filter functions are one and the same thing. Both now use standard SQL 
commands and have exactly the same result. There is no longer a fixed menu of query 
commands. You can design and save your own commands. 
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#explore  
 

Tree Views Tree Views are now available in all tables. You can also design and save your own multi-
level Tree Views. https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#treeviews  
 

Link file fields 
 
 

Link fields in v7 are now referred to as custom fields. These fields can be added to all tables 
and rather than being treated as add-ons, they become a more integrated part of your 
database. For example, they are added to the main data grids rather than optionally 
appearing below the grid. 
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#custom  
 

Lookup list The v7 custom look up list table is now separated to two tables: look up fields and look up 
values. The field list includes meta data about the lookup fields such as whether there is 
forced lookup or free test entry is permitted. The values table has entries for all lookup 
values – abbreviations are no longer used. 
 

Tagging  
 

Tags (adding a symbol to the TAG field) in v7 were added to the main data files. Thus, on 
networks, one person’s tags could interfere with those of another. In v8, while, as before, 
tags appear in the main tables, they are held in a user specific tag table. Thus, all tags and 
tag functions are now specific to each user. 
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#tagging  
 

Excel  V8 has much improved connectivity with Excel. You can open Excel xlsx files more easily and 
transfer the data into BRAHMS. You can also save data more easily to xlsx files. 
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#importing  
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#exporting  
 

Memo fields The concept of memo does not exist and you will not see ‘memo’ in the data grids. 
However, the text fields that replace them are effectively the same in that they store any 
length text strings. 
 

Opening and docking multiple 
tables 

Unlike v7, you can open as many tables as you need at the same time. These tables can be 
docked in different ways to optimise viewing. You can use multiple monitors to display 
tables, forms, images, maps and other windows.  
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple  
 

Dynamic web links 
 

You can now open multiple external website links at the same time and these will auto 
update as you scroll through your data grid. 
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#weblinks  
 

Mapping In addition to the v7 mapping options, v8 includes has in-built ArcGIS API mapping to 
display your data. Map points and grid records are connected allowing you to locate the 
current record or map point, very handy for finding map errors. 
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#mapping  
 

RDE 
 

The concept of Rapid Data Entry (RDE) remains. RDE files continue as portable and flexible 
flat files for data transfers and capture. RDE file structures are now identical to the tables 
they represent; you can hide and reorganise fields but not remove them; each record has a 
GUID providing 100% connectivity after import to the main database; RDE data can be 
edited and used to update data that have already been imported. 
  

BRAHMS online Website design and data uploading are more fully integrated in v8. For example, you can 
see your web page updates online as you edit the HTML. 
 

 

 

 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#explore
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#treeviews
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#custom
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#tagging
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#importing
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#exporting
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#weblinks
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#mapping
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