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BRAHMS Version 8 

Managing Natural History 

BRAHMS is a scalable management system for preserved, fossil and living natural history collections as well as 

those undertaking floristic or taxonomic research. Its development is based on almost 30 years of database 

implementation.  

For collection managers in museums, botanic gardens, herbaria and seed banks, BRAHMS helps integrate your 

data for management and research, increasing outputs and productivity. 

 

 

 

 

 

 

 

 

 

 

 

Data integration for research and collection management is a key objective with BRAHMS. 

 

 

BRAHMS has been developed to store all categories of natural history collection.  

 

Some database project examples: 

• manage a grasshopper or beetle collection;  

• develop a comprehensive botanic garden or seed bank management system;  

• create a catalogue of fungi or cultivated plants;  

• produce an annotated checklist for a mountain in Cameroon;  

• create an online portal to search and display your data, images and maps; 

• help prepare a monograph for a family or a genus;  

• or all of these together within a larger natural history museum or herbarium. 
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BRAHMS development priorities 

• easy to install and maintain, intuitive to use;  

• follow published data standards for preserved and living collections; 

• scalable from small research projects to large, multi-site enterprise systems; 

• capable of managing and integrating all categories of preserved and living collection; 

• extendable, allowing projects to add custom storage fields; 

• modular, allowing others to add components including web-based add-ons; 

• international with respect to data store and user interface; 

• a sustainable solution with the potential for distributed development. 

 

Online videos  

 

Performance in a large database 

Connecting to the conifer demo database 

Adding a new user account 

Editing user access and permissions 

Using the species table form 

Adding text entries to taxa 

Using data grid filters 

Selecting visible columns 

Merging values - a fast way to tidy your data 

Creating an RDE file for geographic data 

Importing plant names from IPNI 

Importing bird sample data from an Excel table 

Adding species names to an RDE file 

 

 

 

Mapping in action 

Editing map points 

Printing a garden plant list 

Updating and viewing calculated fields 

Opening, docking and linking tables 

Using tags, filters and maps 

Generating labels and saving to pptx 

Images -> specimen RDE file for data capture 

Tracking edits and using Undo 

Managing transactions 

Deleting records  

 

  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#performancevideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#coniferconnect
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#useraccount
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#userpermissions
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#speciesformvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#addingspeciestext
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#datagridfilters
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#columnviewvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mergevalues
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#rdevideogazetteer
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#importingfromipni
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#importingfromexcel
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#rdevideoaddspeciesrde
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mappingvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#editmappoints
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#plantlist
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#calcfields
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#opendocklink
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#tagsandmaps
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#labelstoppt
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#specimenimages
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#edithistory
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#transactions
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#deletion
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Building a database for botanic gardens 

Introduction 

The development of a well organised database is often a key activity for botanic garden managers and others 

undertaking research on the plants. The strategy adopted will vary depending on your resources, the amount 

of data to manage and your short- and longer-term objectives. However, in all these cases, the paths to 

successful database development are broadly similar. 

Hardware 

Having adequately resourced hardware is an important aspect of any sizable database project. For small 

projects, the software and database may be installed on a personal computer running Windows or on a Mac 

with Windows emulation. Aside from having sufficient disk space and as much RAM as possible (8GB or ideally 

more), there are no special requirements other than that the .NET version is sufficiently up to date.  For 

institutions with large collections, perhaps many millions, and many simultaneous users, the database will be 

stored on a server and it is important that this is well resourced. The server will need sufficient disk space, 

adequate RAM and a good processor.  If you try to run any large database on an inadequately resourced 

server, performance will not be optimal. The BRAHMS software itself will usually be installed on a shared 

drive that all users can access – but it may also be located on individual client workstations. You can also have 

a set up with remote server log in by users located on different sites. On larger networks, the set up you 

adopt will be fine-tuned to achieve the maximum performance, a specialised IT task not further discussed 

here.  

Data migration  

You may have data in an earlier version of BRAHMS, in Excel or Access tables or in other database packages. 

These data can be migrated into BRAHMS. For v7 users, a function is provided to export all your data to v8 via 

XML. Data in Excel can be imported to BRAHMS via RDE. Data held in other packages may require some form 

of migration input. However, one way or another, the idea of migration is that you maintain all the data your 

currently have. 

Optimising data capture 

Data entry efficiency (speed + accuracy) can be sensibly optimised for all projects. While smaller number of 

records can be added directly into BRAHMS, the recommended procedure for larger scale data capture is to 

use Rapid Data Entry (RDE). Data are added to external RDE spreadsheets (themselves portable mini-

databases) and after checking, these data are transferred into the main database. RDE files can themselves be 

optimised for specific projects by setting up the desired fields and field order. 

To take full advantage of RDE, your database can be kick-started by importing useful dictionaries of data, for 

example, lists of taxa, garden locations, geographic names and other widely used lists. Lookup lists can be 

added for any field where you have a fixed set of values. Although lookup lists can be generated on the fly, it’s 

usually best to have these defined in advance. You are then in a position to force selection for a defined list or 

allow the data entry person to add new entries. A more complete range of optimising procedures is discussed 

in the RDE section of the manual. 

Exploring your data 

One of the key attractions of BRAHMS is that you can explore your data in smart spreadsheets known as data 

grids. While the BRAHMS forms are great for data editing, the data grids, together with the many toolbar 

options, are incredibly powerful for viewing, sorting, filtering, calculating and analysis. Data grids are 

virtualized, ensuring they are fast even if you are working in tables with millions of records. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#performancevideo
https://herbaria.plants.ox.ac.uk/bol/brahms/datamigration
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Reports  

Aside from using the data export options provided in BRAHMS, you may want to create report templates for 

plant lists, labels, loan forms and others. BRAHMS is fully integrated with reporting tools developed by 

Stimulsoft. You can gradually build up a library of handy report templates – and many of the tricks to learn for 

that are reviewed in detail in the report design section of the manual. Learning to design cool reports is one 

aspect of mastering BRAHMS where users with interest to do so can go the extra mile, delving into complete 

range of report design options – for example see https://www.youtube.com/user/StimulsoftVideos. 

Exporting data 

Aside from reporting, all data can be exported to Excel or CSV – and all such exports respect your currently 

selected column views, applied filters and sort order. In v8.1. a new XML designer will allow you to export to 

XML using a user-defined XML schema. By combining the query and column selection tools, you can easily 

export any data to Excel – perhaps to send for garden label engraving/printing. 

Mapping 

Almost all botanic garden projects want to produce maps. All the procedures for creating maps using different 

GIS options such as QGIS are reviewed in the map section of the manual. Assuming you are online, you also 

have access to the in-built ArcGIS API and the map point location editor. One of the handiest features in 

BRAHMS v8 is the ability to view data records and map points together, dynamically linking these to highlight 

the current data record, and respect filters. 

Choice of data store 

SQLite (personal data store) is intended for small to medium sized projects. It is portable and the entire data 

store is easily moved from one location to another. BRAHMS always uses SQLite for RDE files which are 

designed to be entirely portable, operating on a server or from a memory stick.  

SQLite is less suitable for large, multiple-user projects. Such projects will use MSSQL Server or PostgreSQL 

with appropriate security and maintenance. 

A ‘data store’ refers to a named instance of SQLite, MSSQL Server or PostgreSQL. Each store may include one 

to many separate database projects. 

 

 

BRAHMS is entirely scalable - managing small research projects or millions of records in larger museums and networks. 

  

https://www.stimulsoft.com/en/documentation
https://www.youtube.com/user/StimulsoftVideos


BRAHMS v8 – Getting started  7 | P a g e  

Species, gardens, herbaria and seed banks 
BRAHMS includes specialist modules, all fully integrated. These include modules for rapid data entry, manging 

geographic data and mapping, transactions and database administration. All of these are important for 

garden management. The key specialist modules for taxonomy, gardens themselves, herbaria and seedbanks 

have been developed collaboratively with different institutions ensuring that they provide the day to day 

curation and research support that projects need. The following notes provide an introduction to some of 

these features.  

Species and other taxonomic data 

BRAHMS has separate tables for Higher Classification, Families, Genera and Species, the latter including infra-

specific names and cultivars. All the key ICN and ICNCP ranks are covered. There are also separate tables to 

store authors, common names, plant uses and text descriptions. While some projects require only a simple list 

of names, others assemble comprehensive details as required for different types of research publication. In 

this respect, BRAHMS manages all details of nomenclature for taxonomic research. 

 

Field selection in the higher classification table. 

 

 

A sample species table with the data grid showing selected columns. The taxa form and column management tool are 
opened and docked right. 
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Botanic Gardens 

The living collections module manages data and images for botanic gardens, arboreta, estates and other 

horticultural projects. The module takes advantage of all the standard BRAHMS features to edit, query, 

report, map, export and publish online with additional features for garden accessions and plants. As living 

collections data are fully integrated within BRAHMS, it becomes possible to develop a comprehensive system 

for both curation and research, linking also to herbarium material if needed. 

 

 

 

 

This module benefits from the standard BRAHMS features to edit, query, report, map, export and publish 

online with additional features for managing garden data. Fully integrated within BRAHMS, it becomes 

possible to develop a comprehensive management system for gardens that shares data and resources with 

other system components including the herbarium and seed bank modules. 

The taxonomic framework allows you to develop an infrastructure of taxa for all ICN and ICNCP ranks from 

higher level classifications down to infra-specific levels, cultivars and hybrids, add synonymy, common names, 

trade names, groups, series, grexes, patent IDs, descriptions, native distribution, hardiness, shade tolerance, 

water requirements, conservation status and more.  

Garden Accession records include details of the type and amount of material received, from who or where, 

receipt date, IPEN,  the wild origin or derived source and the initial identification.  

Plant records hold all details of plants in the garden from planting out to disposal or death.  
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A history of management events and requests for plants can be added. Examples are garden maintenance 

and stock-checks; name changes; label checks; propagation activities; plant movements; periodic 

observations on features such as leaf flush, flowering, fruiting, disease and cause of death. Event categories 

are defined to suit your project management procedures and objectives. 

Plant propagation data can be stored for production propagation; experiments with seed, cuttings and grafts. 

Plant garden location can be recorded from defined garden areas or theme zones down to pinpoint map 

locations with options to record bed and grid numbering as used locally. 

Interactive mapping features using the inbuilt ArcGIS API or your preferred GIS. 

Transactions can be recorded to store batch receipts and different categories of garden exchange.  

Legal and permit data such as Nagoya protocol , Import, Export, Phytosanitary, Collection and Research 

permit details can be recorded using the Permits and Permissions feature. PDF files, Excel sheets and other 

documents can be linked to accessions, individual plants, transactions, species and other records. An example 

would be linking a material transfer agreement to a garden exchange. 

Images of plants  (physical files or media library URLs) in their original habitat or in the garden can be added 

and linked to records in the database as appropriate. Images of herbarium specimen vouchers and other 

associated specimens or illustrations can be added.  

Individual projects can extend data file structures by adding custom fields. For example, if a project wanted 

to store details about species or individual plant accessions using fields not provided by default in BRAHMS, 

additional data fields can be registered and become a permanent part of your database. 

The module is supported by Rapid Data Entry (RDE) which can be used to capture data in batches and to 

transfer data from other formats such as Excel worksheets.  RDE can also be used to upload stock-checks, 

propagation data and plant observations for plant accessions. 

Voucher specimens (herbarium specimen, DNA, wood, seed, etc.) can be linked through the preserved 

collections module. Vouchers may be from original wild collections and/or from established garden plants.  

You can design your own website and publish a virtual botanic garden or online plant catalogue directly from 

BRAHMS using its WebConnect features.  

Collections and preserved specimens 

Many botanic gardens also manage collection event data recording plant wild origins and there may be a 

need cross-reference to preserved material such as herbarium specimens.  

If a collection event leads to vouchers being taken, the physical specimens will likely be deposited in a 

museum/herbarium collection. They may be formally mounted and incorporated to a museum collection. 

Examples are birds, insects, fungi, ferns, higher plants – or indeed any form of preserved natural history 

material.  

Each specimen is linked to a collection event which stores the collector name and number, date, location, 

initial identification and usually some other details about the collection.  A single collection event may lead to 

multiple specimens (or duplicates). These may be deposited at different institutions and be different types of 

material (an insect or bird, a herbarium sheet, a DNA sample, seeds, wood section, fruit, etc.).  

Specimens may have barcodes and/or accession numbers. They may be ‘types’ of a certain category 

(holotype, isotype, etc.). Each specimen may have multiple determinations. 
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Selecting a specific collection category alters the toolbar menu options. 

       

 

 

• Scalable to manage any size of collection, allowing multiple users to add and edit data simultaneously. 

• Store data for any category of specimen: whole organisms, herbarium sheets, DNA samples, Xylarium, etc.  

• Store one to many physical specimens per collection event, each specimen with one to many determinations. 

• Add project specific fields to your database structure if these are not included by default. 

• Link images to specimens as physical files or media library URLs. 

• Design reporting templates for lists, loan forms, labels and determination slips. 

• Optimize specimen data capture using the Rapid Data Entry module. 

• Import specimen data donated from other databases and websites. 

• Use specimen data to develop checklists and analyse diversity for differently scaled areas. 

• Map geo-referenced collections to show distribution by species or any other queried dataset. 

• Publish specimen details with images online. 

Seed Banks 

The seed module, developed collaboratively with the Millennium Seed Bank at RBG Kew, has broad curation 

and research applications for projects who collect, store, test and distribute seed. Seed accession and test 

data, related vouchers and images are all integrated and can be published online. 

Material may or may not be held in boxes and folders as shown here. Each can 
have their own barcode – as can the individual specimens. Screen taken from 
Naturalis herbarium database. 
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• Seed accession records including all passport and wild origin data can be managed with links to voucher details, 

project and agreement details, and seed batch data. 

• Data from collection cleaning methodology, cleaning time and results, the precise store bank location as well as any 

records of collection duplication to other seed banks. 

• Seed counting processes including absolute and/or estimates via seed sample weights, incorporation of x-ray and/or 

cut-testing analysis to provide adjusted quantities per collection. 

• Germination test design including addition of multiple conditions and treatments. 

• Germination test results provided for both germination and viability percentages, including germination rate. 

• Automated scoring of collections/batches against Millennium Seed Bank Partnership Seed Conservation Standards. 

• PDF files, Excel sheets and other documents can be linked to accession, individual plant, species and other records. 

Examples are material transfer documents and species level spreadsheets. 

• Images of seed or the plants in their original habitat can be added, together with voucher images as available. 

• Projects can extend the standard BRAHMS seed data file structures by editing BRAHMS extension files which become 

a part of your database. 

• The Rapid Data Entry (RDE) module is used to capture new seed accessions and test data or to transfer data from 

other formats such as Excel worksheets.  

• You can design your own website and publish a virtual seedbank garden or online plant catalogue directly from 

BRAHMS using BRAHMS WebConnect. For example see the RBG Kew MSBP data Warehouse at 

http://brahmsonline.co.uk/msbp.  
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Logging in to the demo database 
If you have not yet installed BRAHMS and/or do not have a link to the conifer database or any another 

database, refer to Annex section 1 and Annex section 2.  

Otherwise, the login steps are as follows: 

• Locate and run the brahms.exe file. You can create a desktop shortcut to this file. If the application does 

not start, the most likely cause is an installation security issue. Refer to the troubleshooting section. 

• On the log in form, choose the settings as shown below: 

              

A splash screen window is displayed as the system gathers the necessary resources. With BRAHMS Authentication, the 
default user name is ‘Demo’ and the password is lower case ‘demo’. The delay here depends a little on the installation set 
up and your available RAM. The name of the Data Location may differ as this depends on the name assigned when the 
data connection was added.  

Note: if the demo database is located on a shared drive and your data connection is to the shared drive, 

multiple users can be logged into the database at the same time. 

 

The opening screen will vary, depending on your selected background imagery. 
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Task 1: Set system background 
To set the BRAHMS application background, select System > Options > Background Image. If you are online, 

try Bing images of the day. This cycles through some wonderfully distracting images every 30 seconds or so. 

Bing images are updated each day. You can also display background images from your own image gallery 

choosing Use my images. 

 

 

                   

      

                  

 

 

 

 

 

Bing images cycle through a different batch of images each day. A link is provided on the BRAHMS window below the 
image to visit the image URL.  
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Task 2: Opening tables and using data grids 

Opening and closing tables in data grids 

By default, BRAHMS uses data grids with context sensitive toolbars to browse, locate, sort, edit, query and 

analyse your data. Data tables are opened using a single click on the selected menu entry. The use of forms is 

discussed in the Using data forms task. 

• On the Taxa menu, click once on Families.  

 

When a table opens, the toolbar will usually change to Data Tools which is where you will likely find what you 

need to do next. For Taxa specific tools or if you want to open another taxa table, return to the Taxa menu. 

• To close the table, select the X next to the opened table name.  

 

Closing a table using the X mark next to the table name. 

• Alternatively, to close tables, use Alt+X. Function keys such as Alt X are listed using Shift+F1 when in any 

data grid. A grid must be active to do this.  Refer to the section on navigation and function keys. 

Opening multiple tables 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple   

You can open and utilise different tables at the same time. The task here is to open the main family, genus, 

species and collection events tables. 

• On the Taxa menu, click once on Families.  

• Return to the Taxa menu and click on Genera. Repeat this now for Species. Note that each time you open 

a table, the Data Tools toolbar is activated – so you have to return to the Taxa menu.  

• Finally, on the main menu, select Collections and choose Collection events. 

 

Each table has a tab which can be selected to view the data in that table. 

With the opened tables organised in this way, the problem is that you can only view one table at a time. The 

next task explains how to resolve this. 

  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple  
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Task 3: Docking tables 
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple   

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#opendocklink  

 

To view two or more of the tables opened in the last exercise at the same time, you can use the docking 

features. Each table can be detached from its centrally docked position and docked to the side, above or 

below another table – or dragged off the application to a different monitor. Forms, images, external web 

sites, maps, query tools and others are all dock-able. 

Positioning tables and other items takes a little practice - there are many potential docking positions and 

arrangements. It also depends on how many monitors you have. The tasks here assume only one monitor – 

but if you have two or more, take advantage of these to display tables and other screens fully undocked. 

• Using your mouse, drag table tabs to undock them. Initially, it can be a little tricky to grab the tab 

correctly. When you drag any table to undock it, a series of yellow ‘docking boxes’ appear.  

• Drop the table on one of these docking options – the central box redocks the table as it was. 

• As a first try, drag the genus table and re-dock this by placing and releasing your mouse pointer over one 

of the yellow docking points. Repeat for the species table. 

 

Here the genus table has been undocked and is floating above the other tables. And the species table is about to be docked 
to the right. 

• Repeat this with the collection events table, docking elsewhere or moving it to a different monitor. 

 

The various tables rearranged with collections events dragged off the main application 

 

The yellow docking points appear when you drag a table from a docked position.. Docking options vary depending on the 
windows opened. Some experimentation is required. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple  
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#opendocklink
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Docking examples 

 

Map screen undocked and dragged to separate monitor. In this example, data records have been tagged using different 
colour symbols, these reflected on the map.  A column summary on the Tag column is also active and docked to the right of 
the main grid. 

 

 

Left monitor with the plants table filtered on Malus collections, docked next to a column summary. An ArcGIS map of these 
plants is displayed on the right-side monitor. Maps are updated dynamically as filters change. 
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Task 4: Data grid navigation and function keys 
There are a few tricks to learn to move efficiently between columns and rows in BRAHMS data grids. Many of 

the navigation keys are similar to those used in MS Office applications such as Excel. 

BRAHMS draws data from the data store into the grids, and presents the data with low-lag data virtualization, 

storing as much data as possible in memory.  As you scroll up or down, the system retrieves the relevant data 

to memory and refreshes the opened grid. 

• Close all the tables used in the previous task. 

• Select Collections > Collection Events to open the events table.  Activate the grid by clicking in any data 

cell. NB: if you click on a column header, this will sort the table.  

• The default mode for data grids is read-only mode, nothing can be edited. 

Action in non-edit mode Keys 

  

Move to the next / previous column Right / Left Arrow 

First/Last column Home / End keys 

First/Last row CTRL Home / CTRL End 

Next /Previous row Down / Up arrow 

Scroll up and down PgUp / PgDn 

Select or activate a column or cell Click in the cell 

  

  

Action in edit mode Keys 

  

Move to the next / previous column TAB / Shift TAB 

Next /Previous row Down / Up arrow or use Alt+Arrows in memo or numeric fields 

  

 

 

  

You can list Function Key assignments by selecting Shift+F1 which opens the F Key template. Before selecting Shift+F1, click 
anywhere in a data grid. Examples are using F6 to tag or un-tag records; using the DEL key to mark a record for deletion; 
CTRL+E to swap to Edit mode and Alt+X to close a table. 

• Press Ctrl+F6 to ensure all records in this table are untagged. 

• Now press F6 several times to tag a few records. 

• Try Alt+F6 to set a filter on the tagged records. Ctrl+F11 removes all filters. 

NB: all these functions can be executed using toolbar options, for example NoFilter to remove all active filters. 
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Task 5: Optimising data entry and editing 
When editing data, the challenge is to maximise efficiency. This comes through mastering the use of function 

keys, lookups and a few handy tools such as value merging. The F keys make most editing tasks more 

efficient, lookups (select from a list) minimise typing and help standardise your data and other tools help find 

and clean up errors.  

Users often assume it’s easier to add/edit data using forms. However, it’s often faster working in the grids. 

You can create and save custom column views and use function keys to look-up and copy data.  

• To enable edit mode (grids and forms), select the Edit option on the Data Tools toolbar or enter CTRL+E. 

By default, tables are opened in read-only mode. 

The behaviour of the data grids changes slightly in edit mode. For example, you will find that TAB and Shift 

TAB are needed to move through the fields rather than the left and right arrows. 

• Select Taxa > Species to open the main species table.  

• To list available function keys, enter Shift+F1 in an active grid. An example: use Alt+X to close a table. 

• New records are added using Add on the Data Tools toolbar. You can add a single record or in batches as 

offered on the Add drop-down. Adding records enables edit mode. A faster way: use CTRL+N. 

• To mark the records for deletion, use the toolbar option or your DEL key (toggle). To remove these 

records, choose Remove records marked for deletion on the toolbar Delete dropdown. 

  

 

There are two categories of lookup, both activated using F9, CTRL+L or using Relational Lookup on the 

toolbar. A) selecting values from the larger database dictionaries such as people, taxa and place names and B) 

selecting values from your central lookup dictionary. 

• Add a blank record and then click in the newly added genus cell. Use F9 or CTRL+L to open the genus 

lookup. You can select a genus by typing in the Find box or by using the grid filter options. Similar lookups 

will also work in fields such as Family and Author. 

• The specific epithets Species, Subspecies, etc. are typed in as these are free text fields to be edited. 

The field Taxon Status uses values stored in your custom lookup list. You can generate lists here using the 

toolbar option Edit Lookup Values or edit the list directly from Management > Lookup Lists. In edit mode, the 

Taxon Status field displays as a drop down because it is registered in the custom lookups list. 

• To check or edit the values available, select Edit Lookup Values on the Data Tools toolbar. 

     

 

 

 

 

 

Some fields in the main tables cannot be edited directly - usually fields 
from a related table or calculated fields. Examples here are Family and 
Genus. To edit these data, you must use a lookup. Fields with lookups 
have the lookup icon in the header and are displayed in a darker shade. 

The Edit Lookup Values form allows you to define and edit lookup values. Options include  ‘Use the full value 
in selections’ which would result in storing ‘Accepted name’ instead of ‘Acc’. 

A lookup activated in the Taxon Status field, set to use full value rather than the abbreviation. The same drop 
down is available in form mode. 
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Task 6: Merging data values and records 
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mergevalues 

 The tasks here demonstrate Value Merging and Record Merging. 

Value merging: The Column Summary tool, as well as listing and giving a count for each different value in the 

selected column, can be used to quickly clean up data errors in non-relational, non-read-only fields.  

Value merging standardises different spellings of the same value in a column – and is a fast way to find and 

clean these errors. You can use value merging in any table – as long as the field is not read-only. 

• In the conifer demo database, select Geo > Gazetteer and select the Major Admin Name and/or Minor 

Admin Name columns. 

• Select the Summary tool on the Data Tools toolbar. Sort the summary record by values by click on the 

value header. 

• Tag the value(s) to be merged - then select the correct value by click on that record (no need to tag).  Use 

Merge to Selected to complete the task. 

         

In the example on the left, either spelling of Alpes-Maritimes may be acceptable but clearly, it is better to be consistent. 
The right-side example is in the Minor Admin Name column where you will find plenty of other entries to correct. Note that 
aa grid filter has been used with the Minor Admin example to narrow down the summary entries. 

Record merging: Record merging leads to 2 or more similar or identical records being merged into one record 

with a resulting deletion of the merged records. When record merging takes place, the system must ensure all 

child records are moved to the selected record. Record merging is used to clear up double (or more) entries of 

entire records – for example if you had two or more entries in the genus table for the same genus, both with 

linked species, you could not simply delete one, you would need to merge the records. 

In this example, you can merge some gazetteer records. 

• In the conifer demo database, select Geo > Gazetteer and enter ‘jiang’ in the grid filter bar for the field 

Locality Name. Click on the column header to sort by name. Locate the entries ‘Nu Jiang - Qi Qu divide’ 

which is entered twice, slightly differently. 

• Tag the one you want to remove and then select the record to merge into. Then select the Merge option 

on Data Tools. 

  

In this example, the calculated field shows 
each of these Nu Jiang  records has 1 linked 
collection event. These will be joined under 
the selected entry. 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mergevalues
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Task 7: Using data forms 
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#speciesformvideo  

 

Forms are provided for most of the main data grids. As well as being used for editing, they often provide 

options to list related records and calculated fields. The data on forms update as you navigate to different 

data grid records. Forms can be docked (default), dragged elsewhere and re-sized. In order to edit data on 

forms, you need to be in Edit mode. If you are not, data will not be saved and lookup options are not enabled. 

 

  The form edit icon indicates if you are in Edit mode or not. 

Most forms have the option to edit data and then Save or Cancel the edits made. Once any edits have been 

made, the form is given a red surround. 

• As an example, select Taxa > Species and then select the Form option on Data Tools. The species form is, 

by default, docked right. 

• Review the various tabs on the species form, moving through grid records to update the form. 

 

 

Data can be viewed and edited using grids or forms. Forms can be resized, docked or dragged to separate monitors. 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#speciesformvideo
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Plant Accession data grid and form. The form here is showing the plants for this accession together with a calculated 
summary of the accession origin.  

 

 

Plant data grid and form with the form set to list the events for the current plant record. In this example, the events are 
plant ‘observations. The data grids on forms themselves can also be filtered. 
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Task 8: Dynamic weblinks 
You can dynamically link your database to external websites as provided on the WebLinks toolbar. WebLink 

options will soon be configurable in BRAHMS, allowing you to add the websites that you find most useful. 

WebLinks are available from many of the BRAHMS tables, especially when there is a species name in the 

table. You can test these options in different tables but for this initial task:  

• Select Taxa > Species to open the main species table. 

• Select WebLinks > POWO (Plants of the World Online). 

    

In this example, the POWO website has been opened on Podocarpus taxifolius, a synonym of Prumnopitys montana. 
Moving data grid records auto-updates the open weblink page.  The species form is opened on the synonyms tab and the 
various windows are docked. 

 

 

 

Examples with the ant genus Acromyrmex, top Google Images, lower using AntWeb. 
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Task 9: Adjust and save column views  
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#columnviewvideo  

 

When you open a table, the default data grid columns will be visible. You can adjust and save new column 

views using the Column Management options. This applies to all tables. Selecting a particular set of visible 

columns is a handy way to view selected data and speed up specific editing tasks. 

• Select Collections ensuring the category is set to Living Collection.  Select Plants  then Grid Tools > 

Manage Columns… .  

 

The Column Management Tool allows you to select visible columns. 

Once you have selected the columns you need, you can optionally save these using Save layout on the Grid 

Tools toolbar. This will create a small data grid view file with extension .dgv and save this file to your 

BRAHMS\Columns folder. You can create as many views as you want. 

 

An example saved column view with a selection of ordered fields, the records sorted in this case by garden location + grid. 

• Another way to adjust visible columns and their field order is to right-click on any of the column headers. 

This opens a dialogue form with options to show hidden columns and alter the column order.  

And here’s another handy way to hide columns: 

• Click anywhere on the Family table to make it the active table. Now click in a field you want to hide.  

Select the Grid Tools tab and then Hide Current – this hides the selected field. 

 

In summary, there are various ways to select and view columns in your data grids. Different views are useful 

for specific editing tasks.  Deleting a .dgv file from the Columns folder will remove it from your list. You can 

share .dgv files with other users.  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#columnviewvideo
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Task 10: Sorting records 
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#sorting 

The ability to sort records is vital for reporting. It’s also useful to locate records and find errors.  

Sort on single or multiple columns 

Tables can be sorted on single columns by clicking on the column header, Shift Clicking on multiple column 

headers … or using the Sorting Tool. 

• Select Taxa > Genera to open the main genus table. 

• Click once on the Family column header to sort A-Z. Click the same column header again to sort Z-A. Click 

a third time to remove the sort.  

• You can combine as many columns as needed using Shift Click on columns headers. 

 

 

Saving complex sort commands 

• Using the Sorting tool, you can add fields of any type to create complex sorts. You can save these sorts 

using the Save option provided. 

 

Using the sort form, any combination of character, numeric, date and logical field can be selected to sort your records. 
Complex commands can be named and saved for future use.  

Sorting collection events by collector and number 

Collection event field numbers are alphanumeric and thus, by default, sorting the field number column AZ 

gives an incorrect sort order. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#sorting
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As can be seen here on the left, sorting these Wilson, EH collections on Field Number gives a bad result. This is resolved 
using the calculated field # Field Number (sortable) shown on the right which pads the number field with zeros.   

• To display this field, select Grid Tools > # Calc Fields 

• You could now sort the collection events table on the Collectors + Field Number (sortable) fields but in 

reports, still refer to the column Field Number. 

Date sorting 

Records can be sorted on date fields. For example, you can sort on the audit fields Created By, Created On, 

Last Modified By and Last Modified On and such sorts are useful for a variety of purposes.  

When you add a new record, the data grid is auto-sorted on the Created On field. But you may find it useful to 

sort on this field (click on field header) at other times, perhaps in combination with other fields. 

For example, to view records most recently added, you can sort on Created On, clicking the column header 

twice to bring the most recently added record to the top of your data grid. 

If you want to sort collection events by date, sort on year, month and day in that field order, shift clicking on 

fields for multiple selections. 
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Task 11: Tagging functions 
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#tagging 

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#tagsandmaps  

 

Tagging refers to the addition of a single character to the TAG field. This field is available in all tables in the 

first column. Tagging has multiple uses throughout BRAHMS with record selection and grouping. While the 

default tag symbol is *, you can tag records with different symbols or numbers. Each of these can be assigned 

a colour.  Tags are user-specific, thus one users’ tags do not interfere with those of another working in the 

same table. This is achieved by holding tags in a related, user specific table. 

 

 

 

Clicking on the Tag option on the Data Tools toolbar adds the selected symbol to the TAG field. The Tag toolbar dropdown 
provides a list of handy tagging options. 

Transfer tags Copy tags to child records, for example, species tags can be copied to all collection 
events, specimens and det history records 

Count tags A count of all tagged records.  

Filter on tagged Show only tagged records 

Tag all Tag all records in table – respecting any filters 

Clear all grid tags Remove your tags from all tables – does not respect filters 

Clear current grid tags Remove your tags from the current table – respecting current filters 

Invert tags Tagged records are set to no tag; records that had no tag are tagged * 

Tag with Choose tag symbol from list 

 

 

Records tagged with a variety of symbols. 

  

Select System > Options > Tag 
Highlight Colours to edit the default 
colour options. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#tagging
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#tagsandmaps
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Task 12: Column summaries 
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#colsum 

The column summary option lists the different values in the selected column, providing the total number of 

records per value. 

• Select Collections ensuring the collection category is set to ‘Living Collections’. Then select the Accessions 

option. 

• Locate and click in the column # Full Name and then select the Summary option on Data Tools. 

 

Here, the summary shows the number of plant accessions per species. Moving to a different column will update the 
summary, assuming Auto-update on column change is selected. Click on the summary columns to sort by field name or 
count. 

 

  

The summary option can also be used to apply filters on one or more selected values. 

• Open any table you want and test the Column Summary function in any column. Moving to different 

columns auto-updates the list unless the form option Auto-update on column change is disabled. 

 

 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#colsum
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Task 13: Adding custom fields to BRAHMS 
BRAHMS databases and the tables they contain are provided with a defined structure. However, as well as 

defining the data columns that you choose to see in your data grids, you can add new data storage fields that 

are specific to your project.  

You can choose the field name, type and size. These custom fields become a permanent part of your database 

unless you subsequently opt to delete them. This also applies to RDE files. 

• Select Collections > Collection events - or another table if you prefer. 

• Select Grid Tools > Manage Columns. 

• Add one or more new columns using the Custom Columns tab. Field names can include spaces. 

 

The Column Manager form - options to add and edit custom columns are enlarged on the right side.  

On this form, you have the option to add new fields. If the field is of type Text and you set Max. Chars to NULL 

or 0, this creates a text field equivalent to a v7 memo field.  Using the Editor tab options, you can list and 

remove your custom fields. Field position can be modified using the buttons provided above the field list. You 

can also load existing field layouts, edit and save as a new layout. 

 

Custom fields appear in your main data grids, assuming they are selected for inclusion in your data grid view. They have a 
different font to standard fields. 
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Task 14: Find, Filter, Query 
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#datagridfilters  

Queries using the grid filter bar 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#explore 

• Open the living collection Accession file using Collections > Accessions.  

• Enter values into the yellow, top grid filter row as shown below. You can use operators *, =, <, >,<=, >=  

and combine values using capitalized AND/OR statements. The grid filter bar is a very efficient way to 

apply filters and locate records. Note that you must use capitalized key words. 

 

Using the grid filter row, you can add values to as many columns as needed. For text strings, the default filter mode is 
‘includes’. Use = to make a precise match. This example include 4 filter options. 

• You can use * to select ‘starts with’ and ‘ends with’, thus: 

 

Setting a filter where collector name starts with ‘ter (left) or includes ‘ter’ (centre) and right, where the genus ends ‘illa’. 

Queries using Selection and +Selection 

You can set filters on current cell values using the Selection and +Selection options.  

• Open the main file collection events table using Collections > Collection Events.  Set a filter on a cell 

value by clicking on the value and then the Selection toolbar. This option overrides any previous filters. 

• You can add multiple cell-based queries using the +Selection option.  As soon as you select Selection 

rather than +Selection, the filter will be again restricted to a single value. 

 

Using the Selection toolbar options. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#datagridfilters
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#explore
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Task 15: Building and saving more complex queries  
Using the main Query tool form, you can design and save your own queries. Queries can mix and match fields 

of any type.  Each command you add is saved unless you remove it from the list. You can then selectively 

enable and combine the one-line commands and optionally name and save combinations of commands. 

• Select the  toolbar option to open the main Query Tool. Use the various drop downs to add the query 

commands you want, using Add to add the command to the command list. The AND/OR settings can be 

adjusted if necessary. 

• Use Apply filters to run the query. 

 

An example Query Tool form with previously used commands, three commands enabled. You can name and save a 
combination of query commands. The Query Tool form can be undocked and dragged off the application. 

 

A further example Query Tool form with previously used commands, three commands enabled. Note that the SQL 
command used by BRAHMS is displayed in the lower part of the screen. 

 

Active filters can be displayed using the Filter Info option next to the Filter option. 
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Task 16: Saving data to Excel 
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#exporting  

Data are easily exported to Excel spreadsheets using the Tag -> Excel or CSV options on Data Tools. Exporting 

works only with tagged records. Exports respect applied filters and your currently selected column view. 

In this task, export specimen data from BRAHMS, sorted by family and species name, restricting the export to 

some columns and the filter selection to holotypes. 

• Select Collections from the main menu and choose ‘Living Collection’ using the Category drop down. 

• Select Plants to open that table.   

• Now select Grid Tools > Manage Columns and here you can remove any columns you don’t want to 

export and sort the table as wanted.  

• Tag some records using F6 or the Tag option on the Data Tools toolbar. 

• You can now use the Tag ->Excel option to save the tagged records. 

 

Using the grid filter option to restrict to selected plant records and a selection of columns. 

You can list all saved files using the View option on the Export Data toolbar section. 

In data grids, you can click on a record to select the record. You can use Shift Click to select groups of 

contiguous records or CTRL Click to select individual records – the same as in other packages.  Selected 

records are displayed in a shaded colour. Copy the selection using CTRL+C. You can then paste CTRL+V these 

records elsewhere, for example to Excel. Be sure to select the correct paste option to format the data 

appropriately. 

  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#exporting
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Task 17: Register and open a Rapid Data Entry file 
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#labelstoppt 

While data can be entered directly into BRAHMS, RDE is recommended for entering larger numbers of records 

and also as a first step when importing or transferring data from other software packages such as Excel. 

 

 

 

RDE files are entirely separate mini SQLite databases linked to your main BRAHMS database. They provide 

portability and flexibility – optimising data entry and cleaning.  

While data can be entered directly into BRAHMS, RDE is recommended for entering larger numbers of 

records. It is also used as a first step when importing data from packages such as Excel and Access.  

You can store data in one or more RDE files and use these data to create summaries, maps, reports, manage 

images, and in general, use most of the BRAHMS tools and functions.  Some users continue to work in RDE as 

it does all they need. However, RDE files are more like Excel spreadsheets with BRAHMS features - a series of 

separate RDE files does not constitute a ‘database’. 

This example opens an RDE file of specimen data prepared by John Wood (Oxford based botanist) from his 

field work in Bolivia.  

• First download the file RDE_Bolivia_JRIWood.zip and open the zip to the folder 

Documents/BRAHMS/RDE.  This is the default location for RDE files.  

The zip file includes an RDE file of specimens and a report template sample for labels. 

• Log into BRAHMS – choosing any project and select Rapid Data Entry > RDE File Manager. This will list 

any RDE files located in all registered RDE folders. 

• To open the RDE file downloaded above, double-click on the RDE manager entry ‘JRI Wood Bolivia’. 

• Explore this RDE file using the Column Summary option on Data Tools. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#labelstoppt
https://herbaria.plants.ox.ac.uk/bol/Content/Software/v8/RDE_Bolivia_JRIWood.zip
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An RDE opened with a column summary in the Family field. The summary shows the number of records per different 
family. Clicking in a different column will update the summary. 

 

RDE folders 

 

RDE files can be stored in any registered folder. New folders are added using the Add option of the left panel. 

Folders can use UNC paths or drive letters.  Only database administrators have access to the folder 

management options. Administrators can register new RDE folders and assign access permissions to one or 

more non-admin level users. 

All users, regardless of their database role, have access to their default Documents\BRAHMS\RDE folder. 

Beyond this, non-admin and non-manager users need to be given access to folder(s) by the system 

administrator or database manager. 
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Task 18: Import from Excel to RDE 
Data and images (as references) can be imported from .xlsx tables into RDE using the Excel Data Import 

Wizard. This tool allows you to locate and open an Excel .xlsx file, then match the columns in the file to your 

opened RDE file. The matching between Excel and RDE columns can be adjusted as necessary to pull in as 

many fields as possible. This process also allows you to import data from custom fields – assuming the custom 

fields have been added to your RDE file. It also means that field names in foreign languages can be mapped to 

the standard names. For example, your Excel table may store country names in a column with heading PAÍS or 

国家 or PAYS. The task is to align this with the standard RDE field COUNTRY. 

This example uses collection data (species x locality) taken from museum specimens. But you could work with 

other data, for example, just a list of taxon names. The data may be animal, plant or any other data. If you do 

not have your own data to experiment with, download the sample Excel: 

https://herbaria.plants.ox.ac.uk/bol/Content/Software/v8/SampleExcel_RDE_Import.xlsx.  

• In BRAHMS, select Rapid Data Entry > RDE File Manager then use the Add option on the Data Tools 

toolbar to create a new RDE file. Choose the Category ‘Specimens’ – and provide a file title. Enter Next.  

• If you want to add some custom columns to the RDE, use the options provided in the right-side panel. 

Knowing whether to add custom data fields requires some knowledge of what the default fields are.  

• When you Finish, the new RDE will be created and registered in your RDE manager. 

• Open the file by double-clicking on the record. Then choose Rapid Data Entry > Import from Excel… 

• Follow the Excel Data Importer steps as prompted. 

           

 

 

 

 

Once the data have been processed by the Excel Wizard, you can then choose to transfer selected records or all the data 
into your new RDE file. 

 

 

        

If your Excel file includes image references as physical file names (path + 
file name) or URLs, these can be imported to and viewed in the RDE file. 
If there is more than one image cited in the same field, the entries should 
be comma or semi-colon separated or on different lines. 

 

By default, BRAHMS checks for the fields Imagelist or Images and auto-
selects either if they are available. Otherwise, you can select the image 
field using the field selector.  

These screens show the matching process (left) and the data processed 
and ready to import to RDE. This may not be fully possible if the data are 
in the wrong format – but you will probably be able to get close. Data in 
different formats can be adjusted in Excel or processed after transfer to a 
custom field in RDE. 

 

https://herbaria.plants.ox.ac.uk/bol/Content/Software/v8/SampleExcel_RDE_Import.xlsx
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Task 19: Mapping from RDE  
You need to be online for this task which uses the in-built ArcGIS API (no installation required). You can also 

map to QGIS, Diva GIS, ArcGIS, Google Earth and GeoCAT. Further mapping tasks are provided in the section 

Mapping from the main database. 

• To map the RDE file opened above, select Maps > ArcGIS in BRAHMS.  

• Initially, if no records are tagged, no points will be plotted. To map the entire file, remove the mark from 

Tagged only on the map toolbar.  

 

The RDE file mapped with the Tagged only option de-selected.  

• If you now tag some records, you can use the Tagged Only option to restrict the map to tagged.  

• The yellow point represents the current grid record. This updates as you move to a different grid record. 

• With the map remaining open, set a filter on a geographic area. In the example below, the text ‘vela’ has 

been added to the grid filter bar in the field Minor Area Name, here selecting the area Velasco.  

• You can change the base map using the option provided on the ArcGIS screen. 

 

• Clicking on a map point will locate that record in the data grid, an excellent way to locate and edit data 

errors.  
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Task 20: Adding and editing map points in RDE 
The map location editor can be used in RDE and in the main tables for collection events and botanic garden 

plant points. You can use the map location editor to add a new map point or edit an existing one. The editor 

opens an online map form which updates as you move through the data grid. You need to be online to use 

this feature in BRAHMS.  A right-click on the map resets the point position and either auto-saves this to the 

grid or awaits confirmation via the Save option. 

• In the opened RDE file, select the Map point editor option on the map toolbar. You can also use the 

standard F9 lookup from the latitude or longitude fields. 

 

Once opened, the location editor can be used to edit points and altitude in your data grid. 

 

 

 

 

Location editor settings 

Setting Notes 
Base map Choose base map that best suits the editing task in hand. 

Auto-zoom on/off If selected, as you move to different records, the map zooms to the current point using your 
zoom scale setting. 

Zoom to marker Zoom to current point based on your Zoom Scale setting. 

Zoom Scale Choose the optimal zoom setting. Maximum shows a world map. 

Reset Zoom Reset the zoom, if adjusted, to your current setting. 

Map units Select the entry mode for manually editing data.  

Lat Long checked Mark a record as ‘map checked’. 

Auto-save If selected, a right-click on the map will adjust the point and save the map point change. 

 

The map location editor 
displaying the current point, 
set to Auto-save.  

In this mode, a right-click on 
the map will update the 
Latitude and Longitude values 
in the data grid without using 
the Save option.  

This example screen has no 
zoom and is displaying the 
entire globe. 

The same point displayed 
at a very different zoom 
level.  

Right-click the map to edit 
point location. 
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Task 21: Reporting from RDE 
Reporting in BRAHMS provides almost limitless power to generate lists, labels, charts, cross-tabs and more. 

You can print reports directly from BRAHMS or send the outputs to documents, Excel, pptx and elsewhere. 

Report design is covered in detail in the full guide.  

To produce some labels in your opened RDE file, you must tag some records as the reporter only works with 

tagged records. If you wanted to print labels for the entire file, use the Tag all option on the Tag dropdown – 

otherwise manually tag some records. 

• To open the sample report template provided, select Reports then File > Browse and locate the report 

file ‘RDE specimen label sample.mrt’. It will be located in the same folder as your RDE file – 

Documents/BRAHMS/RDE. 

 

The reporter opened here on the Home tab which is where report design can be edited. Report design is not further 
discussed here. 

 

 

To view the labels, select the Preview tab at the top of the reporting application. 

 

 

On the Preview tab, you can choose various Save options including MS Word. If exported to MS Word etc., your labels can 
be edited prior to printing.   
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Task 22: Mapping from the main database 
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#mapping  

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mappingvideo  
 

The in-built ArcGIS API provides a wealth of handy mapping features which you can take advantage of without 

installing any further GIS software. However, you do need to be online. 

Some advantages of the in-built ArcGIS tool:  * No installation required; * data points are highlighted on the 

map as you browse through your data grid; * clicking on a map point locates the grid record, an excellent way 

to locate errors; * maps are auto-updated as you apply grid filters; * calculation of Extent of Occurrence 

(EOO); * selectable base map including world imagery; * map tagged only or map all, exclude cultivated 

records; * search maps; * save map as a png file and import to a document.  

• Select Collections > Collection events then select the Mapping toolbar followed by ArcGIS in BRAHMS.  

• If no filter is applied, by default, this will plot all tagged records. To plot records, tagged or not, adjust the 

Tagged only option.  The map window can be dragged to another monitor and made full screen size. 

     

 

 

 

 

With the ArcGIS Auto Zoom disabled, you can plot different taxa without changing the current base map area. 

A map displaying all conifer 
collections (no filters applied).  

The setting here does not restrict to 
tagged records and a dark gray base 
map is selected.    

The current data grid  record in 
Kenya is hightlighted on the map. 

 

 

Here, a filter set on New Zealand 
with the base map set to World 
imagery.  

The point colour has been 
changed and the current grid 
record is highlighted. 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#mapping
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mappingvideo
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Task 23: Images and Documents 
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#images  

Images 

Images can be linked to any record in BRAHMS and you can link multiple images to the same record. All 

images are listed in the central images table with their full pathname or web URL.  

Images may be located in any location including in media libraries and cloud servers. Read more about 

managing images in BRAHMS. You can store links to images using a URL – you do not need to have a copy of 

the image file. 

Images can be viewed from the main file and/or wherever they are linked. As an example, you can link some 

images to a species:  

• Select Taxa > Species. On Data Tools, select Images… to open the Image Viewer. 

• Here, you can either use the Link … button or simply drag images to the Image Viewer.  

 

The Image Viewer has several handy toolbar options (Rotate, Zoom, etc.). You can also use F keys and your mouse to 
control the viewer, for example Shift + mouse wheel = zoom in/out around central point.  

As discussed in the RDE sections, images can be transferred from Excel files to RDE and also from RDE to 

BRAHMS. 

Documents 

Multiple documents of any type can be linked to any record in BRAHMS. This could be a PDF material transfer 

agreement or collection permit linked to a specimen, accession or transaction; a protologue description linked 

to a species; a sound file linked to an animal entry; or perhaps a video or slideshow linked to a botanic garden 

greenhouse record.  

 

Linking pdf, docx, wav, pptx and xlsx documents to a species record. Media and documents can be opened using the Open 
option or double-clicking on the linked entry. 

  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#images
http://herbaria.plants.ox.ac.uk/bol/brahms/modules/images
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Task 24: Creating your own database 
You can create a new database project in just a few steps. For practice purposes, it will be fastest to create 

this using SQLite but you could also use MSSQL Server or PostgreSQL. Another decision is whether to use an 

existing data store or whether to create a new one. For example, you could create a new database/project 

using the existing conifer data store conifers.db, bearing in mind that a data store can hold fully separated 

database projects. This example starts by creating a new project in the default personal brahms.db store. 

Creating a new database or data store - SQLite 

 

 

You can also create an entirely separate personal SQLite data store in any folder location: 

 

 

Creating a new database – MSSQL Server 

To create a new data store in MSSQL Server (local or server based) or to connect to an existing one: 

Prerequisite:  You must be able to connect to an MSSQL Server with sufficient permission to create new 

databases and to manage user login accounts. This will usually be someone with a Database Administrator 

(DBA) role. 

• Log into the default personal store (or any other data connection). 

• Select System > Manage Data Connections > New choosing the MSSQL Data Provider option. 

• Choose Create a new MSSQL hosted data location. 

• Follow the Wizard Tool instructions – which will lead to a script being run in the connected MSSQL Server 

to create a completely new BRAHMS data store. 

 

To create a new project in the existing brahms.db 

data store: 

• Log into the default personal store. If this has no 

database projects (as initially installed), as soon 

as you log in, the Database Manager Form will 

open.  

• If you already have created a project here, 

select System > Manage Database Projects… > 

New and enter the project name and a few 

other details as requested. 

 

 

 
To create an entirely new data store: 

• Log into the default personal store (or any other 

data connection). 

• Select System > Manage Data Connections > New 

choosing the Local Filesystem option. 

• Choose Create a new file… 

• Once created and saved, you can log in to this new 

data store and proceed to create a database project 

as described above. 
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Task 25: Adding data to a newly created database  
Assuming not upgrading a v7 database, you can either add data directly to BRAHMS or import data from RDE. 

The tasks here will do both. These examples use data grids rather than forms. Remember to use Edit mode. 

Adding data to your new database – directly 

In practice, you would not use this method to add many new records to a new database but it is reviewed 

here in multiple steps to explain the process.  

• Start by logging into your new database. 

• Optionally, select Taxa > Higher Classification.  Here, you can add a new record, adding as much detail as 

you wish from Kingdom to Order. You may want to add custom fields to define additional taxa levels. 

• Select Taxa > Family.   Add a family name, here e.g. Acrididae (grasshoppers). Use a lookup in the Order 

field to connect the Higher Classification record just added. 

• If you want to add Author names, this is done from Management > People. To link an author, use a 

lookup in the Family Author field. On the name selection form, use New if the name is not included in the 

compiled author name(s) list. 

• This can now be repeated to add a genus to the main genus table, using a looking in the family field. 

 

  

 

 

Using RDE to add the above data 

In practice, if adding multiple taxa names as above (or adding new specimens etc.), it will be far faster to add 

these using RDE. The key point is that new family, genus, species and author names can be more easily added 

to a single RDE table. The same applies to specimen and other data categories. If the names are new to 

BRAHMS, they are added to the relevant database tables when the RDE file is transferred into BRAHMS. 

 

A sample RDE file with 4 entries added. The first 4 columns have been copied down using the F4 copy function. 

Adding a new entry to the People 
table. Import here for use as 
authors of taxa is to include the 
abbreviation. 

In this example, some higher classification 
data have been added (top grid) form 
Order name upwards. The field Superorder 
has been added as custom field. You could 
add further or different fields as needed. 
The family table (lower grid) also has some 
custom fields added. 

Having added the family and genus 
names, the species level data can 
be added, in this case, 4 subspecies 
of Melanoplus sanguinipes, with 
their authors. Here, a lookup is 
used in the Genus and author 
fields.  
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Transferring from RDE into BRAHMS 

To transfer the RDE data into BRAHMS: 

• Open the RDE table you wish to transfer to BRAHMS. You can optionally restrict the transfer to tagged 

records and if you wish to do that, tag the records to transfer. Otherwise, this is not necessary.  

• If you want to run checks prior to the transfer, select Analyse RDE file. This process checks which records 

in your RDE file are new to BRAHMS. The results are displayed in the RDE file itself using a series of logical 

fields are displayed below. 

 

The Analysis fields can be enabled or hidden using the Show analysis flags option. This example indicates that all the data 
records (where data has been entered) are new entries. The yellow grid filter bar can be used to filter for new entries. 

In fact, this (optional) analysis takes place behind the scenes whenever you run the actual transfer. The ability 

to use this separately provides an opportunity to check the file before transfer using filter options to locate 

and review new records. 

• Before proceeding, you can hide these flags if you want. 

• On the Rapid Data Entry menu, select Transfer RDE to BRAHMS…. and on the Step 1: Run data analysis 

page, select Run Analysis which is the same analysis as above – although it leads to a printable report. 

          

The import log can be saved/printed. 

Now select Next to go to Step 2: Import the Data and select Import Data 

 

The above step with import report shows the result after importing the data for a second time. There is nothing new to 
import. 
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Task 26: Adding a user account and setting permissions 
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#useraccount 

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#userpermissions 

Adding users and setting permissions is described in detail in the BRAHMS guide. In summary, you can add 

users with BRAHMS, Local Windows account or Domain account authentication. Users can be assigned access 

and permissions to one or more databases.  

In this example, add a new BRAHMS authentication user and assign this user permissions suitable for a 

transaction (e.g. loans) manager. Needless to say, the permissions assigned in practice by your institution may 

vary. Feel free to add other user accounts including your own local Windows account – this then allowing you 

to log in with no additional password entry. 

NB. You cannot save changes to the ‘Default’ permission set as used by Administration. 

• Log into the demo database and select System > Manage Users and Permissions. 

• Choose the User List option above the grid (or use Add on the Data Tools toolbar). 

• Select New User > Add BRAHMS User adding the User Name, Password and ‘Known As’ name. Do not set 

the user as an Administrator. 

         

Select Create this User and then Finished to complete the user addition. At the bottom of the screen, you can assign 
database projects to the new user. If there is only one database in the connected store, it is auto-assigned as shown here. 

• Close the user form and select the new user on the User Management data grid. Then select the Access 

and Permissions option.  

• After editing the settings, assign new permission role name (here ‘Transaction Manager’) and use the 

Apply As option to save the settings and assign this Permission Set to the current user. 

 

Choose the options you feel appropriate for the selected user.  

 

  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#useraccount
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#userpermissions
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Task 27: Two challenges 
The challenges are to create screens similar to those shown below.  

 

 

This conifer database example with docked windows shows collection event data filtered to Pinus hwangshanensis, a map, 
a column summary and the POWO and Google Images weblink options.  

 

 

 

In the main species table, generate the above screen for Podocarpus magnifolius. It includes a website link and one of the 
form tabs. 
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Annex 1: Installation and login 

Have an existing BRAHMS v8 test version? 

Delete your current BRAHMS software folder. Also, delete your Documents\BRAHMS folder. If you have 

installed the conifer database, delete this and download again - see Connecting to the conifer database. This 

is because table structures may have changed during the testing phases. 

Prerequisites and .NET 

BRAHMS operates under Windows - or on Macs with Parallels, Virtual Box, Boot Camp or equivalent. Your 

installed Windows .NET framework version needs to be v 4.7.2 or later. If it is not, BRAHMS prompts you to 

upgrade. If you do have to upgrade .NET, it will be best to restart your PC after. Ideally, workstations would 

have 8GB of RAM or more. RAM is very useful for database applications as it helps the system cache data, 

speeding up most operations. 

Install BRAHMS v8 

• Open the single software zip file to any location.  

Do not use the default windows file extraction tool as this will result in a blocked security status of the files. 

Use 7z or similar to open the brahmsv8 zip to any location on your local Windows PC or server.  

BRAHMS 8 can be installed on each local workstation where it will be used - or on a shared folder. It can be 

installed in any folder location. Installation strategies and data access options are discussed in the full guide. 

 

Typical BRAHMS software folder. The installation folder contains the file brahms.exe which you run to start the application. 
You can create a shortcut to this in the normal way. 

Login to the personal data store 

If you have a problem getting to the BRAHMS log in, refer to the troubleshooting section. 

• As a first step, log into BRAHMS using the Personal Data Location. The system will initially default to 

Windows Authentication using your Windows identity and thus you do not need to add a password. 

 

After installation, logging in using Window Authentication to the Personal database, no password will be needed. 



BRAHMS v8 – Getting started  46 | P a g e  

When you first log in, the system creates an empty SQLite data store called brahms.db in your 

Documents/BRAHMS folder. This folder is created automatically. This may be on your physical PC or on a 

network drive with roaming profiles.  

 

Close the initial Database Projects Manager screen. 

 

 

 

Troubleshooting 

          

 

If the install zip is opened using the Windows default extraction, this blocks access to DLL files. When logging 

in, you may see a message similar to the left-side screen above. The solution is to delete your BRAHMS 

software folder and then again open the zip file you have downloaded using 7z https://www.7-

zip.org/download.html or another utility. Another possible explanation is your security system (e.g. anti-virus) 

requires you to include brahms.exe as a trusted exception. 

If the error is similar to the right-side screen above, you need to download the Microsoft Visual c++ 2017 

redistributable as on: https://social.msdn.microsoft.com/Forums/vstudio/en-US/e653a57a-bc32-4134-87bf-

df33058f0531/download-microsoft-visual-c-2017-redistributable 

 

  

• If for any reason you cannot log in under 

Windows authentication, change this 

setting to BRAHMS authentication on the 

log in form. 

• Choose any user name and select a new 

password. Passwords are case sensitive. 

• As the default personal database is 

empty, the first log in will auto-open 

the Database Projects Manager screen 

with options New and Import. 

 

• At this stage, Close this screen and 

move on to connecting the conifer  

database as discussed below. 

 

https://www.7-zip.org/download.html
https://www.7-zip.org/download.html
https://social.msdn.microsoft.com/Forums/vstudio/en-US/e653a57a-bc32-4134-87bf-df33058f0531/download-microsoft-visual-c-2017-redistributable
https://social.msdn.microsoft.com/Forums/vstudio/en-US/e653a57a-bc32-4134-87bf-df33058f0531/download-microsoft-visual-c-2017-redistributable
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Annex 2: Connecting to the conifer database 
The conifer database, provided by Aljos Farjon, includes all published conifer names with nomenclatural details, Red List 
codes, species descriptions and more. It also includes specimen data for all conifer taxa, almost all map referenced.  

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#coniferconnect 

The Conifer Database is available on: http://herbaria.plants.ox.ac.uk/bol/brahms/support/samples/conifers. 

 

You can also access this database from the System menu. 

To connect BRAHMS to the sample database: 

• Create a new folder e.g. C:\Conifer Database – this can be on your PC or a networked location. Open the 

downloaded version 8 conifer zip to this folder. This will create the single file conifers.db. 

• Log into Personal using the credentials as first used above (i.e. Windows Authentication). Close the 

Database Projects Manager form if this opens. 

• Now choose System > Manage Data Connections… then New and enter a connection name such as 

Conifer Database. The Connection Provider will be the default Local Filesystem.   

• Use Browse for an existing file to navigate to your conifers.db file and then select Save and then Done. 

• Select System > Sign out.  

• When you next log in, change the Data Location to ‘Conifer database’ or the name you added above. 

 

Browse to locate the downloaded conifer.db sample database - then save. 

The log in credentials for the demo Conifer database are as follows: Authentication: BRAHMS Authentication; 

User name: Demo (not case sensitive); Password: demo (lower case). 

 

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#coniferconnect
http://herbaria.plants.ox.ac.uk/bol/brahms/support/samples/conifers

